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1. INTRODUCTION

The RCM3000 RabbitCore module is designed to be the heart of
embedded control systems. The RCM3000 features an inte-
grated Ethernet port and provides for LAN and Internet-enabled
systems to be built as easily as serial-communication systems.

Throughout this manual, the term RCM3000 refers to the complete series of RCM3000
RabbitCore modules unless other production models are referred to specifically.

The RCM3000 has a Rabbit 3000 microprocessor operating at 29.4 MHz, static RAM,
flash memory, two clocks (main oscillator and timekeeping), and the circuitry necessary
for reset and management of battery backup of the Rabbit 3000’s internal real-time clock
and the static RAM. Two 34-pin headers bring out the Rabbit 3000 I/O bus lines, parallel
ports, and serial ports.

The RCM3000 receives its +3.3 V power from the customer-supplied motherboard on
which it is mounted. The RabbitCore RCM3000 can interface with all kinds of CMOS-
compatible digital devices through the motherboard.

1.1 RCM3000 Features

e Small size: 1.85" x 2.65"” x 0.86"
(47 mm x 67 mm X 22 mm)

e Microprocessor: Rabbit 3000 running at 29.4 MHz

e 52 parallel 5 V tolerant I/O lines: 44 configurable for I/0O, 4 fixed inputs, 4 fixed outputs
e Two additional digital inputs, two additional digital outputs

e External reset input

e Alternate I/O bus can be configured for 8 data lines and 6 address lines (shared with
parallel I/O lines), I/O read/write

e Ten 8-bit timers (six cascadable) and one 10-bit timer with two match registers
e 256K-512K flash memory, 128K-512K SRAM
e Real-time clock

e Watchdog supervisor
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e Provision for customer-supplied backup battery via connections on header J2

e 10/100-compatible RJ-45 Ethernet port with 10Base-T interface

e 10-bit free-running PWM counter and four width registers

e Two-channel Input Capture can be used to time input signals from various port pins

e Two-channel Quadrature Decoder accepts inputs from external incremental encoder

modules

e Six CMOS-compatible serial ports: maximum asynchronous baud rate of 1.84 Mbps,
maximum synchronous baud rate of 7.35 Mbps. Four ports are configurable as a
clocked serial port (SPI), and two ports are configurable as SDLC/HDLC serial ports.

e Supports 1.15 Mbps IRDA transceiver

There are two production models in the RCM3000 series. If the standard models do not
serve your needs, other variations can be specified and ordered in production quantities.
Contact your Rabbit Semiconductor sales representative for details.

Table 1 below highlights the differences between the two models in the RCM3000 family.

Table 1. RCM3000 Versions

Feature RCM3000 RCM3010
Microprocessor Rabbit 3000 running at 29.4 MHz
Flash Memory 512K 256K
Static RAM 512K 128K

Serial Ports

for programming

6 shared high-speed, CMOS-compatible ports:
6 are configurable as asynchronous serial ports;
4 are configurable as clocked serial ports (SPI);
2 are configurable as SDLC/HDLC serial ports;
1 asynchronous clocked serial port is dedicated

NOTE: The RCM3010 is the RabbitCore module supplied with the Development Kit.

In addition, there is an RCM3100 series of RabbitCore modules that omits the RCM3000
series’ Ethernet connectivity, but offer a much smaller footprint, which is about one-half

that of the RCM3000 series.

The RabbitCore modules can be programed locally, remotely, or via a network using
appropriate interface hardware.

Appendix A, “RCM3000 Specifications,” provides detailed specifications for the

RCM3000.
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1.2 Advantages of the RCM3000

e Fast time to market using a fully engineered, “ready to run” microprocessor core.

e Competitive pricing when compared with the alternative of purchasing and assembling
individual components.

e Easy C-language program development and debugging
e Utility programs for rapid production loading of programs.

e Generous memory size allows large programs with tens of thousands of lines of code,
and substantial data storage.

e Integrated Ethernet port for network connectivity, royalty-free TCP/IP software.
1.3 Development and Evaluation Tools

A complete Development Kit, including a Prototyping Board and Dynamic C develop-
ment software, is available for the RCM3000. The Development Kit puts together the
essentials you need to design an embedded microprocessor-based system rapidly and effi-
ciently.

1.4 How to Use This Manual

This user’s manual is intended to give users detailed information on the RCM3000 mod-
ule. It does not contain detailed information on the Dynamic C development environment
or the TCP/IP software support for the integrated Ethernet port. Most users will want more
detailed information on some or all of these topics in order to put the RCM3000 module to
effective use.

1.4.1 Additional Product Information

Information about the RCM3000 and its associated Development Kit and Prototyping
Board can be found in this RabbitCore RCM3000 User’s Manual, which is provided on
the accompanying CD-ROM in both HTML and Adobe PDF format.

In addition to the product-specific information contained in the RabbitCore RCM3000
User’s Manual (this manual), several higher level reference manuals are provided in
HTML and PDF form on the accompanying CD-ROM. Advanced users will find these
references valuable in developing systems based on the RCM3000 modules:

e Dynamic C User’s Manual

e Dynamic C Function Reference Manual

e An Introduction to TCP/IP

e Dynamic C TCP/IP User’s Manual

e Rabbit 3000 Microprocessor User’s Manual
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1.4.2 Online Documentation

The online documentation is installed along with Dynamic C, and an icon for the docu-
mentation menu is placed on the workstation’s desktop. Double-click this icon to reach the
menu. If the icon is missing, use your browser to find and load default.htm in the docs
folder, found in the Dynamic C installation folder.

The latest versions of all documents are always available for free, unregistered download
from our Web sites as well.
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2. HARDWARE SETUP

This chapter describes the RCM3000 hardware in more detail, and
explains how to set up and use the accompanying Prototyping Board.

NOTE: This chapter (and this manual) assume that you have the RCM3000 Development
Kit. If you purchased an RCM3000 module by itself, you will have to adapt the infor-
mation in this chapter and elsewhere to your test and development setup.

2.1 Development Kit Contents

The RCM3000 Development Kit contains the following items:

e RCM3010 module with Ethernet port, 256K flash memory, and 128K SRAM.
e RCM30/31/32XX Prototyping Board.

e AC adapter, 12 V DC, 1 A. (Included only with Development Kits sold for the North
American market. A header plug leading to bare leads is provided to allow overseas
users to connect a power supply compatible with their local mains power.)

e 10-pin header to DB9 programming cable with integrated level-matching circuitry.
e Dynamic C CD-ROM, with complete product documentation on disk.

e Getting Started instructions.

e A bag of accessory parts for use on the Prototyping Board.

e Rabbit 3000 Processor Easy Reference poster.

e Registration card.
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2.2 Hardware Connections
2.2.1 Attach Module to Prototyping Board

Turn the RCM3000 module so that the Ethernet connector end of the module extends off
the Prototyping Board, as shown in Figure 1 below. Align the pins from headers J1 and J2
on the bottom side of the module into header sockets RCM2JA and RCM2JB on the Proto-
typing Board (these sockets were labeled J12 and J13 on earlier versions of the Prototyping
Board).

[—

\\\W [e]e]e]e]e]e]e]e]elo]e]o]c]e]e]o]e]e]o]e]ele]e]e]0]0]e;
000000000000 000O00O00O0O0000000000OJ
¢ 000000000000 000O00O00OOO0000000O00OJ

000000000000 000O00O00OOO0000000000OJ
0000000000000 00000O0O00OO0O0000O0000000
0000000000000 00000O0O00OO0O0000O0000000
0O00000000000000000O0OO0OO0O000O0O0O0000
0000000000000 000000O0OO0O0000O0000000
OOOOOOq

Do not press down
here.

aaaaaaaaaaaaaaaaa

o por

uuuuuuuuuu

Figure 1. Install the RCM3000 Module on the Prototyping Board

Although you can install a single module into either the MASTER or the SLAVE position
on the Prototyping Board, all the Prototyping Board features (switches, LEDs, serial port
drivers, etc.) are connected to the MASTER position — install a single module in the
MASTER position.

NOTE: Itis important that you line up the pins on headers J1 and J2 of the RCM3000
module exactly with the corresponding pins of sockets RCM2JA and RCM2JB on the
Prototyping Board. The header pins may become bent or damaged if the pin alignment
is offset, and the module will not work. Permanent electrical damage to the module may
also result if a misaligned module is powered up.

Press the module’s pins firmly into the Prototyping Board header sockets—press down in
the area above the header pins using your thumbs or fingers over the connectors as shown
in Figure 1. Do not press down on the middle of the RCM3000 module to avoid flexing
the module, which could damage the module or the components on the module.

Should you need to remove the RCM3000 module, grasp it with your fingers along the sides
by the connectors and gently work the module up to pull the pins away from the sockets
where they are installed. Do not remove the module by grasping it at the top and bottom.
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2.2.2 Connect Programming Cable

The programming cable connects the RCM3000 module to the PC running Dynamic C to
download programs and to monitor the module for debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J3 on
the RCM3000 module as shown in Figure 2. Be sure to orient the marked (usually red)
edge of the cable towards pin 1 of the connector. (Do not use the DIAG connector, which is
used for a normal serial connection.)

NOTE: Be sure to use the programming cable (part number 101-0513) supplied with this
Development Kit—the programming cable has red shrink wrap around the RS-232 con-
verter section located in the middle of the cable. Programming cables with blue or clear
shrink wrap from other from other Rabbit Semiconductor kits were not designed to work
with RCM3000 modules.

eeeeeeee

, eToTel0T0]
0QQRO0OOOOOO0OOOOOOOOQQOOON]
= O0000000OOOOOOOOOOOOOOOOOOJ

O0000000OOOOOOOOOOOOOOOOOOOOOOOOJ
F] O0000000OOOOOOOOOOOOOOOOOOOOOOOOJ

O00000O0OOOOOOOOOOOOOOOOOOOOOOOOJ
O0000000O0OOOOOOOOOOOOOOOOOOOOOOOOY
Q00000000 0OOOOOOOOOOOOOOOOOOOOOOOOY
000000000 0OOOOOOOOOOOOOOOOOOOOOOOOY
O0000000000OOOOOOOOOOOOOOOOOOOO0OO00

00000000000000Q00000000000000000000!

3| Q’Q]SQMMQ R bbbty | Tt -
o
9
o “mb 10
& = PC COM port
o
3= T \ Colored

,,,,,, o~ shrink wrap

Colored edge

Programming Cable

Figure 2. Connect Programming Cable to RCM3000

Connect the other end of the programming cable to a COM port on your PC.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use
an RS-232/USB converter with the programming cable supplied with your RabbitCore
module. An RS-232/USB converter is available through the Web store. Note that not all
RS-232/USB converters work with Dynamic C.
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2.2.3 Connect Power

When all other connections have been made, you can connect power to the Prototyping
Board.

Connect the wall transformer to jack J11 on the Prototyping Board as shown in Figure 3
below.

3-pin
power connector

0000000000000

= 000000000000000O00000000O000
000000000000000000000C0000000000]
£ [POO0000000000000000000000000000000)
00000000000000000000000000000000]
0000000000000 0000000O0000000000000J
0000000000000000000000000000000000]
0000000000000000000000000000000000]
0000000000000000000000000000000000]
QOOOOOOOOOq

Trizia 3
0000000000000

e

RCM30/31/32XX SERIES
g PROTOTYPING BOARD

uuuuuuuuuuuu

Figure 3. Power Supply Connections

Plug in the wall transformer. The power LED on the Prototyping Board should light up.
The RCM3000 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow hardware reset
without disconnecting power.

To power down the Prototyping Board, unplug the power connector from J11. You should
disconnect power before making any circuit adjustments in the prototyping area, changing
any connections to the board, or removing the RCM3000 from the Prototyping Board.

2.2.3.1 Overseas Development Kits

Development kits sold outside North America include a header connector that may be
connected to 3-pin header J9 on the Prototyping Board. The connector may be attached
either way as long as it is not offset to one side. The red and black wires from the connec-
tor can then be connected to the positive and negative connections on your power supply.
The power supply should deliver 8 V-24 V DC at 8 W.
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2.3 Run a Sample Program

If you already have Dynamic C installed, you are now ready to test your programming
connections by running a sample program.

If you are using a USB port to connect your computer to the RCM3000 module, choose
Options > Project Options and select “Use USB to Serial Converter” under the
Communications tab.

Find the file PONG. ¢, which is in the Dynamic C sAMPLES folder. To run the program,
open it with the File menu (if it is not still open), compile it using the Compile menu, and
then run it by selecting Run in the Run menu. The STDIO window will open and will dis-
play a small square bouncing around in a box.

This program shows that the CPU is working. The sample program described in
Section 6.10, “Run the PINGME.C Sample Program,” tests the TCP/IP portion of the board.

2.3.1 Troubleshooting

If Dynamic C appears to compile the BIOS successfully, but you then receive a communi-
cation error message when you compile and load the sample program, it is possible that
your PC cannot handle the higher program-loading baud rate. Try changing the maximum
download rate to a slower baud rate as follows.

e Locate the Serial Options dialog in the Dynamic C Options > Project Options >
Communications menu. Select a slower Max download baud rate.

If a program compiles and loads, but then loses target communication before you can
begin debugging, it is possible that your PC cannot handle the default debugging baud
rate. Try lowering the debugging baud rate as follows.

e Locate the Serial Options dialog in the Dynamic C Options > Project Options >
Communications menu. Choose a lower debug baud rate.

If there are any other problems:

e Check to make sure you are using the PROG connector, not the DIAG connector, on
the programming cable.

e Check both ends of the programming cable to ensure that they are firmly plugged into
the PC and the programming port on the RCM3000.

e Ensure that the RCM3000 module is firmly and correctly installed in its connectors on
the Prototyping Board.

e Select a different COM port within Dynamic C. From the Options menu, select
Project Options, then select Communications. Select another COM port from the
list, then click OK. Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. If
Dynamic C still reports it is unable to locate the target system, repeat the above steps until
you locate the active COM port.
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2.4 Where Do | Go From Here?

We recommend that you proceed to the next chapter and install Dynamic C (if you do not
already have it installed), then run the PONG. ¢ sample program to verify that the
RCM3000 module and the Prototyping Board are set up and functioning correctly.

If everything appears to be working, we recommend the following sequence of action:

1. Run all of the sample programs described in Chapter 3 to get a basic familiarity with
Dynamic C and the RCM3000 module’s capabilities.

2. For further development, refer to the RabbitCore RCM3000 User’s Manual for details
of the module’s hardware and software components.

3. For advanced development topics, refer to the Dynamic C User’s Manual and the
Dynamic C TCP/IP User’s Manual, also in the online documentation set.

2.4.1 Technical Support

NOTE: If you purchased your RCM3000 through a distributor or through a Rabbit Semi-
conductor partner, contact the distributor or partner first for technical support.

If there are any problems at this point:
e Use the Dynamic C Help menu to get further assistance with Dynamic C.

e Check the Rabbit Semiconductor Technical Bulletin Board at
www.rabbit.com/support/bb/.

e Use the Technical Support e-mail form at www.rabbit.com/support/.
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3. RUNNING SAMPLE PROGRAMS

To develop and debug programs for the RCM3000 (and for all
other Rabbit Semiconductor hardware), you must install and use
Dynamic C.

3.1 Introduction

To help familiarize you with the RCM3000 modules, Dynamic C includes several sample
programs. Loading, executing and studying these programs will give you a solid hands-on
overview of the RCM3000’s capabilities, as well as a quick start with Dynamic C as an
application development tool.

NOTE: The sample programs assume that you have at least an elementary grasp of the C
programming language. If you do not, see the introductory pages of the Dynamic C
User’s Manual for a suggested reading list.

Complete information on Dynamic C is provided in the Dynamic C User’s Manual.
In order to run the sample programs discussed in this chapter and elsewhere in this manual,

1. Your RCM3000 module must be plugged in to the Prototyping Board as described in
Chapter 2, “Hardware Setup.”

2. Dynamic C must be installed and running on your PC.

3. The RCM3000 module must be connected to your PC through the serial programming
cable.

4. Power must be applied to the RCM3000 through the Prototyping Board.

Refer to Chapter 2, “Hardware Setup,” if you need further information on these steps.

To run a sample program, open it with the File menu, then press function key F9 to com-
pile and run the program.
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3.2 Sample Programs

Of the many sample programs included with Dynamic C, several are specific to the
RCM3000. Sample programs illustrating the general operation of the RCM3000, and
serial communication are provided in the SAMPLES\RCM3000 folder. Each sample pro-
gram has comments that describe the purpose and function of the program. Follow the
instructions at the beginning of the sample program.

CONTROLLED.C—uses the STDIO window to demonstrate digital outputs by toggling
LEDs DS1 and DS2 on the Prototyping Board on and off.

Parallel Port G bit 6 = LED DS1
Parallel Port G bit 7 = LED DS2

Once you have compile this program and it is running, you will be prompted via the
Dynamic C STDIO window to select LED DS1 or DS2. Use your PC keyboard to make
your selection.

Once you have selected the LED, you will be prompted to select to turn the LED either
ON or OFF. A logic low will light up the LED you selected.

FLASHLED1 .c—demonstrates the use of costatements to flash LEDs DS1 and DS2 on

the Prototyping Board at different rates. Once you have compile this program and it is
running, LEDs DS1 and DS2 will flash on/off at different rates.

FLASHLED2 . c—demonstrates the use of cofunctions and costatements to flash LEDs
DS1 and DS2 on the Prototyping Board at different rates. Once you have compile this
program and it is running, LEDs DS1 and DS2 will flash on/off at different rates.

TOGGLESWITCH.c—demonstrates the use of costatements to detect switches using the
press-and-release method of debouncing. LEDs DS1 and DS2 on the Prototyping
Board are turned on and off when you press switches S2 and S3.

IR DEMO.c—Demonstrates sending Modbus ASCII packets between two Prototyping
Board assemblies via the IrDA transceivers with the IrDA transceivers facing each other.
Note that this sample program will only work with the RCM30/31/32XX Prototyping
Board.

First, compile and run this program on one Prototyping Board assembly, then remove
the programming cable and press the RESET button on the Prototyping Board so that
the first RabbitCore module is operating in the Run mode. Then connect the program-
ming cable to the second Prototyping Board assembly with the RCM3000 and compile
and run the same sample program. With the programming cable still connected to the
second Prototyping Board assembly, press switch S2 on the second Prototyping Board
to transmit a packet. Once the first Prototyping Board assembly receives a test packet, it
will send back a response packet that will be displayed in the Dynamic C STDIO win-
dow. The test packets and response packets have different codes.

Once you have loaded and executed these sample programs and have an understanding of
how Dynamic C and the RCM3000 modules interact, you can move on and try the other
sample programs, or begin building your own.
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3.2.1 Serial Communication

The following sample programs can be found in the SAMPLES\RCM3 000\ SERIAL folder.

e FLOWCONTROL.C—This program demonstrates hardware flow control by configuring

Serial Port C (PC3/PC2) for CTS/RTS with serial data coming from TxB at 115,200 bps.
One character at a time is received and is displayed in the STDIO window.

To set up the Prototyping Board, you will need to tie TxB and RxB

together on the RS-232 header at J5, and you will also tie TxC and RxC TxC
. : L : J5
RxC together using the jumpers supplied in the Development Kit as =[Edoo

TxB RxB GND

shown in the diagram.

A repeating triangular pattern should print out in the STDIO window.
The program will periodically switch flow control on or off to demonstrate the effect of
no flow control.

PARITY.C—This program demonstrates the use of parity modes by
repeatedly sending byte values 0—127 from Serial Port B to Serial Port RueTxe

C. The program will switch between generating parity or not on Serial " x@;g G?VDJ5
Port B. Serial Port C will always be checking parity, so parity errors

should occur during every other sequence.

To set up the Prototyping Board, you will need to tie TxB and RxC together on the
RS-232 header at J5 using the jumpers supplied in the Development Kit as shown in the
diagram.

The Dynamic C STDIO window will display the error sequence.

SIMPLE3WIRE.C—This program demonstrates basic RS-232 serial
communication. Lower case characters are sent by TxC, and are R 1
received by RxB. The characters are converted to upper case and are D J5
sent out by TxB, are received by RxC, and are displayed in the

Dynamic C STDIO window.

To set up the Prototyping Board, you will need to tie TxB and RxC together on the
RS-232 header at J5, and you will also tie RxB and TxC together using the jumpers
supplied in the Development Kit as shown in the diagram.

SIMPLESWIRE.C—This program demonstrates 5-wire RS-232 serial communication
with flow control on Serial Port C and data flow on Serial Port B.

To set up the Prototyping Board, you will need to tie TxB and RxB
together on the RS-232 header at J5, and you will also tie TxC and Js
RxC together using the jumpers supplied in the Development Kit as S
shown in the diagram.

Once you have compiled and run this program, you can test flow con-

trol by disconnecting TxC from RxC while the program is running. Characters will no
longer appear in the STDIO window, and will display again once TxC is connected
back to RxC.
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Two sample programs,

SIMPLE485MASTER.C and Vee
SIMPLE485SLAVE. C, are available to vee 485+

illustrate RS-485 master/slave com- T biasg 681 Q
munication. To run these sample pro- PCO DI A

grams, you will need a second Rabbit- PCA1 ROl Rs-485 termi-< 220 O
based system with RS-485, and you PD4 DE| CHIP |p nation

will also have to add an RS-485 trans- GND [RE bias < 681 Q
ceiver such as the SP483E and bias _L_L_ 485

resistors to the RCM30/31/32XX - =

Prototyping Board.

SWITCHCHAR.C—This program demonstrates transmitting and then receiving an
ASCII string on Serial Ports B and C. It also displays the serial data received from both
ports in the STDIO window.

To set up the Prototyping Board, you will need to tie TxB and RxC
together on the RS-232 header at J5, and you will also tie RxB and R 16
TxC together using the jumpers supplied in the Development Kit as D J5
shown in the diagram.

Once you have compiled and run this program, press and release S2
and S3 on the Prototyping Board. The data sent between the serial ports will be dis-
played in the STDIO window.

The diagram shows the connections. You will have to connect PCO and PC1 (Serial Port D)
on the RCM30/31/32XX Prototyping Board to the RS-485 transceiver, and you will con-
nect PD4 to the RS-485 transceiver to enable or disable the RS-485 transmitter.

The RS-485 connections between the slave and master devices are as follows.

RS485+ to RS485+
RS485- to RS485-
GND to GND

SIMPLE485MASTER.C—This program demonstrates a simple RS-485 transmission of
lower case letters to a slave RCM3000. The slave will send back converted upper case
letters back to the master RCM3000 and display them in the STDIO window. Use
SIMPLE485SLAVE. C to program the slave RCM3000.

SIMPLE485SLAVE.C—This program demonstrates a simple RS-485 transmission of
lower case letters to a master RCM3000. The slave will send back converted upper case
letters back to the master RCM3000 and display them in the STDIO window. Use
SIMPLE485MASTER. C to program the master RCM3000.

3.2.2 Other Sample Programs

Section 6.11 describes the TCP/IP sample programs, and Appendix C.8 provides sample
programs for the optional LCD/keypad module that can be installed on the Prototyping
Board.
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4. HARDWARE REFERENCE

Chapter 3 describes the hardware components and principal hardware
subsystems of the RCM3000. Appendix A, “RCM3000 Specifica-
tions,” provides complete physical and electrical specifications.

Figure 4 shows these Rabbit-based subsystems designed into the RCM3000.

32 kHz || 14 MHz
oSsC oscC
SRAM RABBIT ® logic-level serial signal
3000
Flash
Level
converter
Ethernet
RS-232, RS-485, IRDA
serial communication
RabbitCore Module drivers on motherboard

Figure 4. RCM3000 Subsystems
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4.1 RCM3000 Digital Inputs and Outputs

The RCM3000 has 52 parallel I/O lines grouped in seven 8-bit ports available on headers
J1 and J2. The 44 bidirectional I/O lines are located on pins PAO-PA7, PBO, PB2-PB7,
PD2-PD7, PEO-PE1, PE3-PE7, PFO-PF7, and PGO-PG7.

Figure 5 shows the RCM3000 pinouts for headers J1 and J2.

J1 J2
GND [|m o[ ] STATUS /RES [|m o[ ]PBO
PA7 o o[ PA6 PB2 |o o[ 1PB3
PA5 o o[ ] PA4 PB4 |o o[ 1PB5
PA3[|o o[ ] PA2 PB6 |0 o[ 1PB7
PA1 o o[ PAO PF4 o o[ JPF5
PF3[] o o[ JPF2 PF6 o o[ 1PF7
PF1[ o o[ PFO PE7 [ |o o[ 1 PE6
PCO|o o[ ]PC1 PESC |0 o[ 1 PE4
PC2|o o[ JPC3 PE3[ |0 o[ 1PE1
PC4 o o[ 1PC5 PEOL |2 o[ 1PpPG7
PC6 o o[ JPC7 PG6 o o[PG5
PGO[ | o o| 1 PG1 PG4 [ o o[ J/IOWR
PG2[ |0 o|1PG3 /IORD ] © © [ SMODEO
PD4 o o[ 1PD5 SMODE1 | = o[ J/RESET_IN
PD2|c o[ 1PD3 VRAM | o 5[] VBAT EXT
PD6 o o[ PD7 +33v] o o[ JGND
nc.C|o o[ Jnec. nc.L12 o[ JGND

n.c. = not connected
Note: These pinouts are as seen on
the Bottom Side of the module.

Figure 5. RCM3000 Pinouts

Headers J1 and J2 are standard 2 x 34 headers with a nominal 2 mm pitch. An RJ-45 Ether-
net jack is also included with the RCM3000.

The signals labeled PD2, PD3, PD6, and PD7 on header J1 (pins 29-32) and the pins that
are not connected (pins 33—34 on header J1 and pin 33 on header J2) are reserved for
future use on other models in the RCM3000.
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Figure 6 shows the use of the Rabbit 3000 ports in the RCM3000 modules.

PCO, PC2, PC4 4
PC1, PC3, PC5 NI

PG2, PG6 {um
PG3, PG7 I

PC6
PB1, PC7, /IRES

4 Ethernet signaIsH

nitst

PBO,
PAO-PAT PB2-PB7 PD4-PD5
Port D
PortA Port B (+Ethernet Port)
Port C
(Serial Ports B.,C & D) | I =J¥-1-7¢ A& Port E
3000
Port G
(Serial Ports E & F) Port F
Programming Real-Time Clock Port G
(Serial Port A Watchdog (TR
11 Timers
Ethernet Slave Port Misc. 1/0
e Clock Doubler
RAM Backup Battery Flash

Support

EO-PEA1,

P
PE3-PE7

PFO-PF7

PG0-PG1,

PG4-PG5

/RES_IN
/IORD

/RESET,
/IOWR,
STATUS
SMODEO
SMODE1

Figure 6. Use of Rabbit 3000 Ports

The ports on the Rabbit 3000 microprocessor used in the RCM3000 are configurable, and
so the factory defaults can be reconfigured. Table 2 lists the Rabbit 3000 factory defaults
and the alternate configurations.
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