
Chipsmall Limited consists of a professional team with an average of over 10 year of expertise in the distribution

of electronic components. Based in Hongkong, we have already established firm and mutual-benefit business

relationships with customers from,Europe,America and south Asia,supplying obsolete and hard-to-find components

to meet their specific needs.

With the principle of “Quality Parts,Customers Priority,Honest Operation,and Considerate Service”,our business

mainly focus on the distribution of electronic components. Line cards we deal with include

Microchip,ALPS,ROHM,Xilinx,Pulse,ON,Everlight and Freescale. Main products comprise

IC,Modules,Potentiometer,IC Socket,Relay,Connector.Our parts cover such applications as commercial,industrial,

and automotives areas.

We are looking forward to setting up business relationship with you and hope to provide you with the best service

and solution. Let us make a better world for our industry!

Contact us
Tel: +86-755-8981 8866 Fax: +86-755-8427 6832

Email & Skype: info@chipsmall.com Web: www.chipsmall.com

Address: A1208, Overseas Decoration Building, #122 Zhenhua RD., Futian, Shenzhen, China

    



RabbitCore RCM3365/RCM3375
C-Programmable Core Module

with NAND Flash Mass Storage and Ethernet

User’s Manual

019–0150 • 080528–G



RabbitCore RCM3365/RCM3375

Rabbit Semiconductor Inc.

www.rabbit.com

RabbitCore RCM3365/RCM3375 User’s Manual

Part Number 019-0150 • 080528–G • Printed in U.S.A.

©2005–2008 Digi International Inc.   •   All rights reserved.

Digi International reserves the right to make changes and
improvements to its products without providing notice.

Trademarks

Rabbit, RabbitCore, and Dynamic C are registered trademarks of Digi International Inc.

Rabbit 3000 is a trademark of Digi International Inc.

xD-Picture Card is a trademark of Fuji Photo Film Co., Olympus Corporation, and Toshiba Corporation.

No part of the contents of this manual may be reproduced or transmitted in any form or by any means 

without the express written permission of Digi International.

Permission is granted to make one or more copies as long as the copyright page contained therein is 

included. These copies of the manuals may not be let or sold for any reason without the express written 

permission of Digi International.

The latest revision of this manual is available on the Rabbit Web site, www.rabbit.com, 

for free, unregistered download.



User’s Manual

TABLE OF CONTENTS

Chapter 1.  Introduction 1
1.1  RCM3365 and RCM3375 Features ......................................................................................................2

1.2  Comparing the RCM3900/RCM3910 and RCM3365/RCM3375 ........................................................4

1.3  Advantages of the RCM3365 and RCM3375.......................................................................................5

1.4  Development and Evaluation Tools......................................................................................................6

1.4.1  RCM3365/RCM3375 Development Kit .......................................................................................6
1.4.2  Software ........................................................................................................................................7
1.4.3  Accessories....................................................................................................................................7
1.4.4  Online Documentation ..................................................................................................................7

Chapter 2.  Getting Started 9
2.1  Install Dynamic C .................................................................................................................................9

2.2  Hardware Connections........................................................................................................................10

2.2.1  Step 1 — Attach Module to Prototyping Board..........................................................................10
2.2.2  Step 2 — Connect Serial Programming Cable............................................................................11

2.2.2.1  Programming via Ethernet Option ..................................................................................... 12

2.2.3  Step 3 — Connect Power ............................................................................................................13
2.2.3.1  Alternate Power-Supply Connections ................................................................................ 13

2.3  Starting Dynamic C ............................................................................................................................14

2.3.1  Running Dynamic C via Serial Programming Cable ..................................................................15
2.3.1.1  Run a Sample Program....................................................................................................... 15

2.3.1.2  Troubleshooting ................................................................................................................. 15

2.3.2  Running Dynamic C via Ethernet Cables ...................................................................................16
2.3.2.1  Run a Sample Program....................................................................................................... 16

2.3.2.2  Troubleshooting ................................................................................................................. 17

2.4  Where Do I Go From Here? ...............................................................................................................17

2.4.1  Technical Support .......................................................................................................................17

Chapter 3.  Running Sample Programs 19
3.1  Introduction.........................................................................................................................................19

3.2  Sample Programs ................................................................................................................................20

3.2.1  Use of NAND Flash....................................................................................................................21
3.2.2  Hot-Swapping xD-Picture Card ..................................................................................................23
3.2.3  Serial Communication.................................................................................................................24
3.2.4  Real-Time Clock .........................................................................................................................25
3.2.5  RabbitNet ....................................................................................................................................26
3.2.6  Other Sample Programs ..............................................................................................................26

Chapter 4.  Hardware Reference 27
4.1  RCM3365/RCM3375 Inputs and Outputs ..........................................................................................28

4.1.1  Memory I/O Interface .................................................................................................................33
4.1.2  Other Inputs and Outputs ............................................................................................................33
4.1.3  LEDs ...........................................................................................................................................33

4.2  Serial Communication ........................................................................................................................34

4.2.1  Serial Ports ..................................................................................................................................34
4.2.2  Ethernet Port ...............................................................................................................................34
4.2.3  Serial Programming Port.............................................................................................................35



RabbitCore RCM3365/RCM3375

4.3  Serial Programming Cable ................................................................................................................. 36

4.3.1  Changing Between Program Mode and Run Mode.................................................................... 36
4.3.2  Standalone Operation of the RCM3365/RCM3375 ................................................................... 37

4.4  Memory .............................................................................................................................................. 38

4.4.1  SRAM......................................................................................................................................... 38
4.4.2  Flash EPROM............................................................................................................................. 38
4.4.3  NAND Flash............................................................................................................................... 38

4.5  Other Hardware .................................................................................................................................. 40

4.5.1  Clock Doubler ............................................................................................................................ 40
4.5.2  Spectrum Spreader...................................................................................................................... 40

Chapter 5.  Software Reference 41
5.1  More About Dynamic C..................................................................................................................... 41

5.1.1  Developing Programs Remotely with Dynamic C ..................................................................... 43
5.2   Dynamic C Functions........................................................................................................................ 44

5.2.1  Digital I/O................................................................................................................................... 44
5.2.2  SRAM Use.................................................................................................................................. 44
5.2.3  Serial Communication Drivers ................................................................................................... 45
5.2.4  TCP/IP Drivers ........................................................................................................................... 45
5.2.5  NAND Flash Drivers.................................................................................................................. 45
5.2.6  Prototyping Board Functions...................................................................................................... 46

5.2.6.1  Board Initialization ............................................................................................................  46

5.2.6.2  Digital I/O..........................................................................................................................  47

5.2.6.3  Switches, LEDs, and Relay ...............................................................................................  48

5.2.6.4  Serial Communication .......................................................................................................  49

5.2.6.5  RabbitNet Port ...................................................................................................................  50

5.3  Upgrading Dynamic C ....................................................................................................................... 52

5.3.1  Extras.......................................................................................................................................... 52

Chapter 6.  Using the TCP/IP Features 53
6.1  TCP/IP Connections ........................................................................................................................... 53

6.2  TCP/IP Primer on IP Addresses ......................................................................................................... 55

6.2.1  IP Addresses Explained.............................................................................................................. 57
6.2.2  How IP Addresses are Used ....................................................................................................... 58
6.2.3  Dynamically Assigned Internet Addresses................................................................................. 59

6.3  Placing Your Device on the Network ................................................................................................ 60

6.4  Running TCP/IP Sample Programs.................................................................................................... 61

6.4.1  How to Set IP Addresses in the Sample Programs..................................................................... 62
6.4.2  How to Set Up your Computer for Direct Connect .................................................................... 63

6.5  Run the PINGME.C Sample Program................................................................................................ 64

6.6  Running Additional Sample Programs With Direct Connect ............................................................ 64

6.6.1  RabbitWeb Sample Programs..................................................................................................... 65
6.7  Where Do I Go From Here? ............................................................................................................... 65

Appendix A.  RCM3365/RCM3375 Specifications 67
A.1  Electrical and Mechanical Characteristics ........................................................................................ 68

A.1.1  Headers ...................................................................................................................................... 72
A.2  Bus Loading ...................................................................................................................................... 73

A.3  Rabbit 3000 DC Characteristics ........................................................................................................ 76

A.4  I/O Buffer Sourcing and Sinking Limit............................................................................................. 77

A.5  Jumper Configurations ...................................................................................................................... 78

A.6  Conformal Coating ............................................................................................................................ 80

Appendix B.  Prototyping Board 81
B.1  Introduction ....................................................................................................................................... 82

B.1.1  Prototyping Board Features ....................................................................................................... 83
B.2  Mechanical Dimensions and Layout ................................................................................................. 85



User’s Manual

B.3  Power Supply .....................................................................................................................................87

B.4  Using the Prototyping Board..............................................................................................................88

B.4.1  Adding Other Components.........................................................................................................89
B.4.2  Digital I/O...................................................................................................................................90

B.4.2.1  Digital Inputs ..................................................................................................................... 90

B.4.3  CMOS Digital Outputs ...............................................................................................................91
B.4.4  Sinking Digital Outputs..............................................................................................................91
B.4.5  Relay Outputs .............................................................................................................................91
B.4.6  Serial Communication................................................................................................................92

B.4.6.1  RS-232 ............................................................................................................................... 93

B.4.6.2  RS-485 ............................................................................................................................... 94

B.4.7  RabbitNet Ports ..........................................................................................................................95
B.4.8  Other Prototyping Board Modules .............................................................................................96
B.4.9  Quadrature Decoder ...................................................................................................................96
B.4.10  Stepper-Motor Control .............................................................................................................96

B.5  Prototyping Board Jumper Configurations ........................................................................................98

B.6  Use of Rabbit 3000 Parallel Ports ....................................................................................................100

Appendix C.  LCD/Keypad Module 103
C.1  Specifications ...................................................................................................................................103

C.2  Contrast Adjustments for All Boards ...............................................................................................105

C.3  Keypad Labeling ..............................................................................................................................106

C.4  Header Pinouts .................................................................................................................................107

C.4.1  I/O Address Assignments.........................................................................................................107
C.5  Mounting LCD/Keypad Module on the Prototyping Board ............................................................108

C.6  Bezel-Mount Installation..................................................................................................................109

C.6.1  Connect the LCD/Keypad Module to Your Prototyping Board...............................................111
C.7  Sample Programs .............................................................................................................................112

C.8  LCD/Keypad Module Function Calls ..............................................................................................113

C.8.1  LCD/Keypad Module Initialization..........................................................................................113
C.8.2  LEDs.........................................................................................................................................113
C.8.3  LCD Display.............................................................................................................................114
C.8.4  Keypad......................................................................................................................................130

Appendix D.  Power Supply 133
D.1  Power Supplies.................................................................................................................................133

D.1.1  Battery Backup.........................................................................................................................133
D.1.2  Battery-Backup Circuit ............................................................................................................134
D.1.3  Reset Generator ........................................................................................................................135

Appendix E.  Programming via Ethernet Crossover Cable 137
E.1  Load TCP/IP Parameters to the RCM3365 Module.........................................................................138

E.2  Load TCP/IP Parameters to the PC, Notebook, or Workstation ......................................................139

E.3  Run a Program..................................................................................................................................141

E.3.1  Troubleshooting........................................................................................................................141

Appendix F.  RabbitNet 143
F.1  General RabbitNet Description ........................................................................................................143

F.1.1  RabbitNet Connections .............................................................................................................143
F.1.2  RabbitNet Peripheral Cards ......................................................................................................144

F.2  Physical Implementation ..................................................................................................................145

F.2.1  Control and Routing..................................................................................................................145
F.3  Function Calls...................................................................................................................................146

F.3.1  Status Byte ................................................................................................................................152

Index 153



RabbitCore RCM3365/RCM3375

Schematics 157



User’s Manual 1

1.  INTRODUCTION

The RCM3365 and RCM3375 RabbitCore modules feature a

compact module that incorporates the latest revision of the power-

ful Rabbit® 3000 microprocessor, flash memory, mass storage

(NAND flash), static RAM, and digital I/O ports. The RCM3365

and RCM3375 present a new form of embedded flexibility with

removable (“hot-swappable”) memory cards. The RCM3365 and

RCM3375 both have an integrated 10/100Base-T Ethernet port,

and provide for LAN and Internet-enabled systems to be built as

easily as serial-communication systems.

In addition to the features already mentioned above, the RCM3365 and RCM3375 have 

two clocks (main oscillator and real-time clock), reset circuitry, and the circuitry necessary 

for management of battery backup of the Rabbit 3000’s internal real-time clock and the 

static RAM. Two 34-pin headers bring out the Rabbit 3000 I/O bus lines, parallel ports, 

and serial ports.

The RCM3365/RCM3375’s mass-storage capabilities make them suited to running the 

optional Dynamic C FAT file system module where data are stored and handled using the 

same directory file structure commonly used on PCs. A removable xD-Picture Card can 

be hot-swapped to transfer data quickly and easily using a standardized file system that 

can be read away from the RCM3365/RCM3375 installation.

The RCM3365 or RCM3375 receives +3.3 V power from the customer-supplied mother-

board on which it is mounted. The RCM3365 and RCM3375 can interface with all kinds 

of CMOS-compatible digital devices through the motherboard.

The Development Kit has what you need to design your own microprocessor-based 

system: a complete Dynamic C software development system including the Dynamic C 

FAT File System module, and a Prototyping Board that allows you to evaluate the 

RCM3365 or RCM3375, and to prototype circuits that interface to the RCM3365 or 

RCM3375 module.
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1.1  RCM3365 and RCM3375 Features

• Small size: 1.85" x 2.73" x 0.86"

(47 mm x 69 mm x 22 mm) 

• Microprocessor: Rabbit 3000 running at 44.2 MHz

• 52 parallel 5 V tolerant I/O lines: 44 configurable for I/O, 4 fixed inputs, 4 fixed outputs

• Three additional digital inputs, two additional digital outputs

• External reset

• Alternate I/O bus can be configured for 8 data lines and 6 address lines (shared with 

parallel I/O lines), plus I/O read/write

• Ten 8-bit timers (six cascadable) and one 10-bit timer with two match registers 

• 512K flash memory, 512K program execution SRAM, 512K data SRAM

• Fixed and hot-swappable mass-storage flash-memory options, which may be used with 

the standardized directory structure supported by the Dynamic C FAT File System 

module.

• Real-time clock

• Watchdog supervisor

• Provision for customer-supplied backup battery via connections on header J4

• 10-bit free-running PWM counter and four pulse-width registers

• Two-channel Input Capture (shared with parallel I/O ports) can be used to time input 

signals from various port pins

• Two-channel Quadrature Decoder accepts inputs from external incremental encoder 

modules

• Five or six 3.3 V CMOS-compatible serial ports with a maximum asynchronous baud 

rate of 5.525 Mbps. Three ports are configurable as a clocked serial port (SPI), and two 

ports are configurable as SDLC/HDLC serial ports (shared with parallel I/O ports).

• Supports 1.15 Mbps IrDA transceiver

• Supports Dynamic C RabbitSys, which supports Ethernet access for remote application 

updates, and remote monitoring and control of a RabbitSys-enabled RCM3365

The RCM3900/RCM3910 and RCM3365/RCM3375 RabbitCore modules are similar to 

the RCM3305/RCM3315 and RCM3309/RCM3319, but they use fixed NAND or remov-

able media for their mass-storage memories instead of the fixed serial flash options of the 

RCM3305/RCM3315 and the RCM3309/RCM3319.
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Table 1 below summarizes the main features of the RCM3365 and the RCM3375 modules.

NOTE: M-type xD-Picture Cards are not supported at this time.

The RCM3365 and RCM3375 are programmed over a standard PC serial port through a 

serial programming cable supplied with the Development Kit, and can also be programed 

through a USB port with an RS-232/USB converter, or directly over an Ethernet link using 

the Dynamic C download manager with or without a RabbitLink; Dynamic C RabbitSys 

may also be used with a RabbitSys-enabled RCM3365 over an Ethernet link.

Appendix A provides detailed specifications for the RCM3365 and the RCM3375.

Table 1.  RCM3365/RCM3375 Features

Feature RCM3365 RCM3375

Microprocessor Rabbit 3000 running at 44.2 MHz

SRAM 512K program (fast SRAM) + 512K data

Flash Memory 

(program)
512K

Flash Memory

(mass data 

storage)

32MB (fixed)* +

up to 128MB (removable)

(NAND flash)

* RCM3365 modules sold before 2008 had 16MB fixed NAND flash 

memory.

up to 128MB (removable)

(NAND flash)

Serial Ports

6 shared high-speed, 3.3 V CMOS-compatible ports:

• all 6 are configurable as asynchronous serial ports;

• 4 are configurable as a clocked serial port (SPI) and 1 is 

configurable as an HDLC serial port;

• option for second HDLC serial port at the expense of 2 

clocked serial ports (SPI)
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1.2  Comparing the RCM3900/RCM3910 and RCM3365/RCM3375

We can no longer obtain certain components for the RCM3365/RCM3375 RabbitCore 

modules that support the originally specified -40°C to +70°C temperature range. Instead of 

changing the design of the RCM3365/RCM3375 RabbitCore modules to handle available 

components specified for the original temperature range, we decided to develop a new 

product line — the RCM3900 series.

The RCM3900 series of RabbitCore modules is similar in form, dimensions, and function 

to the RCM3365/RCM3375 modules. We strongly recommend that existing RCM3365/

3375 customers and designers of new systems consider using the new RCM3900 series 

RabbitCore modules.

This section compares the two lines of RabbitCore modules.

• Temperature Specifications — RCM3365/RCM3375 RabbitCore modules manufac-

tured after May, 2008, are specified to operate at 0°C to +70°C. The RCM3900/

RCM3910, rated for -20°C to +85°C, are offered to customers requiring a larger 

temperature range after May, 2008.

• Removable Mass Storage — The hot-swappable xD-Picture Card™ mass storage 

device with up to 128MB of memory has been replaced with the miniSD Card with up 

to 1GB of memory. The miniSD Card is more readily available today, and is expected 

to remain readily available for a long time. In addition, miniSD Cards provide a signif-

icantly larger memory capacity, which has been requested by customers. The trade-off 

for the larger memory capacity is that the data transfer rate to/from the miniSD Card is 

about an order of magnitude slower than to/from the xD-Picture Card.

NOTE: RCM3365/RCM3375 RabbitCore modules may eventually be discontinued 

because of changes to the xD-Picture Card™.

• Serial Ports — Serial Port B, available as either a clocked serial port or an asynchro-

nous serial port on the RCM3365/RCM3375, is used by the RCM3900/RCM3910 as a 

clocked serial peripheral interface (SPI) for the miniSD™ Card, and is not brought out 

for customer use.

• General-Purpose I/O — PD2, a configurable I/O pin on the RCM3365/RCM3375, is 

used to enable/disable the RabbitNet SPI interface when the RCM3365/RCM3375 is 

installed on the Prototyping Board. The RCM3900/RCM3900 use PD2 to detect 

whether the miniSD™ Card is installed, and so PD2 is not brought out for customer use 

on the RCM3900/RCM3910.

• Maximum Current — The RCM3365/RCM3375 draws 250 mA vs. the 325 mA 

required by the RCM3900/RCM3910.

• LEDs — The SPEED and user (USR/BSY)LED locations have been swapped between 

the RCM3365/RCM3375 and the RCM3900/RCM3910, the LNK/ACT LEDs have 

been combined to one LED on the RCM3900/RCM3910, and the RCM3900/RCM3910 

has an FDX/COL LED instead of the FM LED on the RCM3365/RCM3375. The LED 

placements on the boards remain unchanged.
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• Ethernet chip — A different Ethernet controller chip is used on the RCM3900/

RCM3910. The Ethernet chip is able to detect automatically whether a crossover cable 

or a straight-through cable is being used in a particular setup, and will configure the 

signals on the Ethernet jack interface.

• Dynamic C — As long as no low-level FAT file system calls or direct xD-Picture Card 

access calls to the NFLASH.LIB library were used in your application developed for the 

RCM3365/RCM3375, you may run that application on the RCM3900/RCM3910 after 

you recompile it using Dynamic C v. 9.60.

NOTE: The Dynamic C RabbitSys option for programming an RCM3365 over an 

Ethernet link is not supported for the RCM3900.

1.3  Advantages of the RCM3365 and RCM3375

• Fast time to market using a fully engineered, “ready-to-run/ready-to-program” micro-

processor core.

• Competitive pricing when compared with the alternative of purchasing and assembling 

individual components.

• Easy C-language program development and debugging

• Program download utility (Rabbit Field Utility) and cloning board options for rapid 

production loading of programs.

• Generous memory size allows large programs with tens of thousands of lines of code, 

and substantial data storage.

• Integrated Ethernet port for network connectivity, with royalty-free TCP/IP software.

• Ideal for network-enabling security and access systems, home automation, HVAC 

systems, and industrial controls
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1.4  Development and Evaluation Tools

1.4.1  RCM3365/RCM3375 Development Kit

The RCM3365/RCM3375 Development Kit contains the hardware you need to use your 

RCM3365 or RCM3375 module.

• RCM3365 module.

• Prototyping Board.

• AC adapter, 12 V DC, 1 A (included only with Development Kits sold for the North Amer-

ican market). A header plug leading to bare leads is provided to allow overseas users to 

connect their own power supply with a DC output of 8–30 V.)

• Serial programming cable with 10-pin header and DE9 connections.

• 2 CDs — Dynamic C® and Dynamic C FAT File System module — with complete product 

documentation on disk.

• Getting Started instructions.

• 32 MB xD-Picture Card™.

• Accessory parts for use on the Prototyping Board.

• Screwdriver and Ethernet cables.

• Rabbit 3000 Processor Easy Reference poster.

• Registration card.

Figure 1.  RCM3365/RCM3375 Development Kit
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Development Kit Contents

The RCM3365/RCM3375 Development Kit contains the following items:

• RCM3365 module.

• RCM3300 Prototyping Board.

• AC adapter, 12 V DC, 1 A. (Included only with Development Kits sold for the North American market. 

A header plug leading to bare leads is provided to allow overseas users to connect their own power 

supply with a DC output of 8–30 V.)

• 10-pin header to DB9 programming cable with integrated level-matching circuitry.

• 2 CDs — Dynamic C and Dynamic C FAT File System module — with complete product documentation 

on disk.

• Ethernet cables and screwdriver.

• Getting Started instructions.

• 32 MB xD-Picture Card™ (NAND flash)

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 3000 Processor Easy Reference poster.

• Registration card.

Installing Dynamic C®

Insert the CD from the Development Kit in your PC’s CD-ROM drive. If the instal-

lation does not auto-start, run the setup.exe program in the root directory of the 

Dynamic C CD. Install any Dynamic C modules after you install Dynamic C.
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1.4.2  Software

The RCM3365 and the RCM3375 are programmed using version 9.24 or later of Dynamic C. 

A compatible version is included on the Development Kit CD-ROM.

Rabbit is also offering RCM3365 RabbitCore modules preloaded with Dynamic C Rabbit-

Sys firmware to allow these modules to run Dynamic C RabbitSys. Dynamic C RabbitSys 

requires Dynamic C version 9.30 or later, and allows the RCM3365 to be accessed via an 

Ethernet connection for remote application updates, and for remote monitoring and con-

trol. A RabbitSys Development Kit is available with all the hardware and software tools 

that are needed to develop a RabbitSys application.

Dynamic C v. 9.60 includes the popular µC/OS-II real-time operating system, point-to-

point protocol (PPP), FAT file system, RabbitWeb, and other select libraries that were 

previously sold as individual Dynamic C modules.

Rabbit also offers for purchase the Rabbit Embedded Security Pack featuring the Secure 

Sockets Layer (SSL) and a specific Advanced Encryption Standard (AES) library. In addi-

tion to the Web-based technical support included at no extra charge, a one-year telephone-

based technical support subscription is also available for purchase. Visit our Web site at 

www.rabbit.com for further information and complete documentation, or contact your 

Rabbit sales representative or authorized distributor.

NOTE: Version 2.10 or later of the Dynamic C FAT file system module is required to use 

the FAT file system with the RCM3365 and RCM3375 models.

1.4.3  Accessories

Rabbit has available a USB Removable Memory Card Reader and a Connector Adapter 

Board.

• USB Removable Memory Card Reader (Part No. 20-101-1104)—allows you to read 

data from the xD-Picture Card via your PC.

• Connector Adapter Board (Part No. 151-0114)—allows you to plug the RCM3365/

RCM3375 whose headers have a 2 mm pitch into header sockets with a 0.1" pitch.

Visit our Web site at www.rabbit.com or contact your Rabbit sales representative or autho-

rized distributor for further information.

1.4.4  Online Documentation

The online documentation is installed along with Dynamic C, and an icon for the docu-

mentation menu is placed on the workstation’s desktop. Double-click this icon to reach the 

menu. If the icon is missing, use your browser to find and load default.htm in the docs 

folder, found in the Dynamic C installation folder.

The latest versions of all documents are always available for free, unregistered download 

from our Web sites as well.
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2.  GETTING STARTED

This chapter explains how to set up and use the RCM3365/

RCM3375 modules with the accompanying Prototyping Board.

NOTE: It is assumed that you have a Development Kit. If you purchased an RCM3365 or 

RCM3375 module by itself, you will have to adapt the information in this chapter and 

elsewhere to your test and development setup.

2.1  Install Dynamic C

To develop and debug programs for the RCM3365/RCM3375 (and for all other Rabbit 

hardware), you must install and use Dynamic C.

If you have not yet installed Dynamic C version 9.24 (or a later version), do so now by 

inserting the Dynamic C CD from the Development Kit in your PC’s CD-ROM drive. If 

autorun is enabled, the CD installation will begin automatically.

If autorun is disabled or the installation otherwise does not start, use the Windows 

Start | Run menu or Windows Disk Explorer to launch setup.exe from the root folder 

of the CD-ROM.

The installation program will guide you through the installation process. Most steps of the 

process are self-explanatory.

Dynamic C uses a COM (serial) port to communicate with the target development system. 

The installation allows you to choose the COM port that will be used. The default selec-

tion is COM1. You may select any available port for Dynamic C’s use. If you are not cer-

tain which port is available, select COM1. This selection can be changed later within 

Dynamic C.

NOTE: The installation utility does not check the selected COM port in any way. Speci-

fying a port in use by another device (mouse, modem, etc.) may lead to a message such 

as "could not open serial port" when Dynamic C is started.

Once your installation is complete, you will have up to three icons on your PC desktop. 

One icon is for Dynamic C, one opens the documentation menu, and the third is for the 

Rabbit Field Utility, a tool used to download precompiled software to a target system.

If you have purchased the optional Dynamic C Rabbit Embedded Security Pack, install it 

after installing Dynamic C. You must install the Rabbit Embedded Security Pack in the 

same directory where Dynamic C was installed.
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2.2  Hardware Connections

There are three steps to connecting the Prototyping Board for use with Dynamic C and the 

sample programs:

1. Attach the RCM3365/RCM3375 module to the Prototyping Board.

2. Connect the serial programming cable between the RCM3365/RCM3375 and the worksta-

tion PC or if you have an RCM3365 with RabbitSys firmware you may connect the 

RCM3365 and the PC using Ethernet cables.

3. Connect the power supply to the Prototyping Board.

2.2.1  Step 1 — Attach Module to Prototyping Board

Turn the RCM3365/RCM3375 module so that the Ethernet jack is facing the direction shown 

in Figure 2 below. Align the pins from headers J3 and J4 on the bottom side of the module into 

header sockets JA and JB on the Prototyping Board. The picture card (NAND flash) does not 

have to be inserted into connector J6 on the RCM3365/RCM3375 at this time.

Figure 2.  Install the RCM3365/RCM3375 Module on the Prototyping Board

NOTE: It is important that you line up the pins on headers J3 and J4 of the RCM3365/

RCM3375 module exactly with the corresponding pins of header sockets JA and JB on 

the Prototyping Board. The header pins may become bent or damaged if the pin align-

ment is offset, and the module will not work. Permanent electrical damage to the mod-

ule may also result if a misaligned module is powered up.

Press the module’s pins firmly into the Prototyping Board header sockets—press down in the 

area above the header pins using your thumbs or fingers over the header pins as shown in 

Figure 2. Do not press down on the picture card connector (J6) unless the picture card is 

installed, but rather press down on the circuit board along the edge by the connector. Also, do 

not press down on the middle of the module to avoid flexing the module, which could damage 

the module or components on the module.

Should you need to remove the module, grasp it with your fingers along the sides by the con-

nectors and gently work the module up to pull the pins away from the sockets where they are 

installed. Do not remove the module by grasping it at the top and bottom.
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2.2.2  Step 2 — Connect Serial Programming Cable

The serial programming cable connects the RCM3365/RCM3375 to the PC running 

Dynamic C to download programs and to monitor the module during debugging.

Connect the 10-pin connector of the serial programming cable labeled PROG to header J1 

on the RCM3365/RCM3375 module as shown in Figure 3. There is a small dot on the cir-

cuit board next to pin 1 of header J1. Be sure to orient the marked (usually red) edge of the 

cable towards pin 1 of the connector. (Do not use the DIAG connector, which is used for a 

nonprogramming serial connection.)

Figure 3.  Connect Serial Programming Cable and Power Supply

NOTE: Be sure to use the serial programming cable (part number 101-0542) supplied 

with this Development Kit—the serial programming cable has blue shrink wrap around 

the RS-232 converter section located in the middle of the cable. Programming cables with 

clear or red shrink wrap from other Rabbit kits are not designed to work with RCM3365/

RCM3375 modules.

Connect the other end of the serial programming cable to a COM port on your PC.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use 

an RS-232/USB converter (Part No. 20-151--0178) with the serial programming cable 

supplied with the RCM3365/RCM3375 Development Kit. Note that not all RS-232/

USB converters work with Dynamic C.
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2.2.2.1  Programming via Ethernet Option

An Ethernet cable connects a RabbitSys-enabled RCM3365 to the PC running Dynamic C 

with Dynamic C RabbitSys via a DHCP network to download programs and to monitor 

the RCM3365 module during debugging.

Use a straight-through CAT 5/6 Ethernet cable to connect the Ethernet jack on the RCM3365 

to a DHCP-enabled network. Your PC should also be connected to this network—you will 

need a second straight-through CAT 5/6 Ethernet cable to connect the PC to the network 

since only one straight-through Ethernet cable is supplied with the Development Kit.

Figure 4.  Connect Ethernet Cable for Ethernet Programming Option

You may also use a crossover CAT 5/6 Ethernet cable to connect the Ethernet jack on the 

RCM3365 directly to your PC, but there will be additional steps required to configure the 

TCP/IP parameters on the RCM3365 and on your PC if your PC does not have a DHCP 

server. These steps are described in Appendix E.
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2.2.3  Step 3 — Connect Power

When all other connections have been made, you can connect power to the Prototyping 

Board. Connect the wall transformer to jack J1 on the Prototyping Board as shown in 

Figure 3.

Plug in the wall transformer. The core LED on the Prototyping Board should light up. The 

RCM3365/RCM3375 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board to allow a hardware reset 

without disconnecting power. The RCM3365/RCM3375 can also be reset from 

Dynamic C by pressing <Ctrl-Y> if your PC is connected to the RCM3365/RCM3375 

via the serial programming cable.

2.2.3.1  Alternate Power-Supply Connections

All Development Kits include a header connector that may be used to connect your power 

supply to 3-pin header J2 on the Prototyping Board. The connector may be attached either 

way as long as it is not offset to one side—the center pin of J2 is always connected to the 

positive terminal, and either edge pin is negative. The power supply should deliver 8 V to 

30 V DC at 8 W.
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2.3  Starting Dynamic C

Once the RCM3365/RCM3375 is connected as described in the preceding pages, start 

Dynamic C by double-clicking on the Dynamic C icon on your desktop or in your Start 

menu. Select Code and BIOS in Flash, Run in RAM on the “Compiler” tab in the 

Dynamic C Options > Project Options menu. Click OK.

Section 2.3.1 explains the remaining Dynamic C configurations to run a sample program 

via the serial programming cable, and Section 2.3.2 explains the remaining Dynamic C 

configurations to run a sample program via an Ethernet cable.
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2.3.1  Running Dynamic C via Serial Programming Cable

Dynamic C uses the serial port on your PC that you specified during installation.

If you are using a USB port to connect your computer to the RCM3365/RCM3375 module, 

choose Options > Project Options and select “Use USB to Serial Converter” on the 

Communications tab.

2.3.1.1  Run a Sample Program

Use the File menu to open the sample program PONG.C, which is in the Dynamic C 

SAMPLES folder. Press function key F9 to compile and run the program. The STDIO 

window will open on your PC and will display a small square bouncing around in a box.

This program shows that the CPU is working. The sample program described in 

Section 6.5, “Run the PINGME.C Sample Program,” tests the TCP/IP portion of the board.

2.3.1.2  Troubleshooting

If Dynamic C cannot find the target system (error message "No Rabbit Processor 

Detected."):

• Check that the RCM3365/RCM3375 is powered correctly — the red CORE LED on the 

Prototyping Board should be lit when the RCM3365/RCM3375 is mounted on the Prototyping 

Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into 

the PC and the PROG connector, not the DIAG connector, is plugged in to the program-

ming port on the RCM3365/RCM3375 with the marked (colored) edge of the program-

ming cable towards pin 1 of the programming header.

• Ensure that the RCM3365/RCM3375 module is firmly and correctly installed in its 

connectors on the Prototyping Board.

• Dynamic C uses the COM port specified during installation. Select a different COM 

port within Dynamic C. From the Options menu, select Project Options, then select 

Communications. Select another COM port from the list, then click OK. Press 

<Ctrl-Y> to force Dynamic C to recompile the BIOS. If Dynamic C still reports it is 

unable to locate the target system, repeat the above steps until you locate the COM port 

used by the programming cable.

If Dynamic C appears to compile the BIOS successfully, but you then receive a communi-

cation error message when you compile and load the sample program, it is possible that 

your PC cannot handle the higher program-loading baud rate. Try changing the maximum 

download rate to a slower baud rate as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > 
Communications menu. Select a slower Max download baud rate.

If a program compiles and loads, but then loses target communication before you can 

begin debugging, it is possible that your PC cannot handle the default debugging baud 

rate. Try lowering the debugging baud rate as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > 
Communications menu. Choose a lower debug baud rate.
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2.3.2  Running Dynamic C via Ethernet Cables

The firmware needed to run RabbitSys has been preloaded on RCM3365 RabbitCore 

modules sold for use with Dynamic C RabbitSys. The software from the Dynamic C and 

the Dynamic C RabbitSys CDs must be installed on your PC. A system running RabbitSys 

can be connected to a DHCP network using straight-through Ethernet cables, or it can be 

connected directly to the PC via an Ethernet crossover cable.

• If you are connecting to a network with a DHCP server, use a CAT 5/6 straight-through 

Ethernet cable to connect the PC or workstation to the network, and connect the 

Ethernet jack on the RCM3365 to the network using a second CAT 5/6 straight-through 

Ethernet cable.

• If your PC or workstation is running a DHCP server, connect the CAT 5/6 Ethernet 

crossover cable from the PC or workstation directly to the Ethernet jack on the 

RCM3365. Follow the instructions below for a straight-through Ethernet cable.

TIP: It is recommended that you use one of the above options for a PC/workstation or 

network with a DHCP server or the serial cable programming option when you are 

using the RCM3365 for the first time since these options are easier to set up and run.

• If your PC/workstation does not have a DHCP server, you will have to enter the TCP/IP 

parameters into the RCM3365 module and on to the PC, notebook, or workstation. See 

Appendix E for more information on this option.

Using DHCP Network with Straight-Through Ethernet Cables

Enable separate instruction and data spaces and select “Compile program in RabbitSys user 

mode” from the Dynamic C Options > Project Options > Compiler menu.

Before you compile and run a program via the Ethernet for the first time via a DHCP net-

work, you must run the rdiscover utility by double-clicking it on your PC desktop. Your 

PC must be connected to the same DHCP network as the RCM3365. The utility will open a 

window and list the MAC addresses for any RabbitSys boards connected to the network.

Select a board from the list to display additional information such as the board’s Internet 

address. This is the IP address to enter when you access the Dynamic C Options > Project 

Options > Communications menu to select “Use TCP/IP Connection.” You must also 

enter “32023” for the Control Port and the default login values of “admin” and “pass-

word.”

2.3.2.1  Run a Sample Program

Use the File menu to open the sample program PONG.C, which is in the Dynamic C 

SAMPLES folder. Press function key F9 to compile and run the program. The STDIO 

window will open on your PC and will display a small square bouncing around in a box.

This program shows that the CPU is working. The sample program described in 

Section 6.5, “Run the PINGME.C Sample Program,” tests the TCP/IP portion of the board.
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2.3.2.2  Troubleshooting

If the rdiscover utility could not find your RCM3365:

• Check that your network has a DHCP server, and that the RCM3365 and your PC are 

connected to the same network.

• If you compiled and ran a sample program with the RabbitSys project option disabled, 

you may have overwritten the RabbitSys binary file. Use the serial programming cable 

to connect programming header J1 on the RCM3365 to your PC COM port to reload 

the RabbitSys binary file via the Dynamic C Compile > Reload RabbitSys binary 

menu.

If the rdiscover utility could not find your RCM3365, and you were unable to reload the 

RabbitSys binary file, your RCM3365 does not have the firmware to support Dynamic C 

RabbitSys and cannot be used with Dynamic C RabbitSys.

If Dynamic C returns an error message, check that the RCM3365 is powered correctly. The 

red CORE LED on the Prototyping Board should be lit when the RCM3365 is mounted on 

the Prototyping Board and the AC adapter is plugged in. Ensure that the RCM3365 mod-

ule is firmly and correctly installed in its connectors on the Prototyping Board.

2.4  Where Do I Go From Here?

If the sample program ran fine, you are now ready to go on to other sample programs and 

to develop your own applications. The source code for the sample programs is provided to 

allow you to modify them for your own use. The RCM3365/RCM3375 User’s Manual 

also provides complete hardware reference information and describes the software func-

tion calls for the RCM3365 and the RCM3375, the Prototyping Board, and the optional 

LCD/keypad module.

For advanced development topics, refer to the Dynamic C User’s Manual, the Dynamic C 

RabbitSys User’s Manual, and the Dynamic C TCP/IP User’s Manual, also in the online 

documentation set.

2.4.1  Technical Support

NOTE: If you purchased your RCM3365/RCM3375 through a distributor or through a 

Rabbit partner, contact the distributor or partner first for technical support.

If there are any problems at this point:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ 

and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.
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3.  RUNNING SAMPLE PROGRAMS

To develop and debug programs for the RCM3365/RCM3375

(and for all other Rabbit hardware), you must install and use

Dynamic C.

3.1  Introduction

To help familiarize you with the RCM3365 and RCM3375 modules, Dynamic C includes 

several sample programs. Loading, executing and studying these programs will give you a 

solid hands-on overview of the RCM3365/RCM3375’s capabilities, as well as a quick 

start using Dynamic C as an application development tool.

NOTE: The sample programs assume that you have at least an elementary grasp of the C 

programming language. If you do not, see the introductory pages of the Dynamic C 

User’s Manual for a suggested reading list.

More complete information on Dynamic C is provided in the Dynamic C User’s Manual.

In order to run the sample programs discussed in this chapter and elsewhere in this manual,

1. Your RCM3365/RCM3375 module must be plugged in to the Prototyping Board as 

described in Chapter 2, “Getting Started.”

2. Dynamic C must be installed and running on your PC.

3. The RCM3365/RCM3375 module must be connected to your PC either through the 

serial programming cable or through an Ethernet cable/network if you have a 

RabbitSys-enabled RCM3365.

4. Power must be applied to the RCM3365/RCM3375 through the Prototyping Board.

Refer to Chapter 2, “Getting Started,” if you need further information on these steps.

Since the RCM3365 and the RCM3375 run at 44.2 MHz and are equipped with a fast pro-

gram execution SRAM, remember to allow the compiler to run the application in the fast 

program execution SRAM by selecting Code and BIOS in Flash, Run in RAM from the 

Dynamic C Options > Project Options > Compiler menu.

To run a sample program, open it with the File menu, then press function key F9 to com-

pile and run the program.
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