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1.  INTRODUCTION

The RCM4200 series of RabbitCore modules is one of the next

generation of core modules that take advantage of new Rabbit®

4000 features such as hardware DMA, clock speeds of up to

60 MHz, I/O lines shared with up to six serial ports and four

levels of alternate pin functions that include variable-phase

PWM, auxiliary I/O, quadrature decoder, and input capture.

Coupled with more than 500 new opcode instructions that help to

reduce code size and improve processing speed, this equates to a

core module that is fast, efficient, and the ideal solution for a wide

range of embedded applications. The RCM4200 also features an

integrated 10/100Base-T Ethernet port, an A/D converter, and a

serial flash memory for mass storage.

Each production model has a Development Kit with the essentials

that you need to design your own microprocessor-based system,

and includes a complete Dynamic C software development sys-

tem. The Development Kits also contains a Prototyping Board

that will allow you to evaluate the specific RCM4200 module and

to prototype circuits that interface to the module. You will also

be able to write and test software for the RCM4200 modules.

Throughout this manual, the term RCM4200 refers to the complete series of RCM4200 

RabbitCore modules unless other production models are referred to specifically.

The RCM4200 has a Rabbit 4000 microprocessor operating at up to 58.98 MHz, static 

RAM, flash memory, serial flash mass-storage option, an 8-channel A/D converter, two 

clocks (main oscillator and timekeeping), and the circuitry necessary for reset and man-

agement of battery backup of the Rabbit 4000’s internal real-time clock and 512K of static 

RAM. One 50-pin header brings out the Rabbit 4000 I/O bus lines, parallel ports, A/D 

converter channels, and serial ports.

The RCM4200 receives its +3.3 V power from the customer-supplied motherboard on 

which it is mounted. The RCM4200 can interface with all kinds of CMOS-compatible 

digital devices through the motherboard.
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1.1  RCM4200 Features

• Small size: 1.84" × 2.42" × 0.84" (47 mm × 61 mm × 21 mm) 

• Microprocessor: Rabbit 4000 running at up to 58.98 MHz

• Up to 33 general-purpose I/O lines configurable with up to four alternate functions

• 3.3 V I/O lines with low-power modes down to 2 kHz

• Up to six CMOS-compatible serial ports — four ports are configurable as a clocked 

serial ports (SPI), and two ports are configurable as SDLC/HDLC serial ports.

• Combinations of up to eight single-ended or four differential 12-bit analog inputs 

(RCM4200 only)

• Alternate I/O bus can be configured for 8 data lines and 6 address lines (shared with 

parallel I/O lines), I/O read/write

• 512K flash memory, 512K SRAM, and a fixed mass-storage flash-memory option that 

may be used with the standardized directory structure supported by the Dynamic C FAT 

File System module

• Real-time clock

• Watchdog supervisor
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There are two RCM4200 production models. Table 1 summarizes their main features.

The RCM4200 is programmed over a standard PC USB port through a programming cable 

supplied with the Development Kit.

NOTE:  The RabbitLink cannot be used to program RabbitCore modules based on the 

Rabbit 4000 microprocessor.

Appendix A provides detailed specifications for the RCM4200.

Table 1.  RCM4200 Features

Feature RCM4200 RCM4210

Microprocessor Rabbit® 4000 at 58.98 MHz Rabbit® 4000 at 29.49 MHz

Data SRAM 512K

Fast Program-Execution 

SRAM
512K —

Flash Memory (program) 512K

Flash Memory

(mass data storage)
8 Mbytes (serial flash) 4 Mbytes (serial flash)

A/D Converter 12 bits —

Serial Ports

4 high-speed, CMOS-compatible 

ports:

• all 4 configurable as asynchro-

nous (with IrDA), 4 as clocked 

serial (SPI)

• 1 asynchronous clocked serial 

port shared with programming 

port

• 1 clocked serial port shared with 

serial flash

• 1 clocked serial port shared with 

A/D converter

5 high-speed, CMOS-compatible 

ports:

• all 5 configurable as asynchro-

nous (with IrDA), 4 as clocked 

serial (SPI), and 1 as 

SDLC/HDLC

• 1 clocked serial port shared with 

serial flash

• 1 asynchronous clocked serial 

port dedicated for programming
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1.2  Advantages of the RCM4200

• Fast time to market using a fully engineered, “ready-to-run/ready-to-program” micro-

processor core.

• Competitive pricing when compared with the alternative of purchasing and assembling 

individual components.

• Easy C-language program development and debugging

• Rabbit Field Utility to download compiled Dynamic C .bin files, and cloning board 

options for rapid production loading of programs.

• Generous memory size allows large programs with tens of thousands of lines of code, 

and substantial data storage.
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1.3  Development and Evaluation Tools

1.3.1  RCM4200 Development Kit

The RCM4200 Development Kit contains the hardware essentials you will need to use the 

RCM4200 module. The items in the Development Kit and their use are as follows.

• RCM4200 module.

• Prototyping Board.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., 

U.K., and European style plugs). Development Kits sold in North America may contain 

an AC adapter with only a North American style plug.

• USB programming cable with 10-pin header.

• 10-pin header to DB9 serial cable.

• Dynamic C® CD-ROM, with complete product documentation on disk.

• Getting Started instructions.

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Figure 1.  RCM4200 Development Kit

Rabbit and Dynamic C are registered trademarks of Rabbit Semiconductor Inc.

RabbitCore RCM4200

The RCM4200 RabbitCore module features an onboard A/D converter and 10/100Base-T Ethernet, allow-

ing you to create a low-cost, low-power, network as part of your control solution for your embedded 

application. These Getting Started instructions included with the Development Kit will help you get your 

RCM4200 up and running so that you can run the sample programs to explore its capabilities and develop 

your own applications.

Development Kit Contents

The RCM4200 Development Kit contains the following items:

• RCM4200 module.

• Prototyping Board.

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and European 

style plugs). Development Kits sold in North America may contain an AC adapter with only a North 

American style plug.

• USB programming cable with 10-pin header.

• 10-pin header to DB9 serial cable.

• Dynamic C® CD-ROM, with complete product documentation on disk.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws and washers.

• A bag of accessory parts for use on the Prototyping 

Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for 

the latest information on peripherals and accessories that 

are available for all RCM4200 RabbitCore module models.

Installing Dynamic C®

Insert the CD from the Development Kit in 

your PC’s CD-ROM drive. If the installation 

does not auto-start, run the setup.exe pro-

gram in the root directory of the Dynamic C 

CD. Install any Dynamic C modules after you 

install Dynamic C.
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1.3.2  Software

The RCM4200 is programmed using version 10.09 or later of Dynamic C. A compatible 

version is included on the Development Kit CD-ROM.

Rabbit Semiconductor also offers add-on Dynamic C modules containing the popular 

µC/OS-II real-time operating system, the FAT file system, as well as PPP, Advanced 

Encryption Standard (AES), and other select libraries. In addition to the Web-based 

technical support included at no extra charge, a one-year telephone-based technical 

support module is also available for purchase. Visit our Web site at www.rabbit.com or 

contact your Rabbit Semiconductor sales representative or authorized distributor for 

further information.

1.3.3  Online Documentation

The online documentation is installed along with Dynamic C, and an icon for the docu-

mentation menu is placed on the workstation’s desktop. Double-click this icon to reach the 

menu. If the icon is missing, use your browser to find and load default.htm in the docs 

folder, found in the Dynamic C installation folder.

The latest versions of all documents are always available for free, unregistered download 

from our Web sites as well.
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2.  GETTING STARTED

This chapter describes the RCM4200 hardware in more detail, and

explains how to set up and use the accompanying Prototyping Board.

NOTE: This chapter (and this manual) assume that you have the RCM4200 Development 

Kit. If you purchased an RCM4200 module by itself, you will have to adapt the infor-

mation in this chapter and elsewhere to your test and development setup.

2.1  Install Dynamic C

To develop and debug programs for the RCM4200 series of modules (and for all other 

Rabbit Semiconductor hardware), you must install and use Dynamic C.

If you have not yet installed Dynamic C version 10.09 (or a later version), do so now by 

inserting the Dynamic C CD from the Development Kit in your PC’s CD-ROM drive. If 

autorun is enabled, the CD installation will begin automatically.

If autorun is disabled or the installation does not start, use the Windows Start | Run menu 

or Windows Disk Explorer to launch setup.exe from the root folder of the CD-ROM.

The installation program will guide you through the installation process. Most steps of the 

process are self-explanatory.

Dynamic C uses a COM (serial) port to communicate with the target development system. 

The installation allows you to choose the COM port that will be used. The default selec-

tion is COM1. You may select any available port for Dynamic C’s use. If you are not cer-

tain which port is available, select COM1. This selection can be changed later within 

Dynamic C.

NOTE: The installation utility does not check the selected COM port in any way. Speci-

fying a port in use by another device (mouse, modem, etc.) may lead to a message such 

as "could not open serial port" when Dynamic C is started.

Once your installation is complete, you will have up to three new icons on your PC desk-

top. One icon is for Dynamic C, another opens the documentation menu, and the third is for 

the Rabbit Field Utility, a tool used to download precompiled software to a target system.

If you have purchased any of the optional Dynamic C modules, install them after installing 

Dynamic C. The modules may be installed in any order. You must install the modules in 

the same directory where Dynamic C was installed.
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2.2  Hardware Connections

There are three steps to connecting the Prototyping Board for use with Dynamic C and the 

sample programs:

1. Prepare the Prototyping Board for Development.

2. Attach the RCM4200 module to the Prototyping Board.

3. Connect the programming cable between the RCM4200 and the PC.

4. Connect the power supply to the Prototyping Board.

2.2.1  Step 1 — Prepare the Prototyping Board for Development

Snap in four of the plastic standoffs supplied in the bag of accessory parts from the Devel-

opment Kit in the holes at the corners as shown in Figure 2.

Figure 2.  Insert Standoffs
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2.2.2  Step 2 — Attach Module to Prototyping Board

Turn the RCM4200 module so that the mounting holes line up with the corresponding 

holes on the Prototyping Board. Insert the metal standoffs as shown in Figure 3, secure 

them from the bottom using two screws and washers, then insert the module’s header J2 

on the bottom side into socket RCM1 on the Prototyping Board.

Figure 3.  Install the Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J2 of the module exactly with 

socket RCM1 on the Prototyping Board. The header pins may become bent or damaged 

if the pin alignment is offset, and the module will not work. Permanent electrical dam-

age to the module may also result if a misaligned module is powered up.

Press the module’s pins gently into the Prototyping Board socket—press down in the area 

above the header pins. For additional integrity, you may secure the RCM4200 to the stand-

offs from the top using the remaining two screws and washers.
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2.2.3  Step 3 — Connect Programming Cable

The programming cable connects the module to the PC running Dynamic C to download 

programs and to monitor the module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J1 on 

the RCM4200 as shown in Figure 4. Be sure to orient the marked (usually red) edge of the 

cable towards pin 1 of the connector. (Do not use the DIAG connector, which is used for a 

normal serial connection.)

Figure 4.  Connect Programming Cable and Power Supply

NOTE: Never disconnect the programming cable by pulling on the ribbon cable. 

Carefully pull on the connector to remove it from the header.

NOTE: Either a serial or a USB programming cable was supplied with the Development 

Kit. If you have a serial programming cable, an RS-232/USB converter (Rabbit Part 

No. 20-151-0178) is available to allow you to use the serial programming cable with a 

USB port.

Depending on the programming cable, connect the other end to a COM port or a USB port 

on your PC.
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If you are using a USB programming cable, your PC should recognize the new USB hard-

ware, and the LEDs in the shrink-wrapped area of the programming cable will flash — if 

you get an error message, you will have to install USB drivers. Drivers for Windows XP 

are available in the Dynamic C Drivers\Rabbit USB Programming Cable\

WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for 

other operating systems are available online at www.ftdichip.com/Drivers/VCP.htm.

2.2.4  Step 4 — Connect Power

Once all the other connections have been made, you can connect power to the Prototyping 

Board.

If you have the universal AC adapter, prepare the AC adapter for the country where it will 

be used by selecting the appropriate plug. Snap in the top of the plug assembly into the slot 

at the top of the AC adapter as shown in Figure 4, then press down on the plug until it 

clicks into place.

Connect the AC adapter to 3-pin header J1 on the Prototyping Board as shown in Figure 4 

above. The connector may be attached either way as long as it is not offset to one side—

the center pin of J1 is always connected to the positive terminal, and either edge pin is 

ground.

Plug in the AC adapter. The PWR LED on the Prototyping Board next to the power con-

nector at J1 should light up. The RCM4200 and the Prototyping Board are now ready to be 

used.

NOTE: A RESET button is provided on the Prototyping Board next to the battery holder 

to allow a hardware reset without disconnecting power.

To power down the Prototyping Board, unplug the power connector from J1. You should 

disconnect power before making any circuit adjustments in the prototyping area, changing 

any connections to the board, or removing the RCM4200 from the Prototyping Board.
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2.3  Run a Sample Program

Once the RCM4200 is connected as described in the preceding pages, start Dynamic C by 

double-clicking on the Dynamic C icon on your desktop or in your Start menu. For the 

RCM4200 model, select Code and BIOS in Flash, Run in RAM on the “Compiler” tab in the 

Dynamic C Options > Project Options menu. (Select Code and BIOS in Flash for the 

RCM4210.) Click OK.

If you are using a USB port to connect your computer to the RCM4200, click on the 

“Communications” tab and verify that Use USB to Serial Converter is selected to sup-

port the USB programming cable. Click OK. You may have to determine which COM port 

was assigned to the RS-232/USB converter. Open Control Panel > System > Hardware > 

Device Manager > Ports and identify which COM port is used for the USB connection. 

In Dynamic C, select Options > Project Options, then select this COM port on the 

Communications tab, then click OK. You may type the COM port number followed by 

Enter on your computer keyboard if the COM port number is outside the range on the 

dropdown menu.

Now find the file PONG.C, which is in the Dynamic C SAMPLES folder. To run the pro-

gram, open it with the File menu, compile it using the Compile menu, and then run it by 

selecting Run in the Run menu. The STDIO window will open on your PC and will dis-

play a small square bouncing around in a box.

2.3.1  Troubleshooting

If you receive the message No Rabbit Processor Detected, the programming 

cable may be connected to the wrong COM port, a connection may be faulty, or the target 

system may not be powered up. First, check to see that the power LED on the Prototyping 

Board is lit. If the LED is lit, check both ends of the programming cable to ensure that it is 

firmly plugged into the PC and the programming header on the RCM4200 with the marked 

(colored) edge of the programming cable towards pin 1 of the programming header. Ensure 

that the module is firmly and correctly installed in its connectors on the Prototyping Board.

If Dynamic C appears to compile the BIOS successfully, but you then receive a communi-

cation error message when you compile and load a sample program, it is possible that your 

PC cannot handle the higher program-loading baud rate. Try changing the maximum 

download rate to a slower baud rate as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > 

Communications menu. Select a slower Max download baud rate.

If a program compiles and loads, but then loses target communication before you can 

begin debugging, it is possible that your PC cannot handle the default debugging baud 

rate. Try lowering the debugging baud rate as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > 

Communications menu. Choose a lower debug baud rate.
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If there are no faults with the hardware, check that you have selected the correct COM port 

within Dynamic C as explained for the USB port above. Press <Ctrl-Y> to force Dynamic C 

to recompile the BIOS. If Dynamic C still reports it is unable to locate the target system, 

repeat the above steps for another available COM port. You should receive a Bios 

compiled successfully message once this step is completed successfully. 

2.4  Where Do I Go From Here?

If the sample program ran fine, you are now ready to go on to the sample programs in 

Chapter 3 and to develop your own applications. The sample programs can be easily 

modified for your own use. The user's manual also provides complete hardware reference 

information and software function calls for the RCM4200 series of modules and the 

Prototyping Board.

For advanced development topics, refer to the Dynamic C User’s Manual, also in the 

online documentation set.

2.4.1  Technical Support

NOTE: If you purchased your RCM4200 through a distributor or through a Rabbit partner, 

contact the distributor or partner first for technical support.

If there are any problems at this point:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Semiconductor Technical Bulletin Board and forums at 

www.rabbit.com/support/bb/ and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.
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3.  RUNNING SAMPLE PROGRAMS

To develop and debug programs for the RCM4200 (and for all

other Rabbit Semiconductor hardware), you must install and use

Dynamic C. This chapter provides a tour of its major features

with respect to the RCM4200.

3.1  Introduction

To help familiarize you with the RCM4200 modules, Dynamic C includes several sample 

programs. Loading, executing and studying these programs will give you a solid hands-on 

overview of the RCM4200’s capabilities, as well as a quick start with Dynamic C as an 

application development tool.

NOTE: The sample programs assume that you have at least an elementary grasp of ANSI C. 

If you do not, see the introductory pages of the Dynamic C User’s Manual for a sug-

gested reading list.

In order to run the sample programs discussed in this chapter and elsewhere in this manual,

1. Your module must be plugged in to the Prototyping Board as described in Chapter 2, 

“Getting Started.”

2. Dynamic C must be installed and running on your PC.

3. The programming cable must connect the programming header on the module to your 

PC.

4. Power must be applied to the module through the Prototyping Board.

Refer to Chapter 2, “Getting Started,” if you need further information on these steps.

To run a sample program, open it with the File menu (if it is not still open), then compile 

and run it by pressing F9.

Each sample program has comments that describe the purpose and function of the pro-

gram. Follow the instructions at the beginning of the sample program.

More complete information on Dynamic C is provided in the Dynamic C User’s Manual.
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3.2  Sample Programs

Of the many sample programs included with Dynamic C, several are specific to the 

RCM4200 modules. These programs will be found in the SAMPLES\RCM4200 folder.

• CONTROLLED.C—Demonstrates use of the digital outputs by having you turn LEDs 

DS2 and DS3 on the Prototyping Board on or off from the STDIO window on your PC.

Parallel Port B bit 2 = LED DS2

Parallel Port B bit 3 = LED DS3

Once you compile and run CONTROLLED.C, the following display will appear in the 

Dynamic C STDIO window.

Press “2” or “3” on your keyboard to select LED DS2 or DS3 on the Prototyping 

Board. Then follow the prompt in the Dynamic C STDIO window to turn the LED ON 

or OFF. A logic low will light up the LED you selected.

• FLASHLED1.C—demonstrates the use of assembly language to flash LEDs DS2 and 

DS3 on the Prototyping Board at different rates. Once you have compiled and run this 

program, LEDs DS2 and DS3 will flash on/off at different rates.

• FLASHLED2.C—demonstrates the use of cofunctions and costatements to flash LEDs 

DS2 and DS3 on the Prototyping Board at different rates. Once you have compiled and 

run this program, LEDs DS2 and DS3 will flash on/off at different rates.
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• TAMPERDETECTION.C—demonstrates how to detect an attempt to enter the bootstrap 

mode. When an attempt is detected, the battery-backed onchip-encryption RAM on the 

Rabbit 4000 is erased. This battery-backed onchip-encryption RAM can be useful to 

store data such as an AES encryption key from a remote location.

This sample program shows how to load and read the battery-backed onchip-encryption 

RAM and how to enable a visual indicator.

Once this sample is compiled and running (you pressed the F9 key while the sample 

program is open), remove the programming cable and press the reset button on the 

Prototyping Board to reset the module. LEDs DS2 and DS3 will be flashing on and off.

Now press switch S2 to load the battery-backed RAM with the encryption key. The 

LEDs are now on continuously. Notice that the LEDs will stay on even when you press 

the reset button on the Prototyping Board.

Reconnect the programming cable briefly and unplug it again to simulate an attempt to 

access the onchip-encryption RAM. The LEDs will be flashing because the battery-

backed onchip-encryption RAM has been erased. Notice that the LEDs will continue 

flashing even when you press the reset button on the Prototyping Board.

You may press switch S2 again and repeat the last steps to watch the LEDs.

• TOGGLESWITCH.C—demonstrates the use of costatements to detect switch presses 

using the press-and-release method of debouncing. LEDs DS2 and DS3 on the Proto-

typing Board are turned on and off when you press switches S2 and S3. S2 and S3 are 

controlled by PB4 and PB5 respectively.

Once you have loaded and executed these five programs and have an understanding of 

how Dynamic C and the RCM4200 modules interact, you can move on and try the other 

sample programs, or begin building your own.
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3.2.1  Use of Serial Flash

The following sample programs can be found in the SAMPLES\RCM4200\Serial_Flash 

folder.

• SERIAL_FLASHLOG.C—This program runs a simple Web server and stores a log of 

hits on the home page of the serial flash “server.” This log can be viewed and cleared 

from a browser at http://10.10.6.100/. You will likely have to first “configure” your net-

work interface card for a “10Base-T Half-Duplex,” “100Base-T Half-Duplex,” or an 

“Auto-Negotiation” connection on the “Advanced” tab, which is accessed from the 

control panel (Start > Settings > Control Panel) by choosing Network 

Connections.

• SFLASH_INSPECT.C—This program is a handy utility for inspecting the contents of a 

serial flash chip. When the sample program starts running, it attempts to initialize a 

serial flash chip on Serial Port C. Once a serial flash chip is found, the user can perform 

five different commands to print out the contents of a specified page, set all bytes on 

the specified page to a single random value, clear (set to zero) all the bytes in a speci-

fied page, set all bytes on the specified page to a given value, or save user-specified text 

to a selected page.
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3.2.2  Serial Communication

The following sample programs are found in the SAMPLES\RCM4200\SERIAL folder.

• FLOWCONTROL.C—This program demonstrates how to configure Serial Port D for 

CTS/RTS flow control with serial data coming from Serial Port C (TxC) at 115,200 bps. 

The serial data received are displayed in the STDIO window.

To set up the Prototyping Board, you will need to tie TxD and RxD 

together on the RS-232 header at J4, and you will also tie TxC and 

RxC together using the jumpers supplied in the Development Kit as 

shown in the diagram.

A repeating triangular pattern should print out in the STDIO window. 

The program will periodically switch flow control on or off to demonstrate the effect of 

flow control.

If you have two Prototyping Boards with modules, run this sample program on the 

sending board, then disconnect the programming cable and reset the sending board so 

that the module is operating in the Run mode. Connect TxC, TxD, and GND on the 

sending board to RxC, RxD, and GND on the other board, then, with the programming 

cable attached to the other module, run the sample program.

• PARITY.C—This program demonstrates the use of parity modes by 

repeatedly sending byte values 0–127 from Serial Port C to Serial Port D. 

The program will switch between generating parity or not on Serial 

Port C. Serial Port D will always be checking parity, so parity errors 

should occur during every other sequence.

To set up the Prototyping Board, you will need to tie TxC and RxD together on the 

RS-232 header at J4 using one of the jumpers supplied in the Development Kit as 

shown in the diagram.

The Dynamic C STDIO window will display the error sequence.

• SERDMA.C—This program demonstrates using DMA to transfer data from a circular 

buffer to the serial port and vice versa. The Dynamic C STDIO window is used to view or 

clear the buffer.

Before you compile and run the sample program, you 

will need to connect the RS-232 header at J4 to your PC 

as shown in the diagram using the serial to DB9 cable 

supplied in the Development Kit.

Once you have compiled and run the sample program, 

start Tera Term or another terminal emulation program 

to connect to the selected PC serial port at a baud rate of 

115,200 bps. You can observe the output in the Dynamic C 

STDIO window as you type in Tera Term, and you can 

also use the Dynamic C STDIO window to clear the 

buffer.

The Tera Term utility can be downloaded from 

hp.vector.co.jp/authors/VA002416/teraterm.html.
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