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Seeeduino LoRaWAN

SKU 102010128

LoRaWAN Class A/C

Ultra long range communication

Ultra low power consumption

Arduino programming (based on Arduino Zero bootloader)
Embeded with lithim battery management chip

4 Grove connectors onboard

Description

Seeeduino LoRaWAN is an Arduino development board with LoRaWan protocol embeded,
through which you can get started quickly to experience LLoRa's advantage in the field of IoT.

Based on communication module RHF76-052AM, Seeeduino LoRaWAN is compatible with
LoRaWAN Class A/C and supports a variety of communication frequencies. The 4 onboard

standard grove connectors allow Seeeduino LoRaWan to connect with hundreds of grove sensors



and actuators for Seeeduino conveniently, as a result, users are able to be more focus on the

application itself without worrying about the compatibility issue between different modules.

In addition, the board has embeded an integrated lithium battery management chip that allows
the board to be charged by USB interface. In low consumption mold, a full charged lithium
battery can power the board for several months. By using Seeeduino LoRaWAN. You can build

an IoT application very quickly.

We also offer another version with GPS module embeded, click here to find the Seeeduino
LoRaWAN W/GPS.

Features

LoRaWAN Class A/C

Ultra long range communication

Ultra low power consumption

Arduino programming (based on Arduino Zero bootloader)
Embeded with lithim battery management chip

4 Grove connectors onboard

Seeeduino LoRaWAN

Introduction

Seeeduino LoRaWAN is an Arduino development board with LoRaWan protocol embedded,

through which you can get started quickly to experience LoRa’s advantage in the field of IoT.



Based on the communication module RHF76-052AM, Seeeduino LoRaWAN is compatible with

LoRaWAN Class A/C and supports a variety of communication frequencies.

The 4 onboard standard Grove connectors allow Seeeduino LoRaWan to connect with hundreds
of Grove sensors and actuators from Seeedstudio conveniently, as a result, users are able to be
more focus on the application itself without worrying about the compatibility issue between
different modules. In addition, the board has embedded an integrated lithium battery
management chip that allows the board to be charged by USB interface. In low consumption

mode, a full charged lithium battery can power the board for several months.

If you want to build an IoT application quickly, Seeeduino LoRaWAN is your best choice.

Product Version Released Date
Seeeduino LoORaWAN Dec 20, 2016
Seeeduino LoRaWAN W/GPS Dec 20, 2016

Tip

Seeeduino LoRaWAN W/GPS is consist of GPS module.

Features

Minimum current (3.7V lipo battery) - 2mA
Minimum current (3.7V lipo battery & remove PWR LED) - 650 uA

Arduino/Processor

ATSAMD21G18 @ 48MHz with 3.3V logic/power

Arduino compatible (based on Arduino Zero bootloader)

Embedded with lithium battery management chip and status indicator led
20 GPIOs

4 on-board Grove connectors

18 x PWM pins

6 x analog inputs

1 x analog output (AO)

3.3V regulator with 200mA output

Reset button



e © e ¢ ¢ O O © o o

LoRaWAN/RHF76-052

1.45uA sleep current in WOR mode (Spec of the modules, not the board)
High link budget of 160dB. -140dBm sensitivity and 19dBm Output power.
Dual band, 434/470MHz and 868/915MHz

19dBm@434MHz/470MHz

14dBm@868MHz/915MHz

Support LoRaWAN protocol, Class A/C

Ultra long range communication

Ultra low power consumption

Firmware upgrade

Small size: 23mm X 28mm with 33 pin SMT package

Warning

Unlike most Arduino & Genuino boards, the Zero runs at 3.3V. The maximum voltage that the
I/O pins can tolerate is 3.3V. Applying voltages higher than 3.3V to any 1/O pin could damage
the board.

Specification
Item Value
Microcontroller ATSAMD21G18, 32-Bit ARM Cortex MO+
Operating Voltage 3.3V
Digital I/0 Pins 20
PWM Pins All but pins 2 and 7
UART 2 (Native and Programming)
Analog Input Pins 6, 12-bit ADC channels
Analog Output Pins 1, 10-bit DAC

External Interrupts All pins except pin 4



Item Value

DC Current per 1/0 Pin 7 mA

Flash Memory 256 KB

SRAM 32 KB

EEPROM None

Clock Speed 48 MHz

Lenght 68 mm

Width 53 mm

Weight 19.6g(without GPS), 19.9(with GPS)

Application Ideas

Internet of Things
Smart House
Security

Smart Grid
Intelligent Farm
Intelligent Park

Tip
Use Grove modules to expand your application
There are 4 Grove connects on board. If this is your first time to hear about Grove, please put

had on Grove System for more details. In brief, Groves is hundreds of sensor that in standard

style, which is consist of sensors, actuators, displays as well as communication.
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Hardware Overview

L
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. Micro USB - Programming and supply power to the board
. Grove connectors

. JST2.0 Lipo battery input (3.7V) and charge status led
. DFU Button - Firmware mode button

. Reset Button

. Arduino Pinout

. ICSP pins

. Firmware mode led

9. Wire antenna

A. uFL antenna

B. RF module - RHF76-052AM

C. ARM Cortex MO processor - ATSAMD21G18

D. LEDs

RX/TX - blink when data on UART(from/to USB)

L - an led connect to D13

PWR — power

AU AW =



Pin Map

Pin
Name

0

10

11

12

13

SDA

SCL

A0

Al

A2

A3

A4

GPIO

Num

#0

#1

#2

#3

#4

#5

#6

#7

#3

#9

#10

#11

#12

#13

#20

#21

#A0

#A1

#A2

#A3

#A4

External
Interrupt

YES
YES
YES

YES

YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES

YES

PWM

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

YES

Analog
In

YES

YES

YES

YES

YES

Analog .
Out Function
RX(Seriall)
TX(Seriall)
SPI_MOSI
SPI_MISO
SPI_SCK
YES

Voltage of



Pin GPIO External Analog Analog

Name Num Interrupt PWM In Out Function
Battery

A5 #AS YES YES YES Charge
Status

All pins can act as Digital Input and Output

Getting Started - Arduino IDE

This chapter is based on Win10 and Arduino IDE v1.6.0

First you need to install the latest Arduino IDE, and ADD Seeeduino LoRa to your Arduino IDE.

Install the Driver (For Windows)

When the first time to insert the board, you should get a USB COM device name Seeeduino
LoRaWAN that need to install a driver. Click on the below button to download driver for the
board.

Download Driver for Seeeduino LoRaWAN

To make sure the driver was installed successful, open your Device Manager to see if Seeeduino
LoRaWAN exists.



ﬁ Device Manager
File Action View Help

e @ E HFE P EX®

> o Imaging devices
» Keyboards
» g Mice and other pointing devices
» [ Monitors
> ? Metwork adapters
5 @ Portable Devices
v i Ports (COM & LPT)
ﬁ Seeeduino LoRaWAN (COMS3)
> [ Print queues
» ﬂ Processors
> B Software devices
¥ Iq Sound, video and game contrellers
> & Storage controllers

Blink

Now we can upload our first demo - Blink to Seeeduino LoRaWAN.

Open your Arduino IDE and click on File > Examples > 01.Basics > Blink to open the sketch or

copy the blow code:

// the setup function runs once when you press reset or power the board

void setup() {

// initialize digital pin 13 as an output.

pinMode(13, OUTPUT);
}

// the loop function runs over and over
void loop() {
digitalWrite(13, HIGH); // turn the

delay(1000); // wait for
digitalWrite(13, LOW); // turn the
delay(1000); // wait for
}
And Then,

again forever

LED on (HIGH is the voltage Llevel)
a second
LED off by making the voltage LOW
a second

Click on Tools > Board > Seeeduino LoRaWAN
Click on Tools > Port to select a right port number. (Don’t choose COM1)



€2 Blink | Arduino 1.6.9 - (] X

File Edit Sketch| Tools |Help

':»_5‘} t:':jj ﬁ [: Auto Format Ctrl+T
Archive Sketch
Fix Encoding & Reload
Serial Monitor Ctrl+Shift+M Lo
Serial Plotter Ctrl+Shift+L

Board: "Seeeduino LoRaWAN" >
Port: “COM353 (Seeeduino LoRaWAN)" >
Get Board Info

Programmer: "Parallel Programmer”

Burn Bootloader

Seeeduino LoRaWAN on COMS3

Then click on the Upload button on the left-top of Arduino IDE, seconds later the sketch was

uploaded successful.

€ Blink | Arduine 1.6.9 - O X
File Edit Sketch Tools Help

Q0 BEE

Seeeduino LoRaWAN on COMS3

If the uploading is success, you should the some info in red and please the on-board LED, it’s

blinking.



Seeeduino LoRaWAN on COMS3

Battery

You can power the board via a 3.7V Lipo battery. There’s a JST2.0 cable included, use it if you
can’t get a battery with JST2.0 connector.

Make sure the positive and negative end of your battery is connected right, otherwise the board

may be damaged.

Charge status pin and positive pin of the battery had beed connect to A4 and AS, which allow

you to detect the charge status and measure voltage of the battery via coding.

Copy and upload the below code to detect the battery status.

setup

Loop



Charge status return 0 while charging, return 1 while charge done or no battery insert.

Send and Receive Example

There is a well written library for the LoRaW AN modules, for simple applications you even
don’t need to know much about the protocol about LoRa, which is complex and hard to read.
And please note that you till need some acknowledge about LoRa protocol if you want an
advanced application. You don’t need to download the library, it’s included in the package

already. You can open it at File > Examples > LoRaWAN.

You need 2 piece of Seeeduino LoRaWAN to complete this example, one for sending and

another for receiving.

Sending
Open your Arduino IDE and click on File > Examples > LoRaWAN > p2p_tx to open the

sketch or you can copy the code below. This sketch will broadcast a string “Hello World!” every
3000 ms.

include
void (void)
SerialUSB.begin(115200);

lora.init();
lora.initP2PMode(433, SF12, BW125, 8, 8, 20);

=2

void (void)
{
lora.transferPacketP2PMode("Hello World!");
SerialUSB.println("Send string.");

delay(3000);

Receiving

Open your Arduino IDe and click on File > Examples > LoRaWAN > p2p_rx to open the

sketch or you can copy the code below.

#tinclude <LoRaWan.h)|

unsigned char buffer[128] = {0, };




SerialUSB.begin(115200);

lora.init

lora.initP2PMode(433, SF12, BW125, 8, 8, 20);

=

void loop(void)
{

short length = 0;
memset (buffer, 0, 128);
length = lora.receivePacketP2PMode(buffer, 128, &rssi, 1);

if(length)

[ {]
SerialUSB.print("Length is: ");

SerialUSB.println(length);

SerialUSB.print("RSSI is: "),

SerialUSB.println(rssi);

SerialUSB.print("Data is: ");
for(unsigned char i = 0; i < length; i ++)

SerialUSB.print("ex");

SerialUSB.print(buffer[i], HEX);

SerialUSB.print(" ");

SerialUSB.println();

After both of the sketch is well uploaded, open the serial monitor of the receiving board, check if

you can get some data as below.

® : 0
Send

Data is: Hello World! ~
Length is: 12
RS8I is: —20
Data 1s: Hello World!
Length 1s: 12
FSSI 1s: —19
Data is: Hello World!
Length i1s: 12
RS51 1s: —19
Data 1s: Hello World!

W

[] dutezerall Ho line ending < | [115200 bhaud



There will be a gateway kit for LoRa soon, and we will add getting started about APB and
OTAA mode at wiki of the kit.

Examples

We had provide many useful examples. You can open File > Examples > LoRaWan get more

details. Those examples include:

ABP

OTAA
p2p-rx
p2p-tx

GPS Data

This chapter works with Seeeduino LoRaWAN W/GPS only.

Copy below code you Seeeduino LoRaWAN W/GPS.

. ( )5
( .available())
[ {] ________
.write( .read());
[} ____
( .available())
[ {]
write( .read());
i
i

Open Serial Monitor then you will get data from GPS.
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Send

$GPGLL, , ,,, 001052, 799, V, li*7B A
$GPFMC, 001053. 799, V,,,,, 0.00, 0. 00, 060180, , , li*42
$GPVIG, 0. 00, T, , M, 0. 00, It, 0. 00, K, 1*32

$GPGGA, 001053. 799,,,,,0,0,, . M, , M, , #48

$CPGSA AL, svsssrssrsssns *1E

$GPGSY, 1, 1, 00%79

$GPGLL, ,,,, 001053, 799, V, IxTA

$GPEMC, 001054. 799, V,, .., 0.00, 0. 00, 060180, , , 1*45
$GPVIG, 0.00, T, , M, 0. 00, I, 0. 00, K, 1i*32

$GPGGA, 001054. 799, ,,,.0,0,, , M, M, , #4F

$CPGBA, M Lsiiiisvinisivi®IB

$GPGSV, 1, 1, 00479

$GPGLL, , ., , 001054. 799, V, Iix7D

v

Ehutoscroll lesline | 1115200 baud ~

Update firmware

The firmware version of is 2.0.10, if you want to update firmware, few steps need to follow.

If you want to check version of you board, please upload below code to your board.

void setup()
{

Seriall.begin(9600);

SerialUSB.begin(115200);

=

void loop()

while(Seriall.available())

=

SerialUSB.write(Seriall.read());

while(SerialUSB.available())

Seriall.write(SerialUSB.read());

H—‘!

Open your Serial Monitor and INPUT

AT+VER

Then you will get the version of your board.



& COM6 (Seeeduino LoRaWAN) — O X

| | send
HVER: 2.0.10 dm—o

v

Autoscroll Hewline vl lll baud v~

Stepl

Copy and upload below code to your board.

// Update firmware to RHF76-052AM
#include <Arduino.h>

void setup()

{
SerialDBG.begin(115200);
SerialUSB.begin(115200);
}
void Loop()
{
while(SerialDBG.available())
{
SerialUSB.write(SerialDBG.read());
}
while(SerialUSB.available())
{
SerialDBG.write(SerialUSB.read());
}
}

Input AT+VER to get the version of your board. If it’s not the most recent version, please
following below steps to upgrade it.



Step2

Remove the board form USB and reconnect again, then press the DFU Button, after the

Firmware mode led blinking you can go to the next step.

Step3

Click to download the latest firmware, which is a .bin file.

Firmware V2.0.10

Step4

Open PuTTy and connect to the board

@ PuTTY Configuration (Save mode: File) = ] x
Category
=i S_essmn ~ ‘ Basic options for your PuTTY session |
*Laggng Specify the destination you want to connect to
(=l Teminal ——
B Keyboard Serial line Speed
Bel |comsn |[115200 |
-- Features Connection type:
o1 BxraPuTTY ORaw  OTehd  ORogn  OS5H
-- Settings () Cygterm
-- StatusBar
[&- Files Transfer Load. save or delete a stored session
=- Window Saved Sessions
-- Appearance | ‘
__.?z:_‘a:;l::‘ Default Settings |$|
-- Selection i_:‘:‘rl
Colours L
- Hyperinks Delte
(= Connection
--Data
Frowy
- Telnet
Rlogin Close window on exit:
- SSH O Aways O Never (@) Only on clean exit
~ Serial & () Never, Auto-Connect
- Curdem
Poout | | open || cancel

Tip

You can find the latest PuTTy here: http://www.extraputty.com/download.php

Step5S



After connect your board to PuTTy successful, you will find the char ‘C’ print on the monitor
continually. Click on Files Transfer > Ymodem > Send, and select the .bin file we had
downloaded at Step4.

Then the updating is started.

&

Transfering File

FileName: thi76-052am-v2.0.10-20160323
Protocot YMODEM 1K
Packet#: 53/57

-
Transfering ...

00:03:12 Connected  SERIAL/1152008 N1

Resources

Schematics in Eagle

Sketchup file(3D)

CE certification of RHF 76-052
RHF76-052 Firmware V2.0.10
Datasheet of RHF76-052AM

Help us make it better

Thank you for choosing Seeed. A couple of months ago we initiated a project to improve our
documentation system. What you are looking at now is the first edition of the new

documentation system. Comparing to the old one, here is the progresses that we made:

Replaced the old documentation system with a new one that was developed from Mkdocs, a more widely
used and cooler tool to develop documentation system.

Integrated the documentation system with our official website, now you can go to Bazaar and other
section like Forum and Community more conveniently.

Reviewed and rewrote documents for hundreds of products for the system’s first edition, and will
continue migrate documents from old wiki to the new one.



An easy-to-use instruction is as important as the product itself. We are expecting this new system
will improve your experience when using Seeed’s products. However since this is the first
edition, there are still many things need to improve, if you have any suggestions or findings, you
are most welcome to submit the amended version as our contributor or give us suggestions in the

survey below, Please don’t forget to leave your email address so that we can reply.

Happy hacking

Copyright © 2008-2016 Seeed Development Limited All rights reserved



	Contact us

