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Overview

Would you like to add powerful and easy-to-use Bluetooth Low Energy to your wearable

FLORA project? Heck yeah! With BLE now included in modern smart phones and tablets, its

fun to add wireless connectivity. So what you really need is the new Adafruit Flora Bluefruit

LE!

The Flora Bluefruit LE makes it easy to add Bluetooth Low Energy connectivity to your Flora.

Sew 4 traces (or solder 4 wires) and BooM! Bluetooth Low Energy!
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Get started fast with the Bluefruit App

Using our Bluefruit iOS App (http://adafru.it/iCi) or Android App (http://adafru.it/f4G), you can

quickly get your interactive project prototyped by using your iOS or Android phone/tablet as a

controller. We have a color picker (http://adafru.it/iCI),

quaternion/accelerometer/gyro/magnetometer or location (GPS) (http://adafru.it/iCI), and an 8-

button control game pad (http://adafru.it/iCI). After you connect to the Bluefruit, you can send

commands wirelessly in under 10 minutes
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For advanced hackers, they'll be very happy to use the standard Nordic UART RX/TX

connection profile. In this profile, the Bluefruit acts as a data pipe, that can 'transparently'

transmit back and forth from your iOS or Android device. You can use our iOS

App (http://adafru.it/iCi) or Android App (http://adafru.it/f4G), or write your own to communicate

with the UART service (http://adafru.it/iCF).

You can do a lot more too! 

The Bluefruit can also act like an HID Keyboard (http://adafru.it/iCJ) (for devices that

support BLE HID)

Can become a BLE Heart Rate Monitor (http://adafru.it/iCK) (a standard profile for BLE)

- you just need to add the pulse-detection circuitry

Turn it into a UriBeacon (http://adafru.it/iCL), the Google standard for Bluetooth LE

beacons. Just power it and the 'Friend will bleep out a URL to any nearby devices with

the UriBeacon app installed.

Built in over-the-air bootloading capability so we can keep you updated with the hottest

new firmware. (http://adafru.it/iCM) Use any Android or iOS device to get updates and

install them!
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This is the same module and firmware as our BLE UART Friend (http://adafru.it/2479) but in a

nice rounded shape, so you can switch between the two and have the same working code.

This Bluefruit LE does not have the hardware flow control pins so it is best used with a

microcontroller with hardware serial support (like, y'know, the Flora!)
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Pinouts

Power Pads

3.3V: This is the power supply for the module, supply with 3.3V power supply input. You

can dip down to maybe 2.7V and up to 3.6V or so, but regulated 3.3V is ideal

GND: The common/GND pad for power and logic

Data Pads

TX - This is the UART Transmit pin out of the breakout (Bluefruit LE --> Flora RX), it's at

3.3V logic level.

RX - This is the UART Receive pin into the breakout (Flora TX --> Bluefruit LE) it
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requires 3.3V logic level.

These 4 pads are in perfect order to connect directly to your Flora!

Other Pads

MODE: Mode Selection. The Bluefruit has two modes, Command and Data. You can

keep this pin disconnected, and use the slide switch to select the mode. Or, you can

control the mode by setting this pin voltage, it will override the switch setting!  High =

Command Mode, Low = UART/DATA mode. This pin requires 3.3V logic
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Reverse Side

On the back we also have a few breakouts!

Opt. 32 KHz: If you're doing some funky low power work, we wanted to give you the option of

solderin in a 32khz oscillator.  (http://adafru.it/f4U)Our firmware doesn't support it yet but its

there!

SWDCLK: This is the SWD clock pin, 3v logic - for advanced hackers!

SWDIO: This is the SWD data pin, 3v logic - for advanced hackers!

F.RST: This is the factory reset pin. When all else fails and you did something to really weird

out your module, tie this pad to ground while powering up the module and it will factory reset.

You should try the DFU reset method first tho (see that tutorial page)
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Sewing

Sewing the Flora BLE to a Flora is very straight-forward: the four required pads line up so just

sew those in short straight lines from one module to another. the MODE pad is not required for

most uses so you can leave that unconnected.

When you power it on, you should see the red LED on the BLE blink a few times and then

pause & repeat, so you know that it has power!
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Factory Reset

There are several methods that you can use to perform a factory reset on your Bluefruit LE

module if something gets misconfigured, or to delete persistent changes like UriBeacon or

advertising payload changes, etc.

Factory Reset via DFU Button

Once the module is powered up, if you hold the DFU button down for >5 seconds, the blue

LED on the module will start  blinking and the device will perform a factory reset as soon as

you release the DFU button.

FactoryReset Sample Sketch

There is a FactoryReset sample sketch in the Adafruit Bluefruit LE library, which can be

access in the File > Examples > Adafruit_BluefruitLE_nRF51 folder:
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Upload this sketch and open the Serial Monitor and it should perform a factory reset for you:

AT+FACTORYRESET

© Adafruit Industries https://learn.adafruit.com/adafruit-flora-bluefruit-le Page 14 of 68



You can also perform a factory reset by sending the AT+FACTORYRESET command to your

Bluefruit LE module in your favorite terminal emulator or using

the ATCommand (http://adafru.it/iCk) example sketch. Make sure its in command mode first,

then type in:

AT+FACTORYRESET

OK

This command will also cause the device to reset.

Factory Reset via F.RST Test Pad

On the back of the Bluefruit LE UART Friend board there is a test pad that exposes the

Factory Reset pin on the modules (marked F.RST). Setting this pad low when the device is

powered up will cause a factory reset at startup.
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Firmware Updates

We're constantly working on the Bluefruit LE firmware to add new features, and keep up to

date with what customers need and want.

To make sure you stay up to date with those changes, we've included an easy to use over the

air updater on all of our nRF51 based Bluefruit LE modules.

Adafruit Bluefruit LE Connect

Updating your Bluefruit LE device to the latest firmware is as easy as installing Adafruit's

Bluefruit LE Connect application (http://adafru.it/f4G) from the Google Play Store.  (An

updated iOS version with DFU support will be available shortly!)

Any time a firmware update is available, the application will propose to download the latest

binaries and take care of all the details of transferring them to your Bluefruit device, as shown

in the video below:
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Installing Software

In order to try out our demos, you'll need to download the Adafruit BLE library for the nRF51

based modules such as this one (a.k.a. Adafruit_BluefruitLE_nRF51)

You can check out the code here at github, (http://adafru.it/f4V) but its likely easier to just

download by clicking:

Download Adafruit_BluefruitLE_nRF51

http://adafru.it/f4W

Rename the uncompressed folder Adafruit_BluefruitLE_nRF51 and check that the

Adafruit_BluefruitLE_nRF51 folder contains Adafruit_BLE.cpp and Adafruit_BLE.h (as

well as a bunch of other files)

Place the Adafruit_BluefruitLE_nRF51 library folder your arduinosketchfolder/libraries/

folder. 

You may need to create the libraries subfolder if its your first library. Restart the IDE.

We also have a great tutorial on Arduino library installation at:

http://learn.adafruit.com/adafruit-all-about-arduino-libraries-install-use (http://adafru.it/aYM)

After restarting, check that you see the library folder with examples:
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Example Code

We have tons of examples that will get you going with the Bluefruit, and its really easy! Since

we have one library for both wearable and non-wearable Bluefruit's, the example code is the

same but may require some minor tweaks to adjust for Flora.

Most importantly, the flora bluefruit is for use with Hardware Serial only and does not have

flow control pins. Also, we expect you will not use the mode pad so you can keep the switch

set to CMD and then change into Data mode by sending +++ .

Configuring for Flora

For all of the examples, look near the top for a line like this:

//#define BLUEFRUIT_HWSERIAL_NAME           Serial1

and remove the // comment marks. Do the same for:

//Adafruit_BluefruitLE_UART ble(BLUEFRUIT_HWSERIAL_NAME, BLUEFRUIT_UART_MODE_PIN);

Next, remove the code for the SoftwareSerial type, find these lines and delete them:

/* Create the bluefruit object, either software serial... */

SoftwareSerial bluefruitSS = SoftwareSerial(BLUEFRUIT_SWUART_TXD_PIN, BLUEFRUIT_SWUART_RXD_PIN);

Adafruit_BluefruitLE_UART ble(bluefruitSS, BLUEFRUIT_UART_MODE_PIN,

                      BLUEFRUIT_UART_CTS_PIN, BLUEFRUIT_UART_RTS_PIN);

Finally, unless you happen to be using the MODE pad, make sure

BLUEFRUIT_UART_MODE_PIN is set to -1

#define BLUEFRUIT_UART_MODE_PIN         -1   // Not used with FLORA

Same with RTS and CTS, find these lines and set both to -1

#define BLUEFRUIT_UART_CTS_PIN          -1   // Not used with FLORA

#define BLUEFRUIT_UART_RTS_PIN          -1   // Not used with FLORA
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ATCommand

The ATCommand example allows you to execute AT commands from your sketch, and see

the results in the Serial Monitor.  This can be useful for debugging, or just testing different

commands out to see how they work in the real world. It's a good one to start with!

Opening the Sketch

To open the ATCommand sketch, click on the File > Examples >

Adafruit_BluefruitLE_nRF51 folder in the Arduino IDE and select atcommand:

This will open up a new instance of the example in the IDE, as shown below:
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Configuration

Check the Configuration! page earlier to set up the sketch for Software/Hardware UART or

Software/Hardware SPI. The default is hardware SPI

If using software or hardware Serial UART:

This tutorial does not need to use the MODE pin, make sure you have the mode
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switch in CMD mode if you do not configure & connect a MODE pin

Don't forget to also connect the CTS pin on the Bluefruit to ground if you are not

using it! (The Flora has this already done)

Running the Sketch

Once you upload the sketch to your board (via the arrow-shaped upload icon), and the upload

process has finished, open up the Serial Monitor via Tools > Serial Monitor, and make sure

that the baud rate in the lower right-hand corner is set to 115200:

To send an AT command to the Bluefruit LE module, enter the command in the textbox at the

top of the Serial Monitor and click the Send button:
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The response to the AT command will be displayed in the main part of the Serial Monitor. The

response from 'ATI' is shown below:

You can do pretty much anything at this prompt, with the AT command set. Try AT+HELP to

get a list of all commands, and try out ones like AT+HWGETDIETEMP (get temperature at the

nRF51822 die) and AT+HWRANDOM (generate a random number)

© Adafruit Industries https://learn.adafruit.com/adafruit-flora-bluefruit-le Page 22 of 68



 

© Adafruit Industries https://learn.adafruit.com/adafruit-flora-bluefruit-le Page 23 of 68



BLEUart

The BLEUart example sketch allows you to send and receive text data between the Arduino

and a connected Bluetooth Low Energy Central device on the other end (such as you mobile

phone using the Adafruit Bluefruit LE Connect application for Android (http://adafru.it/f4G) or

iOS (http://adafru.it/f4H) in UART mode).

Opening the Sketch

To open the ATCommand sketch, click on the File > Examples >

Adafruit_BluefruitLE_nRF51 folder in the Arduino IDE and select bleuart_cmdmode:

This will open up a new instance of the example in the IDE, as shown below:
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Configuration

Check the Configuration! page earlier to set up the sketch for Software/Hardware UART or

Software/Hardware SPI. The default is hardware SPI

If using software or hardware Serial UART:
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