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Disclaimer

Specifications written in this document are believed to be accurate, but are not guar-
anteed to be entirely free of error. The information in this manual is subject to
change for functional or performance improvements without notice. Please make sure
your manual is the latest edition. While the information herein is assumed to be
accurate, SEGGER Microcontroller GmbH & Co. KG (the manufacturer) assumes no
responsibility for any errors or omissions. The manufacturer makes and you receive
no warranties or conditions, express, implied, statutory or in any communication with
you. The manufacturer specifically disclaims any implied warranty of merchantability
or fitness for a particular purpose.

Copyright notice

You may not extract portions of this manual or modify the PDF file in any way without
the prior written permission of the manufacturer. The software described in this doc-
ument is furnished under a license and may only be used or copied in accordance
with the terms of such a license.

© 2013 SEGGER Microcontroller GmbH & Co. KG, Hilden / Germany

Trademarks

Names mentioned in this manual may be trademarks of their respective companies.

Brand and product names are trademarks or registered trademarks of their respec-
tive holders.

Contact address

SEGGER Microcontroller GmbH & Co. KG

In den Weiden 11
D-40721 Hilden

Germany

Tel.+49 2103-2878-0

Fax.+49 2103-2878-28
Email: support@segger.com
Internet: http://www.segger.com

Revisions

This manual describes the Flasher device.

For further information on topics or routines not yet specified, please contact us.

Revision Date By Explanation

V4.64a Rev. 0 132602 EL
Chapter "Working with Flasher"
  * Section "LED status indicators" updated.

V4.63a Rev. 0 130131 EL
Chapter "Remote Control"
  * Section "ASCII command interface"
     Chapter "ASCII interface via Telnet" added.

V4.62 Rev. 0 130125 EL
Flasher ARM, Flasher RX and Flasher PPC manual 
have been combined.
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About this document

This document describes the Flasher family (Flasher ARM, Flasher RX and Flasher
PPC). It provides an overview about the major features of the Flasher, gives some
background information about JTAG and describes Flasher related software packages
available from Segger. Finally, the chapter Support and FAQs on page 61 helps to
troubleshoot common problems. 

For simplicity, we will refer to Flasher ARM/RX/PPC as Flasher in this manual.

Typographic conventions

This manual uses the following typographic conventions:

Style Used for

Body Body text.

Keyword
Text that you enter at the command-prompt or that appears on the 
display (that is system functions, file- or pathnames).

Reference Reference to chapters, tables and figures or other documents.

GUIElement Buttons, dialog boxes, menu names, menu commands.

Table 1.1: Typographic conventions



4

Flasher User Guide (UM08022) © 2004-2013 SEGGER Microcontroller GmbH & Co. KG

EMBEDDED SOFTWARE
(Middleware)

emWin
Graphics software and GUI

emWin is designed to provide an effi-

cient, processor- and display control-

ler-independent graphical user 

interface (GUI) for any application that 

operates with a graphical display. 

Starterkits, eval- and trial-versions are 

available.

embOS
Real Time Operating System

embOS is an RTOS designed to offer 

the benefits of a complete multitasking 

system for hard real time applications 

with minimal resources. The profiling 

PC tool embOSView is included. 

emFile
File system

emFile is an embedded file system with 

FAT12, FAT16 and FAT32 support.  

emFile has been optimized for mini-

mum memory consumption in RAM and 

ROM while maintaining high speed. 

Various Device drivers, e.g. for NAND 

and NOR flashes, SD/MMC and Com-

pactFlash cards, are available.

emUSB
USB device stack

A USB stack designed to work on any 

embedded system with a USB client 

controller. Bulk communication and 

most standard device classes are sup-

ported.

SEGGER TOOLS

Flasher 
Flash programmer

Flash Programming tool primarily for  microcon-

trollers.

J-Link
JTAG emulator for ARM cores

USB driven JTAG interface for  ARM cores.

J-Trace
JTAG emulator with trace

USB driven JTAG interface for ARM cores with 

Trace memory. supporting the ARM ETM (Embed-

ded Trace Macrocell).

J-Link / J-Trace Related Software
Add-on software to be used with SEGGER�s indus-

try standard JTAG emulator, this includes flash 

programming software and flash breakpoints.

SEGGER Microcontroller GmbH & Co. KG develops

and distributes software development tools and ANSI

C software components (middleware) for embedded

systems in several industries such as telecom, medi-

cal technology, consumer electronics, automotive

industry and industrial automation. 

SEGGER�s  intention is to cut software development-

time for embedded applications by offering compact flexible and easy to use middleware,

allowing developers to concentrate on their application.

Our most popular products are emWin, a universal graphic software package for embed-

ded applications, and embOS, a small yet efficient real-time kernel. emWin, written

entirely in ANSI C, can easily be used on any CPU and most any display. It is comple-

mented by the available PC tools: Bitmap Converter, Font Converter, Simulator and

Viewer. embOS supports most 8/16/32-bit CPUs. Its small memory footprint makes it

suitable for single-chip applications. 

Apart from its main focus on software tools, SEGGER develops and produces programming

tools for flash microcontrollers, as well as J-Link, a JTAG emulator to assist in develop-

ment, debugging and production, which has rapidly become the industry standard for

debug access to ARM cores.

Corporate Office:
http://www.segger.com

United States Office:
http://www.segger-us.com
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Chapter 1

Introduction

This chapter gives a short overview about the different models of the Flasher family
and their features.
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1.1 Flasher overview
Flasher is a programming tool for microcontrollers with on-chip or external flash
memory. Flasher is designed for programming flash targets with the J-Flash software
or stand-alone. In addition to that Flasher can also be used as a regular J-Link. For
more information about J-Link in general, please refer to the J-Link / J-Trace User
Guide which can be downloaded at http://www.segger.com.
Flasher connects to a PC using the USB/Ethernet/RS232 interface, running Microsoft
Windows 2000, Windows XP, Windows 2003, Windows Vista, Windows 7 or Windows
8. In stand-alone mode, Flasher can be driven by the start/stop button, or via the
RS232 interface (handshake control or ASCII interface). Flasher always has a 20-pin
connector, which target interfaces are supported depends on the Flasher model:

� For Flasher ARM: JTAG and SWD are supported.
� For Flasher RX: JTAG is supported. Flasher comes with additional 14-pin RX

adapter
� For Flasher PPC: JTAG is supported. Flasher comes with additional 14-pin PPC

adapter.

1.1.1 Features of Flasher
� Three boot modes: J-Link mode, stand-alone mode, MSD mode
� Stand-alone JTAG/SWD programmer (Once set up, Flasher can be controlled

without the use of PC program)
� No power supply required, powered through USB
� Supports internal and external flash devices 
� 64 MB memory for storage of target program
� Can be used as J-Link (emulator) with a download speed of up to 720 Kbytes/

second
� Serial in target programming supported
� Data files can updated via USB/Ethernet (using the J-Flash software), via RS232

or via the MSD functionality of Flasher

1.1.2 Working environment

General

Flasher can operate from a PC with an appropriate software like J-Flash or in stand-
alone mode.

Host System

IBM PC/AT or compatible CPU: 486 (or better) with at least 128MB of RAM, running
Microsoft Windows 2000, Windows XP, Windows 2003, Windows Vista, Windows 7 or
Windows 8. It needs to have a USB, Ethernet or RS232 interface available for com-
munication with Flasher.

Power supply

Flasher requires 5V DC, min. 100mA via USB connector. If USB is not connected, the
USB connector is used to power the device. Supply voltage is the same in this case.
Please avoid excess voltage.

Flasher model Supported cores

Supported 

target 

interfaces

Flash programming speed

(depending on target 

hardware)

Flasher ARM ARM7/ARM9/Cortex-M JTAG, SWD
between 30-300 Kbytes/
second

Flasher RX
Renesas RX610, RX621, 
RX62N, RX62T

JTAG
between 170 and 300 
Kbytes/second

Flasher PPC Power PC e200z0 JTAG up to 138 Kbytes/second
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Installing Flasher PC-software J-Flash

The latest version of the J-Flash software, which is part of the J-Link software and
documentation package, can always be downloaded from our website: http://
www.segger.com/download_jlink.html. For more information about using J-Flash
please refer to UM08007_FlasherARM.pdf (J-Flash user guide) which is also available
for download on our website.
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1.2 Specifications

1.2.1 Specifications for Flasher ARM

General

Supported OS

Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows XP x64
Microsoft Windows 2003
Microsoft Windows 2003 x64
Microsoft Windows Vista
Microsoft Windows Vista x64
Microsoft Windows 7
Microsoft Windows 7 x64
Microsoft Windows 8
Microsoft Windows 8 x64

Operating Temperature +5 °C ... +60 °C

Storage Temperature -20 °C ... +60 °C

Relative Humidity (non-condensing) <90% rH

Mechanical

Size (without cables) 121mm x 66mm x 30mm

Weight (without cables) 119g

Available interfaces

USB Host interface USB 2.0, full speed

Ethernet Host interface 10/100 MBit

RS232 Host interface RS232 9-pin

Target interface JTAG 20-pin (14-pin adapter available)

JTAG Interface, Electrical

Power Supply
USB powered, 100mA for Flasher ARM. 
500 mA if target is powered by Flasher 
ARM

Target interface voltage (VIF) 1.2 ... 5V

Target supply voltage
4.5V...5V (on the 14-pin adapter the tar-
get supply voltage can be switched 
between 3.3V and 5V)

Target supply current max. 400mA

Reset Type
Open drain. Can be pulled low or 
tristated

Reset low level output voltage (VOL) VOL <= 10% of VIF

For the whole target voltage range (1.8V <= V IF <= 5V)

LOW level input voltage (VIL) VIL <= 40% of VIF

HIGH level input voltage (VIH) VIH >= 60% of VIF

For 1.8V <= V IF <= 3.6V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 10% of VIF

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 90% of VIF

For 3.6 <= V IF <= 5V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 20% of VIF

Table 1.1: Flasher ARM specifications
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1.2.1.1 Flasher ARM download speed

The following table lists Flasher ARM performance values (Kbytes/second) for writing
to memory (RAM) via the JTAG interface:

Note: The actual speed depends on various factors, such as JTAG, clock speed,
host CPU core etc.

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 80% of VIF

JTAG Interface, Timing

Max. JTAG speed up to 12MHz

Data input rise time (Trdi) Trdi <= 20ns

Data input fall time (Tfdi) Tfdi <= 20ns

Data output rise time (Trdo) Trdo <= 10ns

Data output fall time (Tfdo) Tfdo <= 10ns

Clock rise time (Trc) Trc <= 10ns

Clock fall time (Tfc) Tfc <= 10ns

Hardware ARM7 memory download

Flasher ARM 720 Kbytes/s (12MHz JTAG)
Table 1.2: Download speed of Flasher ARM

Table 1.1: Flasher ARM specifications
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1.2.2 Specifications for Flasher RX

General

Supported OS

Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows XP x64
Microsoft Windows 2003
Microsoft Windows 2003 x64
Microsoft Windows Vista
Microsoft Windows Vista x64
Microsoft Windows 7
Microsoft Windows 7 x64
Microsoft Windows 8
Microsoft Windows 8 x64

Operating Temperature +5 °C ... +60 °C

Storage Temperature -20 °C ... +60 °C

Relative Humidity (non-condensing) <90% rH

Mechanical

Size (without cables) 121mm x 66mm x 30mm

Weight (without cables) 119g

Available interfaces

USB Host interface USB 2.0, full speed

Ethernet Host interface 10/100 MBit

RS232 Host interface RS232 9-pin

Target interface
JTAG 20-pin (shipped with 14-pin adapter 
for Renesas RX)

JTAG Interface, Electrical

Power Supply
USB powered, 100mA for Flasher ARM. 
500 mA if target is powered by Flasher 
ARM

Target interface voltage (VIF) 1.2 ... 5V

Target supply voltage
4.5V...5V (on the 14-pin adapter the tar-
get supply voltage can be switched 
between 3.3V and 5V)

Target supply current max. 400mA

Reset Type
Open drain. Can be pulled low or 
tristated

Reset low level output voltage (VOL) VOL <= 10% of VIF

For the whole target voltage range (1.8V <= V IF <= 5V)

LOW level input voltage (VIL) VIL <= 40% of VIF

HIGH level input voltage (VIH) VIH >= 60% of VIF

For 1.8V <= V IF <= 3.6V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 10% of VIF

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 90% of VIF

For 3.6 <= V IF <= 5V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 20% of VIF

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 80% of VIF

Table 1.3: Flasher RX specifications



Flasher User Guide (UM08022) © 2004-2013 SEGGER Microcontroller GmbH & Co. KG

13

1.2.2.1 Flasher RX download speed

The following table lists Flasher RX performance values (Kbytes/second) for writing
to memory (RAM) via the JTAG interface:

Note: The actual speed depends on various factors, such as JTAG, clock speed,
host CPU core etc.

JTAG Interface, Timing

Max. JTAG speed up to 12MHz

Data input rise time (Trdi) Trdi <= 20ns

Data input fall time (Tfdi) Tfdi <= 20ns

Data output rise time (Trdo) Trdo <= 10ns

Data output fall time (Tfdo) Tfdo <= 10ns

Clock rise time (Trc) Trc <= 10ns

Clock fall time (Tfc) Tfc <= 10ns

Hardware Flasher RX600 series memory download

Flasher RX 720 Kbytes/s (12MHz JTAG)
Table 1.4: Download speed of Flasher RX

Table 1.3: Flasher RX specifications
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1.2.3 Specifications for Flasher PPC

General

Supported OS

Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows XP x64
Microsoft Windows 2003
Microsoft Windows 2003 x64
Microsoft Windows Vista
Microsoft Windows Vista x64
Microsoft Windows 7
Microsoft Windows 7 x64
Microsoft Windows 8
Microsoft Windows 8 x64

Operating Temperature +5 °C ... +60 °C

Storage Temperature -20 °C ... +60 °C

Relative Humidity (non-condensing) <90% rH

Mechanical

Size (without cables) 121mm x 66mm x 30mm

Weight (without cables) 119g

Available interfaces

USB Host interface USB 2.0, full speed

Ethernet Host interface 10/100 MBit

RS232 Host interface RS232 9-pin

Target interface
JTAG 20-pin (shipped with 14-pin adapter 
for Renesas PPC)

JTAG Interface, Electrical

Power Supply
USB powered, 100mA for Flasher ARM. 
500 mA if target is powered by Flasher 
ARM

Target interface voltage (VIF) 1.2 ... 5V

Target supply voltage
4.5V...5V (on the 14-pin adapter the tar-
get supply voltage can be switched 
between 3.3V and 5V)

Target supply current max. 400mA

Reset Type
Open drain. Can be pulled low or 
tristated

Reset low level output voltage (VOL) VOL <= 10% of VIF

For the whole target voltage range (1.8V <= V IF <= 5V)

LOW level input voltage (VIL) VIL <= 40% of VIF

HIGH level input voltage (VIH) VIH >= 60% of VIF

For 1.8V <= V IF <= 3.6V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 10% of VIF

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 90% of VIF

For 3.6 <= V IF <= 5V

LOW level output voltage (VOL) with a 

load of 10 kOhm
VOL <= 20% of VIF

HIGH level output voltage (VOH) with a 

load of 10 kOhm
VOH >= 80% of VIF

Table 1.5: Flasher PPC specifications
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1.2.3.1 Flasher PPC download speed

The following table lists Flasher PPC performance values (Kbytes/second) for writing
to memory (RAM) via the JTAG interface:

Note: The actual speed depends on various factors, such as JTAG, clock speed,
host CPU core etc.

JTAG Interface, Timing

Max. JTAG speed up to 12MHz

Data input rise time (Trdi) Trdi <= 20ns

Data input fall time (Tfdi) Tfdi <= 20ns

Data output rise time (Trdo) Trdo <= 10ns

Data output fall time (Tfdo) Tfdo <= 10ns

Clock rise time (Trc) Trc <= 10ns

Clock fall time (Tfc) Tfc <= 10ns

Hardware Memory download

Flasher PPC 530 Kbytes/s (8 MHz JTAG)
Table 1.6: Download speed of Flasher PPC

Table 1.5: Flasher PPC specifications
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Chapter 2

Working with Flasher

This chapter describes functionality and how to use Flasher.
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2.1 Setting up the IP interface
Since hardware version 3 Flasher family comes with an additional Ethernet interface
to communicate with the host system. These Flashers also come with a built-in web-
server which allows some basic setup of the emulator, e.g. configuring a default
gateway which allows using it even in large intranets.

2.1.1 Connecting the first time

When connecting Flasher the first time, it attempts to acquire an IP address via
DHCP. The recommended way for finding out which IP address has been assigned to
Flasher is, to use the J-Link Configurator. The J-Link Configurator is a small GUI-
based utility which shows a list of all emulator that are connected to the host PC via
USB and Ethernet. For more information about the J-Link Configurator, please refer
to UM08001_JLinkARM.pdf (J-Link / J-Trace user guide), chapter Setup, section J-
Link Configurator. The setup of the IP interface of Flasher is the same as for other
emulators of the J-Link family. For more information about how to setup the IP inter-
face of Flasher, please refer to UM08001, J-Link / J-Trace User Guide, chapter Setup,
section Setting up the IP interface. For more information about how to use Flasher
via Ethernet or prepare Flasher via Ethernet for stand-alone mode, please refer to
Operating modes on page 19.
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2.2 Operating modes
Flasher is able to boot in 3 different modes:

� J-Link mode
� Stand-alone mode
� MSD (Mass storage device) mode

If Flasher can establish an Ethernet uplink or can enumerate on the USB port, it
boots in "J-Link mode". In this mode, Flasher can be used as a J-Link. When supply
power is enabled and Flasher can not establish a connection with the host, the
"stand-alone mode" is started. In this mode Flasher can be used as a stand-alone
flash programmer. When the Start/Stop button is pressed when power supply is
enabled, Flasher boots in "MSD mode". In this mode, Flasher boots as a mass storage
device.

2.2.1 J-Link mode

If you want to use Flasher for the first time you need to install the J-Link software
and documentation package. After installation, connect Flasher to the host PC via
USB or Ethernet. For more information about how to install the J-Link software and
documentation package please refer to the J-Link / J-Trace User Guide, chapter
Setup which can be downloaded from http://www.segger.com/download_jlink.html.

2.2.1.1 Connecting the target system

Power-on sequence

In general, Flasher should be powered on before connecting it with the target device.
That means you should first connect Flasher with the host system via USB / Ethernet
and then connect Flasher with the target device via JTAG or SWD. Power-on the
device after you connected Flasher to it. Flasher will boot in "J-Link mode".

Verifying target device connection with J-Link.exe

If the USB driver is working properly and your Flasher is connected with the host sys-
tem, you may connect Flasher to your target hardware. Then start the J-Link com-
mand line tool JLink.exe, which should now display the normal Flasher related
information and in addition to that it should report that it found a JTAG target and
the targets core ID. The screenshot below shows the output of JLink.exe.

2.2.1.2 Setting up Flasher for stand-alone mode

In order to set up Flasher for the stand-alone mode it needs to be configured once
using the J-Flash software. For more information about J-Flash, please refer to the J-
Flash User Guide.
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After starting J-Flash, open the appropriate J-Flash project for the target Flasher
shall be configured for, by selecting File -> Open Project. If J-Flash does not come
with an appropriate sample project for the desired hardware, a new project needs to
be created by selecting File -> New Project.

After the appropriate project has been opened / created, the data file which shall be
programmed needs to be loaded, by selecting File -> Open. After this J-Flash
should look like in the screenshot below.
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Before downloading the configuration (project) and program data (data file) to
Flasher, the connection type (USB/IP) needs to be selected in the project. These set-
tings are also saved on a per-project basis, so this also only needs to be setup once
per J-Flash project. The connection dialog is opened by clicking Options -> Project
settings -> General.

The connection dialog allows the user to select how to connect to Flasher. When con-
necting to a Flasher via TCP/IP it is not mandatory to enter an IP address. If the field
is left blank and File->Download to programmer is selected, an emulator selection
dialog pops up which shows all Flasher which have been found on the network. The
user then can simply select the Flash he wants to download the configuration to.
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In order to download the configuration and program data to the Flasher, simply select
File -> Download config & data file to Flasher.
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The J-Flash log window indicates that the download to the emulator was successful.

From now on, Flasher can be used in stand-alone mode (without host PC interaction)
for stand-alone programming.

2.2.2 Stand-alone mode

In order to use Flasher in "stand-alone mode", it has to be configured first, as
described in Setting up Flasher for stand-alone mode on page 19. To boot Flasher in
the "stand-alone mode", only the power supply to Flasher has to be enabled (Flasher
should not be connected to a PC). In the "stand-alone mode" Flasher can be used as
a stand-alone flash programmer.

Note: Flasher can only program the target device it was configured for. In order
to program another target device, you have to repeat the steps described in Setting
up Flasher for stand-alone mode on page 19.
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2.2.2.1 LED status indicators

Progress and result of an operation is indicated by Flasher�s LEDs:

2.2.3 MSD mode

When pressing the Start/Stop button of Flasher while connecting it to the PC, Flasher
will boot in the "MSD mode". This mode can be used to downdate a Flasher firmware
version if a firmware update did not work properly and it can be used to configure
Flasher for the "stand-alone mode", without using J-Flash. 

If Flasher has been configured for "stand-alone mode" as described in the section
above, there will be four files on the MSD, FLASHER.CFG, FLASHER.DAT, FLASHER.LOG,
SERIAL.TXT.

FLASHER.CFG contains the configuration settings for programming the target device
and FLASHER.DAT contains the data to be programmed. FLASHER.LOG contains all log-
ging information about the commands, performed in stand-alone mode. The
SERIAL.TXT contains the serial number, which will be programmed next. J-Flash sup-
ports to configure Flasher for automated serial number programming. For furhter
information about how to configure

Currently, J-Flash does not support to configure Flasher for automated serial number
programming.

If you want to configure multiple Flasher for the same target you do not have to use
J-Flash all the time. It is also possible to copy the FLASHER.CFG and the FLASHER.DAT
files from a configured Flasher to another one. To copy these files boot Flasher in
"MSD mode".

# Status of LED Meaning

0
GREEN
high frequency blinking
(On/Off time: 50ms => 10Hz)

Flasher ARM is waiting for USB enumeration or 
ethernet link. As soon as  USB has been enumer-
ated or ethernet link has been established, the 
green LED stops flashing and is switched to con-
stant green. In stand-alone-mode, Flasher 
remains in the high frequency blinking state until 
state #1 is reached. 
Flasher goes to state #1 as soon as a #START 
command has been received via the ASCII inter-
face or the Start button has been pushed. 

1
GREEN
constant

Connect to target and perform init sequence.

2
GREEN
slow blinking

Flashing operation in progress:
1. Erasing (slow blinking on/off time: 80

ms => 6.25 HZ)
2. Programming (slow blinking on/off

time: 300ms => ~1.67 Hz)
3. Verifying (slow blinking, on/off time:

100ms => 5 Hz)

3
GREEN
constant

Operation successful. Goes back to state #0 
automatically.

4
RED
constant

Operation failed. Goes back to state #0 automat-
ically but red LED remains on until state #1 (next 
programming cycle) is entered again.

Table 2.1: Flasher LEDs
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2.3 Multiple File Support
It is also possible to have multiple data files and config files on Flasher, to make
Flasher more easy to use in production environment. To choose the correct configura-
tion file and data file pair, a FLASHER.INI file is used. This init file contains a [FILES]
section which describes which configuration file and which data file should be used
for programming. A sample content of a FLASHER.INI file is shown below:

[FILES]
DataFile = "Flasher1.dat"
ConfigFile = "Flasher1.cfg"

Using this method all configuration files and data files which are used in the produc-
tion only have to be downloaded once. From there on a configuration file / data file
pair can be switched by simply replacing the FLASHER.INI by a new one, which con-
tains the new descriptions for the configuration file and data file. The FLASHER.INI
can be replaced in two ways:

1. Boot Flasher in MSD mode in order to replace the FLASHER.INI
2. If Flasher is already integrated into the production line, runs in stand-alone mode

and can not be booted in other mode: Use the file I/O commands provided by the
ASCII interface of Flasher, to replace the FLASHER.INI. For more information
about the file I/O commands, please refer to File I/O commands on page 42.
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