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Preface

INTRODUCTION

This chapter contains general information that will be useful to know before using the 

EMC1182 Temperature Sensor Evaluation Board. Items discussed in this chapter 

include:

� Document Layout

� Conventions Used in this Guide

� Recommended Reading

� The Microchip Web Site

� Customer Support

� Document Revision History

DOCUMENT LAYOUT

This document describes how to use the EMC1182 Temperature Sensor Evaluation 

Board as a development tool to emulate and debug firmware on a target board. The 

manual layout is as follows:

� Chapter 1. “Product Overview” – Important information about the EMC1182 

Temperature Sensor Evaluation Board. 

� Chapter 2. “Installation and Operation” – Includes instructions on installing and 

starting the SMSC™ Chip Manager application.

� Chapter 3. “Hardware Description” – Shows hardware details of the EMC1182 

Temperature Sensor Evaluation Board.

� Chapter 4. “Software Description” – Describes the main operations in the 

SMSC Chip Manager software.

� Appendix A. “Schematic and Layouts” – Shows the schematic and layout 

diagrams for the EMC1182 Temperature Sensor Evaluation Board.

� Appendix B. “Bill of Materials (BOM)” – Lists the parts used to build the 

EMC1182 Temperature Sensor Evaluation Board.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 

documentation are constantly evolving to meet customer needs, so some actual dialogs 

and/or tool descriptions may differ from those in this document. Please refer to our web site 

(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 

page, in front of the page number. The numbering convention for the DS number is 

“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 

document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help. 

Select the Help menu, and then Topics to open a list of available online help files.
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 

dialog

“Save project before build”

Underlined, italic text with 

right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 

where N is the total number of 

digits, R is the radix and n is a 

digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 

any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 

[options]

Curly brackets and pipe 

character: { | }

Choice of mutually exclusive 

arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 

var_name...]

Represents code supplied by 

user

void main (void)

{ ...

}
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RECOMMENDED READING

This user's guide describes how to use the EMC1182 Temperature Sensor Evaluation 

Board. Another useful document is listed below. The following Microchip document is 

available and recommended as a supplemental reference resource.

� EMC1182 Data Sheet – “Dual Channel 1.8V SMBus/I2C Temperature Sensor 

with Resistance Error Correction, Beta Compensation” 

(EMC1182 DS Rev. 1.0)

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web 

site is used as a means to make files and information easily available to customers. 

Accessible by using your favorite Internet browser, the web site contains the following 

information:

� Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 

latest software releases and archived software

� General Technical Support – Frequently Asked Questions (FAQs), technical 

support requests, online discussion groups, Microchip consultant program 

member listing

� Business of Microchip – Product selector and ordering guides, latest Microchip 

press releases, listing of seminars and events, listings of Microchip sales offices, 

distributors and factory representatives

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

� Distributor or Representative

� Local Sales Office

� Field Application Engineer (FAE)

� Technical Support

Customers should contact their distributor, representative or field application engineer 

(FAE) for support. Local sales offices are also available to help customers. A listing of 

sales offices and locations is included in the back of this document.

Technical support is available through the web site at: 

http://www.microchip.com/support.

DOCUMENT REVISION HISTORY

Revision A (August 2013)

� Initial Release of this Document.
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Chapter 1.  Product Overview

1.1 INTRODUCTION

The EMC1182 Temperature Sensor Evaluation Board provides an easily accessible 

platform to test the various features of the EMC1182. The System Management Bus 

(SMBus) communication is accomplished using an Universal Serial Bus (USB) bridge, 

providing a standard interface for the application code interface. The board is popu-

lated with a 3x3 DFN version of the EMC1182 device.

1.2 EMC1182 DEVICE FEATURES

The EMC1182 device is a two-channel SMBus temperature sensor featuring both 

pin-selectable and fixed SMBus address capability. The communications bus is also 

compatible with I2C communication protocol (see SMSC® application note AN 14.0 

rev.1.1 - “SMSC Dedicated Slave Devices in I2C Systems” for details on the differences 

between the SMSC SMBus implementation and standard I2C/SMBus). 

One externally connected temperature diode and one internal diode are available for 

temperature sensing. THERM and ALERT outputs have programmable temperature 

limits. 

1.3 WHAT IS THE EMC1182 TEMPERATURE SENSOR EVALUATION BOARD?

All functions of the EMC1182 device can be tested and observed using the USB-based 

EMC1182 Temperature Sensor Evaluation Board. Figure 1-1 shows the block diagram 

of this board.

FIGURE 1-1: EMC1182 Temperature Sensor Evaluation Board Block Diagram.

EMC1182

8LD 3x3 
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USB to SMBus 

Bridge

EXT DIODE 1

Temperature
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USB 
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SMBus 

Connector
SMBus ALERT#

REC

EXT DIODE 1

ALERT#

Address 

Select
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The evaluation system is comprised of the EMC1182 Temperature Sensor Evaluation 

Board and the SMSC Chip Manager application. The EMC1182 Temperature Sensor 

Evaluation Board has the following features:

� Headers for connecting an external diode or CPU/GPU

� Resistance Error Correction verification

� USB-to-SMBus bridge for power and communications

� Capability to connect directly to an external SMBus master

The user can perform the following operations using the Chip Manager:

� Viewing and changing register values

� Saving settings of all registers, allowing for quick configuration at a later time

� Graphing of any register

The evaluation board was designed for ease of use and experimentation purposes. 

Figure 1-2 shows the top silk screen of the EMC1182 Temperature Sensor Evaluation 

Board. 

FIGURE 1-2: EMC1182 Temperature Sensor Evaluation Board Top Silk Screen.

1.4 WHAT THE EMC1182 TEMPERATURE SENSOR EVALUATION BOARD KIT 
CONTAINS

This EMC1182 Temperature Sensor Evaluation Board kit includes:

� EMC1182 Temperature Sensor Evaluation Board (ADM00516)

� Supplied USB cable

� Important Information Sheet

SMBus Jumper Remote Diode

EMC1182

USB
Connector
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Chapter 2.  Installation and Operation

2.1 GETTING STARTED

2.1.1 System Requirements

To use the EMC1182 Temperature Sensor Evaluation Board, the following are required:

� A PC running the Microsoft® Windows® operating system

� A display resolution of 800x600 or larger, for viewing several windows 

simultaneously

� An available USB port

2.1.2 Installing the Evaluation Board

Follow the next steps to install the SMSC Chip Manager.

1. Download the ChipMan.zip file from the board web page. Unzip the archive. 

The application’s revision history and install/uninstall notes may be found in the 

readme.txt file. 

2. To install the Chip Manager application and the device driver on the PC, run the 

Setup.exe. 

3. Connect the supplied USB cable to an available USB port on the PC. Plug the 

mini-B end of the USB cable into the board connector P3. The +3.3V and the 

Bridge ACT LEDs should illuminate. 

4. If the USB Bridge driver has not previously been installed on the selected USB 

port, the Driver Software Installation window pops up, prompting for the driver 

install (see Figure 2-1).
 

FIGURE 2-1: Device Driver Load and Complete.
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5. After the driver installation is complete, the initial setup screen for the Chip 

Manager application appears (see Figure 2-2). Click Next to start the installation.

FIGURE 2-2: InstallShield Wizard Startup Window.

6. Read and accept the licensing agreement, in order to complete the installation. 

To continue, click Yes.

FIGURE 2-3: License Agreement Dialog.
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7. On the Choose Destination Location dialog, browse for the desired location, or 

click Next to install in the default location (see Figure 2-4). The application setup 

window appears, showing the installation progress (see Figure 2-5).

FIGURE 2-4: Destination Path Dialog.

FIGURE 2-5: Setup Progress Window.
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8. After the setup is complete, the MSXML Parser used by the Chip Manager 

software is installed, as shown in Figure 2-6. Once the setup completes 

successfully, press Finish to exit the install.

FIGURE 2-6: MSXML Parser Install Window.

9. Start the software by either going to Windows Start button > All Programs > 

SMSC > SMSC Chip Manager or by double-clicking the software icon ( ) on 

the desktop. The evaluation board software will initialize and the SMSC Chip 

Manager with the Quick Help screen appears (see Figure 2-7). 

FIGURE 2-7: SMSC Chip Manager with Quick Help Window.



Installation and Operation

 2013 Microchip Technology Inc. DS50002189A-page 17

10. If a message stating that no device has been selected appears, click Yes to 

select a device. Alternatively, go to the Chip Manager’s main menu, select 

Options > Select Device. In either case, the Select SMSC Device window dis-

plays, as shown in Figure 2-8.

In the “SMSC Device” list, choose EMC1182. From the “Master Controller” 

drop-down list choose “SMBus USB-SMB-SPI Bridge”. Click OK to complete the 

device selection.

FIGURE 2-8: Select SMSC Device Window.
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11. From the Chip Manager main menu, ensure that Options > Auto refresh 

Registers is checked. In the left panel, click the hardware monitor (HWM) to 

expand the content, then select any of the register groups, as shown in 

Figure 2-9. The USB Activity LED on the board starts blinking when any of the 

register groups are selected. The register values are automatically updated 

every second when the Auto Refresh option is on. 

FIGURE 2-9: Chip Manager Register Groups.



EMC1182 TEMPERATURE

SENSOR EVALUATION

BOARD USER’S GUIDE

 2013 Microchip Technology Inc. DS50002189A-page 19

Chapter 3.  Hardware Description

3.1 INTRODUCTION

The EMC1182 Temperature Sensor Evaluation Board provides the means to 

demonstrate all of the EMC1182 features, and allows the registers to be viewed and 

modified. LEDs indicating status information and test points are included to enable 

system voltage monitoring, using a voltmeter or an oscilloscope. 

3.1.1 Power Source

The board requires only one universal serial bus (USB) connection to power the board. 

The USB-to-SMBus bridge regulates the +5V USB power to +3.3V used by the 

EMC1182 and other evaluation board circuitry.

3.2 USB-TO-SMBUS BRIDGE

The USB-to-SMBus bridge is based on an 8-bit microcontroller with integrated USB 

and SMBus interfaces, as well as internal flash and RAM. During the evaluation board 

manufacturing process, the firmware is loaded into the bridge that provides the inter-

face between the USB and the SMBus. Power is sourced to the microcontroller from 

the USB interface for device power and communication. 

3.2.1 Direct SMBus Connect Option

It is also possible to connect an external SMBus master to the EMC1182 Temperature 

Sensor Evaluation Board. A few jumper settings are required to drive the EMC1182 on 

the evaluation board, as explained in the following steps: 

� Remove the jumpers on header JP10 and connect the SMBus master to the SDA, 

SCL and ALERT pins (3, 5 and 7, respectively), as well as an external supply for 

+3.3V (pin 1).

� Remove resistors R19, R20, R22 and R25, shown in Figure 3-1.

� The +3.3V can be supplied by the SMBus bridge by leaving the +3.3V jumper in 

place and retaining the USB connection.

3.2.2 Supplemental 1.8V SMBus Pull-up

A 1.8V (nominal) linear regulator is placed on the board along with the jumpers to 

connect SDA and SCL to a 1.8V pull-up supply. Once the jumper resistors are 

disconnected, jumpers connecting J2-1 to J2-2 and J2-3 to J2-4 may be installed to 

activate the 1.8V pull-ups. This jumper is identified in Figure 3-1 by the blue circle.
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FIGURE 3-1: SMBus Jumper Resistors.

3.3 RESISTANCE ERROR CORRECTION (REC)

The external diode 1 (Q1) on the board has a series resistance adjustment on the DN 

line. Checking the Resistance Error Correction (REC) feature is accomplished by 

turning the resistor wheel R5. With the REC on, the temperature will not change as the 

wheel is turned. With REC off, a significant temperature error will occur.

3.4 TEST POINTS

The EMC1182 Temperature Sensor Evaluation Board includes test points for the 

following:

� ALERT output (TP1)

� THERM output (TP2)

3.5 LED INDICATORS

Table 3-1 details the LEDs status of the following signals:

  

Remove resistors for 

Direct SMBus Connect
Jumpers connection for 

1.8V pull-up activation

TABLE 3-1: LED STATUS INDICATORS

LED No. Signal When LED is OFF When LED is ON Color

LED1 ALERT +3.3V power OFF ALERT red

LED3 +3.3V +3.3V power OFF +3.3V power ON green

LED4 Bridge Activity NO Activity on USB/SMBus Bridge Activity on USB/SMBus Bridge green

LED5 USB Activity NO Activity on USB port Activity on USB port green
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3.6 REMOTE DIODES

The evaluation board is populated with jumpers to connect to the on-board diode or an 

off-board diode (see Table 3-2). 

To connect to an off-board CPU or GPU, remove both jumpers from header J1. Then 

connect Pin 1 to the ‘remote+’ terminal of the off-board diode and Pin 2 to the ‘remote–’ 

terminal of the off-board diode. Make sure a common ground exists between the 

off-board diode (GPU, etc.) and the evaluation board. Ensure that the off-board diode 

is properly biased. Consult the CPU manufacturer’s data sheet for guidance on 

interfacing to the thermal diode. Refer to the EMC1182 Temperature Sensor Evaluation 

Board schematic in Appendix A. “Schematic and Layouts” for details on the 

evaluation board header connections.

3.7 OTHER SENSOR FEATURES

Other features, such as Conversion Rate, Dynamic Averaging and Digital Filtering, can 

be controlled with the EMC1182 registers. Refer to the device data sheet for details on 

the register description.

TABLE 3-2: REMOTE DIODE CONFIGURATIONS

Jumper Configuration Pin 1 Pin 2 Pin 3 Pin 4

J1 On-board diode (Q1) short/DP short/DN

General purpose remote diode open remote+/DP open remote–/DN

 CPU/GPU diode good common ground
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Chapter 4.  Software Description

4.1 CHIP MANAGER APPLICATION OVERVIEW

The Chip Manager application enables the user to display temperature readings, set 

temperature limits and read/write configuration register values. The Chip Manager 

initially displays a Quick Help screen (see Figure 2-7). For detailed information on 

application features and usage, select Help > Contents to display the HTML-based 

Help document, as shown in Figure 4-1.

FIGURE 4-1: Chip Manager Help Screen.

4.1.1 Real-Time Register Graphs

The Chip Manager software has the ability to plot register values in real-time, up to a 

10 Hz continuous rate.
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4.1.2 Selecting Registers to Plot

1. To plot a register, right-click the desired register name or value. Select the “Add 

Register(s) to Plot” from the context menu (see Figure 4-2), to add the register 

or value to the plot list.

FIGURE 4-2: Adding Registers to Plot.

2. Once the desired register is added to be plotted, a graphic plot window will 

appear with a legend on top, as shown in Figure 4-3. The two windows can be 

rearranged independently. 

FIGURE 4-3: Register Plot Window.

3. To plot additional registers, go back to the Chip Manager main window and 

repeat Step 1.
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4.1.3 Starting the Plots

All plots can be started simultaneously by selecting Control > Plots > Start All Plots from 

the menu, in the main application window. Multiple plots will be in sync if they are 

started simultaneously.

Individual plots may be paused at any time by clicking Control > Pause in the plot 

window. This will not cause loss of captured data on the other plot windows.

For a better view on the plot, select a different “Time per division” value in the 

drop-down menu at the bottom of the plotting window. This scale change affects both 

the real-time mode and the playback mode, while the rate at which data is recorded is 

unaffected.

4.1.4 Sampling a Plot

Figure 4-4 is an example of temperature history. Internal Temperature, External 

Diode 1 Temperature and External Diode 1 High Limit are selected for plotting. The 

results after the plot starting are that the External Diode Temperature High Limit is 

reduced, the External diode 1 starts at room temperature and is then heated by simply 

placing a finger on the external diode Q1. 

FIGURE 4-4: EMC1182 Temperature History Graph.
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