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Evaluating the ADUX1020 Photometric Sensor for Gesture and Proximity

FEATURES

ADUX1020 full configuration
Register level
Parameter level
Graph views
Time series view
Gesture recognition view
UDP transfer capability

EVALUATION KIT CONTENTS

ADUX1020-EVAL-MCM standard evaluation board
ADUX1020-EVAL-SMALL breakout board
EVAL-SDP-CB1Z controller board

Mini USB cable

ADDITIONAL EQUIPMENT NEEDED

PC running Windows 7 operating system
ADUX1020-EVALZ-LED daughterboard (optional)

ONLINE RESOURCES

ADUX1020 data sheet
Optical Gesture Evaluation Tool

GENERAL DESCRIPTION

The ADUX1020-EVAL-SDP evaluation kit provides users with a
simple means of interfacing with the ADUX1020, collecting data
from the ADUX1020, and evaluating gesture recognition
capabilities.

The ADUX1020-EVAL-SDP is a kit that includes the
ADUX1020-EVAL-SMALL and the ADUX1020-EVAL-MCM.

The evaluation kit requires the Optical Gesture Evaluation Tool,
which can be downloaded from the ADUX1020-EVAL-SDP
product page, a graphical user interface (GUI) that provides users
with low level and high level configurability, real-time data analysis,
and user datagram protocol (UDP) transfer capability so the
evaluation board can easily interface to a PC.

The USB port of the PC powers the ADUX1020-EVAL-SDP Kkit.
On-board voltage regulators provide voltage supplies for the
ADUX1020.

The evaluation board schematics indicate signal names for easy
identification. For additional information on the functionality of
the ADUX1020, refer to the ADUX1020 data sheet.

ADUX1020-EVAL-SDP EVALUATION KIT PHOTOGRAPH
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PLEASE SEE THE LAST PAGE FOR AN IMPORTANT
WARNING AND LEGAL TERMS AND CONDITIONS.
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EVALUATION BOARD SOFTWARE QUICK START PROCEDURES

INSTALLING THE OPTICAL GESTURE EVALUATION
TOOL

Download the Optical Gesture Evaluation Tool software package
from the ADUX1020-EVAL-SDP product page. Unzip the down-
loaded software folder, run the enclosed ADI_OpticalGesture_
EvaluationTool.exe file, and follow the prompts for installing the
Optical Gesture Evaluation Tool software (see Figure 2). For further
information, follow the full installation guide included with the
Optical Gesture Evaluation Tool software in the downloaded folder.

ol = s

Welcome to the Optical Gesture
Evaluation Tool ¥1.5.0 Setup Wizard

Il Optical Gesture Evaluation Tool w1.5.0 Setup

This wizard will guide vou through the installation of Optical
Gesture Evaluation Tool +1.5.0.

1t is recommended that vou close all other applications
befare starting Setup. This will make it possible to update
relevant system files without having to reboot vour
computer,

Click Mext to continue.

Figure 2. Optical Gesture Evaluation Tool Setup

14766-002

To start the Optical Gesture Evaluation Tool application, navigate
to the ADI_OpticalGesture_EvaluationTool from the Start menu
and click the ADI_OpticalGesture_EvaluationTool icon (see
Figure 3).

Analog Devices
A0L OpticalGesture_EwvaluationTool
Aduxllx
|: ADI OpticalGesture_Ewvaluatic
{7 Uninstall

Figure 3. Navigate to Optical Gesture Evaluation Tool from Start Menu

14766-003

At startup, the Optical Gesture Evaluation Tool application
automatically checks if the installed Optical Gesture Evaluation
Tool software version is up to date. If there is a newer version
available, the user is prompted to download the newest version.

EVALUATION BOARD USB CONNECTION

Ensure the provided EVAL-SDP-CB1Z controller board and
ADUX1020-EVAL-MCM connect together and connect to a PC
via the USB cable included with the evaluation kit. After the
Optical Gesture Evaluation Tool application opens, click File >
Connect (see Figure 4) and select SDP ASIC Bridge (Debug).
The Optical Gesture Evaluation Tool then acknowledges the
ADUX1020-EVAL-SDP kit is connected.

[] Optical Gesture Bvaluation Tool
| File | View  Tools  Help
Connect » || SDPASIC Bridge (Debug)
Disconnect IART ASIC Bridge (Debug)
Durnp Reagister View
Load Cfg
Sawve Cfg Mame
Spply Config
Exit: §

Figure 4. SDP ASIC Connection

CONFIGURING THE ADUX1020-EVAL-SDP
EVALUATION KIT

Before operating the ADUX1020-EVAL-SDP kit, connect any
jumper across Header J7 on the ADUX1020-EVAL-MCM. If
using the ADUX1020-EVALZ-LED daughterboard, disconnect
the jumper from Header J7.

To operate the ADUX1020 in gesture detect mode, click File >
Load Cfg. Select the 004_ADUX1020_StandardR1.dcfg file
and click Open (see Figure 5).

T30 iptie ol Grtuns Evalustion Tad
3 0en .

s AD OptigGeiture EveluatnTonl » Adud0E » Samgledfys =4y »

L DU SramdardRL ity

File gams: 034 ADLXIEN Standurdlildefy = | Deniee Ol bl Ptefy)

T Cancel
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Figure 5. Loading the Configuration File

Next, click View > Off-Chip Analysis and Gesture View to open
the Graph XYT tab (see Figure 6). With the evaluation board
positioned so there are no objects around it within at least a 20 cm
radius, click the Channel Auto Calibration button to calibrate the
ADUX1020-EVAL-SDP kit. The Optical Gesture Evaluation Tool
then acknowledges if calibration is successful.

Rev.0|Page 3 of 9
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Figure 6. Running the Channel Auto Calibration

STREAMING DATA

Press the Play button to begin streaming data from the evaluation
board. Move an object or hand within 15 cm above the ADUX1020
to see the corresponding output of the device on the graphs. The Y
Ratio vs X Ratio graph shows the calculated x, y position of the
object above the device (see Figure 7). The Intensity graph shows
the average intensity of reflected light seen by the device,
represented in ADC codes.
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Figure 7. Graph of Streaming Data

GESTURE RECOGNITION

To view the gesture recognition capability, navigate to the Gesture
Analysis Algorithm tab and select LSLF Swipe determination
from the drop-down menu. Click the Play button if the device

is not already streaming data.

Move a hand within 15 cm above the device and swipe in any of
the four indicated directions. Alternatively, the center indicator
can be activated by quickly lowering a hand towards the sensor
(see Figure 8).
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Figure 8. Gesture Recognition Algorithm Tab

For more detailed information Optical Gesture Evaluation Tool
and additional features of the software, see the Optical Gesture
Evaluation Tool User Manual, which can be found in the Help
> Help Topics menu.
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ADDITIONAL EVALUATION BOARDS

HIGH POWER LED DAUGHTERBOARD

The ADUX1020-EVALZ-LED is an optional daughterboard for
the standard ADUX1020-EVAL-MCM evaluation board. It
functions as a high-power LED driver intended for gesture
recognition at distances greater than 15 cm.

To use the ADUX1020-EVALZ-LED, attach it to the ADUX1020-
EVAL-MCM evaluation board as shown in Figure 9. The daughter-
board connects to the ADUX1020-EVAL-MCM via five pins,
labeled on the daughterboard as GND, GND1, LEDX, 3.3V, and
VLED. These pins on the daughterboard plug into five similarly
spaced test points on the ADUX1020-EVAL-MCM labeled JL1,
JL2,]JL3, JL4, and JL5. When connecting the ADUX1020-
EVALZ-LED, ensure Header J7 on the ADUX1020-EVAL-
MCM is not connected, as shown in Figure 9.

Operation and configuration of the ADUX1020-EVAL-SDP with
the ADUX1020-EVALZ-LED daughterboard follows the
instructions instructions listed in the Evaluation Board
Software Quick Start Procedures section.

14766-009

Figure 9. Connecting the ADUX1020-EVALZ-LED Daughterboard

SMALL FORM-FACTOR BREAKOUT BOARD

The ADUX1020-EVAL-SMALL is a small form-factor breakout
board (see Figure 10) for the ADUX1020 that allows easy access
to the ADUX1020 pinout via a standard connector cable.

14766-010

Figure 10. ADUX1020-EVAL-SMALL Breakout Board

The top view of the connector pinout for the ADUX1020-EVAL-
SMALL is shown in Figure 11.

12C SDA INT OUTPUT
(1.8V LOGIC) (1.8V LOGIC)

POWER FOR IR LED 12C sCL

14766-011

(2.8V TO 3.3V) (1.8V LOGIC)
Figure 11. ADUX1020-EVAL-SMALL Breakout Board
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2x8 pin header

0.05" pitch
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L=

‘ +2_8VLED

3WAY

1P8_SDA
1P8_INTOUT

RSN

1P8_SCL [

These resistors below are not in the BOM

indicates a trace connection between planes

+1.8VD
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R3 | R2
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AVDD) 0402
- 0402 0402
= — 1 1
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power in from M4 ribbon cable 6
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%
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NOTES
1. IN THE ADUX1020, LGND MEANS DGNG AND AVDD MEANS VDD.
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EXTERNAL (NON USB BUS ) VOLTAGE FOR LED
USED TYPICALLY FOR SERIES LEDS TO ALLOW LARGER CURRENT >200MA)
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NOTES

ESD Caution
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection
m circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality.

Legal Terms and Conditions

By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions
set forth below ("Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement. This Agreement is made by and between you (“Customer”) and Analog Devices, Inc.
("ADI"), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal,
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (i) permit any Third Party to access the Evaluation Board. As used herein, the term
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board.
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER'S POSSESSION OR USE OF
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI'S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable
United States federal laws and regulations relating to exports. GOVERNING LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed.

©2016 Analog Devices, Inc. All rights reserved. Trademarks and ANALOG
registered trademarks are the property of their respective owners.
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