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1. Introduction

1.1 Overview

The CY3218-CAPEXP1 CapSense® Express™ Evaluation Kit is used to evaluate the CapSense

Express device. This kit demonstrates the following features: CapSense buttons, LED drive, digital

input, and I2C. The CapSense Express device is configured via a system-level project in PSoC®

Designer™. A 16-pin QFN CY8C20110 device is mounted on the board. The board is powered with

a AAA battery. A boost converter converts the input, in the range of 1.1 V to 1.5 V, to the device

operating voltage of 3.3 V. The board can also be powered using the CY3240-I2USB bridge

connected to the I2C header. 

1.2 Kit Contents

The CY3218-CAPEXP1 CapSense Express Evaluation Kit includes:

■ CY3218-CAPEXP1 CapSense Express Evaluation Board

■ USB A to Mini-B cable

■ AAA battery

■ 1 mm acrylic overlay 

■ Quick Start Guide

■ Kit CD, which includes 

❐ PSoC Designer IDE

❐ Bridge Control Panel software

❐ CapSense Express datasheets 

❐ Kit release notes 

❐ Kit user guide

❐ Software release notes 

❐ Code example documentation

❐ Hardware design files

❐ Sample silicon CY8C20110-LDX2I (5 numbers)

1.3 Default Jumper Settings

Jumper (J2) on the CY3218-CAPEXP1 CapSense Express Evaluation Kit board configures the

power setting for the board.

■ Default position for J2: Jumper on pin 1 and 2; this enables powering the board via the CY3240-

I2USB bridge.

■ To power the board via battery, remove the jumper at J2.
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1.4 Additional Resources

Visit http://www.cypress.com for additional learning resources in the form of datasheets, technical

reference manual, and application notes.

■ Getting Started with CapSense

This guide is an ideal starting point for those new to capacitive touch sensing (CapSense) as well 

as for learning key design considerations and layout best practices to ensure design success.

1.5 Documentation Conventions

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:

C:\ ...cd\icc\

Italics
Displays file names and reference documentation:

Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:

File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:

Click the File icon and then click Open.

Times New Roman
Displays an equation:

2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Getting Started

2.1 Hardware

The following figure illustrates the CY3218-CAPEXP1 CapSense Express Evaluation Kit board

features.

Figure 2-1 shows the block diagram of the CY3218-CAPEXP1 CapSense Express Evaluation Kit.

The block diagram has two main sections, power supply and CapSense controller. The power supply

section is based on the onboard battery power. The 1.5 V battery voltage is converted into 3.3 V with

boost converter because the CapSense controller does not work below 2.4 V. The connector J2 pro-

vides an option to power the kit from the onboard battery or an external power source, which must

be connected to the J5 connector. An LED indicates the power status of the kit.

The status on touching the three CapSense buttons is indicated using the three LEDs connected to

the GPIOs of CapSense Express. A mechanical switch, which demonstrates the capability of

CapSense Express to read the status of external digital signals, is also provided with the kit. The

CapSense Express controller can be configured and controlled through the I2C interface; therefore,

a 5-pin header is provided for the I2C interface.

Top View                              Bottom View

Status LEDs

Backlighting LEDs

Mechanical Button

CapSense Buttons Power Selection Jumper (J2)

Power LED CapSense Express 

AAA Battery Holder (J1)

I2C Header (J5)
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Figure 2-1.  CY3218-CAPEXP1 CapSense Express Evaluation Kit Block Diagram

2.1.1 Power Supply System

The CY8C20110 chip is a low-power CapSense Express Controller, which can be powered from a

single 1.5 V AAA battery. The CapSense Express controller can work only from 2.4 V to 5.5 V power

supply; therefore, a boost converter is used in the kit to generate the 3.3 V power supply required

from the 1.5 V battery. 

Figure 2-2.  Power Supply System

The jumper J2 provides power on/off control for the kit. When the jumper is inserted, the Enable

Input (EN) pin of the boost converter is connected to ground, which cuts off power to the kit. Remov-

ing the jumper J2 connects the EN pin to VDD, to power the kit. The LED turns on when the kit is

powered.

Onboard

Battery

External Power

Supply through

Connector J5

Power Supply

Selection through

Jumper J2

Power

LED

Boost Converter

CY8C20110

CapSense Controller

(Demonstration)

Three CapSense

Buttons

Mechanical

Switch Input

through S1

Three

Backlighting

LEDs

Three Status

LEDs

5-Pin I2C

Header
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2.1.2 Mechanical and CapSense Buttons

Figure 2-3.  Input Schematic (CapSense Button and Mechanical Button)

Figure 2-4.  LED Schematic

2.1.3 CapSense Controller

The CapSense Express controller chip is connected to two input sections and two output sections.

The CapSense rectangular button and mechanical button provides input to the chip. The output is

provided through the status LEDs and backlighting LEDs, which turn green. The mechanical button

provides the signal with mechanical on/off, similar to the CapSense rectangular button.
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Figure 2-5.  CapSense Controller Schematic

2.1.4 I2C Interface

The CY3218-CAPEXP1 CapSense Express Evaluation Kit has the 5-pin header J5 for I2C interface.

The I2C interface is used to connect the CapSense controller with the host system to monitor the

sensor status and configure the CapSense controller according to system requirements. The sensor

is also tuned during the design stage using the I2C interface and the CY3240-I2USB Bridge tool.

I2C communication needs pull-up resistors, both SCL and SDA signals, on the master or slave side.

The kit hardware has footprints R13 and R15 (no-load components by default) to populate pull-up

resistors if they are not available on the master side.

The CapSense Express controller supports 50 kHz, 100 kHz, and 400 kHz data transfer speed for

the I2C interface.  

Figure 2-6.  I2C Interface Schematic
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3. Installation

3.1 Install Hardware

CAUTION  Make sure you do not touch the board anywhere other than the edges or on the buttons.

Touching the board in the wrong area can lead to a short and an unresponsive board. If this hap-

pens, reset power to the board. To do this, disconnect the battery supply by placing the jumper on

J2. To power the board again, remove the jumper from J2. 

The CY3218-CAPEXP1 CapSense Express Evaluation Kit is preprogrammed with demonstration

firmware. These instructions assume that your board is not reconfigured from the factory settings. If

it has, follow the instructions given in Create Project with CY3218-CAPEXP1 chapter on page 21 to

configure the board.

1. Unpack the CY3218-CAPEXP1 CapSense Express Evaluation Kit.

2. Insert the AAA battery into the battery holder.

3. Remove the jumper from J2 (back, left, and center of board). The red LED, D1, on the back of the 

board lights up.

4. Touch a button on the board. The LED in the center of the button and the LED above the button 

lights up.

5. Press the mechanical button at the bottom of the board; the three LEDs above the buttons turn 

on.

6. Turn the board off by replacing the jumper on J2. Note that replacing the jumper disables battery 

operation.

3.2 Install Software

Install the software required to load and run the code examples.

3.2.1 Before You Begin

All Cypress software installations require administrator privileges, but this is not required to run the

installed software. 

1. Shut down all Cypress software that is currently running. 

2. Disconnect ICE-Cube or MiniProg1 devices from your computer. 

Note that CapSense Express runs on an older version of PSoC Designer (PD5.0). Therefore, both

versions of PSoC Designer are required - PD5.0 for CapSense Express and PD5.1 for all other

devices.

3.2.2 Installing Software

To use the CY3218-CAPEXP1 CapSense Express Evaluation Kit, you need:

■ PSoC Designer 5.0 SP6

■ PSoC Programmer 3.13.3 or later 

■ Bridge Control Panel 1.3 or later (packaged with PSoC Programmer)
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If PSoC Designer (versions older than PD5.0 SP6), PSoC Programmer (versions older than

PP3.13.3), and Bridge Control Panel (versions older than BCP1.3) are currently installed, uninstall

the same before reinstalling. To uninstall, go to Start > Control Panel > Add or Remove Programs

and click the Remove button adjacent to the particular software. Follow the instructions to uninstall.

Follow these steps to install the software:

1. Insert the kit CD/DVD into your PC's CD/DVD-ROM drive. Click Install PSoC Programmer 

3.13.3… on the installation startup screen.

2. Wait for the installer to copy all the necessary files to a temporary folder.
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3.  Click Next to install in the default location. To select a different location, click the Change button.

4. Wait for the installation to complete.
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5. The CyInstaller window for PSoC Programmer is displayed when the installer is ready. Select 

Typical in the Installation Type options list and click Next to proceed.

6. Read the Software License Agreement and select I accept the terms in the license agreement; 

click the Next button.
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7. Wait for the installation to complete.

8. Click Finish to complete the installation. Select the View Release Notes option to open the 

release notes after the installer window closes. 
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9. Click Install PSoC Designer 5.0… in the installer startup screen.

Note If the installer does not start automatically, start it manually by executing cyautorun.exe in 

the CD/DVD's root directory.

10.Wait for the installer to copy all the necessary files to a temporary folder.
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11.Read the Software License Agreement and select I accept the terms of the license agreement; 

click the Next button.

12.Click Next to proceed with the Installation.
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13.Click Next to install in the default location. To customize the install location, click on the Browse 

button and navigate to the respective directory.

14.Review the settings before starting the installation. Click Back to change the settings, if required. 

Otherwise, click Next to start the installation.
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15.Wait for the PSoC Designer 5.0 installation to complete.

16.Click Yes if you want a shortcut to PSoC Designer on your desktop; click No to continue with the 

installation.

17.Click Finish to complete the installation. Select the View Release Notes option to open the 

Release Notes after completing the installation.
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3.2.2.1 PSoC Designer Overview

PSoC Designer is the revolutionary integrated design environment (IDE) that helps you to customize

PSoC to meet your specific application requirements. PSoC Designer accelerates system bring-up

and time-to-market. Develop your applications using a library of pre-characterized analog and digital

peripherals in a drag-and-drop design environment. Then, customize your design leveraging the

dynamically generated API libraries of code. Finally, debug and test your designs with the integrated

debug environment including in-circuit emulation and standard software debug features. 

To open the application, click Start > All Programs > Cypress > PSoC Designer <version>>

PSoC Designer <version>.

For instructions on creating and developing firmware projects for CapSense Controller in PSoC

Designer, see the IDE User Guide.pdf available at the following location: 

<Install_directory>:\PSoC Designer\<version>\Documentation\. 
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4. Create Project with CY3218-CAPEXP1

4.1 Functional Description

The board consists of three CapSense buttons; it has three status LEDs and three backlight LEDs

associated with these CapSense buttons. The status LEDs light up when the CapSense buttons are

touched. The backlight LEDs are initially lit 5 percent and glow to full brightness when the CapSense

buttons are touched.

The completed project is available in <CD_root>:\Program\ThreeCapSenseButtons\.

The CY3240-I2USB Bridge is used to transfer the configurations done in PSoC Designer to the

PSoC device on the board. The CY8C20110 device used in this kit is an I2C communication enabled

device for CapSense configuration, reading the status and data registers of the device, and so on.

See the device datasheet for more details.

The I2USB Bridge is used to monitor and tune the CapSense parameters; these parameters can be

transferred to the device from the GUI through the I2USB Bridge without reprogramming the device.

4.2 Create New Project

1. Connect your computer to the CapSense test board I2C connector (J5) using the CY3240-I2USB 

Bridge and a USB cable, as shown in Figure 4-1.

Figure 4-1.  CY3240-I2USB Connection to CY3218-CAPEXP1 Kit

Mini USB Port

Front of Board
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2. Ensure that the jumper J2 at the back of the board is open and the red LED, D1, is ON.

3. Launch PSoC Designer.

4. To create a new project, click on File > New Project.

5. Select the System-level Project icon in Project types; name the project 

‘ThreeCapSenseButtons’ and save it to a location of your choice.

6. Select View > All Driver Catalogs and then select the Inputs tab, as shown in the figure. Open 

CapSense Express > CY8C20110, right-click the 10 GPIO/CS Button Set driver, and select 

Add to Design. The Add Input Driver window opens.
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7. Name the driver ThreeButtons and click OK. The CapSense Express 10 GPIO/CS Button Set 

window opens.

8. In the system-level project, each CapSense button, LED, and the mechanical button require a 

separate driver. The ‘10 GPIO/CS Button’ driver is a special driver that allows you to configure all 

the buttons, LEDs, and the mechanical button in one interface. Based on the I/O requirements, 

drivers are available in the driver catalog.
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4.3 Configure the Driver

By default, all I/Os in the Configure Local Parameters pane are set to CapSense Input. To set up

backlight LEDs with PWM, set the Pin Type for C3 through C5 to PWM and the Drive Mode to

Strong Drive. Similarly, to set up status LEDs, set the Pin Type for C6 through C8 to GPOutput and

the Drive Mode to Strong Drive. For the mechanical button, set C9 to GPInput and set the Drive

Mode to Resistive Pull Up and Inversion to Yes. Set the Finger Threshold of C0 through C2

CapSense inputs to 150.

4.4 Configure Button and LED Behavior

1. In the Pin Specific Tuning pane, choose G3 from the Select Pin menu.

2. Click on the yellow box of the CapSense button you want to assign to LED G3. For LED output 

pin G3, select the CapSense button C0. A small line connects C0 to the purple OR box. To turn 

the LED on when the button is touched, click the small box (highlighted in the following figure) to 

the right of the purple OR box. 
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