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document may be the trademarks of their respective holders.

Purchase of I2C components from Cypress or one of its sublicensed Associated Companies conveys a license under the
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Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its

family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.

There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our

knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can guaran-

tee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."
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Safety Information

The “High Voltage Programmable Power Line Communication Development Kit” CY3274 is intended

for use as a development platform for hardware or software in a laboratory environment. The board

is an open system design, which does not include a shielded enclosure. Due to this reason the board

may cause interference to other electrical or electronic devices in close proximity. In a domestic

environment, this product may cause radio interference. In such cases, the user may be required to

take adequate preventive measures. Also, this board should not be used near any medical

equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default

may affect its performance and cause interference with other apparatus in the immediate vicinity. If

such interference is detected, suitable mitigating measures should be taken. 
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Safety Information

General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that the user perform

procedures only at an ESD workstation. If ESD workstation is not available, use appropriate ESD

protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal

surface) on the board when handling parts.

Handling Boards

CY3274 boards are sensitive to ESD. Hold the board only by its edges. After removing the board

from its box, place it on a grounded, static free surface. Use a conductive foam pad if available. Do

not slide board over any surface.

CAUTION: High Voltage (Risk of Electric Shock)

Extreme care is necessary when you work with powerline communication 

equipment. 

Use caution when using power supplies or power related equipment.

Use the board with expert technical supervision. There is high voltage (110-V, 240-

V AC) power on the board.

■ Accidental human contact with high voltage is dangerous.

■ The capacitors on the board can be energized even after disconnecting the board 

from the main power supply. Be careful not to touch any parts on the board 

immediately after you disconnect the main power supply.

■ Safety plastic casing is provided on the top of the high voltage section. Do not 

touch the protected area during live operation for debugging, probing, or for any 

other purpose. 

Cypress bears no responsibility for any consequences that may result from the 

improper or hazardous use of this board.

The kit CY3274 contains electrostatic discharge (ESD) sensitive devices. 

Electrostatic charges readily accumulate on the human body and any equipment, 

and can discharge without detection. Permanent damage may occur on devices 

subjected to high-energy discharges. Proper ESD precautions are recommended to 

avoid performance degradation or loss of functionality. Store unused CY3274 

boards in the protective shipping package.

End-of-Life / Product Recycling

This Kit has an end-of-life cycle after five years from the date of manufacturing 

mentioned on the back side of the box. Please contact your nearest recycler for 

discarding the kit.
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1. Introduction

1.1 Kit Contents

Figure 1-1.  Kit Contents 

The CY3274 PLC HV development kit contains:

■ CY3274 quick start guide

■ CY3274 PLC HV development board

■ AC power cable

■ MiniProg1 to program CY8CPLC20

■ 25 jumper wires 

■ LCD module

■ USB-I2C bridge

■ USB A to mini B cable

■ Five CY8CPLC20-28PVXI Device Samples
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1.2 Using the PLC Kit

Cypress’s Powerline Communication Solution (PLC) makes it possible to transmit and receive data

and control data over high voltage and low voltage powerlines. This solution is developed for low

bandwidth powerline communication. 

The CY3274 PLC high voltage (HV) PLC development kit provides the capability to develop an

application on the Cypress CY8CPLC20 device that can transmit and receive data over high voltage

(110 V to 240 V AC) powerlines. 

■ Introduction chapter on page 7 provides a brief overview of the Cypress PLC solution. It

describes the contents of the CY3274 development kits and lists special features of the kit. 

■ Getting Started chapter on page 13 provides information on kit software and process for its

installation as well as hardware connections.

■ PLC Development Board chapter on page 41 gives the functional overview of the PLC board and

describes the operating procedure of PLC HV board. It provides a high level hardware

description of the board. 

■ Code Examples chapter on page 51 provides explanation on the example projects and working.

■ Appendix chapter on page 69 contains the schematics, layout, and bill of materials.

1.3 The Cypress PLC Solution

Powerlines are available everywhere in the world. This makes them one of the most widely available

communication media. The pervasiveness of powerlines also makes it difficult to predict their

characteristics and noise. Because of the variability of powerline quality, implementing robust

communication over powerline has been an engineering challenge for years. With this in mind, the

Cypress PLC solution is designed to enable secure, reliable, and robust communication over

powerlines. 

The key features of the Cypress PLC solution are:

■ An integrated powerline PHY modem with optimized filters and amplifiers that work with rugged 

high and low voltage powerlines

■ Powerline optimized network protocol that supports bidirectional communication with 

acknowledgement based signaling and multiple retries

■ Support for 8-bit packet CRC and 4-bit header CRC for error detection and data packet 

retransmission 

■ Carrier Sense Multiple Access (CSMA) scheme that minimizes collisions between packet 

transmissions on the powerline
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The Cypress PLC solution consists of three key elements as shown in Figure 1-2.

■ Powerline network protocol layer

■ Physical layer FSK modem

■ Power amplification and coupling circuits

Figure 1-2.  Cypress PLC Solution Block Diagram 

The powerline network protocol layer and the physical layer FSK modem are implemented on the

CY8CPLC20 chip. The chip also contains a PSoC core in addition to the PLC core. The CY3274

board contains the CY8CPLC20 device along with the power amplification and coupling circuit for

communicating on high voltage (110-240 V AC) powerlines. For a detailed description of the design

parameters for the circuit, refer to the application note Cypress Powerline Communication Board

Design Analysis - AN55427. 

The network protocol layer allows for the addressing of multiple nodes on the network. This enables

point-to-multipoint communication. The protocol layer also provides a defined packet structure for

transmitting data packets from one node to the other as well as error detection and packet retransmit

functionalities. The chip contains a PSoC core in addition to the PLC core. The PSoC core includes

configurable blocks of analog and digital logic, and programmable interconnects. This architecture

enables you to create customized peripheral configurations that match the requirements of each

individual application. A fast CPU, flash program memory, SRAM data memory, and configurable 

I/Os are also included.
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A two-node system level diagram is shown in Figure 1-3. To evaluate this kit, follow the steps in the

quick start guide, which is provided in the kit.

Note To evaluate this kit, a second high voltage PLC kit is required. The compatible kit is CY3274,

with EZ-Color. For information on this kit, visit http://www.cypress.com/go/CY3274.

Figure 1-3.  PLC System Level Block Diagram – Two Nodes 

1.4 Additional Learning Resources

Visit http://www.cypress.com/go/plc for additional learning resources in the form of datasheets,

technical reference manuals, and application notes. 

■ CY3274 Schematic.pdf 

■ CY3274 Board Layout.zip 

■ CY3274 Kit documentation

http://www.cypress.com/go/CY3274

■ For a list of PSoC Designer-related trainings, see

http://www.cypress.com/?rID=40543

■ CY8CPLC20 data sheet

http://www.cypress.com/?rID=38201

■ For more information regarding PSoC Designer functionality and releases, refer to the user guide 

and release notes on the PSoC Designer web page:

www.cypress.com/go/psocdesigner

■ For more information regarding PSoC Programmer, supported hardware, and COM layer, go to 

the PSoC Programmer web page:

www.cypress.com/go/psocprogrammer

■ AN54416, Using CY8CPLC20 in Powerline Communication (PLC) Applications

http://www.cypress.com/?rID=37951
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1.5 Acronyms

Table 1-1.  Acronyms Used in this Document

Acronym Description

AC Alternating Current

BIU Band-In-Use

CPU Central Processing Unit 

CSMA Carrier Sense Multiple Access

DC Direct Current

DIP Dual In-line Package

FSK Frequency-Shift Keying 

GPIO General-Purpose Input/Output

GUI Graphical User Interface

HV High Voltage

I2C Inter-Integrated Circuit

I/O Input/Output

ISR Interrupt Service Routine

LCD Liquid-Crystal Display

LED Light-Emitting Diode

OCD On-Chip Debug

PLC Powerline Communication

PLT Powerline Transceiver

PSoC Programmable System-on-Chip

QFN Quad-Flat No-leads

RH Relative Humidity

SMPS Switched-Mode Power Supply

SRAM Static Random-Access Memory

USB Universal Serial Bus
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1.6 Documentation Conventions

1.7 Technical Reference

For a real-time list of knowledge base articles for the CY3274 Kit, refer to our Online Knowledge

Base.

For any help with the installation of the control panel, refer to the Control Panel User Guide available

on our website. You can download the latest revision of the GUI setup and user guide from

www.cypress.com/go/plc. 

1.8 Technical Support

For assistance, go to our support: http://www.cypress.com/support web page, or contact our

customer support at +1(800) 541-4736 Ext. 2 (in the USA), or +1 (408) 943-2600 Ext. 2

(International).

Table 1-2.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:

C:\ ...cd\icc\

Italics
Displays file names and reference documentation:

Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:

File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:

Click the File icon and then click Open.

Times New Roman
Displays an equation:

2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Getting Started

This chapter describes how to install and configure the CY3274-HV PLC Development Kit. 

2.1 Software Installation

2.1.1 Before You Begin

All Cypress software installations require administrator privileges; however, this is not required to run

the installed software.

■ Shutdown any Cypress software that is currently running.

■ Disconnect any Cypress devices (USB-I2C bridge, ICE Cube, or MiniProg) from your computer.

■ If you have a previous installation of the PLC Control Panel GUI, uninstall it first. To uninstall the 

software, go to Start > Control Panel > Add or Remove Programs (for XP)/Programs and 

Features (for Win 7) and click the Remove/Uninstall button adjacent to the particular software. 

Follow the instructions to uninstall.

2.1.2 Prerequisites

The PLC Control Panel GUI requires the 3.5 SP1 or later version of Microsoft .NET Framework,

Adobe Acrobat Reader, and a Windows Installer. 
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2.1.3 Installing PLC Control Panel Independently

2.1.3.1 Before You Begin

All Cypress software installations require administrator privileges; but this is not required to run the

installed software.

■ Shut down any Cypress software that is currently running.

■ Disconnect any ICE-Cube, USB-I2C Bridge, or MiniProg devices from your computer.

■ If you have a previous installation of the PLC Control Panel GUI, uninstall it first. To uninstall the 

software, go to Start > Control Panel > Add or Remove Programs (for XP)/Programs and 

Features (for Win 7) and click the Remove/Uninstall button adjacent to the particular software. 

Follow the instructions to uninstall.

2.1.3.2 Prerequisites

The following software is required for the PLC Control Panel:

Microsoft .NET Framework 3.5 SP1 or later

To check if this software is installed, go to Start> Control Panel> Add/Remove Programs(for XP)/

Programs and Features (for Win 7). This software can be downloaded from: http://

www.microsoft.com/downloads/details.aspx?Fami-lyID=AB99342F-5D1A-413D-8319-

81DA479AB0D7&displaylang=en

Windows Installer 3.1 or later

To check if this software is installed, go to Start> Control Panel> Add/Remove Programs. This

software can be downloaded from: http://www.microsoft.com/downloads/details.aspx?Fami-

lyID=889482FC-5F56-4A38-B838-DE776FD4138C&displaylang=en

2.1.3.3 Installing PLC Control Panel Software

When installing the PLC Control Panel, the installer checks if the prerequisites - Windows Installer,

Windows.NET, and Acrobat Reader - are installed in your PC. If these applications are not installed,

then the installer prompts you to install them.

1. Download the PLC Control Panel GUI.zip from http://www.cypress.com/?rID=38135 and extract 

it.

2. Run the setup.exe file to start the installer.
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3. As specified, this installation process first determines if you have all prerequisite software. Follow 

the on-screen dialogs to complete all required installations.

Figure 2-1.  Installation Wizard 

4. Click the Next button in Figure 2-1.

Figure 2-2.  Select Installation Folder 
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5. Click Browse to select Installation Folder and then click the Next button in Figure 2-2.

Figure 2-3.  Confirm Installation 

6. Click the Next button in Figure 2-3.

Figure 2-4.  End of Installation Wizard 

7. Click the Close button in Figure 2-4.

8. Verify your installation and setup by opening the PLC Control Panel. To open the PLC Control 

Panel, click Start> All Programs> Cypress> PLC Control Panel> PLC Control Panel.
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9. Continue to the next section to learn how to evaluate the PLC Control Panel with two PLC 

evaluation or development kits. 

After installing PLC Control Panel, refer to the documentation as needed: 

<Install_Dir>\PLC Control Panel\PLC Control Panel Release Notes.pdf

<Install_Dir>\PLC Control Panel\User Guide for Cypress PLC Control Panel GUI.pdf

The PLC Control Panel user guide is also available in the installation directory. It contains extra

information about installation and how to set up the kit to work with the GUI. It can also be accessed

from the Help menu in the PLC Control Panel GUI. 

2.2 Kit Installation

To install the kit software, follow these steps:

1. Download CY3274 kit installer from http://www.cypress.com/go/CY3274 and start installation.

3. The CY3274-HV PLC Development Kit - InstallShield Wizard screen appears. Choose the 

folder location to install the setup files. You can change the location of the folder using Change.

4.  Click Next to launch the kit installer.

Figure 2-5.  CY3274-HV PLC Development Kit - InstallShield Wizard
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5. On the Product Installation Overview screen, select the installation type that best suits your 

requirement. The drop-down menu has the options Typical, Complete, and Custom, as shown 

in Figure 2-6. 

Figure 2-6.  Installation Type Options

6. Click Next in Figure 2-6 to go to Figure 2-7.

Figure 2-7.  Cypress End User License Agreement 
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7. Select “I accept the terms in the license agreement” and then click Next in Figure 2-7 to start the 

installation.

8. When the installation begins, a list of all packages appears on the Installation Page.

9. A green check mark appears next to every package that is downloaded and installed. 

Figure 2-8.  Installation Page
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10.Click Finish to complete the installation.

Figure 2-9.  Installation Completion Page
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2.3 PSoC Designer

1. Click Start > All Programs > Cypress > PSoC Designer <version> > PSoC Designer <ver-

sion>.

2. Click File > New Project to create a new project on the PSoC Designer menu or go to File > 

Open Project/Workspace to work with the existing project on the PSoC Designer menu

Figure 2-10.  PSoC Designer Interconnect View

3. For more details on PSoC Designer, go to Help Topics from the following directory:

<Install_Dir>\Cypress\PSoC Designer\<version>\PSoC Designer 5\Help\PSoCDesigner

(Compiled HTML Help file)
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2.4 PSoC Programmer

1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer 

<version>.

2. Connect the MiniProg from Port Selection.

Figure 2-11.  PSoC Programmer Window

3. Click the File Load button to load the hex file.

4. Use the Program button to program the hex file on to the chip.

5. When the file is successfully programmed, Programming Succeeded appears on the Action 

pane.

6. Close PSoC Programmer.

Note For more details on PSoC Programmer, go to Help Topics from the following path:
<Install_Dir>\Cypress\Programmer\<version>\PSoC_Programmer(Compiled HTML Help file)

2.5 Uninstall Software

2.5.1 Uninstalling the PLC Control Panel Software

The PLC Control Panel GUI supports un-installation through either the Add/Remove Programs tool

in the Control Panel for MS Windows or the shortcut provided in the Start menu.
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3. Kit Operation and PLC Control Panel GUI

This chapter explains kit operation and PLC Control Panel GUI. 

3.1 Theory of Operation

The Cypress PLC family is a single chip solution for powerline communication (PLC). The solution

has a robust FSK modem with a user-friendly powerline network protocol. CY3274 has a simple

powerline coupling circuit to create a low-cost communication interface using the existing power

lines. This interface can be used for intelligent command and control systems such as:

■ Lighting control

■ Automatic meter reading

■ Home automation

Figure 3-1 shows a block diagram of the Cypress CY8CPLC20 PLC Solution. To interface the

CY8CPLC20 device to the powerline, a coupling circuit is required. 

Complete PLC evaluation and development kits, compliant with PLC standards in Europe and North

America, are available at www.cypress.com/go/plc.

Figure 3-1.  CY3274 PSoC1 PLC Solution 

3.1.1 CY8CPLC20 Device Description

The CY8CPLC20 is a Programmable Powerline Communication chip with 

■ Powerline FSK Modem PHY 

■ Powerline Network Protocol Stack.
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3.1.1.1 Powerline FSK Modem PHY

The heart of the CY8CPLC20 device is the frequency shift keying (FSK) modem. The FSK

modulator sends digital data through two distinct frequencies; one frequency represents a digital 1

and the other represents a digital 0 (see Figure 3-2). The FSK demodulator must receive the

transmitted analog signals and demodulate them to determine the correct sequence of 1s and 0s.

Figure 3-2.  Sample FSK Waveform 

Note: This diagram is only for conceptual understanding and is not to scale.

3.1.1.2 Powerline Network Protocol Stack

The network protocol that runs on the processor supports

■ Bidirectional half-duplex communication 

■ Master-slave or peer-to-peer network topologies

■ Multiple masters on powerline network

■ Addressing

❐ 8-bit logical addressing supports up to 256 Powerline nodes

❐ 16-bit extended logical addressing supports up to 65536 Powerline nodes

❐ 64-bit physical addressing supports up to 264 Powerline nodes

❐ Individual broadcast or group mode addressing

■ Carrier Sense Multiple Access (CSMA) 

The protocol provides the random selection of a period between 85 and 115 ms (out of seven 

possible values in this range) in which the band-in-use (BIU) detector must indicate that the line 

is not in use, before attempting a transmission.

■ Band-In-Use (BIU)

A BIU detector, as defined under CENELEC EN 50065-1, is active whenever a signal that 

exceeds 86 dB µVrms anywhere in the range 131.5 kHz to 133.5 kHz is present for at least 4 ms. 

This threshold can be configured for different end-system applications not requiring CENELEC 

compliance. The modem tries to retransmit after every 85 to 115 ms when the band is in use. The 

transmitter times out after 1.1 seconds to 3.5 seconds (depending on the noise on the Powerline) 

and generates an interrupt to indicate that the transmitter was unable to acquire the Powerline.

Note that for non-CENELEC compliant systems, the BIU interval can be modified for improved 

performance by modifying the Timing_Config register. Refer the PLT UM datasheet for more 

details. 

■ Verifies address and packet integrity (CRC) of received packets

■ Transmits acknowledgments after receiving a valid packet, and automatically retransmits if a 

packet is dropped.
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3.2 Functional Description

The CY3274 PLC development board is designed as a product development platform for low

bandwidth (up to 2400 bps) powerline communication.

The user-written application running on the CY8CPLC20 generates the data. The PLC core

encapsulates this data into a PLC network packet. The FSK modem then modulates this packet and

the coupling circuitry incorporates the resulting sinusoidal waveform on to the existing waveform on

the high voltage bus.

3.2.1 Operating Conditions

■ Input voltage: 110 V AC/240 V AC

■ Input current: 100 mA/50 mA

■ Operating temperature: 0 °C to 40 °C

■ Operating humidity condition: 5% to 95% relative humidity (RH), non-condensing

This document provides instructions to install and uninstall Cypress’s Powerline Communication

(PLC) solution. It describes how to set up the boards and includes detailed descriptions of all tabs in

the PLC Control Panel.

3.3 PLC Control Panel GUI

3.3.1 Program CY3274 Boards with I2C-PLC Interface

Follow these steps to configure the boards:

1. Connect a USB A to mini B cable from the PC to the MiniProg programmer, which is included in 

the kit. 

2. Connect the MiniProg to the ISSP 5-pin header on the board.

Figure 3-3.  MiniProg connected to ISSP 5-pin header 

3. Open PSoC Programmer from Start Menu.

4. Click the File Load button or click File > File Load… (F4). Navigate to the folder C:\Program Files 

(x86)\Cypress\PLC Control Panel\ and open PLC20_FW_5.8.hex.
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