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Safety Information

Regulatory Compliance

The CY8CKIT-041-41XX PSoC® 4100S Pioneer Kit is intended for use as a development platform

for hardware or software in a laboratory environment. The board is an open-system design, which

does not include a shielded enclosure. This may cause interference to other electrical or electronic

devices in close proximity. In a domestic environment, this product may cause radio interference. In

such cases, you may be required to take adequate preventive measures. In addition, this board

should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default

may affect its performance and cause interference with other apparatus in the immediate vicinity. If

such interference is detected, suitable mitigating measures should be taken.

General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that you perform

procedures only at an ESD workstation. If an ESD workstation is not available, use appropriate ESD

protection by wearing an antistatic wrist strap attached to a grounded metal object.

Handling Boards

PSoC 4100S Pioneer Kit is sensitive to ESD. Hold the board only by its edges. After removing the

board from its box, place it on a grounded, static-free surface. Use a conductive foam pad if

available. Do not slide the board over any surface.

The PSoC 4100S Pioneer Kit, as shipped from the factory, has been verified to meet

with the requirements of CE as a Class A product.

The PSoC 4100S Pioneer Kit contains ESD-sensitive devices. Electrostatic charges

readily accumulate on the human body and any equipment, and can discharge without

detection. Permanent damage may occur on devices subjected to high-energy

discharges. Proper ESD precautions are recommended to avoid performance

degradation or loss of functionality. Store unused PSoC 4100S Pioneer Kits in the

protective shipping package.

End-of-Life/Product Recycling

The end-of life for this kit is five years from the date of manufacture mentioned as a bar

code on the back of the box. Contact your nearest recycler for discarding the kit.



PSoC® 4100S Pioneer Kit Guide, Doc. # 002-14067 Rev. *C 5

1. Introduction

Thank you for your interest in the CY8CKIT-041-41XX PSoC® 4100S Pioneer Kit. This kit enables

you to evaluate and develop your application using the PSoC 4100S device family. 

The PSoC 4100S device family is an expansion to the PSoC 4 device family. PSoC 4100S is a true

programmable embedded system-on-chip, integrating custom analog and digital peripheral

functions, memory, and an ARM® Cortex®-M0+ microcontroller on a single chip. The programmable

analog and digital peripheral functions allow higher flexibility, in-field tuning of the design, and faster

time-to-market. 

The PSoC 4100S Pioneer Kit offers footprint-compatibility with Arduino™ shields. This kit features a

CapSense® trackpad, two CapSense buttons, a CapSense proximity sensor that allows you to

evaluate Cypress’s fourth-generation CapSense technology, an RGB LED, two user-configurable

push-button switches, potentiometer, an onboard programmer/debugger with USB-UART/I2C bridge

functionality block (KitProg2), a Cypress F-RAM™, an EZ-BLE™ PRoC™ Module, and a

rechargeable battery. This kit supports operating voltages of 1.9 V, 3 V (battery), 3.3 V ,or 5 V.

You will use PSoC Creator™ to develop and debug the PSoC 4100S device projects. PSoC Creator

is Cypress’s standard integrated design environment (IDE). If you are new to PSoC Creator, see the

documentation on the PSoC Creator webpage. You can also refer to application note AN79953 –

Getting Started with PSoC 4, which gives an introduction to the PSoC 4 device.

1.1 Kit Contents

The CY8CKIT-041-41XX PSoC 4100S Pioneer Kit contains the following, as shown in Figure 1-1.

■ PSoC 4100S Pioneer Kit

■ USB Standard-A to Micro-B cable

■ Water dropper

■ Four press-fit connectors (one 8×2, one 10×1, two 8×1)

■ Four jumper wires

■ Quick Start Guide
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Figure 1-1.  Kit Contents

Inspect the contents of the kit; if you find any part missing, contact your nearest Cypress sales office

for help: www.cypress.com/support.

1.2 Board Details

As shown in Figure 1-2, the PSoC 4100S Pioneer Kit features a CapSense trackpad, two CapSense

buttons, and a proximity sensor loop (not visible on the case) that allows you to evaluate Cypress’s

fourth-generation CapSense technology. The kit has two user buttons, an RGB LED, and a potenti-

ometer that can be used in your applications. It also has a reset button and three status LEDs. The

kit can be powered from three power sources: USB connector, rechargeable battery, or an external

power supply. The kit can operate at 1.9 V, 3.3 V, and 5 V when powered from the USB connector or

external power supply and will operate at 3 V when powered from the battery. The USB connector is

also used for programming and debugging your application on PSoC 4100S.
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Figure 1-2.  PSoC 4100S Pioneer Kit
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1. KitProg2 Status LEDs

2. Power LED

3. KitProg2 USB Micro-B connector

4. Potentiometer 

5. Reset button

6. User button

7. KitProg2 user button  
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Figure 1-3.  PSoC 4100S Pioneer Kit without Overlay 

1. CapSense trackpad                                2. CapSense buttons

                                3. Proximity sensor loop

Note: The above �gure shows the kit without color gamut overlay
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Figure 1-4.  PSoC 4100S Pioneer Board (Top View) 
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5. Power LED (LED4)

6. System power (VDD) selection switch (SW6)

10. ArduinoTM compatible power and I/O headers

11. 32.768 kHz crystal oscillator (Y1)

13. Cypress F-RAM 1Mb (FM24V10-G, U11) 

14. RGB LED (LED5)

(SW3)  

17.  User Button (SW2)

18.  Reset button (SW1) 

20. EZ-BLETM PRoCTM Module (CYBLE-022001-00, U3)

21. Potentiometer (R2)

22. VDD source selection switch (SW4)

23. Current measurement selection switch (SW7) 

24. PSoC 4100S (CY8C4146AZI-S433, U1)

       selection switch (SW5)

      (CY8C5868LTI-LP039, U15)
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1.3 PSoC Creator

PSoC Creator is a state-of-the-art, easy-to-use IDE. It introduces revolutionary hardware and soft-

ware co-design, powered by a library of fully-verified and characterized PSoC Components™, as

shown in Figure 1-7. With PSoC Creator, you can:

1. Drag and drop Components to build your hardware system design in the main design workspace

2. Co-design your application firmware with the PSoC hardware

3. Configure Components using configuration tools

4. Explore the library of 100+ Components

5. Access Component datasheets

Figure 1-7.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains

and production programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator.

Table 1-1.  Switches Default Position

Switch Purpose Default Position

SW4 (PWR SEL) VDD Source Selection EXT (VREG/VBUS)

SW5 Programming Target Selection PSoC 4100S

SW6 System Power (VDD) Selection 5 V

SW7 Current Measurement Selection Switches P1, P2, P3, and P4 – OFF; Switch P5 – ON
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1.3.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are accessible from the

PSoC Creator Start Page, as shown in Figure 1-8.

Code examples can speed up your design process by starting you off with a complete design. The

code examples also show how to use PSoC Creator Components for various applications. Code

examples and documentation are included, as shown in Figure 1-9.

In the Find Code Example dialog shown in Figure 1-9, you have several options:

■ Filter for examples based on device family or keyword.

■ Select from the list of examples offered based on the Filter Options.

■ View the project documentation for the selection (on the Documentation tab).

■ View the code for the selection on the Sample Code tab. You can also copy and paste code from 

this window to your project, which can help speed up code development.

■ Create a new workspace for the code example or add to your existing workspace. This can speed 

up your design process by starting you off with a complete, basic design. You can then adapt that 

design to your application.

Figure 1-8.  Code Examples in PSoC Creator
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Figure 1-9.  Code Example with Sample Code

1.3.2 Kit Code Examples

You can access the installed kit code examples from the PSoC Creator Start Page. To access these

examples, expand the Kits under the section Examples and Kits; then, expand the specific kit to see

the code examples. Refer to the Code Examples chapter on page 32 for a list of code examples that

you can use on this kit. 

1.3.3 PSoC Creator Help

Launch PSoC Creator and navigate to the following items:

■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 

the basics for developing PSoC Creator projects.

■ Simple Component Code Examples: Choose File > Code Example. These examples demon-

strate how to configure and use PSoC Creator Components. To access examples related to a 

specific Component, right-click on the Component in the schematic or in the Component Catalog. 

Select the Find Code Example option in the context menu that appears. 

■ System Reference Guide: Choose Help > System Reference > System Reference Guide. 

This guide lists and describes the system functions provided by PSoC Creator.

■ Component Datasheets: Right-click a Component and select Open Datasheet. Visit the 

PSoC 4 Component Datasheets page for a list of all PSoC 4 Component datasheets.

■ Document Manager: PSoC Creator provides a document manager to help you easily find and 

access the document resources. To open the document manager, choose the menu item Help > 

Document Manager.
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1.4 Getting Started

This guide will help you be acquainted with the PSoC 4100S Pioneer Kit:

■ The Software Installation chapter on page 17 describes the installation of the kit software. This 

includes the PSoC Creator IDE to develop and debug the applications, and PSoC Programmer to 

program the .hex files on to the device.

■ The Kit Operation chapter on page 20 describes the major features of the PSoC 4100S Pioneer 

Kit and functionalities such as programming, debugging, and the USB-UART and USB-I2C 

bridges.

■ The Code Examples chapter on page 32 describes multiple PSoC 4100S code examples that will 

help you understand how to create your own PSoC 4 projects.

■ The Appendix on page 36 provides the detailed hardware description, method to use the onboard 

F-RAM, method to use the on board EZ-BLE PRoC Module, kit schematics, and the bill of mate-

rials (BOM).

1.5 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device

for your design, and to help you to quickly and effectively integrate the device into your design. For a

comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and

PSoC 5LP. The following is an abbreviated list for PSoC 4:

■ Overview: PSoC Portfolio and PSoC Roadmap.

■ Product Selectors: PSoC 4 Product Selector. In addition, PSoC Creator includes a device selec-

tion tool.

■ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, 

PSoC 4200, PSoC 4100M, PSoC 4200M, PSoC 4200L, PSoC 4000S and PSoC 4100S device 

families.

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the 

PSoC 4 family of devices.

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced. 

Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples web 

page for a list of all available PSoC Creator code examples. To access code examples from 

within PSoC Creator – see PSoC Creator Code Examples on page 12.

■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and regis-

ters in each PSoC 4 device family.

■ Development Kits:

❐ CY8CKIT-041-40XX, CY8CKIT-041-41XX, CY8CKIT-046, CY8CKIT-044, CY8CKIT-042 and 

CY8CKIT-040 are easy-to-use and inexpensive development platforms. These kits include 

connectors for Arduino-compatible shields. Additionally, CY8CKIT-046, CY8CKIT-044, and 

CY8CKIT-042 include connectors for Digilent Pmod Peripheral Modules.

❐ CY8CKIT-049, CY8CKIT-043 and CY8CKIT-145-40XX are very low-cost prototyping platform 

for sampling PSoC 4 devices.

❐ CY8CKIT-001 is a common development platform for all PSoC family devices.

❐  MiniProg3 device provides an interface for flash programming and debug.

■ Knowledge Base Articles (KBA): Provide design and application tips from experts on using the 

device. 

■ Visit www.cypress.com/training for a set of tutorials, including PSoC Creator training. Each tuto-

rial is a series of videos that provide practical examples on various topics starting with basic con-

cepts and moving on to more advanced features.
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1.6 Technical Support

For assistance, visit Cypress Support or contact customer support at +1(800) 541-4736 Ext. 2 (in the

USA) or +1 (408) 943-2600 Ext. 2 (International).

You can also use the following support resources if you need quick assistance:

■ Self-help (Technical Documents)

■ Local Sales Office Locations

1.7 Documentation Conventions

1.8 Acronyms

Table 1-2.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:

C:\...cd\icc\

Italics
Displays file names and reference documentation:

Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:

File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:

Click the File icon and then click Open.

Times New Roman
Displays an equation:

2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.

Table 1-3.  Acronyms Used in this Document

Acronym Definition

ADC analog-to-digital converter

BLE Bluetooth Low Energy

BOM bill of materials

CINT integration capacitor

CMOD modulator capacitor

CPU central processing unit

CSD CapSense Sigma Delta

CTANK shield tank capacitor

DC direct current

Del-Sig Delta-Sigma

ESD electrostatic discharge

F-RAM Ferroelectric Random Access Memory

FPC flexible printed circuit

GPIO general-purpose input/output
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HID human interface device

I2C inter-integrated circuit

IC integrated circuit

ICSP in-circuit serial programming

IDAC current output digital-to-analog converter

IDE integrated design environment

LED light-emitting diode

PC personal computer

PGA programmable gain amplifier

PTC positive temperature coefficient

PRoC Programmable Radio-on-Chip

PSoC Programmable System-on-Chip

PWM pulse-width modulator 

RGB red green blue

SAR successive approximation register

SPI serial peripheral interface 

SRAM static random access memory

SWD serial wire debug

UART universal asynchronous receiver transmitter

USB Universal Serial Bus

WCO watch crystal oscillator

Table 1-3.  Acronyms Used in this Document (continued)

Acronym Definition
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2. Software Installation

This chapter describes the steps to install the software tools and packages on a PC to use the PSoC

4100S Pioneer Kit. This includes the IDE on which the projects are built and programmed.

2.1 Before You Begin

To install Cypress software, you will require administrator privileges. However, they are not required

to run software that is already installed. Before you install the kit software, close any other Cypress

software that is currently running.

2.2 Install Software

Follow these steps to install the PSoC 4100S Pioneer Kit software:

1. Download the CY8CKIT-041-41XX PSoC 4100S Pioneer Kit software from www.cypress.com/

CY8CKIT-041-41XX. The kit software is available in three different formats for download.

a. CY8CKIT-041-41XX Kit Complete Setup: This installation package contains the files related 

to the kit including PSoC Creator and PSoC Programmer. However, it does not include the 

Windows Installer or Microsoft .NET framework packages. If these packages are not on your 

computer, the installer directs you to download and install them from the Internet.

b. CY8CKIT-041-41XX Kit Only: This executable file installs only the kit contents, which include 

kit code examples, hardware files, and user documents. This package can be used if all the 

software prerequisites (listed in step 5) are installed on your PC.

c. CY8CKIT-041-41XX DVD ISO: This file is a complete package, stored in a DVD-ROM image 

format, which you can use to create a DVD or extract using an ISO extraction program such 

as WinZip® or WinRAR. The file can also be mounted similar to a virtual CD/DVD using virtual 

drive programs such as Virtual CloneDrive and MagicISO. This file includes all the required 

software, utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it on a virtual drive. Extract the ISO contents if you do 

not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted 

content or the mounted ISO if “Autorun from CD/DVD” is not enabled on the computer. The instal-

lation window will appear automatically. 

Note: If you are using the “Kit Complete Setup” or “Kit Only” file, then go to step 4 for installation.
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3. Click Install CY8CKIT-041-41XX to start the PSoC 4100S Pioneer Kit installation, as shown in 

Figure 2-1.

Figure 2-1.  Kit Installer Screen 

4. Select the folder in which you want to install the PSoC 4100S Pioneer Kit-related files. Choose 

the directory and click Next.

5. When you click Next, the installer automatically installs the required software, if it is not present 

on your computer. Following are the required software:

a. PSoC Creator 4.0 or later: This software is available for download separately at 

www.cypress.com/psoccreator.

b. PSoC Programmer 3.25 or later: This is installed as part of the PSoC Creator installation or is 

available separately at www.cypress.com/programmer.

6. Choose the Typical, Custom, or Complete installation type (select Typical if you do not know 

which one to select) in the Product Installation Overview window, as shown in Figure 2-2. Click 

Next after you select the installation type.
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Figure 2-2.  Product Installation Overview

7. Read the license agreement and select I accept the terms in the license agreement to con-

tinue with the installation. Click Next.

8. When the installation begins, a list of packages appears on the installation page. A green check 

mark appears next to each package after successful installation.

9. Enter your contact information or select the Continue Without Contact Information check box. 

Click Finish to complete the CY8CKIT-041-41XX PSoC 4100S Pioneer Kit software installation.

10.After the installation is complete, the kit contents are available at the following location:

<Install_Directory>\CY8CKIT-041-41XX PSoC 4100S Pioneer Kit

Default location: 

Windows 7 (64-bit): C:\Program Files (x86)\Cypress\CY8CKIT-041-41XX PSoC 4100S

Pioneer Kit

Windows 7 (32-bit): C:\Program Files\Cypress\CY8CKIT-041-41XX PSoC 4100S Pio-

neer Kit

Note: For Windows 7/8/8.1/10 users, the installed files and the folder are read-only. To use the

installed code examples, follow the steps outlined in the Code Examples chapter on page 32. These

steps will create an editable copy of the example in a path that you choose so the original installed

example is not modified.

2.3 Uninstall Software

The software can be uninstalled using one of the following methods:

■ Go to Start > All Programs > Cypress > Cypress Update Manager and select the Uninstall 

button that corresponds to the kit software.

■ Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove Pro-

grams for Windows XP; choose the product and select the Uninstall/Change button.
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This chapter introduces you to the various features of the PSoC 4100S Pioneer Kit, including the

theory of operation and the onboard programming and debugging functionality, and the KitProg2

USB-UART and USB-I2C bridges.

3.1 Theory of Operation

The PSoC 4100S Pioneer Kit is built around the PSoC 4100S device. Figure 3-1 shows the block

diagram of the PSoC 4100S device. 

Figure 3-1.  PSoC 4100S Block Diagram 

Given below is a list of major features of PSoC 4100S device.
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❐ 48-MHz ARM® Cortex®-M0+ CPU

❐ Up to 64KB flash, 8KB SRAM

❐ Real-time clock capability with a WCO

■ Programmable Analog Blocks 

❐ One 12-bit, 1-Msps SAR ADC

❐ One 10-bit, 46.8-Ksps Single-Slope ADC

❐ Two opamps configurable as PGAs, comparators, etc.

❐ Two low-power comparators (CMP)

❐ One CapSense® block that supports low-power operation with   self- and mutual-capacitance 

sensing

❐ Two 7-bit IDACs configurable as a single 8-bit IDAC

■ Programmable Digital Blocks

❐ Five 16-bit Timer, Counter, PWM (TCPWM) blocks

❐ Three serial communication blocks (SCBs) that are configurable  as I2C, SPI or UART

■ Packages

❐ 35-ball WLCSP, 32-pin QFN, 40-pin QFN, 48-pin TQFPUp to 36 GPIOs, including 

16 Smart I/Os

Refer to the PSoC 4100S datasheet for more details on the device features. 

Figure 3-2 shows the block diagram for the PSoC 4100S Pioneer Kit.

Figure 3-2.  Block Diagram of PSoC 4100S Pioneer Kit 
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The PSoC 4100S Pioneer Kit comes with a case that has the PSoC 4100S Pioneer board (main

board) and a Flex PCB. Refer to How to Open the Kit Case on page 26 for details on opening the

case.

Figure 3-3 shows the markup of the PSoC 4100S Pioneer board and the CapSense Flex PCB.

Figure 3-3.  PSoC 4100S Pioneer Board and Flex PCB

■ PSoC 4100S Pioneer Board (main board)

The PSoC 4100S Pioneer board contains the PSoC 4100S device, KitProg2 circuit, rechargeable 

battery, EZ-BLE PRoC Module, F-RAM, switches, LEDs and a voltage regulator.

■ CapSense Flex PCB

The Flex PCB has CapSense sensors including buttons, trackpad, and proximity. The Flex PCB 

has two capacitive sensing buttons, a trackpad with seven row and seven column sensors, and a 

proximity sensor loop that is used for CapSense proximity sensing.

Main board

CapSense trackpad

Proximity sensor loop

Flex PCB

CapSense buttons
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Figure 3-4 and Figure 3-5 shows the markup of the PSoC 4100S Pioneer board.

Figure 3-4.  PSoC 4100S Pioneer Board (Top View) 
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5. Power LED (LED4)

6. System power (VDD) selection switch (SW6)

10. ArduinoTM compatible power and I/O headers

11. 32.768 kHz crystal oscillator (Y1)

13. Cypress F-RAM 1Mb (FM24V10-G, U11) 

14. RGB LED (LED5)

(SW3)  

17.  User Button (SW2)

18.  Reset button (SW1) 

20. EZ-BLETM PRoCTM Module (CYBLE-022001-00, U3)

21. Potentiometer (R2)

22. VDD source selection switch (SW4)

23. Current measurement selection switch (SW7) 

24. PSoC 4100S (CY8C4146AZI-S433, U1)

       selection switch (SW5)

      (CY8C5868LTI-LP039, U15)
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Figure 3-5.  PSoC 4100S Pioneer Board (Bottom View) 

The PSoC 4100S Pioneer board has the following peripherals:

1. KitProg2 USB Micro-B connector (J6): The USB cable provided along with the PSoC 4100S 

Pioneer Kit connects between this USB connector and the PC.

2. KitProg2 Status LEDs: Red, amber, and green LEDs (LED1, LED2, and LED3) indicate the sta-

tus of the KitProg2. For details on the KitProg2 status, refer to the KitProg2 User Guide.

3. External power supply (VIN) header (J7): This header connects the external power supply 

input to the onboard regulator. The voltage input from the external supply can be between 6 V 

and 12 V.

4. KitProg2 I/O header (J8): This header brings out a few GPIOs of the onboard PSoC 5LP. This 

includes the USB-I2C bridge and USB-UART bridge lines. The additional PSoC 5LP pins are 

direct connections to the internal programmable analog logic of PSoC 5LP. You can also use 

these pins for custom applications. For more details on the KitProg2, refer to the KitProg2 User 

Guide.

5. Power LED (LED4): The amber power LED turns on when the kit is connected to a power 

source.

6. System power (VDD) selection switch (SW6): This switch selects the kit operating voltage. It 

can select between 1.9 V, 3.3 V, and 5 V.

7. KitProg2 custom application/programming header (J11): This header brings out more GPIOs 

of the PSoC 5LP. It also contains a 5-pin SWD programming header for PSoC 5LP.

8. Voltage regulator circuit: The kit can operate at four voltage levels, 1.9 V, 3.3 V, 5 V from USB 

or external power supply, and 3 V from the rechargeable battery. The kit has an onboard two-

channel regulator from Cypress that provides 3.3 V on one channel and 1.9 V on the other. 3 V is 

derived from the onboard battery and 5 V from the USB.

9. PSoC 4100S 10-pin program and debug header (J13): This 10-pin header allows you to pro-

gram and debug the PSoC 4100S using an external programmer such as MiniProg3. This header 

is not populated by default.

27

27. FPC connector
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10.Arduino-compatible power and I/O headers: This kit is compatible and operates flawlessly with 

third-party Arduino shields. The Arduino-compatible power header (J1) powers Arduino shields. 

This header also has the provision to power the kit though the VIN input pin. The Arduino-com-

patible I/O headers (J1, J2, J3, and J4) bring out the pins from PSoC 4100S to interface with the 

Arduino shields.

11.32.768-kHz crystal oscillator (Y1): This kit has a 32.768-kHz crystal oscillator to provide an 

accurate low-frequency clock for the PSoC 4100S.

12.Voltage level translator for F-RAM (U14): The F-RAM operates at 3.3 V, while the PSoC 4100S 

can operate at 1.9 V, 3.3 V, 5 V, or 3 V. This bidirectional level translator translates the I2C signals 

between the F-RAM and the PSoC 4100S.

13.Cypress F-RAM (U11): This kit features a Cypress F-RAM device (FM24V10-G) of 1 Mb capac-

ity. The F-RAM is connected to the I2C interface of the PSoC 4100S. The F-RAM device can be 

used similar to an external EEPROM memory for data logging operations. Refer to Using the 

FM24V10 F-RAM on page 44 for details on using the F-RAM.

14.RGB LED (LED5): The onboard RGB LED can be controlled from the PSoC 4100S.

15.KitProg2 user button (SW3): This button is used to switch between the KitPorg2 modes. You 

can also use this button to provide input to the PSoC 5LP in custom applications. Note that the 

switch connects the PSoC 5LP pin to ground when pressed. Refer to the KitProg2 User Guide for 

more details.

16.Rechargeable battery (V2): This kit features an onboard rechargeable battery (ML2430-HS1) to 

power the kit at 3 V.

17.User button (SW2): This button can be used to provide input to the PSoC 4100S. Note that the 

switch connects the PSoC 4100S pin to ground when pressed; therefore, you need to configure 

the PSoC 4100S pin as resistive pull-up to detect switch press.

18.Reset button (SW1): This button is used to reset the PSoC 4100S and EZ-BLE PRoC Module.

19. Arduino ICSP-compatible header (J12): This kit features an Arduino ICSP-compatible header 

for SPI interface.

20.EZ-BLE PRoC Module (U3): The kit includes a Cypress EZ-BLE PRoC Module which can be 

used for custom applications.

21.Potentiometer (R2): This kit features a potentiometer, which connects to an ADC input pin of the 

PSoC 4100S.

22.VDD source selection switch (SW4): This switch selects the power source for the kit between 

USB connector/external power supply and battery.

23.Current measurement selection switch (SW7): This switch is used to measure the PSoC 

4100S current consumption by turning off all the switches of SW7 and connecting an ammeter 

between VDD and P4.VDD test points. Refer to Current Measurement Switch on page 39 for 

more details on how to measure the current.

24.PSoC 4100S (U1): This kit is designed to highlight the features of the PSoC 4100S device 

(CY8C4146AZI-S433).

25.Programming target selection switch (SW5): This switch selects the SWD lines between 

PSoC 4100S or EZ-BLE PRoC Module for programming and debugging.

26.KitProg2 (PSoC 5LP) programmer and debugger (U15): The PSoC 5LP device 

(CY8C5868LTI-LP039) serving as KitProg2, is a multi-functional system, which includes a pro-

grammer, debugger, USB-I2C bridge, and a USB-UART bridge. Refer to the KitProg2 User Guide 

for more details.

27.FPC connector (J10): This connects the Flex PCB to the main board.

See Hardware Functional Description on page 36 for details on various hardware blocks.
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