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Safety Information

Regulatory Compliance

The CY8CKIT-042 PSoC® 4 Pioneer Kit is intended for use as a development platform for hardware

or software in a laboratory environment. The board is an open system design, which does not

include a shielded enclosure. Due to this reason, the board may cause interference to other

electrical or electronic devices in close proximity. In a domestic environment, this product may cause

radio interference. In such cases, the user may be required to take adequate preventive measures.

Also, this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default

may affect its performance and cause interference with other apparatus in the immediate vicinity. If

such interference is detected, suitable mitigating measures should be taken.

The CY8CKIT-042 as shipped from the factory has been verified to meet with requirements of CE as

a Class A product.

The CY8CKIT-042 contains electrostatic discharge (ESD) sensitive

devices. Electrostatic charges readily accumulate on the human body

and any equipment, and can discharge without detection. Permanent

damage may occur on devices subjected to high-energy discharges.

Proper ESD precautions are recommended to avoid performance

degradation or loss of functionality. Store unused CY8CKIT-042

boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of-life cycle five years from the date of

manufacturing mentioned on the back of the box. Contact your nearest

recycler for discarding the kit.



CY8CKIT-042 PSoC® 4 Pioneer Kit Guide, Doc. # 001-86371 Rev. *G 6

General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that the user perform

procedures only at an ESD workstation. If an ESD workstation is not available, use appropriate ESD

protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal

surface) on the board when handling parts.

Handling Boards

CY8CKIT-042 boards are sensitive to ESD. Hold the board only by its edges. After removing the

board from its box, place it on a grounded, static free surface. Use a conductive foam pad if

available. Do not slide board over any surface.
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1. Introduction

Thank you for your interest in the PSoC® 4 Pioneer Kit. The kit is designed as an easy-to-use and

inexpensive development kit, showcasing the unique flexibility of the PSoC 4 architecture. Designed

for flexibility, this kit offers footprint-compatibility with several third-party Arduino™ shields. This kit

has a provision to populate an extra header to support Digilent® Pmod™ peripheral modules. In

addition, the board features a CapSense® slider, an RGB LED, a push button switch, an integrated

USB programmer, a program and debug header, and USB-UART/I2C bridges. This kit supports

either 5 V or 3.3 V as power supply voltages.

The PSoC 4 Pioneer Kit is based on the PSoC 4200 device family, delivering a programmable

platform for a wide range of embedded applications. The PSoC 4 is a scalable and reconfigurable

platform architecture for a family of mixed-signal programmable embedded system controllers with

an ARM® Cortex™-M0 CPU. It combines programmable and reconfigurable analog and digital

blocks with flexible automatic routing.

1.1 Kit Contents

The PSoC 4 Pioneer kit contains:

■ PSoC 4 Pioneer board

■ Quick Start Guide

■ USB Standard-A to Mini-B cable

■ Six jumper wires
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Figure 1-1.  Kit Contents

Inspect the contents of the kit; if you find any part missing, contact your nearest Cypress sales office

for help: www.cypress.com/go/support.
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1.2 PSoC Creator™

PSoC Creator is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces

revolutionary hardware and software co-design, powered by a library of pre-verified and pre-

characterized PSoC Components™. 

With PSoC Creator, you can:

■ Drag and drop PSoC components to build a schematic of your custom design

■ Automatically place and route components and configure GPIOs

■ Develop and debug firmware using the included component APIs

PSoC Creator also enables you to tap into an entire tools ecosystem with integrated compiler chains

and production programmers for PSoC devices.

For more information, visit www.cypress.com/Creator.

1.3 Getting Started

This guide helps you to get acquainted with the PSoC 4 Pioneer Kit. The Software Installation

chapter on page 15 describes the installation of the kit software. The Kit Operation chapter on

page 21 explains how to program the PSoC 4 with a programmer and debugger – either the onboard

PSoC 5LP or the external MiniProg3 (CY8CKIT-002). The Hardware chapter on page 31 details the

hardware operation. The Code Examples chapter on page 47 describes the code examples. The

Advanced Topics chapter on page 66 deals with topics such as building projects for PSoC 5LP, USB-

UART functionality, and USB-I2C functionality of PSoC 5LP. The Appendix on page 113 provides the

schematics, pin assignment, use of zero-ohm resistors, troubleshooting, and the bill of materials

(BOM).
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1.4 Additional Learning Resources

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device

for your design, and to help you to quickly and effectively integrate the device into your design. For a

comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4, and

PSoC 5LP. The following is an abbreviated list for PSoC 4: 

■ Overview: PSoC Portfolio, PSoC Roadmap

■ Product Selectors: PSoC 1, PSoC 3, PSoC 4, or PSoC 5LP. In addition, PSoC Creator includes

a device selection tool.

■ Datasheets: Describe and provide electrical specifications for the PSoC 4000, PSoC 4100, and

PSoC 4200 device families.

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the

PSoC 4 family of devices.

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced

level. Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples

webpage for a list of all available PSoC Creator code examples. For accessing code examples

from within PSoC Creator – see PSoC Creator Code Examples on page 12.

■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and

registers in each PSoC 4 device family.

■ Development Kits:

❐ CY8CKIT-042 and CY8CKIT-040, PSoC 4 Pioneer Kits, are easy-to-use and inexpensive

development platforms. These kits include connectors for Arduino compatible shields and Dig-

ilent Pmod daughter cards.

❐ CY8CKIT-049 is a very low-cost prototyping platform for sampling PSoC 4 devices.

❐ CY8CKIT-001 is a common development platform for all PSoC family devices.

■ The MiniProg3 device provides an interface for flash programming and debug.

■ Knowledge Base Articles (KBA): Provide design and application tips from experts on the

devices/kits. For instance, KBA93541, explains how to use CY8CKIT-049 to program another

PSoC 4. 
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1.4.1 PSoC Creator

PSoC Creator is a free Windows-based integrated design environment (IDE). It enables concurrent

hardware and firmware design of systems based on PSoC 3, PSoC 4, and PSoC 5LP. See

Figure 1-2 – with PSoC Creator, you can: 

1. Drag and drop Components to build your hardware system design in the main design workspace

2. Codesign your application firmware with the PSoC hardware

3. Configure Components using configuration tools

4. Explore the library of 100+ Components

5. Access Component datasheets

Figure 1-2.  PSoC Creator Features 

Visit PSoC Creator training page for video tutorials on learning and using PSoC Creator. 
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1.4.2 PSoC Creator Code Examples

PSoC Creator includes a large number of code example projects. These projects are accessible

from the PSoC Creator Start Page, as Figure 1-3 shows.

Example projects can speed up your design process by starting you off with a complete design,

instead of a blank page. The example projects also show how PSoC Creator Components can be

used for various applications. Code examples and datasheets are included, as Figure 1-4 on

page 13 shows.

In the Find Example Project dialog shown in Figure 1-4 on page 13, you have several options:

■ Filter for examples based on device family or keyword

■ Select from the menu of examples offered based on the Filter Options

■ View the datasheet for the selection (on the Documentation tab)

■ View the code example for the selection. You can copy and paste code from this window to your 

project, which can help speed up code development, or

■ Create a new workspace for the example project. This can speed up your design process by 

starting you off with a complete, basic design. You can then adapt that design to your application.

Figure 1-3.  Code Examples in PSoC Creator 
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Figure 1-4.  Code Example Projects with Sample Code 

1.4.3 PSoC Creator Help

Visit the PSoC Creator home page to download the latest version of PSoC Creator. Then, launch

PSoC Creator and navigate to the following items:

■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 

the basics for developing PSoC Creator projects.

■ Simple Component example projects: Choose File > Open > Example projects. These 

example projects demonstrate how to configure and use PSoC Creator Components.

■ Starter designs: Choose File > New > Project > PSoC 4100 / PSoC 4200 Starter Designs. 

These starter designs demonstrate the unique features of PSoC 4.

■ System Reference Guide: Choose Help > System Reference > System Reference Guide. 

This guide lists and describes the system functions provided by PSoC Creator.

■ Component datasheets: Right-click a Component and select “Open Datasheet.” Visit the 

PSoC 4 Component Datasheets page for a list of all PSoC 4 Component datasheets.

■ Document Manager: PSoC Creator provides a document manager to help you to easily find and 

review document resources. To open the document manager, choose the menu item Help > 

Document Manager.
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1.4.4 Technical Support

If you have any questions, our technical support team is happy to assist you. You can create a sup-

port request on the Cypress Technical Support page.

If you are in the United States, you can talk to our technical support team by calling our toll-free num-

ber: +1-800-541-4736. Select option 2 at the prompt.

You can also use the following support resources if you need quick assistance.

■ Self-help.

■ Local Sales Office Locations.

1.5 Documentation Conventions

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:

C:\ ...cd\icc\

Italics
Displays file names and reference documentation:

Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

File > Open
Represents menu paths:

File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:

Click the File icon and then click Open.

Times New Roman
Displays an equation:

2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Software Installation

2.1 Install Kit Software

Follow these steps to install the PSoC 4 Pioneer Kit software:

1. Download and install the PSoC 4 Pioneer Kit software from www.cypress.com/go/CY8CKIT-042.

2. Select the folder to install the CY8CKIT-042 related files. Choose the directory and click Next.

Figure 2-1.  Installation Folder
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3. Select the installation type and click Next.

Figure 2-2.  Installation Type Options

4. Read and accept the End-User Licence Agreement and click Next to proceed with the 

installation.

After the installation is complete, the kit contents are available at the following location: 

<Install_Directory>\CY8CKIT-042 PSoC 4 Pioneer Kit\<version>

Note For Windows 7 users, the installed files and the folder are read-only. To change the property,

right-click the folder and select Properties > Attributes; disable the Read-only radio button. Click

Apply and OK to close the window. 

2.2 Install Hardware

There is no additional hardware installation required for this kit.

2.3 Install Software

When installing the PSoC 4 Pioneer Kit, the installer checks if the required software is installed in the

system. If the required applications are not installed, then the installer prompts you to download and

install them.

The following software is required:

■ PSoC Creator 3.2 Service Pack 1 or later: Download the latest software from 

www.cypress.com/go/Creator.

■ PSoC Programmer 3.23.1 or later: Download the latest software from 

www.cypress.com/go/Programmer.

■ Code examples: After the kit installation is complete, the code examples are available in the kit 

firmware folder. Download the CD ISO image or the setup files to install the kit from

 www.cypress.com/go/CY8CKIT-042.
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2.4 Uninstall Software

The software can be uninstalled using one of the following methods:

■ Go to Start > All Programs > Cypress > Cypress Update Manager > Cypress Update Man-

ager; select the Uninstall button.

■ Go to Start > Control Panel > Programs and Features; select the Uninstall/Change button.

2.5 Develop Code Fast and Easy with Code Examples

PSoC Creator provides several example projects that make code development fast and easy. To

access these projects, click Find Example Project… under the Example and Kits section in the

Start Page of PSoC Creator or navigate to the Creator tool bar and select File > Example Project.

Figure 2-3.  Find Example Project

The Find Example Project section has various filters that help to locate the most relevant project. 
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PSoC Creator also provides several starter designs for each device family. These designs highlight

features that are unique to each PSoC family. They provide users with a starting place instead of

creating a new empty design. These starter projects come loaded with various pre-selected compo-

nents. To use a starter design, navigate to File > New > Project and select the design required.

Figure 2-4.  Starter Designs 

In addition to the example projects and starter designs that are available within PSoC Creator,

Cypress continuously strives to provide the best support. Click here to view a growing list of applica-

tion notes for PSoC 3, PSoC 4, and PSoC 5LP.
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2.6 Open an Example Project in PSoC Creator

1. Launch PSoC Creator from the Start menu.

Figure 2-5.  PSoC Creator Start Page

2. Open the example project from the Start Page by clicking <Project.cywrk> present under Exam-

ples and Kits > Kits > CY8CKIT-042.

Figure 2-6.  Open Example Project
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3. The example project opens and displays the project files in the Workspace Explorer. Subsequent 

sections of this user guide describe how to build, program, and understand the example projects 

supported in this kit.

Figure 2-7.  Workspace Explorer
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3. Kit Operation

The PSoC 4 Pioneer Kit can be used to develop applications using the PSoC 4 family of devices and

the Arduino shields and Digilent Pmod daughter cards. Figure 3-1 is an image of the PSoC 4

Pioneer board with a markup of the onboard components.

Figure 3-1.  PSoC 4 Pioneer Board
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Kit Operation

3.1 Pioneer Kit USB Connection

The PSoC 4 Pioneer Kit connects to the PC over a USB interface. The kit enumerates as a

composite device and three separate devices appear under the Device Manager window in the

Windows operating system.

Table 3-1.  PSoC 4 Pioneer Kit in Device Manager After Enumeration

Figure 3-2.  KitProg Driver Installation

Port Description

USB Composite Device Composite device

USB Input Device USB-I2C bridge, KitProg command interface

KitProg Programmer and debugger

KitProg USB-UART USB-UART bridge, which appears as the COM# port
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3.2 Programming and Debugging PSoC 4

The kit allows programming and debugging of the PSoC 4 device in two modes:

■ Using the onboard PSoC 5LP programmer and debugger

■ Using a CY8CKIT-002 MiniProg3 programmer and debugger

3.2.1 Using the Onboard PSoC 5LP Programmer and Debugger

The default programming interface for the kit is a USB-based, onboard programming interface.

Before trying to program the device, PSoC Creator and PSoC Programmer must be installed. See

Install Software on page 16 for information on installing the kit software. 

1. To program the device, plug the USB cable into the programming USB connector J10, as shown 

in Figure 3-3. The kit will enumerate as a composite device. See Pioneer Kit USB Connection on 

page 22 for details.

Figure 3-3.  Connect USB Cable to J10

2. The onboard PSoC 5LP uses serial wire debug (SWD) to program the PSoC 4 device. See 

Figure 3-4 for this implementation.

Figure 3-4.  SWD Programming PSoC 4 Using PSoC 5LP
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3. The Pioneer Kit’s onboard programmer will enumerate on the PC and in the software tools as 

KitProg. Load an example project in PSoC Creator (such as the project described in Install 

Software on page 16) and initiate the build by clicking Build > Build Project or [Shift]+[F6]. 

Figure 3-5.  Build Project in PSoC Creator 

4. After the project is built without errors and warnings, select Debug > Program or [Ctrl]+[F5] to 

program the device. 

Figure 3-6.  Program Device from PSoC Creator 

The onboard programmer supports only the RESET programming mode. When using the onboard

programmer, the board can either be powered by the USB (VBUS) or by an external source such as

an Arduino shield. If the board is already powered from another source, plugging in the USB

programmer does not damage the board.



CY8CKIT-042 PSoC® 4 Pioneer Kit Guide, Doc. # 001-86371 Rev. *G 25

Kit Operation

3.2.2 Using CY8CKIT-002 MiniProg3 Programmer and Debugger

The PSoC 4 on the Pioneer Kit can also be programmed using a MiniProg3 (CY8CKIT-002). To use

MiniProg3 for programming, use the J6 connector on the board, as shown in Figure 3-7. With

MiniProg3, programming is similar to the onboard programmer; however, the setup enumerates as a

MiniProg3. Only the RESET programming mode is available.

The board can also be powered from the MiniProg3. To do this, select Tool > Options. In the

Options window, expand Program and Debug > Port Configuration; click MiniProg3 and select

the settings shown in Figure 3-8. Click Debug > Program to program and power the board.

Note: The CY8CKIT-002 MiniProg3 is not part of the PSoC 4 Pioneer Kit contents. It can be

purchased from the Cypress Online Store.

Figure 3-7.  PSoC 4 Programming/Debug Using MiniProg3
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