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Copyrights

© Cypress Semiconductor Corporation, 2015. The information contained herein is subject to change without notice. Cypress

Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress

product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor

intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express

written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-

support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The

inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use

and in doing so indemnifies Cypress against all charges. 

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by

and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty

provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create

derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom

software and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as

specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this

Source Code except as specified above is prohibited without the express written permission of Cypress. 

Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS

MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS

FOR A PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials

described herein. Cypress does not assume any liability arising out of the application or use of any product or circuit

described herein. Cypress does not authorize its products for use as critical components in life-support systems where a

malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product

in a life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies

Cypress against all charges. 

Use may be limited by and subject to the applicable Cypress software license agreement. 

PSoC and CapSense are registered trademarks and PSoC Creator, PRoC, and EZ-BLE are trademarks of Cypress

Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective

corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its

family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.

There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our

knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can

guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as ‘unbreakable’.

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly

evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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Safety Information

Regulatory Compliance

The CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit is intended for use as a development platform

for hardware or software in a laboratory environment. The board is an open system design, which

does not include a shielded enclosure. This may cause interference to other electrical or electronic

devices in close proximity. In a domestic environment, this product may cause radio interference. In

such cases, take adequate preventive measures. In addition, this board should not be used near any

medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default

may affect its performance and cause interference with other apparatus in the immediate vicinity. If

such interference is detected, suitable mitigating measures should be taken.

The CY8CKIT-043 PSoC 4 M-Series Prototyping Kit, as shipped from the factory, has been verified

to meet with requirements of CE as a Class A product.

The kit contains ESD-sensitive devices. Electrostatic charges readily

accumulate on the human body and any equipment, and can discharge

without detection. Permanent damage may occur on devices subjected

to high-energy discharges. Proper ESD precautions are recommended

to avoid performance degradation or loss of functionality. Store unused

kit boards in the protective shipping package.

End-of-Life/Product Recycling

This kit has an end-of life five years from the date of manufacture

mentioned on the back of the box. Contact your nearest recycler to

dispose the kit.
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General Safety Instructions

ESD Protection

ESD can damage boards and associated components. Cypress recommends that you perform

procedures only at an ESD workstation. If such a workstation is not available, use appropriate ESD

protection by wearing an antistatic wrist strap attached to the chassis ground (any unpainted metal

surface) on your board when handling parts.

Handling Boards

The CY8CKIT-043 PSoC 4 M-Series Prototyping boards are sensitive to ESD. Hold the board only 

by its edges. After removing the board from its box, place it on a grounded, static-free surface. Use a 

conductive foam pad if available. Do not slide board over any surface.
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1. Introduction

Thank you for your interest in the CY8CKIT-043 PSoC® 4 M-Series Prototyping Kit. This kit is

designed as an easy-to-use and inexpensive prototyping platform. It supports the PSoC 4 M-Series

device family, delivering a complete system solution for a wide range of embedded applications at a

very low cost. The PSoC 4200M device is an expansion of the PSoC 4 device family, which offers

more flash, GPIOs, and programmable analog and digital blocks. The PSoC 4200M device is a true

programmable embedded system-on chip, integrating custom analog and digital peripheral

functions, memory, and an ARM® Cortex®-M0 microcontroller on a single chip. The programmable

analog and digital peripheral functions allow higher flexibility, in-field tuning of the design, and faster

time-to-market. 

The PSoC 4 M-Series Prototyping Kit offers an open footprint breakout board to maximize the end-

utility of the PSoC 4200M device. This kit provides a low-cost alternative to device samples while

providing a platform to easily develop and integrate the PSoC 4200M device into your end-system.

In addition, the board includes the following features:

■ Onboard CMOD capacitors to enable CapSense® development

■ Bypass capacitors to ensure high-quality ADC conversions

■ An LED to provide feedback

■ A push button to provide a simple user input 

■ Load capacitors to connect the 32-kHz external crystal oscillator

■ 3.3-V to 5.5-V operation

The PSoC 4 M-Series Prototyping Kit also integrates the Cypress KitProg, which enables onboard

programming, debugging, and bridging functionality, such as USB-UART and USB-I2C. The KitProg

is used to program and debug the target PSoC 4200M device (see Figure 1-1). The prototyping kit

allows you to separate the KitProg board from the PSoC 4 M-Series target board.

1.1 Kit Contents

This kit contains only the PSoC 4 M-Series Prototyping Kit board. 

Figure 1-1.  CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

PSoC 4200M TargetKitProg
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1.2 PSoC Creator

PSoC Creator™ is a state-of-the-art, easy-to-use integrated design environment (IDE). It introduces

revolutionary hardware and software co-design, powered by a library of preverified and

precharacterized PSoC Components. With PSoC Creator, you can:

1. Drag and drop Components to build your hardware system design in the main design workspace

2. Codesign your application firmware with the PSoC hardware

3. Configure Components using configuration tools

4. Explore the library of 100+ Components

5. Review Component datasheets

Figure 1-2.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains

and production programming programmers for PSoC devices.

For more information, visit www.cypress.com/psoccreator. Visit PSoC Creator training page for video

tutorials on learning and using PSoC Creator.
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1.2.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are available from the

PSoC Creator Start Page, as Figure 1-3 shows.

Code examples can speed up your design process by starting you off with a complete design,

instead of a blank page. The code examples also show how PSoC Creator Components can be

used for various applications. Code examples and documentation are included, as shown in

Figure 1-4 on page 10.

In the Find Example Project dialog shown in Figure 1-4, you have several options:

■ Filter for examples based on architecture or device family, that is, PSoC 3, PSoC 4, or 

PSoC 5LP; project name; or keyword.

■ Select from the menu of examples offered based on the Filter Options.

■ Review the example project’s description (on the Documentation tab).

■ Review the code from the Sample Code tab. You can copy the code from this window and paste 

to your project, which can help speed up code development.

■ Create a new project (and a new workspace if needed) based on the selection. This can speed 

up your design process by starting you off with a complete, basic design. You can then adapt that 

design to your application.

Figure 1-3.  Code Examples in PSoC Creator
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Figure 1-4.  Code Example Projects with Sample Code

1.2.2 Kit Code Example

In addition to the examples built into PSoC Creator, this kit includes a simple example, which can be

used to quickly evaluate the functionality of this kit. The example is described in the Code

Examples chapter on page 33. In addition, the chapter also includes a section explaining how to use

PSoC Creator code examples with the kit by taking one example.

1.2.3 PSoC Creator Help

Visit the PSoC Creator home page to download the latest version of PSoC Creator. Then, launch

PSoC Creator and navigate to the following items:

■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 

the basics for developing PSoC Creator projects.

■ Simple Component example projects: Choose File > Example project.... These example 

projects demonstrate how to configure and use PSoC Creator Components.

■ Starter designs: Choose File > New > Project > PSoC 4100M / PSoC 4200M Starter Designs. 

These starter designs demonstrate the unique features of the PSoC 4 M-Series.

■ System Reference Guide: Choose Help > System Reference Guides. This guide lists and 

describes the system functions provided by PSoC Creator.

■ Component datasheets: Right-click a Component and select Open Datasheet, as shown in 

Figure 1-5 on page 11. Visit the PSoC 4 Component Datasheets page for a list of all PSoC 4 

Component datasheets.

■ Document Manager: PSoC Creator provides a document manager to help you to easily find and 

review document resources. To open the document manager, choose the menu item Help > 

Document Manager.
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Figure 1-5.  Opening Component Datasheet

1.3 Getting Started

This guide will help you get acquainted with the PSoC 4 M-Series Prototyping Kit:

■ The Software Installation chapter on page 13 describes the installation of the kit software. This 

includes installation of PSoC Creator IDE for development and debugging the applications, and 

PSoC Programmer for programming hex files.

■ The Kit Operation chapter on page 16 describes the major features of the PSoC 4 M-Series 

Prototyping Kit and functionalities such as programming, debugging, and the USB-UART and 

USB-I2C bridges.

■ The Hardware chapter on page 20 details the hardware content of the kit and the hardware 

operation.

■ The Code Examples chapter on page 33 describes code examples that will help you create your 

own PSoC 4 M-Series projects.

■ The Appendix on page 42 provides schematics, details about programming the kit using 

MiniProg3, and the bill of materials (BOM).

1.4 Additional Learning Resources

Cypress provides a wealth of information at www.cypress.com to help you to select the right PSoC

device for your design, and to help you to quickly and effectively integrate the device into your

design. For a comprehensive list of resources, see KBA86521, How to Design with PSoC 3, PSoC 4,

and PSoC 5LP. The following is an abbreviated list for PSoC 4:

■ Overview: PSoC Portfolio and PSoC Roadmap

■ Product Selectors: PSoC 1, PSoC 3, PSoC 4, or PSoC 5LP. In addition, PSoC Creator includes a 

device selection tool.

■ Datasheets: Describe and provide electrical specifications for the PSoC 4 device family

■ CapSense Design Guide: Learn how to design capacitive touch-sensing applications with the 

PSoC 4 family of devices.

■ Application Notes and Code Examples: Cover a broad range of topics, from basic to advanced 

level. Many of the application notes include code examples. Visit the PSoC 3/4/5 Code Examples 

webpage for a list of all available PSoC Creator code examples. To access code examples from 

within PSoC Creator, see PSoC Creator Code Examples on page 9.
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■ Technical Reference Manuals (TRM): Provide detailed descriptions of the architecture and 

registers in each PSoC 4 device family.

■ Development Kits:

❐ CY8CKIT-040, CY8CKIT-042, and CY8CKIT-044 are easy-to-use and inexpensive develop-

ment platforms. These kits include connectors for Arduino-compatible shields and Digilent 

Pmod peripheral modules.

❐ CY8CKIT-049 and CY8CKIT-043 are very low-cost prototyping platforms for sampling PSoC 4 

devices.

❐ The MiniProg3 kit provides an interface for flash programming and debug.

■ Knowledge Base Articles (KBA): Provide design and application tips from experts on using the 

device.

■ PSoC Creator Training: Visit www.cypress.com/go/creatorstart/creatortraining for a 

comprehensive list of video trainings on PSoC Creator.

■ Learning From Peers: Visit www.cypress.com/forums to meet enthusiastic PSoC developers 

discussing the next generation embedded systems on Cypress Developer Community Forums.

1.5 Technical Support

If you have any questions, our technical support team is happy to assist you. You can create a

support request on the Cypress Technical Support page.

If you are in the United States, you can talk to our technical support team by calling our toll-free

number: +1-800-541-4736. Select option 2 at the prompt.

You can also use the following support resources if you need quick assistance.

■ Self-help.

■ Local Sales Office Locations.

1.6 Document Conventions

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New Displays file locations, user entered text, and source code:
C:\...cd\icc\

Italics Displays file names and reference documentation:

Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:

[Enter] or [Ctrl] [C]

File > Open Represents menu paths:

File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:

Click the File icon and then click Open.

Times New Roman Displays an equation:

2 + 2 = 4

Text in gray boxes Describes Cautions or unique functionality of the product.
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2. Software Installation

This chapter describes the steps to install the software tools and packages on a computer for using

the PSoC 4 M-Series Prototyping Kit. This includes the IDE on which the projects will be built and

used for programming.

2.1 Before You Begin

All Cypress software installations require administrator privileges, but these are not required to run

the software after it is installed. Close any other Cypress software that is currently running before

installing the kit software.

Note: By default, the kit contents are installed in C:\Program Files\Cypress for a 32-bit

machine and C:\Program Files(x86)\Cypress for a 64-bit machine. This folder will contain

the kit example project. To open this example, it is recommended to use the procedure described in

the Code Examples chapter on page 33. That procedure will create an editable copy of the example

in a path that you chose so that the original installed example will not be modified.

2.2 Install Software

Follow these steps to install the PSoC 4 M-Series Prototyping kit software:

1. Download the kit software from www.cypress.com/CY8CKIT-043. The kit software is available for 

download in three formats.

a. CY8CKIT-043 Kit Setup: This installation package contains the files related to the kit including 

PSoC Creator and PSoC Programmer. However, it does not include the Windows Installer or 

Microsoft .NET framework packages. If these packages are not on your computer, the installer 

directs you to download and install them from the Internet.

b. CY8CKIT-043 Kit Only: This executable file installs only the kit contents, which include a kit 

code example, hardware files, and user documents. This package can be used if all the 

software prerequisites (listed in step 5) are installed on your computer.

c. CY8CKIT-043 DVD ISO: This file is a complete package, stored in a DVD-ROM image format, 

that you can use to create a DVD or extract using an ISO extraction program such as Win-

RAR. The file can also be mounted similar to a virtual CD/DVD using virtual drive programs 

such as Virtual CloneDrive and MagicISO. This file includes all the required prerequisite soft-

ware, utilities, drivers, hardware files, and user documents.

2. If you have downloaded the ISO file, mount it on a virtual drive. Extract the ISO contents if you do 

not have a virtual drive to mount. Double-click cyautorun.exe in the root directory of the extracted 

content or mounted ISO if "Autorun from CD/DVD" is not enabled on the computer. The 

installation window will appear automatically. 

Note: If you are using the "Kit Setup" or "Kit Only" file, then go to step 4 for installation.
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3. Click Install CY8CKIT-043 Kit to start the kit installation, as shown in Figure 2-1.

Figure 2-1.  Kit Installer Screen

4. Select the directory in which you want to install the PSoC 4 M-Series Prototyping kit-related files. 

Choose the directory and click Next.

5. When you click Next, the PSoC 4 M-Series Prototyping kit installer automatically installs the 

required software, if it is not present on your computer. Following are the required software:

a. PSoC Creator 3.2 or later: This software is also available at www.cypress.com/psoccreator.

b. PSoC Programmer 3.23 or later: This is installed as part of PSoC Creator installation 

(www.cypress.com/programmer).

6. Choose the Typical/Custom/Complete installation type (select 'Typical' if you do not know which 

one to select) in the Product Installation Overview window, as shown in Figure 2-2. Click Next 

after you select the installation type.
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Figure 2-2.  Product Installation Overview

7. Read the License agreement and select I accept the terms in the license agreement to 

continue with the installation. Click Next.

8. When the installation begins, a list of packages appears on the installation page. A green check 

mark appears next to each package after successful installation.

9. Enter your contact information or select the check box Continue Without Contact Information. 

Click Finish to complete the kit installation.

10.After the installation is complete, the kit contents are available at the following location:

<Install_Directory>\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

Default location:

Windows OS (64-bit): 

C:\Program Files (x86)\Cypress\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

Windows OS (32-bit):

C:\Program Files\Cypress\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit

Note: For Windows 7/8/8.1 users, the installed files and the folder are read-only. To use the installer

code example, follow the steps outlined in the Code Examples chapter on page 33.

2.3 Uninstall Software

The software can be uninstalled using one of the following methods:

1. Go to Start > All Programs > Cypress > Cypress Update Manager and select the Uninstall 

button next to the product that needs to be uninstalled.

2. Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove 

Programs for Windows XP; choose the product and select the Uninstall/Change button. 
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3. Kit Operation

This chapter introduces you to the features of the PSoC 4 M-Series Prototyping Kit. It describes the

programming and debugging functionality, KitProg USB-UART and USB-I2C bridges, and the

method to update the KitProg firmware.

3.1 Theory of Operation

Figure 3-1 shows the block diagram for the PSoC 4 M-Series Prototyping Kit.

Figure 3-1.  Block Diagram of PSoC 4 M-Series Prototyping Kit

The PSoC 4 M-Series Prototyping Kit is simplistic in design and provides complete access to

develop applications using the PSoC 4200M device family. This kit supports the following features: 

■ KitProg: It is an onboard programmer/debugger, which enables the user to program and debug 

the target PSoC 4200M device. It can also act as a USB-UART and USB-I2C bridge. When used 

as a standalone module, it can be used to program devices of PSoC 3, PSoC 4, or PSoC 5 

families through the SWD interface. For more details on the KitProg functionality, refer to the 

KitProg User Guide.

■ Expansion Headers: The PSoC 4 M-Series Prototyping kit brings all I/Os of the target device to 

the two expansion headers, enabling the user to have maximum access to the capabilities of the 

PSoC 4200M device.
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■ User LED: The onboard LED can be used to display outputs from the PSoC 4200M device. This 

includes modulating the brightness of the LED to notify different states of the device. 

■ Push Button (SW): The push button can be used to provide input to the PSoC 4200M device. 

Note: The switch connects the PSoC 4200M pin to ground when pressed. Therefore, you need to 

configure the PSoC 4200M pin as resistive pull-up for detecting the switch press.

■ Reset Button: This button is used for the following purposes:

❐ Reset the PSoC 4200M device: When pressed, it connects the XRES line of the PSoC 4200M 

to ground and resets the PSoC 4200M device.

❐ Bootload the KitProg: When pressed while connecting the kit’s PCB USB connector to the 

USB port of the PC, the KitProg enters bootloader mode. For more details on the KitProg 

functionality, refer to the KitProg User Guide.

Note: When the two boards are separated, the user can mount the SW2 button on the target board

to reset the PSoC 4200M device using a switch.

■  EZ-BLE: It is a fully integrated, 10×10×1.8 mm, fully certified, programmable BLE module 

designed for ease-of-use and reduced time-to-market. You can use the EZ-BLE module to add 

BLE capabilities to the board. The board only includes a footprint for the module. Refer to 

Section 4.2.7 EZ-BLE PRoC Module on page 30 for details.

■ DPDT switch: This switch is used to select the KitProg's SWD target (PSoC 4200M or EZ-BLE). 

By default, this switch is not populated on-board and the PSoC 4200M SWD lines are hard-wried 

to the KitProg's SWD programming lines.

■ 10-pin program/debug header: This header provides support for program/debug via the 

MiniProg3's 10-pin program/debug header. This header is not populated by default as the pro-

gram/debug functionality is already provided by the on-board KitProg.

3.2 KitProg

The KitProg is a multi-functional system, which includes a programmer, debugger, USB-I2C bridge,

and a USB-UART bridge. The Cypress PSoC 5LP device is used to implement the KitProg

functionality. The KitProg is integrated in most PSoC development kits. For more details on the

KitProg functionality, refer to the KitProg User Guide available on the kit web page or in the following

location: <Install_Directory>\CY8CKIT-043 PSoC 4 M-Series Prototyping Kit\

<version>\Documentation\KitProg_User_Guide.pdf. This is also accessible from inside

PSoC Creator by clicking on the kit name on the Start page (left pane) and then selecting User

Guide for KitProg from the list of available documents (right pane).

3.3 Programming and Debugging the PSoC 4 Target Device

The target PSoC 4 device can be programmed and debugged using the built-in KitProg. Before

programming the device, ensure that PSoC Creator and PSoC Programmer are installed on your

computer. See Install Software on page 13 for more information.

3.3.1 Programming Using PSoC Creator

1. Connect the kit to the computer through the PCB USB connector, J6, as shown in Figure 3-2. The 

kit will enumerate as a composite device when you plug in the PSoC 4 M-Series Prototyping kit to 

your computer for the first time. The kit drivers should be automatically installed.
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Figure 3-2.  Connecting the PSoC 4 M-Series Prototyping Kit to a Computer

2. Open the desired project in PSoC Creator from File > Open > Project/Workspace. This 

provides the option to browse and open a previously saved project. If you want to open the 

example project provided with the kit, follow the instructions in the Code Examples chapter on 

page 33.

3. Select Build > Build Project or press [Shift] [F6] to build the project as shown in Figure 3-3.

Figure 3-3.  Build an Example Project

4. If there are no errors during build, program the firmware into the kit by choosing Debug > 

Program or press [Ctrl] [F5], as shown in Figure 3-4. This programs the target PSoC 4200M 

device on the PSoC 4 M-Series Prototyping Kit; the kit is now ready for use.
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Figure 3-4.  Programming Device From PSoC Creator

3.3.2 Debugging Using PSoC Creator

For debugging the project using PSoC Creator, follow steps 1 to 3 from Programming Using PSoC

Creator on page 17 followed by these steps:

1. Click the Debug icon  or press [F5]. Alternatively, you can choose Debug > Debug.

2. When PSoC Creator opens in Debug mode, use the buttons on the toolbar to debug your appli-

cation. 

For more details on using the debug features, refer to section 3.2 of the KitProg User Guide.

3.3.3 Programming Using PSoC Programmer

PSoC Programmer (3.23 or later) can be used to program existing .hex files into the PSoC 4 M-

Series Prototyping Kit. Refer to section 3.3 of the KitProg User Guide for a detailed explanation on

how to program using PSoC Programmer.

3.4 USB-UART Bridge

The KitProg can act as a USB-UART bridge. The UART lines between the KitProg and the target are

hard-wired on the board, through the snappable area, with UART_RX assigned to P7[1] and

UART_TX assigned to P7[0] on PSoC 4200M. For more details on the KitProg USB-UART function-

ality, refer to section 5 of the KitProg User Guide.

3.5 USB-I2C Bridge

The KitProg can function as a USB-I2C bridge and communicate with the Bridge Control Panel

(BCP) software utility. The I2C lines on the PSoC 4200M device are P4[1] (SDA) and P4[0] (SCL),

which are hardwired on the board to the I2C lines of the KitProg. The USB-I2C supports I2C speeds

of 50 kHz, 100 kHz, 400 kHz, and 1 MHz. For more details on the KitProg USB-I2C functionality,

refer to section 6 of the KitProg User Guide.

3.6 Updating the KitProg Firmware

The KitProg firmware normally does not require any update. You can use PSoC Programmer to

update the KitProg firmware. Refer to section 3.5 of the KitProg User Guide for more details.
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4. Hardware

4.1 Board Details

The PSoC 4 M-Series Prototyping Kit consists of the following blocks:

■ PSoC 4200M device U2 (CY8C4247AZI-M485)

■ PSoC 4200M headers J1 and J2

■ PSoC 4200M 10-pin program/debug header J5 (footprint only)

■ KitProg (PSoC 5LP) device U1 (CY8C5868LTI-LP039) 

■ KitProg headers J8 and J9

■ SWD connection J3 and J7

■ USB finger connector J6

■ EZ-BLE™ PRoC™ module U4 (footprint only)

■ One DPDT switch SW4 to select the SWD target device (footprint only)

■ One blue LED LED1 (User)

■ One amber LED LED2 (Power)

■ One green LED LED3 (Status)

■ User push button SW1

■ Reset buttons SW2 (footprint only) and SW3

■ External reference capacitor C3 (SARADC bypass)

■ CapSense capacitors (CMOD C10 and CTANK C13)

■ Current measurement jumper J4 (footprint only)

■ Perforated ‘snappable’ board design
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Figure 4-1.  PSoC 4 M-Series Prototyping Kit Pin Details

P0_1
P0_0
P3_6
P3_5
P3_4
P3_0
GND

GND
VDDA

EZ-BLE TX ->/P3_0
EZ-BLE RX <-/P3_1

P3_2
P3_3
P3_4
P3_5
P3_6
P3_7

I2C SCL/P4_0
I2C SDA/P4_1
*CMOD/P4_2
*CTANK/P4_3

P4_4
P4_5
P4_6

KitProg TX ->/P7_0
KitProg RX <-/P7_1

P0_0
P0_1
P0_2
P0_3

*WCO IN/P0_4
*WCO OUT/P0_5

P0_6
SW1/P0_7

GND
VDDD

VDDIO
GND
P6_5
P6_4
P6_2
P6_1
P6_0
P2_7
P2_6
P2_5
P2_4
P2_3
P2_2
P2_1
P2_0
P1_7/SAR BYPASS*
P1_6/LED1
P1_5
P1_4
P1_3
P1_2
P1_1
P1_0
P5_5
P5_3
P5_2
P5_1
P5_0
RESET

P12_7/UART TX
P12_6/UART RX
P12_1/I2C SDA
P12_0/I2C SCL
P12_5
GND
VBUS

KitProg

PSoC® 4 M-Series 
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4.2 Hardware Details

4.2.1 Target Board

The target board uses the PSoC 4200M device. PSoC 4 is a scalable and reconfigurable platform

architecture for a family of programmable embedded system controllers with an ARM Cortex-M0

CPU. It combines programmable and reconfigurable analog and digital blocks with flexible automatic

routing. The PSoC 4200M device family, based on this platform architecture, is a combination of a

microcontroller with digital programmable logic, programmable analog, programmable interconnect,

high-performance analog-to-digital conversion, opamps with comparator mode, and standard

communication and timing peripherals. The PSoC 4200M products are fully compatible with

members of the PSoC 4 platform for new applications and design needs. The programmable analog

and digital subsystems allow flexibility and in-field tuning of the design. For more information, refer to

the PSoC 4 web page and the PSoC 4200M Family Datasheet.

Figure 4-2.  Schematic of PSoC 4 (Target)
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4.2.2 KitProg Board

PSoC 5LP on the KitProg board is used to program and debug the target PSoC 4 device. The

KitProg PSoC 5LP connects to the USB port of the computer through the PCB USB connector and to

the SWD interface of the target PSoC 4 device. See the KitProg User Guide for additional details

and functions provided by the KitProg.

Figure 4-3.  Schematic of PSoC 5LP (KitProg)
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4.2.3 Power Supply System

The power supply system on this board is dependent on the power source. For most applications,

you can use the 5-V supply from the USB connection to power the system. You can also connect an

external power supply to the board for low-voltage applications. The kit supports the following

connections:

■ 5 V from the KitProg USB (J6)

■ 3.3 V to 5.5 V from a regulated supply connected to VDD (this will not power the KitProg section 

of the board)

Note: To use an external power supply, while the KitProg is connected to the PCB USB, remove the

D1 diode from the board. This ensures that VTARG supply from the KitProg is not supplied to the tar-

get device. The KitProg measures the target voltage and adjusts the logic levels on the programming

pins accordingly.

Note that this prototyping kit does not have any onboard ESD protection circuitry. Therefore,

the power source for the PSoC 4 M-Series Prototyping Kit must be of a high quality to ensure

that the board is protected from any over-current conditions and swapped-power

connections.

4.2.3.1 Measure PSoC 4 Current Consumption

You can measure current consumption of the PSoC 4200M device by using one of these methods: 

Method 1:

1. Separate the KitProg board by 'snapping' the perforated edge between the two boards.

2. Power the remaining prototyping board via any of the VDD or VTARG terminals.

3. Place an ammeter in series with the VDD or VTARG connection to measure current consumption.

Method 2:

1. Remove the resistor R22 and install a 2-pin jumper in the supplied holes of J4.

2. Connect an ammeter across the 2-pin jumper to measure the current to the PSoC 4200M device.

This method can be used either with USB power or with power supplied to one of the VTARG pins

but NOT when supplying power to one of the VDD pins.

4.2.4 Board Separation (Snapping)

The PSoC 4 M-Series Prototyping Kit consists of both a PSoC 4200M and a KitProg board. To sepa-

rate the two boards for evaluation or development, break the two boards apart at the built-in perfo-

rated edge. 

The easiest method of separating the two boards is to place the kit on the edge of a table, where the

edge of the table is directly below the perforated edge and the smaller KitProg board is off the table

edge. Press gently on the KitProg board and snap the two boards apart. If any material is removed

from the edge of the boards, use shears to clean up the edge of the kit. Note that once the boards

are separated, direct UART and I2C connections between the PSoC 4200M device and KitProg are

lost. This is because the traces connecting the UART and I2C lines are cut off during the separation.

However, you can access the KitProg's UART and I2C lines through headers J8 and J9.
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Figure 4-4.  PSoC 4 M-Series Prototyping Kit Broken into Two Parts

4.2.5 Header Connections

The PSoC 4 M-Series Prototyping Kit supports a number of unpopulated headers on both the

KitProg and the target PSoC 4 boards.

4.2.5.1 Functionality of J1 and J2 Headers (Target Board)

The target board contains two, dual-inline, headers (J1 and J2). Both are 1×29 pin headers and

include all of the I/Os available on the PSoC 4200M device. These headers support all of the avail-

able ports, GND, VDD, and connections to passive elements and user-input devices. The J1 and J2

headers support 100-mil spacing, so you can solder connectors to connect the target board to any

development breadboard.

Figure 4-5.  J1 and J2 Headers
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