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Safety Information

Regulatory Compliance
The CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit is intended for use as a development
platform for hardware or software in a laboratory environment. The board is an open-system design,
which does not include a shielded enclosure. This may cause interference to other electrical or
electronic devices in close proximity. In a domestic environment, this product may cause radio
interference. In such cases, you may be required to take adequate preventive measures. In addition,
this board should not be used near any medical equipment or RF devices.

Attaching additional wiring to this product or modifying the product operation from the factory default
may affect its performance and cause interference with other apparatus in the immediate vicinity. If
such interference is detected, suitable mitigating measures should be taken.

General Safety Instructions

ESD Protection
ESD can damage boards and associated components. Cypress recommends that you perform
procedures only at an ESD workstation. If an ESD workstation is unavailable, use appropriate ESD
protection by wearing an anti-static wrist strap attached to a grounded metal object.

Handling Boards
The PSoC 6 WiFi-BT Pioneer Kit is sensitive to ESD. Hold the board only by its edges. After
removing the board from its box, place it on a grounded, static-free surface. Use a conductive foam
pad, if available. Do not slide the board over any surface.

The PSoC 6 WiFi-BT Pioneer Kit contains electrostatic discharge (ESD) sensitive
devices. Electrostatic charges readily accumulate on the human body and any
equipment, and can discharge without detection. Permanent damage may occur on
devices subjected to high-energy discharges. Proper ESD precautions are
recommended to avoid performance degradation or loss of functionality. Store unused
PSoC 6 WiFi-BT Pioneer Kits in the protective shipping package.

End-of-Life/Product Recycling

The end-of life for this kit is five years from the date of manufacture mentioned
as a bar code on the back of the kit box. Contact your nearest recycler for
information on discarding the kit.
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1. Introduction

Thank you for your interest in the CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit. The PSoC 6
WiFi-BT Pioneer Kit enables you to evaluate and develop your applications using the PSoC 6 MCU. 

The PSoC 6 MCU is Cypress’ latest, ultra-low-power PSoC specifically designed for wearables and
IoT products. It is a programmable embedded system-on-chip, integrating a 150-MHz Arm®

Cortex®-M4 as the primary application processor, a 100-MHz CM0+ that supports low-power
operations, up to 1 MB Flash and 288 KB SRAM, CapSense® touch-sensing, and programmable
analog and digital peripherals that allow higher flexibility, in-field tuning of the design, and faster
time-to-market.

The PSoC 6 WiFi-BT Pioneer board offers compatibility with Arduino™ shields. The board features a
PSoC 6 MCU, a 512-Mb NOR flash, an onboard programmer/debugger (KitProg2), a 2.4-GHz
WLAN and Bluetooth functionality module (CYW4343W), a USB Type-C power delivery system (EZ-
PD™ CCG3), a five-segment CapSense slider, two CapSense buttons, one CapSense proximity
sensing header, an RGB LED, two user LEDs, USB host and device features, and one push button.
The board supports operating voltages from 1.8 V to 3.3 V for the PSoC 6 MCU. 

The CY8CKIT-062-WiFi-BT package includes a CY8CKIT-028-TFT Display Shield that contains a
2.4-inch TFT display, a motion sensor, ambient light sensor, a 32-bit audio codec, and a PDM
microphone. 

This is the first kit that enables development of PSoC 6 MCU + WiFi applications. To develop a
PSoC 6 MCU + WiFi application, WICED™ Studio 6.1 or later must be used. WICED Studio is
Cypress' integrated development environment (IDE) for developing WiFi applications. If you are not
adding WiFi to your design then you can develop and debug PSoC 6 MCU project using PSoC
Creator™. PSoC Creator supports exporting your designs to other third-party firmware development
tools.
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1.1 Kit Contents
The CY8CKIT-062-WiFi-BT package has the following contents, as shown in Figure 1-1.
■ PSoC 6 WiFi-BT Pioneer Board
■ CY8CKIT-028-TFT Display Shield
■ USB Type-A to Type-C cable
■ Four jumper wires (4 inches each)
■ Two proximity sensor wires (5 inches each)
■ Quick Start Guide

Figure 1-1.  Kit Contents 

Inspect the contents of the kit; if you find any part missing, contact your nearest Cypress sales office
for help: www.cypress.com/support.
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1.2 Hardware Introduction

1.2.1 CY8CKIT-062-WiFi-BT Board Details
Figure 1-2 shows the Pioneer board, which has the following features:
■ PSoC 6 MCU
■ Expansion headers that are compatible with Arduino Uno 3.3-V shields1 and Digilent® Pmod™ 

modules
■ Type 1DX ultra-small 2.4-GHz WLAN and Bluetooth functionality module
■ 512-Mbit external quad-SPI NOR flash that provides a fast, expandable memory for data and 

code
■ KitProg2 onboard programmer/debugger with mass storage programming, USB to UART/I2C/

SPI bridge functionality, and custom applications support
■ EZ-PD CCG3 USB Type-C power delivery (PD) system with rechargeable lithium-ion polymer 

(Li-Po) battery support2

■ CapSense touch-sensing slider (five elements) and two buttons, all of which are capable of both 
self-capacitance (CSD) and mutual-capacitance (CSX) operation, and a CSD proximity sensor 
that allows you to evaluate Cypress’ fourth-generation CapSense technology

■ 1.8-V to 3.3-V operation of PSoC 6 MCU is supported. An additional 330-mF super-capacitor is 
provided for backup domain supply (VBACKUP)

■ Two user LEDs, an RGB LED, a user button, and a reset button for PSoC 6 MCU. 
■ Two buttons and three LEDs for KitProg2.

1. 5-V shields are not supported
2. Battery and power-delivery capable USB Type-C to Type-C cable are not included in the kit package and should be purchased separately.
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Figure 1-2.  Pioneer Board 

1. USB PD output voltage availability indicator (LED7)
2. Battery charging indicator (LED6)
3. KitProg2 USB Type-C connector (J10)
4. Cypress EZ-PD™ CCG3 Type-C Port Controller with PD
(CYPD3125-40LQXI, U3) 
5. KitProg2 programming mode selection button (SW3)
6. KitProg2 I/O header (J6)1
7. KitProg2 programming/custom application header (J7)1
8. External power supply connector (J9)
9. PSoC 6 user button (SW2)
10. KitProg2 application selection button (SW4)

11. Digilent® Pmod™ compatible I/O header (J14)1
12. Power LED (LED4)
13. KitProg2 status LEDs (LED1, LED2, and LED3)
14. PSoC 6 reset button (SW1)
15. PSoC 6 I/O header (J18, J19 and J20)
16. Arduino™ Uno R3 compatible power header (J1)
17. PSoC 6 debug and trace header (J12)
18. Arduino Uno R3 compatible PSoC 6 I/O header (J2, J3
and J4)
19. PSoC 6 program and debug header (J11)

21. CapSense slider and buttons

22. PSoC 6 VDD selection switch (SW5)

23. Cypress 512-Mbit serial NOR Flash memory (S25-
FL512S, U4)

24. PSoC 6 user LEDs (LED8 and LED9)

25. RGB LED (LED5)

26. WiFi/BT module (LBEE5KL 1DX, U6)

27. Cypress serial Ferroelectric RAM (U5)1

28. WiFi-BT Antenna

29. VBACKUP and PMIC control selection switch (SW7)2

30. PSoC 6 USB device Type-C connector (J28)

31. Cypress PSoC 6 (CY8C6247BZI-D54, U1)

32. PSoC 6 USB Host Type-A connector (J27)

33. Arduino Uno R3 compatible ICSP header (J5)1

34. PSoC 6 power monitoring jumper (J8)2

35. KitProg2 (PSoC 5LP) programmer and debugger
(CY8C5868LTI-LP039, U2)

36. Battery connector (J15)1,2

37. USB PD output voltage (9V/12V) connector (J16)1
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1.2.2 CY8CKIT-028-TFT Board Details
Figure 1-3 shows the TFT display shield that has the following features:
■ A 2.4-inch Thin-Film Transistor (TFT) LCD module with 240x320 pixel resolution. 
■ A three-axis acceleration and three-axis gyroscopic motion sensor.
■ A PDM microphone for voice input.
■ A 32-bit stereo codec with microphone, headphone, and speaker amplifier capability. 
■ An audio jack with a provision of connecting both AHJ and OMTP headphones. The headset 

standard can be set by an onboard switch.
■ An ambient light sensor IC made of an NPN phototransistor.
■ An LDO that converts 3.3 V to 1.8 V for the digital supply of the audio codec.

Figure 1-3.  TFT Display Shield 

1. 2.4-inch TFT display 

2. Motion Sensor (U1)

3. Ambient Light Sensor (Q1)

4. PDM microphone (U2)

5. Ardunio compatible I/O headers (J2, J3,
J4)

6. Ardunio compatible power header (J1)

7. TFT display power control load switch
(U4)

8. TFT display connector (J5)

9. Audio CODEC (U3)

10. Audio Jack (J6)

11. Audio Jack Selection (OMTP/AHJ)
Switch (SW1)
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1.3 Software Introduction

1.3.1 PSoC Creator Overview
PSoC Creator is a state-of-the-art, easy-to-use IDE. It uses revolutionary hardware and software co-
design, powered by a library of fully verified and characterized PSoC Components™ and peripheral
driver libraries (PDL), as shown in Figure 1-4. With PSoC Creator, you can:
1. Drag and drop Components to build your hardware system design in the main design workspace.
2. Co-design your application firmware with the PSoC hardware.
3. Configure Components using configuration tools or PDL.
4. Explore the library of 100+ Components.
5. Access Component datasheets.
6. Export your design to third-party firmware development tools.

Figure 1-4.  PSoC Creator Features

PSoC Creator also enables you to tap into an entire tool ecosystem with integrated compiler chains
and production programmers for PSoC devices. Use PSoC Creator for all PSoC 6 MCU designs that
do not require WiFi connectivity. If WiFi connectivity is required, use WICED Studio 6.1 or higher.

1.3.1.1 PSoC Creator Code Examples

PSoC Creator includes a large number of code examples. These examples are accessible from the
PSoC Creator Start Page, as shown in Figure 1-5 or from the menu File > Code Example.

Code examples can speed up your design process by starting you off with a complete design. The
code examples also show how to use PSoC Creator Components for various applications. Code
examples and documentation are included.

In the Find Code Example dialog, you have several options:
■ Filter for examples based on device family or keyword.
■ Select from the list of examples offered based on the Filter Options.
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■ View the project documentation for the selection (on the Documentation tab).
■ View the code for the selection on the Sample Code tab. You can also copy and paste code from 

this window to your project, which can help speed up code development.
■ Create a new workspace for the code example or add to your existing workspace. This can speed 

up your design process by starting you off with a complete, basic design. You can then adapt that 
design to your application.

Figure 1-5.  Code Examples in PSoC Creator

1.3.1.2 Kit Code Examples

You can access the installed kit code examples from the PSoC Creator Start Page. To access these
examples, expand the Kits under the section Examples and Kits; then, expand the specific kit to see
the code examples. To work with the code examples using this kit, see PSoC Creator chapter on
page 18. 

1.3.1.3 PSoC Creator Help

Launch PSoC Creator and navigate to the following items:
■ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you 

the basics for developing PSoC Creator projects.
■ Simple Component Code Examples: Choose File > Code Example. These examples demon-

strate how to configure and use PSoC Creator Components. To access examples related to a 
specific Component, right-click the Component in the schematic or in the Component Catalog. 
Select the Find Code Example option in the context menu that appears. 

■ System Reference Guide: Choose Help > System Reference Guide. This guide lists and 
describes the system functions provided by PSoC Creator.

■ Component Datasheets: Right-click a Component and select Open Datasheet.

1.3.2 WICED Studio Development System Overview
WICED Studio 6.1 (or later) supports WiFi and Bluetooth application development using the
CY8CKIT-062-WiFi-BT kit. Tabs and their location in the WICED IDE are as shown in Figure 1-6.

Figure 1-6 illustrates the following:
1. Edit your application firmware.
2. Help Window that contains instructions on building and downloading applications.
3. Explore existing applications/firmware and library of the Software Development Kit (SDK). 
4. View Build messages in the Console window.
5. Create and edit Make Targets for the platform to build your application/project.
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Figure 1-6.  WICED IDE

1.3.2.1 WICED Studio Code Examples

WICED Studio includes libraries and code examples supporting both Bluetooth and WiFi platforms.
Selecting the 43xxx_Wi-fi Filter will show only WiFi platform related files in the project explorer as
shown in Figure 1-7.

Application examples can speed up the design process by serving as templates for development.
Code examples are located under the apps category (in the Project Explorer window), as shown in
Figure 1-8. Code examples under apps are further grouped into demo, snip, test, waf (WICED
application framework), and wwd (WICED WiFi Driver Application) directories. 

The demo directory contains applications that combine various WICED features into a single appli-
cation. The snip directory contains application snippets that demonstrate how to use various WICED
libraries and API functions. The test directory contains applications that are used for simple test
and utility. The waf directory contains applications that are part of WICED application framework, for
instance, the bootloader. The wwd directory contains applications that are developed using the low
level wwd API calls and do not rely on higher level WICED APIs. Located within each subdirectory in
the apps folder is a README.txt that lists and summarizes the applications located within the folder.
Note that not all applications are supported in all platforms. The snip directory contains a
README.txt with a matrix on what applications are supported in what platforms. For more details on
the WICED software stack and APIs, review the application notes and documents available in the
doc folder <WICED SDK installation folder>/WICED-Studio-6.1/43xxx_Wi-Fi/doc. WICED-QSG.pdf,

available in the same path, is a good document to start with.
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Figure 1-7.  Filter for WiFi Code Example in WICED Studio
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Figure 1-8.  Code Examples under apps Category

1.4 Getting Started
This guide will help you to get acquainted with the PSoC 6 WiFi-BT Pioneer Kit:
■ The PSoC Creator chapter on page 18 describes the installation of the kit software. The kit 

software includes the PSoC Creator IDE and PDL to develop and debug the applications, the 
PSoC Programmer to program the .hex files on to the device. 

■ The WICED chapter on page 24 describes the installation of WICED and getting started guide-
lines of the WICED-based example project of the kit. 

■ The Kit Hardware chapter on page 38 describes the CY8CKIT-062-WiFi-BT base board and 
CY8CKIT-028-TFT shield hardware features and functionalities.

■ The Appendix on page 58 provides a detailed hardware description, methods to use the onboard 
components, kit schematics, the bill of materials (BOM), and an FAQ.

1.5 Additional Learning Resources
Cypress provides a wealth of data at www.cypress.com/psoc6 to help you to select the right PSoC
device for your design and to help you to quickly and effectively integrate the device into your
design. 

1.6 Technical Support
For assistance, visit Cypress Support or contact customer support at +1(800) 541-4736 Ext. 3 (in the
USA) or +1 (408) 943-2600 Ext. 3 (International).

You can also use the following support resources if you need quick assistance:
■ Self-help (Technical Documents).
■ Local Sales Office Locations.



PSoC 6 WiFi-BT Pioneer Kit Guide, Doc. # 002-22677 Rev. *B 16

Introduction

1.7 Documentation Conventions

1.8 Acronyms

Table 1-1.  Document Conventions for Guides

Convention Usage
Courier New Displays user entered text and source code:

Italics
Displays file locations, file names, and reference documentation:
Read about the sourcefile.hex file in the PSoC Creator User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.

Table 1-2.  Acronyms Used in this Document
Acronym Definition

ADC analog-to-digital converter

BOM bill of materials

BT Bluetooth

CINT integration capacitor

CMOD modulator capacitor

CPU central processing unit

CSD CapSense sigma delta

CTANK shield tank capacitor

DC direct current

Del-Sig delta-sigma

ECO external crystal oscillator

ESD electrostatic discharge

F-RAM Ferroelectric Random Access Memory

FPC flexible printed circuit

GPIO general-purpose input/output

HID human interface device

I2C Inter-Integrated Circuit

IC integrated circuit

ICSP in-circuit serial programming

IDAC current digital-to-analog converter

IDE integrated development environment

LED light-emitting diode
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PC personal computer

PCM pulse code modulation

PD power delivery

PDM pulse density modulation

PTC positive temperature coefficient

PSoC Programmable System-on-Chip

PWM pulse width modulation 

RGB red green blue

SAR successive approximation register

SMIF serial memory interfac

SPI serial peripheral interface 

SRAM serial random access memory

SWD serial wire debug

TFT thin-film transistor

UART universal asynchronous receiver transmitter

USB Universal Serial Bus

WCO watch crystal oscillator

Table 1-2.  Acronyms Used in this Document (continued)

Acronym Definition
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2. PSoC Creator

This chapter describes the steps to install PSoC Creator and the packages required to use the
PSoC 6 WiFi-BT Pioneer Kit, for non WiFi applications. This includes the IDE on which the projects
will be built and used for programming. For developing WiFi applications, WICED Studio 6.1 or later
must be used (see the WICED chapter on page 24).

2.1 Before You Begin
To install Cypress software, you will require administrator privileges. However, they are not required
to run the software that is already installed. Before you install the kit software, close any other
Cypress software that is currently running.

2.2 Install Kit Software
Follow these steps to install the PSoC 6 WiFi-BT Pioneer Kit software:
1. Download and run the CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit software from 

www.cypress.com/CY8CKIT-062-WiFi-BT. The kit software is available in two different formats for 
download.
a. CY8CKIT-062-WiFi-BT Kit Complete Setup: This installation package contains the files 

related to the kit including PSoC Creator, PSoC Programmer, and PDL. However, it does not 
include the Windows Installer or Microsoft .NET framework packages. If these packages are 
not on your computer, the installer will direct you to download and install them from the 
Internet.

b. CY8CKIT-062-WiFi-BT Kit Only: This executable file installs only the kit contents, which 
include kit code examples, hardware files, and user documents. This package can be used if 
all the software prerequisites (listed in step 3) are installed on your PC.

2. Select the folder in which you want to install the PSoC 6 WiFi-BT Pioneer Kit-related files. 
Choose the directory and click Next.
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Figure 2-1.  Kit Installer Screen 

3. When you click Next, the installer automatically installs the required software, if it is not present 
on your computer. Following are the required software:
a. PSoC Creator 4.2: This software is available for download separately at 

www.cypress.com/psoccreator. PSoC Creator 4.2 installer automatically installs the following 
additional software:
PSoC Programmer 3.27.0 
Peripheral Driver Library 2.1.0 
Peripheral Driver Library 3.0.1 
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4. Choose the Typical, Custom, or Complete installation type (select Typical if you do not know 
which one to select) in the Product Installation Overview window, as shown in Figure 2-2. Click 
Next after selecting the installation type.

Figure 2-2.  Product Installation Overview

5. Read the License agreement and select I accept the terms in the license agreement to con-
tinue with installation. Click Next.

6. When the installation begins, a list of packages appears on the installation page. A green check 
mark appears next to each package after successful installation.

7. Enter your contact information or select the check box Continue Without Contact Information. 
Click Finish to complete the CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit software instal-
lation.

8. After the installation is complete, the kit contents are available at the following location:
<Install_Directory>\CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit

Default location: 
Windows 7 (64-bit): C:\Program Files (x86)\Cypress\CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pio-

neer Kit

Windows 7 (32-bit): C:\Program Files\Cypress\CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer 

Kit

Note: For Windows 7/8/8.1/10 users, the installed files and the folder are read-only. To use the
installed code examples, create an editable copy of the example in a path that you choose, so that
the original installed example is not modified. These steps will create an editable copy of the exam-
ple in a path that you choose, so the original installed example is not modified.
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2.3 Programming and Debugging using PSoC Creator
1. Connect the PSoC 6 WiFi-BT Pioneer Kit to the PC using the USB cable, as shown in Figure 2-3. 

The kit enumerates as a composite device if you are connecting it to your PC for the first time. 
See section 4.3.3 Kit Enumeration and Programming Modes of KitProg2 to know whether the kit 
is successfully enumerated or not. 

Figure 2-3.  Connect USB Cable to USB Connector on the Kit 

2. Open the desired project in PSoC Creator. To do this, go to File > Open > Project/Workspace. 
This provides the option to browse and open your saved project.

3. Select the option Build > Build Project or pressing [Shift] [F6] to build the project.
4. If there are no errors during build, select Debug > Program or press [Ctrl] [F5]. This programs 

the device on the PSoC 6 WiFi-BT Pioneer Kit.

PSoC Creator has an integrated debugger. You can start the debugger by selecting Debug > Debug
or by pressing [F5]. For more details, see the “Debugging Using PSoC Creator” section in the Kit-
Prog2 User Guide.

2.4 Kit Code Examples
The PSoC 6 WiFi-BT Pioneer Kit includes two code examples. One of these two code examples is
developed in PSoC Creator. To access this code example, first download and install the PSoC 6
WiFi-BT Pioneer Kit setup file from www.cypress.com/CY8CKIT-062-WiFi-BT. After the kit package
is installed on your PC, the PSoC Creator-based code examples will be available from Start > Kits
on the PSoC Creator Start Page. This code example can be accessed in the following directory:
<Install_Directory>\CY8CKIT-062-WiFi-BT PSoC 6 WiFi-BT Pioneer Kit\<version>\Firmware\PSoC 6

MCU\CE222221.

2.4.1 Using the Kit Code Examples Built in PSoC Creator
Follow these steps to open and use the code examples:
1. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator <version> > 

PSoC Creator <version>. 
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2. On the Start Page, click CY8CKIT-062-WiFi-BT under Start > Kits. A list of code examples 
appears, as shown in Figure 2-4.

3. Click the desired code example, select a location to save the project, and click OK.

Figure 2-4.  Open Code Example from PSoC Creator

4. Build the code example by choosing Build > Build <Project Name>. After the build process is 
successful, a .hex file is generated.

5. Connect PSoC 6 WiFi-BT Pioneer Kit to the PC using the USB cable, as shown in Figure 2-3 on 
page 21, to program the kit with the code example.

6. Choose Debug > Program in PSoC Creator.
7. If the device is already acquired, programming will complete automatically – the result will appear 

in the PSoC Creator status bar at the bottom left side of the screen. If the device is yet to be 
acquired, the Select Debug Target window will appear. Select KitProg2/<serial_number> and 
click Port Acquire, as shown in Figure 2-5. 

Figure 2-5.  Port Acquire 
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8. After the device is acquired, it is shown in a tree structure below the KitProg2/<serial_number>. 
Click Connect and then OK to exit the window and start programming, as shown in Figure 2-6.
Note: PSoC 6 MCUs have both CM0+ and CM4 CPUs. To program, select one of them and click 
Connect. To debug, select the CPU that needs to be debugged.

Figure 2-6.  Connect Device from PSoC Creator and Program 

9. After programming is successful, the code example is ready to use.

Table 2-1 shows the code example, developed in PSoC Creator, which can be used with this kit.
Table 2-1.  Code Example in PSoC Creator

Project Description

CE222221_TFT_VoiceRecorder

This code example shows how PSoC 6 MCU can be used to 
record audio data, store it, and play it back. It uses a digital 
microphone with the PDM/PCM hardware block. All the audio 
data captured by the microphone is stored in an external flash 
memory. After the recording is completed, you can play the audio 
data over I2S, which interfaces with an audio codec. You can 
record/play/pause/resume with CapSense buttons. You control 
the audio volume with a CapSense slider. The TFT LCD displays 
the current state of the voice recorder, the volume, and the time of 
the record/play.
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3.1 Introduction
This chapter describes the steps to install the WICED software tools and packages required to use
the PSoC 6 WiFi-BT Pioneer Kit for developing WiFi applications. This chapter describes basic quick
start guidelines of the WICED-based example project that can be used for further development
purposes.

3.2 Before You Begin
To install Cypress software, you will require administrator privileges. However, they are not required
to run the software that is already installed. Before you install the kit software, close any other
Cypress software that is currently running.

3.3 Install WICED
The CY8CKIT-062-WiFi-BT kit needs the WICED 6.1 (or later) software to be installed in your sys-
tem. WICED 6.1 needs separate download and installation.
1. Download and install WICED Studio 6.1 (or later) from www.cypress.com/products/wiced-soft-

ware.
2. Select two folders, one for the IDE and the other for the SDK. The SDK folder contains the 

Framework for developing WiFi applications.
3. The installer will ask to select between WiFi and Bluetooth platforms. Select 43xxx_Wi-Fi as the 

default.
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Figure 3-1.  Installer Window Screenshot

3.4 Programming and Debugging in WICED 

3.4.1 Building and Programming a Project for CY8CKIT-062-WiFi-BT in WICED Studio 
IDE
To build and program a project for CY8CKIT-062-WiFi-BT, perform the following steps: 
1. To open the WICED IDE on the Windows PC, go to Start > All Programs > Cypress > WICED-

Studio. 
2. Select 43xxx_Wi-Fi in the WICED Target selector drop-down box as shown in Figure 1-7. Build-

ing a project requires a corresponding make target, located in the Make Target window. All appli-
cations go under the apps directory. The make target path will contain the directory hierarchy 
starting from apps with directory names separated by a period. The project name is followed by a 
hyphen and then the platform name. Finally, the actions to be performed after the build are spec-
ified, such as download and run. For example, to build, download, and run the application scan 
which exists in apps\snip\scan, create the following make target:
snip.scan-CY8CKIT_062 download_apps download run 

This project will periodically scan for Wi-Fi access points and will list them using the serial-to-USB 
connection on the kit.
Perform these steps to create the make target, build, program, and test application scan:

3. Right-click 43xxx_Wi-Fi in the Make Target window as shown in Figure 3-2 and click New.
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