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Preface

Introduction
This chapter contains general information about this manual and contacting 

customer support.

Highlights
Topics covered in this chapter:

• About this Guide

• Warranty Registration

• Recommended Reading

• The Microchip Internet Web Site

• Development Systems Customer Notification Service

• Customer Support

About This Guide

Document Layout

This document describes how to install a PICDEM™ MSC1 (Mixed Signal 

Controller1) on a PC and load the GUI software as a development tool for 

creating the initialization assembly code for your PIC16C781/782 application. 

The PICDEM™ MSC1 is the tradename for the PIC16C781/782 

Microcontroller Evaluation Tool described in this manual. The manual layout is 

as follows:

• Chapter 1: Overview and Installation – What the PICDEM™ MSC1  

is and how to install it.

• Chapter 2: Basic Functions – Describes how to get started using the 

PICDEM™ MSC1 and how to access the basic functions using the GUI 

software.

• Chapter 3: Tutorial/Demo - Provides an example of how you can con-

figure a typical peripheral using the PICDEM™ MSC1 and create the 

initialization assembly code corresponding to your configuration.

• Appendix A: Schematics – Provides the schematics and board layout 

for the PICDEM™ MSC1.

• PICDEM™ MSC1 Worldwide Sales and Service – Lists Microchip 

sales and service locations and telephone numbers worldwide.
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Updates

All documentation becomes dated, and this user’s guide is no exception. 

Since the PICDEM™ MSC1 and other Microchip tools are constantly evolving 

to meet customer needs, please refer to our web site at http://

www.microchip.com to obtain the latest documentation available.

Warranty Registration

Please complete the enclosed Warranty Registration Card and mail it 

promptly. Sending in your Warranty Registration Card entitles you to receive 

new product updates. Interim software releases are available at the Microchip 

web site.

Recommended Reading
This user’s guide describes how to use the PICDEM™ MSC1. The data 

sheets contain current information on programming the specific 

microcontroller devices.

README.TXT

For the latest information on using PICDEM™ MSC1, read the README.txt 

file (ASCII text file) included with the PICDEM™ MSC1 software. The 

README.txt file contains update information that may not be included in this 

document.

MPLAB® IDE User’s Guide (DS51025)

Comprehensive guide that describes installation and features of Microchip’s 

MPLAB Integrated Development Environment (IDE), as well as the editor and 

simulator functions in the MPLAB environment.

MPASM™ User’s Guide with MPLINK™ & MPLIB™ (DS33014)

Describes how to use Microchip Universal PICmicro® Microcontroller 

Assembler (MPASM), Linker (MPLINK), and Librarian (MPLIB).

Technical Library CD-ROM (DS00161)

This CD-ROM contains comprehensive data sheets for Microchip PICmicro® 

MCU devices available at the time of print. To obtain this CD-ROM, contact 

the nearest Microchip Sales and Service location (see back page) or 

download individual data sheet files from the Microchip web site (http://

www.microchip.com).

PICmicro Mid-Range MCU Family Reference Manual (DS33023)

This manual explains the general details and operation of the MCU family 

architecture and peripheral modules. It is designed to complement the device 

data sheets.
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Microsoft® Windows® Manuals

This manual assumes that users are familiar with Microsoft Windows 

operating system. Many excellent references exist for this software program, 

and should be consulted for general operation of Windows.

PIC16C781/782 Data Sheet (DS41171)

This book contains details about the PIC16C781/782 Microcontroller and 

more.

The Microchip Internet Web Site
Microchip provides online support on the Microchip World Wide Web (WWW) 

site.

The web site is used by Microchip as a means to make files and information 

easily available to customers. To view the site, the user must have access to 

the Internet and a web browser, such as Netscape® Communicator or 

Microsoft® Internet Explorer®. Files are also available for FTP download from 

our FTP site.

Connecting to the Microchip Internet Website

The Microchip web site is available by using your favorite Internet browser. 

Visit: 

http://www.microchip.com

The file transfer site is available by using an FTP program/client to connect to:

ftp://ftp.microchip.com

Development Systems Customer Notification Service

Microchip started the customer notification service to help our customers 

keep current on Microchip products with the least amount of effort. Once you 

subscribe to one of our list servers, you will receive e-mail notification 

whenever we change, update, revise or have errata related to that product 

family or development tool. See the Microchip web page at 

http://www.microchip.com for other Microchip list servers.

The Development Systems list names are:

• Compilers

• Emulators

• Programmers

• MPLAB

• Otools (other tools)
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Once you have determined the names of the lists that you are interested in, 

you can subscribe by sending a message to:

listserv@mail.microchip.com 

with the following as the body:

subscribe <listname> yourname

Here is an example: 

subscribe programmers John Doe 

To UNSUBSCRIBE from these lists, send a message to:

listserv@mail.microchip.com 

with the following as the body:

unsubscribe <listname> yourname

Here is an example: 

unsubscribe programmers John Doe

The following sections provide descriptions of the available Development 

Systems lists.

Customer Support
Users of Microchip products can receive assistance through several 

channels:

• Distributor

• Local Sales Office

• Field Application Engineer (FAE)

• Corporate Applications Engineer (CAE)

• Systems Information Upgrade Hotline

Technical Support can be obtained through your local FAE or CAE. CAEs may 

be contacted at (480) 792-7627. Contact the Sales office for prices and 

literature requests. Sales offices are listed on the back cover of this User 

Guide.

In addition, there is a Systems Information and Upgrade Line. This line 

provides system users a listing of the latest versions of all of Microchip's 

development systems software products. Plus, this line provides information 

on how customers can receive any currently available upgrade kits.

The Hotline Numbers are: 

1-800-755-2345 for U.S. and most of Canada, and 

1-480-792-7302 for the rest of the world.
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Chapter 1.  Overview and Installation

1.1  Introduction
The PICDEM™ MSC1 with its PC-based Graphical User Interface (GUI) soft-

ware serves as a stand-alone development and evaluation tool for the 

PIC16C781/782 Microcontrollers, or as a user interface to the peripherals. 

1.2  Highlights
The topics covered in this chapter are:

• Unpacking your PICDEM™ MSC1 hardware and software

• Installing the hardware

• Installing the GUI software

• What the PICDEM™ MSC1  is

• How the PICDEM™ MSC1 helps the Developer

1.3  Unpacking Your PICDEM™ MSC1

1.3.1 Supplied Items

The items contained in your PICmicro box are:

• PICDEM™ MSC1 Circuit Board with a programmed  PIC16C782 

installed

• PIC16C781/782 Data Sheet (DS41171)

• CD-ROM containing: GUI software, User’s Guide, Board Schematics, 

Monitor Firmware, Example Arbitrary Waveform

• Assorted jumpers

1.3.2 Required Items

The items required are:

• PC running Windows 95 or newer operating system

• 9 VDC Power Supply

• 9-pin RS-232 Cable
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1.4  Installing the Hardware
Perform the following procedure to install the PICDEM™ MSC1 hardware:

1. Connect the PICDEM™ MSC1 circuit board to the 9 VDC Power Supply

as shown in the Figure 1.1 and plug in the AC connector for the 9 VDC

Power Supply.

Figure 1.1:  Installing the Hardware

2. Connect one end of the RS-232 cable to the Serial Port of your PC.

3. Connect the other end of the RS-232 cable to the PICDEM™ MSC1 cir-

cuit board as shown in Figure 1.1. This completes the hardware installa-

tion.

To PC Serial Port

RS-232 connector

PICDEM™ MSC1 Circuit Board

9 VDC Power Supply

9 VDC Power Connector

AC Power

RS-232 cable

AVDD LED
VDD LED

Note: The AVDD LED and the VDD LED should be lit, indicating the Ana-

log and Digital Power Supplies are operating.
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1.5  Installing the GUI Software

The GUI software adheres to standard Windows® conventions and should be 

easy to install for anyone familiar with other Windows applications.

Perform the following procedure to install the GUI software:

1. Insert the CD containing the GUI software into your PC. Locate and dou-

ble-click on the setup.exe file in the CD Root Directory. An Installation

Wizard will guide you through the installation process.

2. Follow the instructions in the Installation Wizard. The installation creates

an entry in the Start → Programs group. The Wizard will also create a

PICDEM™ MSC1 icon for your desktop. 

3. You can start the GUI software by using the Start → Programs → 

PICDEM™ MCS1 sequence. 

1.6  What the PICDEM™ MSC1 Is

The Evaluation Tool is comprised of:

• Printed circuit board

• PC based GUI

• UV erasable PIC16C782 with monitor firmware

• 9V power supply (IEC)

• RS-232C cable (9-pin)

• General purpose jumper wires

In stand-alone mode, the GUI is useful for discovering the features of all the 

PIC16C781/782 peripherals and identifying which registers are affected by 

the different configurations. When used in conjunction with the evaluation 

board, the GUI gives instant access to the PIC16C781/782 peripherals allow-

ing on-the-fly configuration changes by means of an RS-232 link between a 

PC and the evaluation board.

The GUI includes a Code Generator that can build the initialization assembly 

code that corresponds to the selected configuration. Developers can use the 

Code Generator to perform an entire configuration using the Evaluation Tool 

and save it as a disk file.

The firmware of the PICDEM™ MSC1 allows you to:

• Configure the inputs and outputs of each peripheral module using your 

application parameters

• Configure the operation of each peripheral module

• Load and view the contents of the Special Purpose Registers needed to 

run your application

• Operate a dynamic conversion loop for scoping the Output of the DAC 

Module

• Save the configuration file that you have created and insert it into your 

application software.
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Chapter 2.  Basic Functions

2.1  Starting Communications with the Evaluation 

Tool

2.1.1 Introduction

Start the GUI software by selecting Start→Programs→ PICDEM MSC1, or 

you can double-click the PICDEM MSC1 program icon on your desktop. The 

GUI Control Panel displays, as shown in Figure 2.1.

2.1.2 Using the GUI Control Panel

Figure 2.1:  PICDEM™ MSC1 Control Panel

Features Global to All Peripherals
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Port Selection

Communications port selection is not automatic, so you need to make the 

communications port selection with the Options→Communications Setup 

pull-down menu option (see Figure 2.2) before attempting to connect to the 

Evaluation Board.

Figure 2.2:  Communications Setup

Select the Communications Port that matches the one you are using for the 

serial communications with the Evaluation Board, as shown in Figure 2.3.

Figure 2.3:  Communications Port Selection Menu
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Starting Communications

Select the Pull-down menu Options→Enable Eval Board to begin communi-

cations between the GUI Control Panel and the PICDEM™ MSC1, as shown 

in Figure 2.4.

Figure 2.4:  Enable Evaluation Board

Select the Input/Output tab and note the Port A and Port B functions to verify 

that the GUI is communicating with the Evaluation Board.

Serial Communications with the PICDEM™ MSC1 Evaluation Board

Since the PIC16C781/782 does not have a UART peripheral, serial communi-

cations are "bit-banged" with software timing loops. Timing calibration is per-

formed automatically each time the board is enabled. The Evaluation Board 

clock is the internal RC oscillator.

One characteristic of this oscillator is that it may drift slightly in frequency with 

changes in temperature. If you expect to use the Evaluation Board over a 

wide temperature variation, you will need to recalibrate the communication 

timing at each new operating temperature. 

You can recalibrate at any time by de-selecting the PICDEM MSC1 board by 

selecting Options→Enable Eval Board, then selecting Options→Enable Eval 

Board a second time to recalibrate and re-establish communications. When 

the connection is made, all registers will be initialized to the values set in the 

GUI. This procedure of disconnecting, then reconnecting, is also useful if you 

accidentally RESET the PIC16C781/782 with a stray probe or ground strap.

PERIPHERAL ORGANIZATION

The PIC16C781/782 peripherals are organized as tabbed pages (see Figure 

2.1), one for each major peripheral function. These include:

• Input/Output

• Analog-to-Digital Converter (ADC)

• Digital-to-Analog Converter (DAC)

• Comparators and Operational Amplifier

• Programmable Switch Mode Controller (PSMC)

Note: The MCLR function in Port A and the Dgtl Out: RB4 and DGtl In:

RB5 functions are shown in gray when the GUI software is initially

communicating with the Evaluation Board.
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• Timers

• Memory Access

When a configuration change is made, the register(s) affected by the change 

will turn red, calling attention to where the changes occurred. Register values 

cannot be entered directly. However, when the Evaluation Board is active, 

register values may be retrieved from the Evaluation Board by double-clicking 

on the register name. The register font color changes to blue in response.

Changing the Default Font

In some cases, the default font will not fit in the Register Display boxes. You 

can change the font selection and size with the Options->Data Font menu 

option, as shown in Figure 2.5.

Figure 2.5:  Data Font Selection

The best results will be obtained by choosing a scalable fixed-spacing font 

such as Courier New.

Some controls of the GUI are interlocked so that a change to one selection 

automatically selects other controls necessary for the proper operation of the 

selected item. For example, selecting PORTA RA0 as the non-inverting Op 

Amp input automatically selects RA1 as the inverting input and RB3 as the 

Op Amp output.

Special Conventions

A special convention pertains to the following edit boxes:

• PORTA

• PORTB

• Timer0

• Timer1

• Memory Address

• Memory Data

When typing in one of these boxes, the font color changes to red, indicating 

that the entry is local only to that box. When the <Enter> key is pressed, the 

entry in the box is sent to the corresponding register and the font color reverts 

to black. If focus (i.e., clicking outside the box) is moved outside of the edit 

box before the <Enter> key is pressed, the box is restored to its original con-
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tents and no action is taken. When the GUI is actively connected to the Eval-

uation Board, entries are instantly and automatically sent to the PIC16C782.

GLOBAL ITEMS

Items that are global to all the peripherals are located in the GUI outside of the 

tabbed pages (see Figure 2.1). Global items include:

• Special Function Registers

• Internal Voltage Reference Control (VR)

• Display Mode Selection (Binary or HEX)

• Pull-Down Menus

• Edit Boxes for the AVDD and VREF1 voltages

File Menu Functions

Click on the File menu to view the options, as shown in Figure 2.6.

Figure 2.6:  File Menu Options

Except for the Generate Code option, the options on the File Menu are stan-

dard Microsoft Windows functions:

• Open... - allows you to open a previously saved version of the PICDEM 

MSC1 GUI configuration with all the parameters and data to use as a 

starting point for a new configuration.

• Save - allows you to capture and save the GUI information and configu-

ration data as a file.

• Save As... - same as Save, but allows you to change the name of the 

file saved.

• Generate Code... - Creates an Initialization assembly code file that cor-

responds to the selected configuration.

• Exit - Closes and terminates the program.

Note: The AVDD and VREF1 entries are used to compute some of the dis-

play values for the ADC and DAC peripherals, and have no other

effects. If these inputs are known to be different than the values

shown, enter the correct values.
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2.1.2.1 Input/Output

Use the Input/Output tab to configure the Port A and B functions, as shown in 

Figure 2.7. Some of the Port pins can be mixed signal (i.e., they can be either 

digital or analog). I/O functions are fully described in Section 3.0 of the 

PIC16C781/782 Data Sheet (DS41171).

Figure 2.7:  Input/Output Functions

Use drop-down menu
to configure Port bit
functions.

Register values are Read Only. Double-click on register name
to read value from PICDEM MSC1 board.
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2.1.2.2 Analog-to-Digital Converter (ADC)

Use the ADC tab to configure the 10 inputs (shown in the ADC Input Select 

area) to the Analog to Digital Converter, as shown in Figure 2.8. The ADC 

allows conversion of an analog input signal to a corresponding 8-bit digital 

value. ADC functions are fully described in Section 9.0 of the PIC16C781/782 

Data Sheet (DS41171).

Figure 2.8:  Analog-to-Digital Converter Peripheral (ADC) Functions

Names change to
correspond with
selected pin
function

Read ADC Continuous Mode checkbox(1)

single ADC read button

ADC - Internal RC clock source - Required when performing
ADC conversions during SLEEP Mode

Note 1: When the Read ADC Continuous Mode is checked, ADC readings are
             automatically updated about 10 times per second.
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2.1.2.3 Digital-to-Analog Converter (DAC)

Use the DAC tab to configure the Digital to Analog Converter (DAC) module, 

as shown in Figure 2.9. The DAC module generates an output voltage pro-

portional to the value in the 8-bit DAC Register. DAC functions are fully  

described in Section 10.0 of the PIC16C781/782 Data Sheet (DS41171).

Figure 2.9:  Digital-to-Analog (DAC) Peripheral Functions

Change DAC Output by moving slider or by entering desired value in Output text box
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ARBITRARY WAVEFORM

The DAC Arbitrary Waveform function is a utility that provides for sending a 

set of user-defined data bytes to the DAC one byte at a time, with a user-

defined dwell time between each byte. The data set must consist of 2 to 80 

bytes. The dwell time is determined by waiting a user-defined number of 

timer0 count intervals. The utility computes dwell time as a function of :

• Timer0 clock

• Timer0 prescale

• Number of points in the waveform

• User-defined waveform period or frequency parameter.

Timer0 counts must be between 2 and 255. Adjust the paramaters to ensure 

the count is within these limits.

The period of the waveform is defined as the time required for all the wave-

form points to be output.

Two types of waveforms can be computed by the utility:

1. A sine wave (see Figure 2.10)

2. A triangle wave (see Figure 2.11)

An unlimited number of other waveforms can be generated external to the util-

ity and saved as a text file, which the utility can retrieve. Each point of the 

waveform is represented as an integer between 0 and 255. The set of points 

is saved as a text file with one integer per line. If the waveform file contains 

more than 80 integers, the Arbitrary Waveform utility accepts only the first 80.

The DAC data is displayed in the preview window when the waveform is gen-

erated or loaded from a file. Two waveform periods are displayed, so that 

unexpected discontinuities between the last and first data bytes can be identi-

fied. The preview window displays the waveform in an unsmoothed format 

that represents the expected DAC output.

Figures 2.10 and 2.11 show examples of utility generated sine and triangle 

waveforms respectively.
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Figure 2.10:  Sine Wave Example

Figure 2.11:  Triangle Waveform Example

Frequency
Divider for
Timer0/WDT

(Up to 80 max)

The more points
sampled, the smoother
the waveform

Timer Counts must be
between 2 and 255

Frequency
Divider for
Timer0/WDT

(Up to 80 max)

Output of DAC
waveform will
resemble this
stepped pattern
on a scope
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2.1.2.4 Comparators/Op Amp

Use the Comparators/Op Amp tab to configure the two separate voltage com-

parators, C1 and C2, as shown in Figure 2.12. Internal voltage reference is 

provided by the VDAC option for both comparators. An external voltage refer-

ence can be supplied to C1 via the AN3/VREF input and the AN2/VREF2 input 

for C2. You can also use the same tab to configure the Operational Amplifier 

(OPA) module.

The Comparator Module functions are fully described in Section 12.0 of the 

PIC16C781/782 Data Sheet.

The Operational Amplifier (OPA) Module is fully described in Section 11.0 of 

the PIC16C781/782 Data Sheet (DS41171). 

Figure 2.12:  Comparators/Op Amp Peripheral Functions

Calibrate function is enabled only when

Enabling the Op Amp automatically configures the GUI I/O pin functions.

PICDEM MSC1 board is active
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2.1.2.5 Programmable Switch Mode Controller (PSMC)

Use the PSMC tab to configure the PSMC module, as shown in Figure 2.13. 

This module provides all the necessary features to implement a pulsed feed-

back control system. The PSMC generates a pulsed output based on its ana-

log feedback. The Programmable Switch Mode Controller (PSMC) is fully 

described in Section 13.0 of the PIC16C781/782 Data Sheet (DS41171).

Figure 2.13:  PSMC Peripheral Functions

Enabling the PSMC automatically configures the GUI I/O pin functions
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2.1.2.6 Timers

Use the Timers tab to configure Timer0 and Timer1, as shown in Figure 2.14. 

Timer0 can operate as either a timer or a counter. The Timer0 Module is 

described in Section 5.0 of the PIC16C781/782 Data Sheet (DS41171). The 

Timer1 module is fully described in Section 6.0 of the PIC16C781/782 Data 

Sheet (DS41171). 

Figure 2.14:  Timers / Peripheral Functions

Internal

External
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