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Preface

INTRODUCTION

This preface contains general information that will be useful to know before you use the 
dsPICDEM� 80-Pin Starter Development Board. Items discussed in this chapter include:

� Document Layout

� Conventions Used in this Guide

� Warranty Registration

� Recommended Reading

� The Microchip Web Site

� Development Systems Customer Change Notification Service

� Customer Support

� Document Revision History

DOCUMENT LAYOUT

This document describes how to use the dsPICDEM 80-Pin Starter Development 
Board as a development tool to emulate and debug firmware on a target board. The 
manual is organized as follows:

� Chapter 1: Introduction � This chapter introduces the dsPICDEM 80-Pin Starter 
Development Board and provides a brief description of the hardware.

� Chapter 2: Tutorial � This chapter details the step-by-step process for getting 
the dsPICDEM 80-Pin Starter Development Board up and running with the 
MPLAB® In-Circuit Debugger 2 (MPLAB ICD 2).

� Chapter 3: Demonstration Program Operation � This chapter describes the 
operational functionality of the sample code that is preprogrammed into the 
dsPIC30F device.

� Chapter 4: dsPICDEM� Development Board Hardware � This chapter describes 
the hardware comprising the dsPICDEM 80-Pin Starter Development Board.

� Appendix A: Hardware Schematics � This appendix provides dsPICDEM 
80-Pin Starter Development Board hardware layout and schematic diagrams.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 

documentation are constantly evolving to meet customer needs, so some actual dialogs 

and/or tool descriptions may differ from those in this document. Please refer to our web site 

(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a �DS� number. This number is located on the bottom of each 

page, in front of the page number. The numbering convention for the DS number is 

�DSXXXXXA�, where �XXXXX� is the document number and �A� is the revision level.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 

Select the Help menu, and then Topics to open a list of available on-line help files.
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CONVENTIONS USED IN THIS GUIDE

This manual uses these documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User�s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

�Save project before build�

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N�Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4�b0010, 2�hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier font:

Plain Courier Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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WARRANTY REGISTRATION

Please complete the enclosed Warranty Registration Card and mail it promptly. 
Sending in the Warranty Registration Card entitles users to receive new product 
updates. Interim software releases are available on the Microchip web site 
(www.microchip.com).

RECOMMENDED READING

This user's guide describes how to use the dsPICDEM 80-Pin Starter Development 
Board. Other useful Microchip documents that are available and recommended as 
supplemental reference resources include:

Readme for dsPICDEM 80-Pin Starter Development Board

For the latest information on using dsPICDEM 80-Pin Starter Development Board, read 
the �Readme for dsPICDEM 80-Pin Starter Development Board.txt� file (an ASCII 
text file) in the Readmes subdirectory of the MPLAB IDE installation directory. The 
Readme file contains update information and known issues that may not be included in 
this user�s guide.

Readme Files

For the latest information on using other tools, read the tool-specific Readme files in 
the Readmes subdirectory of the MPLAB IDE installation directory. The Readme files 
contain update information and known issues that may not be included in this user�s 
guide.

dsPIC30F Family Reference Manual (DS70046)

Consult this document for detailed information on dsPIC30F device operation. This 
reference manual explains the operation of the dsPIC30F Digital Signal Controller 
(DSC) family architecture and peripheral modules but does not cover the specifics of 
each device. Refer to the appropriate device data sheet for device-specific information.

dsPIC30F/dsPIC33F Programmer�s Reference Manual (DS70157)

This manual is a software developer�s reference for the dsPIC30F and dsPIC33F 16-bit 
DSC family of devices. It describes the instruction set in detail and also provides 
general information to assist in developing software for these dsPIC® DSC families.

dsPIC33F Family Data Sheet (DS70165)

Consult this document for detailed information on dsPIC33F Digital Signal Controllers.  
Reference information found in this data sheet includes:

� Device memory map

� Device pinout and packaging details

� Device electrical specifications

� Overview of peripherals included in the device

PIC24H Family Data Sheet (DS70175)

Consult this document for detailed information on the PIC24H 16-bit MCU family.  
Reference information found in this data sheet includes:

� Device memory map

� Device pinout and packaging details

� Device electrical specifications

� Overview of peripherals included in the device
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PIC24FJ128GA Family Device Data Sheet (DS39474)

Consult this document for detailed information on the PIC24FJ128GA 16-bit MCU.  
Reference information found in this data sheet includes:

� Device memory map

� Device pinout and packaging details

� Device electrical specifications

� Overview of peripherals included in the device

dsPIC30F6011A/6012A/6013A/6014A Data Sheet (DS70143)

Consult this document for detailed information on dsPIC30F6011A, dsPIC30F6012A, 
dsPIC30F6013A and dsPIC30F6014A Digital Signal Controllers. Reference 
information found in this data sheet includes:

� Device memory map

� Device pinout and packaging details

� Device electrical specifications

� Overview of peripherals included in the device

MPLAB® ASM30, MPLAB® LINK30 and Utilities User�s Guide (DS51317)

This document details Microchip Technology�s language tools for dsPIC DSC devices 
based on GNU technology. The language tools discussed are:

� MPLAB ASM30 Assembler

� MPLAB LINK30 Linker

� MPLAB LIB30 Archiver/Librarian

� Other Utilities

MPLAB® C30 C Compiler User�s Guide (DS51284)

This document details the use of Microchip�s MPLAB C30 C Compiler for dsPIC DSC 
devices to develop an application. MPLAB C30 is a GNU-based language tool, based 
on source code from the Free Software Foundation (FSF). For more information about 
the FSF, see www.fsf.org.

Other GNU language tools available from Microchip are:

� MPLAB ASM30 Assembler

� MPLAB LINK30 Linker

� MPLAB LIB30 Librarian/Archiver

MPLAB® IDE, Simulator, Editor User�s Guide (DS51025)

Consult this document for more information pertaining to the installation and 
implementation of the MPLAB Integrated Development Environment (IDE) Software. 

To obtain any of these documents, contact the nearest Microchip sales location (see 
back page) or visit the Microchip web site at www.microchip.com.
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THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web 
site is used as a means to make files and information easily available to customers. 
Accessible by using your favorite Internet browser, the web site contains the following 
information:

� Product Support � Data sheets and errata, application notes and sample 
programs, design resources, user�s guides and hardware support documents, 
latest software releases and archived software

� General Technical Support � Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

� Business of Microchip � Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

DEVELOPMENT SYSTEMS CUSTOMER CHANGE NOTIFICATION SERVICE

Microchip�s customer change notification service helps keep customers current on 
Microchip products. Subscribers will receive e-mail notification whenever there are 
changes, updates, revisions or errata related to a specified product family or 
development tool of interest.

To register, access the Microchip web site at www.microchip.com, click on Customer 
Change Notification and follow the registration instructions.

The Development Systems product group categories are:

� Compilers � The latest information on Microchip C compilers and other language 
tools. These include the MPLAB C18 and MPLAB C30 C compilers; MPASM� 
and MPLAB ASM30 assemblers; MPLINK� and MPLAB LINK30 object linkers; 
and MPLIB� and MPLAB LIB30 object librarians.

� Emulators � The latest information on Microchip in-circuit emulators. This 
includes the MPLAB ICE 2000 and MPLAB ICE 4000.

� In-Circuit Debuggers � The latest information on the Microchip in-circuit 
debugger, MPLAB ICD 2.

� MPLAB® IDE � The latest information on Microchip MPLAB IDE, the Windows® 
Integrated Development Environment for development systems tools. This list is 
focused on the MPLAB IDE, MPLAB SIM simulator, MPLAB IDE Project Manager 
and general editing and debugging features.

� Programmers � The latest information on Microchip programmers. These include 
the MPLAB PM3 and PRO MATE® II device programmers and the PICSTART® 
Plus and PICkit� 1 development programmers.
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CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

� Distributor or Representative

� Local Sales Office

� Field Application Engineer (FAE)

� Technical Support

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (October 2005)

� Initial Release of this Document.

Revision B (March 2006)

� Updated document to include dsPIC33F Digital Signal Controllers, and PIC24F 
and PIC24H MCU information.
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Chapter 1.  Introduction

1.1 INTRODUCTION

The dsPICDEM 80-Pin Starter Development Board is a development kit and evaluation 
tool for dsPIC high-performance DSCs and PIC24 MCUs.

1.2 HIGHLIGHTS

This chapter discusses:

� dsPICDEM 80-Pin Starter Development Board Kit Contents

� dsPICDEM 80-Pin Starter Development Board Functionality and Features 

� dsPICDEM 80-Pin Starter Development Board Demonstration Program

� Reference documents

1.3 dsPICDEM 80-PIN STARTER DEVELOPMENT BOARD KIT CONTENTS

The following items comprise the dsPICDEM 80-Pin Starter Development Board Kit:

� The dsPICDEM 80-Pin Starter Development Board printed circuit board 
(see Figure 1-1).

� A preprogrammed dsPIC30F6014A device soldered onto an adapter board, which 
plugs into the Emulation Header on the dsPICDEM 80-Pin Starter Development 
Board (see Figure 1-2). 

� dsPICDEM 80-Pin Starter Development Board CD-ROM containing various 
demonstration programs provided by Microchip.

Note: The term dsPIC DSC used throughout this manual refers to both the 
dsPIC30F and dsPIC33F device families. Unless specified otherwise, 
these devices can be used interchangeably. Similarly, the term PIC24 MCU 
refers to both the PIC24F and PIC24H device families.
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FIGURE 1-1: dsPICDEM� 80-PIN STARTER DEVELOPMENT BOARD   

FIGURE 1-2: TYPICAL PLUG-IN MODULE (PIM)

For information on the components used on the dsPICDEM 80-Pin Starter 
Development Board see Chapter 4. �dsPICDEM� Development Board Hardware�.
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1.4 FUNCTIONALITY AND FEATURES

The dsPICDEM 80-Pin Starter Development Board provides the following capabilities:

Development Board Power 

� On-board variable voltage regulator for 3.3V and 5.0V output with direct input from 9V, 
AC/DC wall adapter

� 9 VDC power source input jack for development board

� Power-on indicator LED

MPLAB ICD 2 and MPLAB ICE 4000 Connections

� MPLAB ICD 2 programming connector

� Emulation header for connection to MPLAB ICE 4000

� Pad location for 80-pin TQFP dsPIC DSC device

Serial Communication Channel

� Single RS-232 communication channel

Analog

� One 10 kΩ Potentiometer (RP2)

� Microchip MCP41010 Digital Potentiometer

� Microchip MCP6022 Operational Amplifier 

- Output configured as low-pass filter for digital potentiometer

- Input configured as low-pass filter for sampling input signals with the ADC

Device Clocking

� 7.37 MHz crystal (Y1) for dsPIC DSC device

Miscellaneous

� Reset push button switch (S3) for resetting the dsPIC DSC device

� Four red LEDs (RD4-RD7)

� Two push button switches (S1-S2) for external input stimulus

� 80-pin dual-row header with labeled pinouts.

� Prototype area for user hardware

� Supports 100-to-80-pin dsPIC33F and PIC24 Plug-in Modules

1.5 dsPICDEM 80-PIN STARTER DEVELOPMENT BOARD DEMONSTRATION 
PROGRAM

The dsPICDEM 80-Pin Starter Development Board is supplied with a pre-loaded 
demonstration program that exercises principal CPU functions and peripheral options 
that allow interaction with the program as follows:

� Demonstrates interrupt handling by using switches S1 and S2 to blink LEDs RD4 
and RD5, respectively.

� Demonstrates digital-to-analog conversion by generating an audio tone on LINE 
OUT.

� Demonstrates analog-to-digital conversion by adjusting Potentiometer RP2 and 
transmitting the resulting digital value to the HyperTerminal on a PC.

Refer to Chapter 3. �Demonstration Program Operation� for details on the 
demonstration code operation.
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1.6 REFERENCE DOCUMENTS

The following documentation is available to support the use of the dsPICDEM 80-Pin 
Starter Development Board:

� �dsPIC30F Family Reference Manual� (DS70046)

� �dsPIC30F Family Reference Manual Errata� (DS80169)

� �dsPIC30F/33F Programmer�s Reference Manual� (DS70157)

� �dsPIC30F6011A/6012A/6013A/6014A Data Sheet� (DS70143)

� �dsPIC33F Family Data Sheet� (DS70165)

� �PIC24H Family Data Sheet� (DS70175)

� �PIC24FJ1285A Data Sheet (DS39747)

� MPLAB® C30 C Compiler User�s Guide� (DS51284)

� �MPLAB® ASM30, MPLAB® LINK30 and Utilities User�s Guide� (DS51317)

� �Using MPLAB® ICD 2� poster (DS51265)

� �MPLAB® ICE Emulator User�s Guide� (DS51159)

You can obtain these reference documents from your nearest Microchip sales office 
(listed in the back of this document) or by downloading them from the Microchip web 
site (www.microchip.com).
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Chapter 2.  Tutorial

2.1 INTRODUCTION

This chapter is a self-paced tutorial to get you started using the dsPICDEM 80-Pin 
Starter Development Board.

2.2 HIGHLIGHTS

Items discussed in this chapter include:

� Tutorial Overview

� Creating the Project

� Building the Code

� Programming the Chip

� Debugging the Code

� Summary

2.3 TUTORIAL OVERVIEW

The tutorial program in Eg1_BlinkLed.s is written in assembly code. This program 
blinks an LED when a key is pressed. The source file is used with a linker script file 
(p30f6014a.gld) and an include file (p30f6014a.inc) to form a complete project. 
This simple project uses a single source code file; however, more complex projects 
might use multiple assembler and compiler source files as well as library files and 
precompiled object files.

There are four steps to this tutorial:

1. Creating a project in MPLAB IDE.

2. Assembling and linking the code.

3. Programming the chip with the MPLAB ICD 2.

4. Debugging the code with the MPLAB ICD 2.

Note: The following tutorial instructions assume the use of the dsPIC30F6014A 
device, which is supplied with the dsPICDEM 80-Pin Starter Development 
Board. However, this information applies to any of the dsPIC30F,  
dsPIC33F, PIC24F and PIC24H devices supported by the board. 
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2.4 CREATING THE PROJECT

The first step is to create a project and a workspace in MPLAB IDE. Typically, there is 
one project in one workspace.

A project contains the files needed to build an application (source code, linker script 
files, etc.) along with their associations to various build tools and build options.

A workspace contains one or more projects and information on the selected device, 
debug tool and/or programmer, open windows and their location and other MPLAB IDE 
configuration settings.

MPLAB IDE contains a Project Wizard to help create new projects. Before starting, 
create a folder named Tutorial for the project files for this tutorial (C:\Tutorial is 
assumed in the instructions that follow). From the Example Code\Tutorial Code 
directory on the Development Kit Software CD-ROM, copy the Eg1_BlinkLed.s file 
into this folder. 

2.4.1 Select a Device

1. Start MPLAB IDE.

2. Close any workspace that might be open (File>Close Workspace).

3. From the Project menu, select Project Wizard.

4. From the Welcome screen, click Next to display the Project Wizard Step One 
dialog (see Figure 2-1). 

FIGURE 2-1: PROJECT WIZARD, STEP 1, SELECT A DEVICE

5. From the Device: pull-down list, select dsPIC30F6014A and click Next >. The 
Project Wizard Step Two dialog displays as shown in Figure 2-2.

Note: These instructions presume the use of MPLAB 7.20 or newer.
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FIGURE 2-2: PROJECT WIZARD, STEP 2, SELECT LANGUAGE 

TOOLSUITE

2.4.2 Select Language Toolsuite

1. From the Active Toolsuite pull-down menu, select Microchip ASM30 Toolsuite. 
This toolsuite includes the assembler and linker that will be used (the C compiler 
is not used). 

2. In the Toolsuite Contents block, select MPLAB ASM 30 Assembler 
(pic30-as.exe).

3. In the Location block, click Browse... and navigate to:
C:\Program Files\Microchip\MPLAB ASM30 Suite\Bin\pic30-as.exe

4. With MPLAB LINK 30 Object Linker (pic30-Id.exe) selected in Toolsuite 
Contents, click Browse... and navigate to:
C:\Program Files\Microchip\MPLAB ASM30 Suite\Bin\pic30-ld.exe

5. Click Next > to continue. The Project Wizard Step Three dialog displays (see 
Figure 2-3).

Note: If you have the MPLAB C30 Toolsuite installed, browse to the  
C:\program files\microchip\MPLAB C30\bin\ location.
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FIGURE 2-3: PROJECT WIZARD, STEP 3, NAME YOUR PROJECT

2.4.3 Name Your Project

1. In the Project Name text box, type MyProject. 

2. Click Browse... and navigate to C:\Tutorial to place your project in the Tutorial 
folder.

3. Click Next > to continue. The Project Wizard Step Four dialog displays (see 
Figure 2-4).

FIGURE 2-4: PROJECT WIZARD, STEP 4, ADD FILES TO PROJECT 
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2.4.4 Add Files to Project

1. From the list of folders on the PC, locate the C:\Tutorial folder and select the 
Eg1_BlinkLed.s file.

2. Click Add>> to include the file in the project.

3. Expand the C:\Program Files\Microchip\MPLAB ASM30 
Suite\Support\gld folder and select the p30f6014a.gld file.

4. Click Add>> to include this file in the project. There should now be two files in 
the project. 

5. Click Next > to continue.

6. When the summary screen displays, click Finish.

After the project wizard completes, the MPLAB project window shows the 
Eg1_BlinkLed.s file in the Source Files folder and the p30f6014a.gld file in the 
Linker Scripts folder (see Figure 2-5).

FIGURE 2-5: PROJECT WINDOW

A project and workspace has now been created in MPLAB IDE. MyProject.mcw is 
the workspace file and MyProject.mcp is the project file. Double click the 
Eg1_BlinkLed.s file in the project window to open the file. MPLAB IDE should now 
look similar to Figure 2-6.

FIGURE 2-6: MPLAB® IDE WORKSPACE 

Project

Window

Output

Window

Source 

Window

Code
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2.5 BUILDING THE CODE

In this project, building the code consists of assembling the Eg1_BlinkLed.s file to 
create an object file Eg1_BlinkLed.o and then linking the object file to create the 

Eg1_BlinkLed.hex and Eg1_BlinkLed.cof output files. The HEX file contains the 
data necessary to program the device, and the .cof file contains additional information 
that lets you debug the code at the source code level.

Before building, there are settings required to tell MPLAB IDE where to find the include 
files and to reserve space for the extra debug code when the MPLAB ICD 2 is used.

The following line is near the top of the Eg1_BlinkLed.s file:

.include "p30f6014a.inc"

This line causes a standard include file to be used. Microchip provides these files with 
all the Special Function Register (SFR) labels already defined for convenience. 

To build the code, select Build Options>Project from the Project menu. The Build 
Options dialog displays (see Figure 2-7). 

FIGURE 2-7: BUILD OPTIONS 

Browse to the location of the 

Assembler Include file
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2.5.1 Identify Assembler Include Path

1. Select the General tab.

2. At the Assembler Include Path, $(AINDIR):box, click Browse... and navigate to:

C:\Program Files\Microchip\MPLAB ASM30 Suite\Support\inc

This path tells MPLAB IDE where to find the include files.

3. Select the MPLAB LINK30 tab to view the linker settings (see Figure 2-8).

FIGURE 2-8: MPLAB® LINK30 BUILD OPTIONS

2.5.2 Link for MPLAB ICD 2

1. Check Link for ICD 2.

2. Click OK. The text box closes while the linker reserves space for the debug code 
used by the MPLAB ICD 2.

3. Click OK again to save these changes. The project is now ready to build.

Check Link for ICD2
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2.5.3 Build the Project

1. From the Project menu, select Make. The Build Output window displays.

2. Observe the progress of the build.

3. When the BUILD SUCCEEDED message displays (see Figure 2-9), you are 
ready to program the device.

FIGURE 2-9: BUILD OUTPUT
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2.6 PROGRAMMING THE CHIP

The MPLAB ICD 2 In-Circuit Debugger is used to program and debug the 
dsPIC30F6014A device in-circuit on the dsPICDEM 80-Pin Starter Development 
Board.

Use the procedures in the following section to program the dsPIC30F6014A device.

2.6.1 Set Up The Device Configuration

1. Use the Configure>Configuration Bits menu to display the configuration settings. 

2. Set up the configuration bits, as shown in Figure 2-10. 

The settings that will most likely need to change are:

FIGURE 2-10: CONFIGURATION SETTINGS

2.6.2 Connect the MPLAB ICD 2 In-Circuit Debugger

1. Connect the MPLAB ICD 2 to the PC with the USB cable (see Figure 2-11).

2. Connect the MPLAB ICD 2 to the dsPICDEM 80-Pin Starter Development Board 
with the short RJ-11 (telephone) cable. 

3. Apply power to the board.

Note: Before proceeding, make sure that the USB driver for the MPLAB ICD 2 has 
been installed on the PC (see the �MPLAB® ICD 2 In-Circuit Debugger 

User�s Guide� (DS51331) for more details regarding the installation of the 
MPLAB ICD 2). 

Oscillator XT w/PLL 4x

Watchdog Timer Disabled

CAUTION

Before you apply power to the board, observe these voltage precautions:

If a dsPIC33F device is being used, J5 should be OPEN or OFF to enable 3.3V to the VDD 

or supply voltage. Operating a dsPIC33F device at 5.0V will cause a catastrophic failure 

of the device.

If a dsPIC30F device is being used, J5 can be open or closed. You will get 3.3V or 5.0V 

voltage to the VDD pin.
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FIGURE 2-11: TYPICAL dsPIC® DSC DEVELOPMENT BOARD CONNECTED 

TO MPLAB® ICD 2

2.6.3 Enable MPLAB ICD 2 Connection

1. From the Debugger menu, click Select Tool>MPLAB ICD 2  to set the MPLAB 
ICD 2 as the debug tool in MPLAB IDE.

2. From the Debugger menu, select Connect to connect the debugger to the device. 
MPLAB IDE should report that it found the dsPIC30F6014A device, as shown in 
Figure 2-12.

FIGURE 2-12: ENABLING MPLAB® ICD 2 

Note: MPLAB IDE may need to download new firmware if this is the first time the 
MPLAB ICD 2 is being used with a dsPIC30F device. Allow it to do so. If 
any errors are shown, double click the error message to get more 
information.

Status indicates 
device is found
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2.6.4 Program the dsPIC30F6014A Device

1. From the Debugger menu, select Program to program the part. The output 
window (Figure 2-13) displays the program steps as they occur. 

2. Observe the results of the programming. When �MPLAB ICD 2 Ready� displays, 
the device is programmed and ready to run.

FIGURE 2-13: PROGRAMMING THE dsPIC® DSC DEVICE

3. Use the Debugger>Run menu to run the code. LED1 should start blinking when 
S1 is pressed.
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