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1.0 INTRODUCTION

The KEELOQ
® Evaluation Kit II provides the opportunity

to evaluate KEELOQ Code Hopping Technology quickly

and easily without having to make a large capital

investment. The evaluation kit contains all the hard-

ware and software necessary to implement a fully func-

tional remote control system and demonstrate all

operating modes of the following devices:

• HCS101, HCS200, HCS201, HCS300, HCS301, 

HCS320, HCS360, HCS361, HCS362, HCS365 

and HCS370 encoders

• SIMPLE (AN663/AN659), NORMAL (AN661/

AN642), SECURE (AN662/AN652) Software 

Decoders and related Application Notes

• HCS500 (8-pin), HCS512 (18-pin) and HCS515 

(14-pin) Decoders

The kit can also be used to program and demonstrate

the Encoder functionality of the HCS410, HCS412 and

HCS473 transponders (trans-coders).

The included Windows-based software can be used

to program the demonstration transmitters and the DIP

samples provided in the sample kit.  Encryption keys,

configuration information and other user selectable

information are automatically programmed into the

encoder’s EEPROM. Although many interdependent

parameters must be taken into account when program-

ming the encoder and decoder combination, the pro-

cess is automated and transparent to the user.

1.1 Evaluation Kit Contents

The KEELOQ Evaluation Kit contains the following hard-

ware, software and documentation:

• Programmer and Decoder Demonstration Board

• Two Demo KEELOQ Transmitter Boards

• KEELOQ Secure Data Product CD-ROM 

• Sample Kit containing various KEELOQ encoder 

and decoder samples

The KEELOQ Secure Data Product CD-ROM contains:

• All KEELOQ Devices data sheets

• All KEELOQ, Security related Application Notes

• All KEELOQ Related Software Tools, including:

-  the Windows GUI software for the Evaluation 

Kit II

- MPLAB - PRO MATE II support software for 

KEELOQ 

• This User’s Guide (DS41155)

• Multiple introductory KEELOQ presentations and 

Training material

A Separate Accessory Kit (AC162048) can be 

purchased providing:

• Power Supply Unit (100 – 240V input, 9V output)

• RS-232 Cable

About the KEELOQ® Evaluation Kit II
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2.0 INSTALLATION

The software provided on the disk is based on the Win-

dows operating system. The KEELOQ Evaluation Kit II

software can be installed either in the default

C:\HCS_EVAL directory or in another directory of

choice.

1. Insert the KEELOQ Secure Data Products CD-

ROM into the CD drive (in the following we will

refer to it as drive D).

2. If you are using Windows® 3.1, from the Pro-

gram Manager File > Run command, type

D:\tools\HCS_EVAL\SETUP. 

If you are using Windows 95, 98 or Windows

NT® 4.0, click on the Start button, select Run

and type D:\tools\HCS_EVAL\SETUP. 

The Setup screen will appear requesting to con-

firm the installation.

Click OK to continue, or Cancel to abort the

installation.

3. The Setup program will then display the “Select

Destination” dialog box.  

Click OK after selecting where the software is to

be installed or click Cancel to abort the installa-

tion.

4. The “Make Backups?” dialog box will appear.

Click Yes to backup files being replaced.

Click No to overwrite files without backup.

Click Cancel to abort the installation.

5. If Yes was selected in the previous step the “The

Select Backup Directory” dialog box appears.

Click OK after selecting a directory where 

backups will be stored.

Click Cancel to abort the installation.

6. After the files have been installed the “Install

Icons” dialog box appears

Click Yes to add the software Icons.

Click No to skip adding the Icons.

Click Cancel to abort installation.

7. After the software has been successfully

installed, a “Setup Complete” message will

appear.

2.1 Serial Port Selection

The KEELOQ software uses a serial port to communi-

cate with the programmer board. The active serial port

defaults to COM1 but can be changed  in the    “Com

Port”    dialog     box (Figure 2-1). The dialog box is dis-

played by selecting “Com Port” from the “Options”

menu.

FIGURE 2-1: SERIAL PORT SELECTION DIALOG BOX

Installing KEELOQ® Evaluation Kit II

KEELOQ® EVALUATION KIT

II USER’S GUIDE
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Test the selected serial port by connecting the pro-

grammer board to the appropriate COM port, power the

programmer board and press the “Test” button. The

software will display a message indicating whether the

programmer has been found or not.

2.2 Checking Windows Software and 
Installed Firmware Versions

The Windows Graphical User Interface (GUI) software

version and the programmer/receiver demo board firm-

ware version may be verified from the main menu:

Help-> About.   The programmer/receiver demo board

must be powered (with a 9V battery or an external

power supply) and connected to the computer’s serial

port for the firmware verification.

FIGURE 2-2:      THE ABOUT DIALOG BOX .

The About command in fact exercises the currently

selected serial port (or the default one) and verifies the

programmer/receiver board’s presence.

If a board is not found or is not powered at the time of

the test, an error message will be displayed in place of

the firmware version numbers.

The two version numbers most probably will differ as

new firmware and software revisions will be released to

improve or add support for new devices and features.

Windows

GUI code

Firmware 

installed

PIC16F877

code

installed
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3.0 THE GRAPHICAL USER 

INTERFACE

The Evaluation Kit II’s new Graphical User Interface

(GUI) is centered around a simple paradigm.  The user

creates a Project by assembling encoder blocks (up to

four) and decoder blocks (up to four) in the project win-

dow and then visually defines their relationship.

Figure 3-1 shows an example configuration screen

shot.  The user is defining a system composed of two

encoders; an HCS365 Advanced Dual Encoder and an

HCS473 3-axis transcoder. There are also two decod-

ers: (1) an HCS515 Integrated 14-pin Decoder and (2)

a Custom defined Transponder Reader.

The Links, represented graphically as arrows, illustrate

how the various encoders are bound to the HCS515

decoder (currently configured for Normal Learn). The

encoders will therefore be programmed with both a

matching Key Generation Algorithm (Normal Learn)

and a matching Manufacturer Code (in this case, the

default value: 0123456789ABCDEF HEX).

The transponder portion of the HCS473 is linked,

instead, to the custom defined Transponder Reader so

the Key used for Authentication (IFF) will match both

the Key Generation Algorithm (Simple Learn in this

case) and the Reader’s Manufacturers Code ( in this

example, the value FEDCBA9876543210 HEX).

FIGURE 3-1: THE EVALUATION KIT II GUI  

3.0.1 CREATING A NEW PROJECT

The user will typically create a new project using the

File->New Project menu. A prompt will confirm the

intention to erase any components of the previous

project and start from scratch with an empty project

window.

Links Project configuration file

Encoders List Decoders List

Encoder

Block
Decoder

Block

Evaluation Kit II GUI Software

KEELOQ® EVALUATION KIT

II USER’S GUIDE
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FIGURE 3-2: THE FILE NEW PROJECT MENU  

3.0.2 ADDING NEW ENCODERS AND 

DECODERS

Select the Edit->New->Encoder or the Edit->New-

>Decoder command (see Figure 3-3)  from the main

menu to add an encoder or decoder block to the current 

project.  Keyboard “E” or “D”, respectively, may be used

as shortcuts.  (refer also to Figure 3-1 for the encoder

and decoder list aspect).

FIGURE 3-3: ADDING ENCODERS AND DECODERS TO A PROJECT  

The program will immediately display a New Encoder

or Decoder Dialog Box (see Figure 3-4 and Figure 3-5)

allowing the user to select a desired model.

The device selection dialog boxes show lists of avail-

able and supported models to choose from.  One of the

many distinguishing characteristics of each device is

indicated: HCS301 operating voltage, HCS201’s

adjustable internal oscillator and HCS473 three-axis

transponder. 
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FIGURE 3-4: THE NEW ENCODER DIALOG BOX 

FIGURE 3-5: THE NEW DECODER DIALOG BOX 

3.0.3 SELECTING AND DELETING AN 

ENCODER OR DECODER

Using the mouse, click on any encoder/decoder block

to select it; its “selected” graphical block representation

will change to a red border (see Figure 3-6).  The key-

board arrow up and arrow down keys change the selec-

tion to adjacent encoders or decoders in the same list.

The keyboard arrow left and arrow right keys will switch

between the lists.

Hitting the DELETE (DEL) key or selecting the Edit-

>Delete function from the main menu removes the

selected block from the project window.  A dialog box

will pop-up asking to confirm the operation before the

actual deletion.

Software

Decoders

Custom

Decoder
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FIGURE 3-6:  THE SELECTED ENCODER/DECODER    

3.0.4 ENCODER AND DECODER 

CONFIGURATION

A selected Encoder/Decoder block may be configured 

by either pressing the ENTER key, double clicking with 

the mouse or by selecting the Edit->Configure option 

from the main menu.

The type and model of the currently selected device 

determines what Configuration Dialog Box aspects will 

immediately open.

Software decoders, based on their respective 

Application Note’s source code, are the only devices 

that cannot be configured; their parameters are 

defined in firmware.  To change software decoder 

parameters one must modify the source code, re-

assemble it and program new samples (using a 

PICSTART Plus or a PRO MATE II Universal 

Programmer).

FIGURE 3-7: THE SOFTWARE DECODERS WARNING MESSAGE 

3.0.5 DEFINING CUSTOM DECODERS

A user may wish to define a decoder component

derived from Application Note software or other Cus-

tom Code developed to fulfill a requirement no existing

decoder could.  A Manchester reception based

decoder using a 40-pin PIC16F77 FLASH microcon-

troller, for example.

Such a Custom decoder is but one device in a larger

project.  Definition of both its Learning Method and

Manufacturer Code is essential when programming the

linked encoders.  For this reason, the last option in the

New Decoder Dialog Box (Figure 3-5) allows the defini-

tion of such a Custom Decoder.  

Selected

Decoder
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FIGURE 3-8: CUSTOM DECODER CONFIGURATION  

Figure 3-8 shows what information to specify in defin-

ing a Custom Decoder.

The Description field allows a “name” or brief textual

description be assigned to the decoder documenting its

role in the project.  The Description may be up to 16

characters.

Perhaps something like “Manch - PIC16F77”,

“MyCode rev. 2.5” or any text string significant to the

project. 

The importance of this Description field will be more

clear later when analyzing Encoder Configuration and

Linking.

The Manufacturer Code is simply a 16-digit hex num-

ber    (64-bit)   that   defines  the Key  unique  to   this

Manufacturer/Project. 

The Learning Method specifies what scheme will be

used to derive the Encryption and Decryption keys

unique to each Encoder in the Project.

Finally, the Transponder Reader check-box helps the

Evaluation Kit software graphically represent the

decoder.  No standard readers exist for KEELOQ Tran-

sponders like the HCS410, HCS412 and HCS473.

Their base station, or Reader, must be a custom design

(perhaps derived from an Application Note) and it must

be represented as such in the Project.  Based on cus-

tom software, the only means of configuring such

devices is by changing source code, re-assembling it

and programming a new PICmicro® microcontroller

(MCU) using a standard Microchip programmer like a

PICSTART Plus or a PRO MATE II.
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3.0.5.1 HCS512 Configuration and 

Programming

If the selected decoder block is an HCS512, the corre-

sponding Configuration Dialog Box will allow the user

to configure:

• Description

• Manufacturer Code

• Learning Method

• Enable/Disable the Sleep Mode

An HCS512 DIP sample must be installed in the appro-

priate Main Board socket to complete the device pro-

gramming attempt.

Pressing the “Program Mode” button will first result in

an internal evaluation of the various configuration val-

ues.  The input fields will then be disabled, grayed-out,

safely freezing the configuration for the following pro-

gramming step.  The “Program Mode” button will reflect

this state by changing its caption to “Program”.  Subse-

quent button activations will now perform the actual

programming attempts.

Failure, success or any serial communication error will

be reported on the status line.

FIGURE 3-9: PROGRAMMING THE HCS512 

3.0.5.2 HCS515 Configuration and 

Programming

If the selected decoder block is an HCS515, the corre-

sponding Configuration Dialog Box will allow the user

to configure:

• Description

• Manufacturer Code

• Learning Method

• Enable/Disable the Repeat Mode

An HCS515 DIP sample must be installed in the appro-

priate Main Board socket to complete the device pro-

gramming attempt.

Pressing the “Program Mode” button will first result in

an internal evaluation of the various configuration val-

ues.  The input fields will then be disabled, grayed-out,

safely freezing the configuration for the following pro-

gramming step.  The “Program Mode” button will reflect

this state by changing its caption to “Program”.  Subse-

quent button activations will now perform the actual

programming attempts.

Failure, success, or any serial communication error will

be reported on the status line.

Status line
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FIGURE 3-10: HCS515 DECODER CONFIGURATION DIALOG BOX 

3.0.5.3 HCS500 Configuration and 

Programming

The HCS500 decoder promises to be obsoleted by the

newer HCS515 model. The Evaluation Kit II Main

Board therefore requires minor hardware modifications

to support the device.  The required modifications are

detailed in Appendix C.

If the selected decoder block is an HCS500, the corre-

sponding Configuration Dialog Box will allow the user

to configure:

• Description

• Manufacturer Code

• Learning Method

• Enable/Disable the Repeat Mode

An HCS500 DIP sample and companion 24LC0X

eeprom must be installed in the appropriately modified

Main Board to complete the device programming

attempt.

Pressing the “Program Mode” button will first result in

an internal evaluation of the various configuration val-

ues.  The input fields will then be disabled, grayed-out,

safely freezing the configuration for the following pro-

gramming step.  The “Program Mode” button will reflect

this state by changing its caption to “Program”.  Subse-

quent button activations will now perform the actual

programming attempts.

Failure, success or any serial communication error will

be reported on the status line.

FIGURE 3-11: HCS500 DECODER CONFIGURATION DIALOG BOX 

Note: When programmed, the HCS500

saves the configuration data in the

companion 24LC0X memory.
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3.0.6 ENCODER CONFIGURATION AND 

PROGRAMMING

Opening a selected Encoder or Trans-coder model

allows the user to view and edit its functional parame-

ters.

FIGURE 3-12: AN EXAMPLE ENCODER CONFIGURATION DIALOG BOX  

While the number and type of configurable parameters

vary from model to model, all dialog boxes share a sim-

ilar template.

The Decoder field Links the Encoder to a particular

decoder; the decoder which the encoder must be com-

patible with.

The Serial Number field displays the most recently

assigned encoder serial number in the current project.

There are several Format configuration options;

Baud Rate (speed) selection field, Modulation format

(PWM, Manchester) and Low Voltage Trip Point Select.

The number of options varies with the selected

Encoder model.

Several Check Boxes to enable and disable various

feature like a Start Pulse or a Minimum number of Code

Words per transmission

The standard Status line to communicate success

and/or Failure of a Programming attempt.

Several Control Buttons:

• “Program Mode” freezes the current configura-

tion. The button then changes to a “Program” 

button for subsequent programming attempts.

• “Default Values” restores a predetermined safe 

configuration (including grayed out advanced 

options).

• “Advanced Mode” enables additional input/

configuration fields that are otherwise disabled 

and grayed-out.  The button is present only in 

complex encoder models and gives the user 

access to the most complete set of configuration 

options available for the part.

• “Close” will register any configuration changes 

and close the dialog box.

• “Help” gives access to a help page relative to the 

selected part.

As previously mentioned, Encoder DIP samples may

be programmed either by placing them in the appropri-

ate Programming Socket or by “In-Circuit Programing”,

if mounted on a demo transmitter connected to the

Transmitter Programming Connector.

Serial Number

Format config.

Check boxes

Status line

Control Buttons

Linked Decoder

Note: At least one decoder must be defined

in the project before an encoder can be

programmed. 
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3.0.7 ADVANCED ENCODER OPTIONS

A great number of configurable parameters exist in

some more complex devices like the HCS365 and

HCS370.  The user is initially offered the option of edit-

ing only a part of them.  The remaining options are still

visible but the input fields are grayed-out indicating

they are disabled.  Modifying these advanced options

will typically result in encoders being programmed with

configurations incompatible with the evaluation kit’s

standard decoders. 

The user can enable/disable the Advanced Options by

selecting Options>Advanced Options on the main

menu before opening an Encoder Configuration Dialog

Box. The same result can be obtained by pressing the

“Advanced Mode” button inside an Encoder Configura-

tion Dialog Box.  The button’s caption changes to “Nor-

mal Mode” allowing the user to disable the advanced

option input when finished.  In general, these options

should only be modified by users already familiar with

KEELOQ encoders and decoders.

FIGURE 3-13: ADVANCED OPTIONS

3.0.8 SAVING A PROJECT

The File->Save Project and File->Save As options

can be selected from the main menu to save the

project’s current status.  Current status includes:

• the list of Encoders, and for every Encoder: 

- the full Encoder Configuration (including last 

Serial Number value)

• the list of Decoders and for every Decoder:

- the full Decoder Configuration

The project file is saved with the assigned name and

extension to the selected directory.  Although the “.cfg”

extension is suggested, any extension will suffice.  The

last project’s configuration file is always remembered

by the Evaluation Kit II software and automatically

loaded at the next launch of the program.

3.0.9 LOADING A PROJECT

Similarly, selecting File->Load Project from the main

menu allows the re-load of a previously saved Project

(configuration file).

The user is warned that in doing so the current Project

configuration is lost.

3.0.10 PRINTING A PROJECT 

CONFIGURATION FILE

Project configuration files are simply ASCII text files

built using Microsoft Windows Private Profile functions.

Their content is organized in sections separated by

section headers (like [Encoder 1]) and every section

has item-value pairs used to store the unique configu-

ration parameters values (like Seed_Type = 1).

As a result, a configuration file can be loaded using

Notepad or any Text Editing program and then printed,

e-mailed or faxed for documentation or support pur-

poses. 

Advanced

Options

Advanced Mode button

Note: The user is recommended not to edit

the configuration file contents by hand

since this could lead to unexpected

results when the Evaluation Kit II GUI

Software re-loads the project.
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4.0 DESCRIPTION

The radio receiver module on the Main Board is con-

nected to all three demonstration decoder sockets as

well as to the main processor (PIC16F877).

The GUI software monitors the Evaluation Kit’s radio

receiver data by selecting the Tools->Monitor Radio

option from the main menu. A Radio Transmission

Monitor dialog box will appear and the GUI software will

begin polling the Main Board for new transmissions at

regular 1/second intervals. The GUI software receives

notification of each new transmission, updates the

Hopping code and Fixed code fields appropriately and

reproduces an oscilloscope-like waveform display for

demonstration purposes.

The initial firmware and software release (rev.3.00)

supports only PWM modulation format and a limited

subset of Baud Rates (200 – 400 µs TE).  Attempting to

Monitor transmissions from encoders configured for

higher or lower Baud Rates or different modulation for-

mats will fail, resulting in the transmission being

ignored.

FIGURE 4-1: THE RADIO TRANSMISSION MONITOR DIALOG BOX

2 4 1234567A36FC5DD

waveform
monitor

Serial Number

Function Code

Status Hopping code

Monitoring KEELOQ® Transmissions

KEELOQ® EVALUATION KIT

II USER’S GUIDE
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4.1 Receiving KEELOQ Transmissions

All Encoder models share a common code word format

composed of:

• 32-bit Hopping Code portion containing the 

encrypted sychronization information

• 28-bit Serial Number that is the unique transmitter 

identifier

• 4-bit Function Code indicating what button(s) 

activated the transmitter.  The Function Code is 

sometimes combined with the serial number 

creating a single 32-bit Extended Serial Number

• 1 Low Voltage indication bit communicating to the 

decoder the transmitter battery status

• 1 to 5, additional status bits depending on the 

encoder model.

The Evaluation Kit II firmware attempts to receive only

the first 66 bits of any radio transmission. The GUI soft-

ware separates this data into the appropriate dialog

box fields after a successful reception.

The example in Figure 4-1 shows that:

• The Hopping Code received is A36FC5DD 16

• The transmitter Serial Number is 123456716

• The Function Code transmitted is 4 (S1 activated 

on the transmitter)

• Status bits are 0 and 1 respectively. Assuming 

the encoder used was an HCS300 they can be 

interpreted as: 

- Low Voltage = 0 

- Repeat = 1

4.2 Troubleshooting

PROBLEM:

The GUI software is unable to initialize the Main Board

and a Serial Communication Error message is dis-

played.

SOLUTIONS:

1. Check that the RS-232 cable between the PC

and main board is in place.

2. Check that the Main Board is powered 

appropriately.

3. Check that the correct serial port has been

selected. 

4. Reset the main board.

PROBLEM:

No transmissions are received:

SOLUTIONS:

1. Check that the connection between the decoder

and main board is correct.

2. Check that the RS-232 cable between the main

board and PC is in place.

3. Check that the JP1 jumper on the main board is

in place.

4. Check that the link JP1 on the Demo Transmitter

board is in place.
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5.0 GENERAL DESCRIPTION

Microchip KEELOQ Code Hopping encoders are

intended for secure authentication and remote control

applications. 

The encoders contain internal non-volatile memory

(EEPROM) for data and configuration storage. They

will retain information for several years, even when

stored without power supply. 

Minimal external components are required to imple-

ment a complete remote transmitter.  All input pull down

resistors, oscillator circuit components, voltage regula-

tion, LED driving, voltage sensing and button debounc-

ing circuits are integrated in the KEELOQ encoder

silicon.

FIGURE 5-1: TYPICAL KEELOQ TRANSMITTER

In addition to the IC, all that is required is a circuit for

transmitting the information over the desired media

(e.g., a UHF radio transmitter), a battery, and a button

switch as shown in Figure 5-1. A single encoder can

command a multifunction decoder to activate up to 15

specific functions/outputs. The user would select the

desired function pressing one or more buttons on the

transmitter.

For a complete list of all the features of the various

KEELOQ encoders and a  description of their features,

consult the related data sheets included in the

CD ROM or download them from the Microchip web

site: http:\\www.microchip.com. 

A brief summary of basic encoder features is given in

Table 5-1.

5.1 Encoder Features

5.1.1 ENCODER SYNCHRONIZATION

Every KEELOQ encoder has at least a 16-bit synchroni-

zation counter that is incremented each time the

encoder is activated. The counter is encrypted and

transmitted as part of a code hopping transmission.

When decoder learns a transmitter, the encoder’s

received serial number, calculated encryption key and

decrypted synchronization information are stored in

EEPROM. It is then very easy for a decoder to check

whether a given transmission is a valid transmission or

a transmission re-transmitted by a code grabber.  The

received counter value must be greater than the stored

synchronization counter value for a transmission to be

valid.

HCS3XX

RF Circuitry

3 to 12V 
battery*

VDD

S3

S2

S1

S0

LED

DATA

VSS

(*Note: depending on actual encoder model) 

KEELOQ® Encoders

KEELOQ® EVALUATION KIT

II USER’S GUIDE
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In addition, provisions must be made for counter dis-

crepancies caused by a user activating the transmitter

while out of range of the decoder. KEELOQ decoders

accommodate this by providing two synchronization

windows. If the synchronization counter received is 1 to

16 counts above the stored counter, the decoder

accepts the transmission as a valid transmission,

updates the stored counter and activates the appropri-

ate output. If the synchronization counter received is

between 16 and 32k counts above the stored counter,

the decoder temporarily stores the received counter

and waits for a second transmission. The second trans-

mission’s counter is compared to the temporary

counter.  If they are consecutive, the decoder re-syn-

chronizes by storing the latest counter and activates

the appropriate output. Counter values outside of these

windows, 32k – 64k counts above the stored counter

value, are considered invalid and these transmissions

are ignored.

5.1.2 ENCODER ACTIVATION

The encoder is activated when one or more of the

encoder inputs (S0, S1, S2, S3) is pulled HIGH. The

function code (“button code”) is one part of the trans-

mitted code word. The function code mirrors the

encoder inputs and may be used to activate specific

functions of a multifunction decoder. For example, S0

could be used to deactivate the alarm and unlock the

car, S1 to open the trunk and when pressed together

they activate a panic function.

5.1.3 TRANSMISSION BAUD RATES AND 

MODULATION FORMATS

Various modulation formats can be selected for the

encoder data output signal. All KEELOQ encoders offer

a Pulse Width Modulation (PWM) format. In addition,

encoders like the HCS360 and HCS362 offer

Manchester Encoding and the HCS361 and HCS365

offer Variable Pulse Width Modulation (VPWM).

Every encoder offers multiple transmission Baud

Rates; expressed in terms of the an elementary time

element (TE) duration. TE typically ranges from a slow-

est Baud Rate pulse width of 800 µs to a fastest Baud

Rate pulse width of 100 µs. The number of Baud Rate

options and exact values vary with the chosen encoder

model.

5.1.4 OPERATING VOLTAGE

The KEELOQ encoder product line covers a wide range

of operating voltages. Most models operate from 2V to

6V which is ideal for applications using one or two 3V

lithium batteries. Selected models operate directly from

a 9V to  12V battery which is convenient for applica-

tions where a standard 9V battery or a common 12V

(type GP23) battery is used.

5.1.5 LOW VOLTAGE DETECTION

All KEELOQ encoders include a low voltage status bit in

each transmission. The bit is set when the encoder

detects the supply voltage has dropped below a set

threshold. This allows the decoder/receiver to indicate

when the transmitter battery needs replacement. Con-

sult the individual encoder data sheets for the exact

threshold levels available.

5.1.6 COUNTER OVERFLOW

A 16-bit synchronization counter, minimum, is incre-

mented, encrypted, and transmitted each time the

encoder is activated. The 16-bit length of the synchro-

nization counter allows 10 activations per day for 18

years before the cycle begins to repeat. Should the

system designer conclude this is not adequate, then

the overflow bits can be used to extend this cycle. One

of the two overflow bits is cleared each time the counter

wraps 0000. Therefore, utilizing one overflow bit dou-

bles the range of the synchronization counter and uti-

lizing both triples the range of the synchronization

counter.

5.1.7 AUTO-SHUTOFF

An auto-shutoff function is available on KEELOQ encod-

ers. If enabled, the auto-shutoff function stops the

device from transmitting if a button is continuously

pressed for a long period of time. This prevents the

encoder from draining the battery if a button is acciden-

tally pressed while in a pocket or purse. The time-out

period is typically 25 seconds but some devices have

shorter or programmable time-out periods essential for

certification in some countries.
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TABLE 5-1: SUMMARY OF KEELOQ ENCODER DIFFERENCES

Encoder PWM Manchester VPWM 13V
Overflow 

Bits

Function

Inputs
LED

HCS101 X — — X — 3 —

HCS200 X — — X — 3 —

HCS201 X — — X — 3 —

HCS300 X — — — — 3 —

HCS301 X — — X 2 4 X

HCS320 X — — X 2 4 X

HCS360 X X — — 1 4 X

HCS361 X — X — 1 4 X

HCS362 X X — — 2 4 X

HCS365 X X X — 2 4 X

HCS370 X X X — 2 6 X

HCS410 X X — — 2 3 X

HCS412 X X — — 2 3 X

HCS473 X X X — 2 4 X
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6.0 DEMONSTRATION 

TRANSMITTERS

The evaluation kit demonstration transmitters support

any 8- or 14-pin DIP KEELOQ encoder as shown in

Figure 6-1. 

The encoder socket U2 supports 8-pin and 14-pin

encoders inserted with pin 1 in the corresponding pin 1

of the 14-pin socket (Figure 6-1). The demo transmitter

PCB leaves pins 5 through 9 unconnected to accom-

modate the different and sometimes conflicting pin

functionalities on the HCS473, HCS370 and future

products. The user is advised to avoid hand contact

with those pins as there may be only weak internal pull

ups on the most sensitive inputs. Inadvertent input sig-

nals could trigger unexpected responses from the

device confusing the demonstration.

The four buttons (S0..S3) on the demonstration trans-

mitters are connected to the appropriate inputs on the

encoder (S0 through S3). The user may activate any

combination of encoder inputs transmitting any of the

15 possible function codes.  The RFEN output is not

used by the demonstration transmitter and should be

disabled as several encoders share its output with a

button input.  If enabled, a button input may be lost.

The RF oscillator uses a Surface Acoustic Wave

(SAW) resonator to operate at 433.92 MHz. Note that

this is not sufficient to ensure compliance with EC and/

or FCC regulations. 

Jumper JP1 connects the DATA output of the encoder

to the RF transmitter modulator circuit input.  If

removed, it can be used to monitor the digital encoder

output while the RF section is disabled. 

FIGURE 6-1: KEELOQ DEMONSTRATION TRANSMITTER

Programming Connector LED control jumper
RF output jumper

Encoder socket

fits 8- and 14-pin

2 x 3V Lithium battery

LED

pin 1

Demonstration Transmitters

KEELOQ® EVALUATION KIT

II USER’S GUIDE



 2001 Microchip Technology Inc. DS41155A-page 19

KEELOQ® EVALUATION KIT II USER’S GUIDE

The battery holder BT1 accepts one or two CR2016

3V lithium batteries, positive side up. While most

encoder models will demonstrate reliable operation

down to 2V, the demo RF oscillator circuit is only

ensured to operate properly down to 4.5V.

The LED functionality varies with the encoder model

mounted in the transmitter’s socket.  Its connection

changes with the encoder model as well. Jumper JP2

must be set according to the following Table 6-1:

TABLE 6-1:      

The Programming Connector (J1) on the left side of

Figure 6-1 enables the transmitter’s direct connection

to   the    programmer    board    for   In-Circuit   Serial 

Programming™ (ICSP™). Each demo transmitter can

therefore be re-configured without removing the

encoder from the transmitter board. 

Encoder LED
When Flashing 

Indicates
Jumper 2 setting

HCS101 NO — Disconnect

HCS200 NO — Disconnect

HCS201 NO — Disconnect

HCS300 YES Low Battery 1-2

HCS301 YES Low Battery 1-2

HCS320 YES Shift Level 1-2

HCS360 YES Low Battery 1-2

HCS361 YES Low Battery 1-2

HCS362 YES Low Battery 1-2

HCS365 YES Once = Low Battery 2-3

HCS370 YES Once = Low Battery 2-3

HCS410 NO — Disconnect

HCS412 YES Once = Low Battery 1-2

HCS473 YES Once = Low Battery 2-3

Note: Although the kit’s included Demonstra-

tion Transmitters connect multiple lines

(up to 8 out of 16 available) to the Pro-

gramming Connector, only four lines are

typically required for production In-Circuit

Serial Programming (ICSP).



DS41155A-page 20  2001 Microchip Technology Inc.

M
7.0 THE MAIN BOARD 

The following chapters examine the main board by

dividing it into areas of specific functionalities (see

Figure 7-1):

• Radio Receiver

• Demo Decoders

• Main Processor

• Serial Interface

• Programming Socket

• Transponder Interface

• Power Supply

• Step Up Circuit

• Prototyping Area   

FIGURE 7-1:  THE MAIN BOARD   

Power Supply Radio Receiver
Transponder Interface

Main Processor

Serial Interface

Prototyping Area

Step Up Circuit

Demo Decoders Programming

Socket

The Main Board

KEELOQ® EVALUATION KIT

II USER’S GUIDE
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7.1 Radio Receiver

The Demo Board contains an ASK Radio Receiver

module that serves the Decoders as well as the Main

Processor.

The module is a standard thick-film hybrid circuit mod-

ule tuned by the manufacturer to 433.92 MHz. The

demodulated digital output signal may be directly fed

into any microcontroller I/O pin. 

This type of radio receiver module is common, low cost

and recommended to those without RF design capabil-

ities. The pin-out is standard. Thus, it may be easily

replaced with similar models accommodating various

frequencies, sensitivity levels, modulation methods

(ASK vs. FSK) as well as complying to various interna-

tional certification standards.

FIGURE 7-2: THE RADIO RECEIVER    

Jumper JP1 allows the radio receiver output to be dis-

connected from the decoders. This permits monitoring

the receiver output on an oscilloscope or injecting an

encoder’s digital output directly into the decoder

7.2 Demonstration Decoders   

The Decoder area is subdivided into three sections:

1. Software Decoders 

2. HCS512 Decoder

3. HCS515 Decoder

Each section has a Learn button, an RC oscillator cir-

cuit and a set of LEDs to show the Decoder’s output

status but they share the radio receiver output at JP1.

A non-volatile memory is available to the software

decoders; 93C46 EEPROM, socket U3.  Voltage super-

vising (Brown out Reset) circuitry and power supply are

common with the Main Processor.

The HCS512 and HCS515 decoders are connected to

the Main Processor with separate pairs of clock and

data lines such that they may be independently config-

ured.  Although the current firmware release does not

support it, the decoder coprocessor functionality could

be demonstrated.

Radio Receiver
Jumper JP1 
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FIGURE 7-3: THE THREE DECODERS    

7.2.1 SOFTWARE DECODERS

Three basic Software Decoders may be demonstrated

in this portion of the board:

1. SIMPLE Learn Decoder 

(AN659_Confidential/AN663_Non Restricted)

2. NORMAL Learn Decoder 

(AN642_Confidential/AN661_Non Restricted)

3. SECURE Learn Decoder 

(AN652_Confidential/AN662_Non Restricted) 

The decoder functionalities are described in the related

Application Notes. Both the Non-Restricted and Confi-

dential versions describe the functionality and method-

ologies for the different Learning Schemes.  The

Confidential version further explains the decryption and

adds the full source code.

An official introduction to KEELOQ and its different

Learning Schemes can be found in either the Applica-

tion Notes or Technical Briefs TB001 and TB003. In

short: 

1. The SIMPLE Learn Decoder uses a single 

common key for all encoders. Such a key is

hard-coded in the decoder’s firmware. The

Learning phase  requires only a single encoder

transmission for the decoder to memorize the

encoder’s unique Serial Number and Synchroni-

zation Information. The values are stored in the

non-volatile memory.

2. The NORMAL Learn Decoder generates a 

different key for every encoder. The encoder

Serial Number is one input to the Key 

Generation algorithm which is in fact the 

Decrypt algorithm. Learning requires two con-

secutive Hopping Code transmissions. 

3. The SECURE Learn Decoder uses a random

Seed value transmitted by the encoder and

either the XOR algorithm or the Decryption 

algorithm (selectable in the application note

source code) as the Key Generation algorithm. 

The Manufacturer’s Key for the Software Decoder sam-

ples is by default set to  0123456789ABCDEF16. 

Since the software decoders are  based on OTP micro-

controllers (PIC16C54 and PIC16C56) they cannot be

configured by the Evaluation Kit software.

Software 

Decoders

HCS512 

Decoder

HCS515

Decoder
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FIGURE 7-4: WARNING RECEIVED WHEN TRYING TO CONFIGURE A DECODER  

7.2.2 HCS512 DECODER

The HCS512 is a fully integrated KEELOQ decoder

since it contains the necessary non-volatile memory to

store the Serial Number and Synchronization Informa-

tion for up to four transmitters. 

The HCS512 can be used either as a stand-alone

decoder, connecting the S0:S3 outputs directly to sys-

tem outputs, or used in “co-processor mode” in con-

junction with a microcontroller when the CLOCK and

DATA synchronous communication lines are used.

A Sleep Mode is available for low power applications.

The HCS512 decoder can be configured by the Evalu-

ation Kit software to perform Normal Learn or Secure

Learn operation using XOR or Decrypt Algorithm as the

Key Generation algorithm.

FIGURE 7-5: THE HCS512 CONFIGURATION DIALOG BOX.   

In the dialog box above the user can:

•  assign text as a title or description of the decoder.  

The entry will be recorded in the project configura-

tion file for documentation purposes.

• change the Manufacturer Code used for the Key 

Generation process during Learning

• select the desired learning scheme among:

- Normal Learn

- Secure Learn - XOR 

- Secure Learn - Decrypt

• enable the Sleep feature to reduce power con-

sumption when there is no signal coming from the 

radio. 
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