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Preface

INTRODUCTION AND HIGHLIGHTS

This section provides general information that will be useful to know before using the 
MCP250XX Development Kit and touches on the following topics:

� About This Guide

� Recommended Reading

� Troubleshooting

� The Microchip Internet Web Site

� Customer Support

ABOUT THIS GUIDE

Document Layout

The User’s Guide layout is as follows:

� Chapter 1: Product Overview and Installation – details the hardware and 
software components and discusses installation procedures.

� Chapter 2: MCP250XX Basic View Tutorial – covers some of the key elements 
of the MCP250XX by going through the steps for setting up and running the 
demonstration program.

� Chapter 3: MCP250XX Register View Tutorial – details the demonstration 
software and  the CAN system, as well as discussing the steps required to 
successfully communicate with the MCP250XX while in the Register template.

� Chapter 4: Programming the MCP250XX Using the Development Board – 
describes the procedure for programming the MCP250XX using the programming 
circuitry and special software.

� Chapter 5: Other Capabilities of the MCP250XX Development Kit - details the 
other capabilities of the MCP250XX Development Kit, including configuring the 
board for multiple oscillators, connecting the board to the MCP2515 development 
board and connecting the board to external CAN busses.

Appendices

� Appendix A: Schematics and Layouts – lists the schematics and layout 
diagrams for the MCP250XX Development Kit.

� Index – cross-reference listing of terms, features and sections of this document.

� Worldwide Sales and Service – provides the address, telephone and fax 
numbers for Microchip Technology Inc. sales and service locations throughout the 
world.

Updates

Since Microchip tools are constantly evolving to meet customer needs, some software 
dialogs and/or tool descriptions may differ from this document. Please refer to the 
Microchip web site to obtain the latest documentation available (www.microchip.com).
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RECOMMENDED READING

For more information regarding the MCP250XX devices and other CAN related topics, 
the following are recommended reading. The following data sheets may be 
downloaded from our internet web site at www.microchip.com.

MCP2502X/2505X Data Sheet (DS21664)

This data sheet provides detailed information regarding the MCP250XX CAN I/O
Expanders.

MCP2515 Data Sheet (DS21291)

This data sheet provides detailed information regarding the MCP2515 Stand-Alone
CAN Controller, which is the master node on the board.

PRO MATE® II User’s Guide (DS30082)

This manual contains a section explaining how to program the MCP250XX devices
using the specified socket module.

MCP250XX Programming Specification (DS20072)

This specification explains the requirements for programming the MCP250XX
using the ICSP™ protocol.

AN815 – Understanding the MCP250XX Devices (DS00815).

AN816 – A CAN System Using Multiple MCP250XX I/O Expanders (DS00816).

AN713 – An Introduction to the CAN Protocol Application Note (DS00713)

This application note provides “the basics” for those not familiar with the CAN
protocol.

AN754 – Understanding Microchip’s CAN Module Bit Timing Application Note 

(DS00754)

This application note is an in-depth discussion of bit timing using Microchip’s CAN
module.

A CAN Kingdom by Lars-Berno Fredriksson (Kvaser AB)

This document covers the CAN Kingdom Specification and should help give some
insight into the main software and some of the menu items that refer to CAN
Kingdom-specific functions.  For more information, please visit CAN Kingdom web
site at www.cankingdom.org

CANKing Help Files

The help files are a good resource for answering some common questions about
the MCP250XX Development Kit, including the CAN Kingdom-specific menu
items.

README Files

Contains the latest information on the MCP250XX evaluation system.

Microsoft® Windows® Manuals

These manuals assume that users are familiar with the Microsoft Windows
operating system. Many excellent references exist for this software program and
should be consulted for general operation of the Windows® operating system.

TROUBLESHOOTING

See the README files for information regarding common problems not addressed in this 
user’s guide.
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THE MICROCHIP INTERNET WEB SITE

Microchip provides easy access to our documentation and on-line support through our 
World Wide Web Site at www.microchip.com. You can download files from the web site 
or from our FTP site at ftp://ftp.microchip.com.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

� Distributor or Representative

� Local Sales Office

� Field Application Engineer (FAE)

� Corporate Applications Engineer (CAE)

� Hot Line

Customers should call their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. See the 
back cover for a listing of sales offices and locations.

Corporate applications engineers (CAEs) may be contacted at:

(480) 792-7627.

In addition, there is a Systems Information and Upgrade Line. This line provides system 
users a listing of the latest versions of all of Microchip’s development systems software 
products. Plus, this line provides information on how customers can receive any 
currently available upgrade kits.

The Hot Line numbers are:

1-800-755-2345 for U.S. and most of Canada, and

1-480-792-7302 for the rest of the world.
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Chapter 1.  Product Overview and Installation

1.1 INTRODUCTION AND HIGHLIGHTS

This chapter provides an overview of the MCP250XX Development Kit and covers the 
following topics:

� What is the MCP250XX Development Kit?

� System Requirements

� MCP250XX Development Kit Components

� MCP2515 Components

� Hardware Installation

� Software Installation

1.2 WHAT IS THE MCP250XX DEVELOPMENT KIT?

The MCP250XX Development Kit is an evaluation, demonstration and development 
tool for Microchip Technology’s 14-pin CAN I/O Expanders. The MCP250XX can be 
evaluated easily by installing the provided software and running the demonstration 
program. Furthermore, development can be accomplished by utilizing the bare CAN 
node with the prototyping area, as well as with the on-board device programmer.

The development board has the ability to program the user-defined defaults by using 
the device programmer module and the supplied software. Alternatively, the In-Circuit 
Serial Programming™ (ICSP™) protocol can be used to program the MCP250XX 
using the 5-pin header, which is connected to a 14-pin socket on the board. See the 
MCP250XX Programming Specification (DS20072) for details on programming via 
ICSP.

Some of the key features of the MCP250XX Development Kit include:

� Evaluation of Microchip’s CAN I/O Expanders

� Programming the MCP2505X devices using supplied software

� Programming the MCP2505X devices via the ICSP protocol

� Connectable to external CAN networks

1.3 SYSTEM REQUIREMENTS

To take full advantage of the MCP250XX features, you must install the supplied 
demonstration/evaluation software on a host computer. The MCP250XX requires:

� Microsoft Windows 95/98/ME/NT/2000 operating system

� One free parallel port

� CD-ROM drive



MCP250XX User’s Guide

DS51266C-page 6   2004 Microchip Technology Inc.

1.4 MCP250XX DEVELOPMENT KIT COMPONENTS

The MCP250XX Development Kit contains:

� MCP250XX Development Board

� MCP250XX Development Kit User’s Guide

� MCP250XX Development Kit CD-ROM with demo and programming software

� Parallel port cable

� 9V DC power supply adapter

� Warranty/Registration card

� Three MCP25020 CAN I/O Expanders

� Three MCP25050 CAN I/O Expanders

FIGURE 1-1: MCP250XX DEVELOPMENT KIT
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1.5 MCP2515 COMPONENTS

The MCP2515 consists of four main parts (see Figure 1-4):

1. PC Node

2. Node A

3. Node B

4. Device Programmer

1.5.1 PC Node

The PC Node is the master node for the demonstration program that controls Node B. 
This node contains a MCP2515 Stand-Alone CAN Controller that is controlled by the 
host PC via a custom parallel port interface.

1.5.2 Node A

Node A is a bare CAN node next to the prototyping area. This node is used for 
MCP250XX prototyping and can also be used to program the user defaults via the 
ICSP protocol. See Figure 1-2 for pinout description.

FIGURE 1-2: NODE A PINOUT

Note: All three nodes are connected to a common CAN bus that has external 
connections via the DB9 connector.
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1.5.3 Node B

Node B is the slave node for the demonstration program. Analog inputs 
(potentiometers), PWM outputs (piezo buzzer and incandescent lamp) and digital 
inputs (push buttons) are all connected to the MCP25050 device. It responds to inputs 
and CAN messages to demonstrate device functionality. See Figure 1-3 for the pinout 
description.

FIGURE 1-3: NODE B PINOUT
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1.5.4 Device Programmer

The Device Programmer module is used with PC software to configure the 
user-defined defaults.

FIGURE 1-4: MCP250XX DEVELOPMENT BOARD

1.5.5 Key Areas of the MCP2515

There are a few key areas on the board. Figure 1-4 illustrates these areas, while 
Table 1-1 details them.

TABLE 1-1: MCP250XX BOARD LAYOUT

Key Areas Description

DB25 DB25 is the connection to the host PC interface.  The PC controls both 

the PC Node and the Device Programmer circuit.

U6 U6 is the CAN Controller (MCP2515) of the PC Node that is controlled 

by the host PC.

U15, J5 and JP4 U15 is the prototyping node. J5 is the ICSP™ header for U15. JP4 jump-

ers board power to the VDD pin of U15 and should be removed if using 

J5 (ICSP header) to isolate U15 from the rest of the board during 

In-Circuit Serial Programming™.

U14 The MCP250XX for the demonstration program. Connected to the 

potentiometers, piezo, buttons and lamp.

U3 U3 is the socket for programming the user-defined defaults using the 

programming software.

Y1, Y2, Y3, JP1 
and JP2

Y1, Y2 and Y3 are the oscillator sockets for each of the three CAN 
nodes. By default, all of the Yx outputs are connected together (JP1 and 

JP2 are shorted via a trace on the back of the board) and only Y1 is pop-

ulated (i.e., Y1 clocks all three CAN nodes). To separate the oscillator 

sockets, the traces shorting JP1 and JP2 must be cut.

U11, U12, U13, J3 

and J4

U11-U13 are the CAN drivers all connected to a common CAN bus.  The 

two DB9s (J3 and J4) are the external CAN bus connections.  Only J4 is 

populated.

D2, D3, D4 and D5 CAN traffic indicator LEDs. D2 represents all traffic. D3-D5 represent 

transmitted traffic of each of the three nodes.
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1.6 HARDWARE INSTALLATION

1.6.1 Connecting the DB25 Cable

The included DB25 cable is a male-to-male configuration and plugs into the parallel 
port of the host PC. Figure 1-5 shows the pin configuration.

FIGURE 1-5: DB25 PIN CONFIGURATION

1.6.2 9V Power Supply Adapter

The power supply is rated at 9V, 750 mA DC.

1.6.3 DB9 External CAN Bus Connectors (optional)

The DB9 connector, as shown in Figure 1-6, is used to connect the MCP2515 to an 
external CAN bus and is not necessary for basic board operation.

FIGURE 1-6: DB9 CAN CONNECTOR

Note: Only the DB9 at J4 is populated. J3 is available as needed.
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1.7 SOFTWARE INSTALLATION

Insert the MCP250XX Development Kit CD-ROM into the CD-ROM drive.

1.7.1 Auto-run Enabled

If auto-run is enabled, the installation program will automatically start. Follow the 
instructions on the screen to install the software.

1.7.2 Auto-run Not Enabled

If auto-run is not enabled:

1. Click the Start button and select Run. Enter d:\setup.exe 
(where d:\ is your CD-ROM drive). Click OK.  Or alternatively, find the CDROM
drive using “Windows Explorer” and double click “setup.exe”.

2. Follow the online instructions to install the software.

Note: Windows NT® and Windows 2000 users must have administrative
privileges in order to install the MXLAB® software.
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Chapter 2.  MCP250XX Basic View Tutorial

2.1 INTRODUCTION

This tutorial discusses the evaluation portion of the kit, details the demonstration soft-
ware (Basic template), CAN system (PC Node and Node B) and covers the steps 
required to successfully run the demonstration network.

The user defaults for Node B are preprogrammed at the factory. Therefore, no user 
default programming is necessary. No discussion of programming user defaults will 
take place in this chapter, as this is detailed in Chapter 4. “Programming the 

MCP250XX User Defaults”.

2.2 HIGHLIGHTS

This chapter covers the following topics:

� Setting up Evaluation mode

� Establishing communications

� Explaining the CAN messages

2.3 SETTING UP THE BASIC TEMPLATE EVALUATION MODE

The MCP250XX Development Kit’s “Basic” template contains the following major 
elements:

1. Menu Bar (Figure 2-1) – The layout is typical of most Windows menu bars.

2. PC Node Bit Timing and Mode (Figure 2-2) – The bit timing and the mode of 
operation (Normal and Configuration) for the MCP2515 (PC Node) are 
configured with this window.

3. Board Status (Figure 2-3) – Indicates if the board is connected to the PC and 
also indicates the parallel port address used.

4. Message Format Window (Figure 2-4) – Selects how CAN messages are 
formatted and interpreted. The default is “Standard Text Format” and is used for 
the demonstration program. The other format is used with the CAN Kingdom 
higher layer protocol.

5. Bus Monitor Window (Figure 2-5) – Also known as the “Output” window. This 
window shows all bus traffic.

6. MCP250XX Demonstration (Figure 2-6) – This window is the graphical 
interpretation of Node B (the demonstration node).

FIGURE 2-1: MENU BAR

Note: The software must be installed and the hardware connected to run the 
demonstration program.
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FIGURE 2-2: PC NODE BIT TIMING AND MODE

FIGURE 2-3: BOARD STATUS
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FIGURE 2-4: MESSAGE FORMAT WINDOW

FIGURE 2-5: BUS MONITOR WINDOW
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FIGURE 2-6: MCP250XX DEMONSTRATION WINDOW
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2.3.1 Starting the Program

1. Start the software by any of the following:

� From the “Start” menu, select “Programs > Microchip > CANKing”

� Select “C:\Program Files\Microchip\Mcan\WC32.exe”

� Double-click on the desktop icon for the MCP250XX Development Kit

2. A notice will appear warning of the potential undesired results if connecting to an 
existing CAN bus (Figure 2-7). Select “OK, I know what I am doing”.

3. A dialog will appear asking if a new template or a saved project should be 
opened. Select “New Template” (Figure 2-9).

4. When the template dialog appears, select “MCP250XX Evaluation” 
(Figure 2-10).

The software is now started.  There are a few other options that the user may want to 
configure for convenience before saving the project and capturing the defaults.

2.3.2 Setting the Numeric Base for Transmit and Monitor Windows

The default numeric base can be changed, as desired, for both the Transmit Buffer 
window and the Bus Monitor window.  Base 16 (hex) numbers are preceded by a “$”.

2.3.2.1 TRANSMIT BUFFER WINDOW

The numeric base for the transmit buffer is configured by selecting “Options > Global...” 
from the menu.  Check desired numeric base.

2.3.2.2 BUS MONITOR WINDOW

If the Select Formatters window is not visible, select it from the View menu. Highlight 
(do not uncheck) Standard Text Format in the Select Formatters window. Click 
Properties and check the desired numeric base (see Figure 2-8).

A few other items must be addressed before proper communication can occur. These 
are discussed in the next section.
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FIGURE 2-7: WARNING ON START-UP

FIGURE 2-8: CHANGING NUMERIC BASE FOR BUS MONITOR
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FIGURE 2-9: OPEN DIALOG

FIGURE 2-10: TEMPLATE DIALOG



MCP250XX User’s Guide

DS51266C-page 20   2004 Microchip Technology Inc.

2.4 ESTABLISHING COMMUNICATIONS

When the software is started from a new template (as it must be the first time it is 
started), some steps must be taken to insure proper operation and to set up the 
software defaults.  These defaults can be saved by saving the template as a project 
and opening the project in subsequent sessions.

2.4.1 Configure Parallel Port

The board status (including parallel port address and connection status) is indicated in 
the Board Status window (Figure 2-3). Assuming the port address, as displayed in the 
window, matches the address as configured by the PC, the board status should 
indicate “connected”, with the indicator in the window being green.

If the status indicator is red and indicates “not connected”, check the port address. To 
change the port address that the software uses, select “Options > MCP2515” and enter 
the correct port address in the appropriate dialog box (Figure 2-11).

FIGURE 2-11: PC NODE OPTIONS

2.4.2 Match Oscillator Frequency with Board

The CAN data rate is a function of the oscillator frequency. Therefore, the proper 
oscillator frequency must be set in order for the software to calculate the CAN data rate 
correctly. Open the same window that was opened to set the parallel port address 
(Figure 2-11). The frequency of oscillation units are displayed in kilohertz (kHz).

Note: Port address is entered as a hex value.
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2.4.3 Configuring the Output Window Display Format

The Output (Bus Monitor) window (Figure 2-5) can display the CAN messages in five 
different ways:

1. Fixed Positions – Messages with the same identifier maintain a fixed position 
(slot) within the window.  The data and time-stamp update normally.  To turn fixed 
positions on/off, right-click the mouse while the cursor is over the Output window 
area and select “Fixed Positions”.

2. Dynamic Positions (Fixed Positions = off) – Each new message is displayed 
below the previous message, regardless of the identifier. This mode is activated 
by unchecking Fixed Positions (right mouse click).

3. Auto-Scroll – Keeps the Output window from auto-scrolling to the most recent 
message (bottom message).  This is useful when messages are being regularly 
received and the user would like to observe old messages at the top of the buffer 
without having the focus shift to the end of the buffer each time a message is 
received.
To activate, right-click the mouse while the cursor is over the Output window and 
select “Auto-Scroll”.

4. Delta Time – This is a time-stamp that indicates the time(s) between two 
messages with the same identifier. Delta time is activated as follows (Figure 2-8): 
If the Select Formatters window is not visible, select it from the View menu. 
Highlight (do not uncheck) the “Standard Text Format” option in the Select 
Formatters window. Click Properties and check the “Delta Times” box.

5. Free-Running Time – A free-running time-stamp between messages with the 
same identifiers. This mode is activated by unchecking the “Delta Times” box.
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