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An Introduction

To Arduino

www.dfrobot.com

Lesson 1



What is Arduino？

Arduino is an open-source hardware and software platform designed for computer programmers, industrial artists, professionals and those 

interested in developing interactive devices and applications specific to an interactive development environment.

Arduino can receive input signals from various sensors and inputs. By controlling light sources, motors, or other actuators, Arduino can change 

the surrounding environment. Programs for the microcontroller on the Arduino board are written in Arduino’s programming language (based on 

ﾓWiringﾔ＠ Ｍ＠｡ｮ＠ｯｰ･ｮ＠ｳｯｵｲ｣･＠ｦｲ｡ｭ･ｷｯｲｫ＠ｦｯｲ＠ｭｩ｣ｲｯ｣ｯｮｴｲｯｬｬ･ｲｳ) and run in the Arduino development environment (based on ﾓProcessingﾔ＠ Ｍ＠｡ｮ＠

ｯｰ･ｮ＠ｳｯｵｲ｣･＠ｰｲｯｧｲ｡ｭｭｩｮｧ＠ｬ｡ｮｧｵ｡ｧ･＠｡ｮ､＠ｩｮｴ･ｧｲ｡ｴ･､＠､･ｶ･ｬｯｰｭ･ｮｴ＠･ｮｶｩｲｯｮｭ･ｮｴ).

Arduino is able to run independently or communicate with software running on a computer (for instance, Flash, Processing and MaxMSP). 

The open-source Arduino IDE, which is free to download, makes it easy for you to write code, upload it to the board and come up with your 

own interactive devices.

◆ Make a line-following robot

◆ Make a fluffy toy that lights up

◆ Make your phone ring when you receive an e-mail

◆ Make a Metroid-style arm cannon

◆ Make a coffee maker that sounds an alarm when your coffee is ready

◆ Make device that can record your heart rate when you ride your bike

What can you do with Arduino?:

All of these things can be achieved with Arduino!

01DFRobot
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The Birth of Arduino

Introduction to DFRduino

Why ﾓArduino��

Arduino started in a small picturesque town in northern Italy as as a 

project for students at the Interaction Design Institute Ivrea. Mem-

bers of Arduino’s core development team were Massimo Banzi, David 

Cuartielles, Tom Igoe, Gianluca Martino, David Mellis and Nicholas 

Zambetti.

Massimo Banzi’s students often complained that they couldn’t find a 

cheap and easy-to-use microcontroller. In the winter of 2005, Banzi 

mentioned this issue while talking with David Cuartielles, a Spanish 

chip engineer who was a visiting scholar to Massimo’s university. 

They decided to design their own circuit board and brought Banzi’s 

student David Mellis into this project to design the programming 

language for their board. Mellis finished the source code within two 

days. It took them another three days to etch the circuit board. They 

named it Arduino.

Now, anyone is able to make magic with Arduino, even without 

knowledge of computer programming. With Arduino, you can make a 

device respond to its0 environment, make flashing light shows 

and  control motors.

In these lessons we will use ��������	 �
� �
��� �� �� ������� ��� board: ﾓDFRduino UnoﾔＮ＠��������＠�������	 �� �����
� ��� 	��� 
��
�	 an Arduino U��Ｎ＠��  !"# $�%&' (�% )(*+ %!,# - .#*/ 0' * $!.. (* *+# ,($1�$�%*1�..#12 Let’s examine its features:

Sections with annotations below are parts that will be regularly used. Digital pins and analog pins marked on the diagram are what we call I/O 

(input/output). Digital pins are numbered from 0 to 13. Analog pins are numbered from 0 to 5.

Voltage supply is also shown on the diagram below. DFRduino can be powered either by a USB connection or through a 6～12V DC supply 

via the barrel jack connector. Also integrated in to the board are four LED lights and a reset button. The LED light marked with 3ON4 is the 

power indicator, which will be on once power is connected. The LED light marked with 454 is an indicator for digital pin 13 which will be dis-

cussed in the next section. TX (transmit) and RX (receive) are indicator lights for serial communication. When we upload a program, these 

two lights will blink rapidly, showing that data is being transmitted and received between the board and your computer.

Ivrea is famous for the story of an oppressed king: In 1002 AD, 

King Arduino took the crown of Italy; however, in 1004 AD, he was 

dethroned by King Henry II of Germany.

There is now a bar named ﾓde Re Arduinoﾔ on 

Cobblestone Street in Ivrea which was opened in commemoration 

of King Arduino. Massimo Banzi was a regular customer there, and 

he fondly named his open-source hardware platform after it.
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First Use

1. Download Arduino IDE

You can download Arduino IDE from this

website:

http://www.arduino.org/software

For Windows users, please click

“Windows (ZIP file)”. For Mac and Linux 

users, please select the corresponding 

link for your operating system.

Once downloaded, extract the files to a 

directory of your choice. Once extracted, 

open the directory. It should look like the 

image below:
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2. Install Drivers

Connect the microcontroller to your comput-

er using a USB cable. Once connected, the

board6s power indicator light will turn on.

Open “Control Panel” and navigate to 

“Device Manager” to set up the drivers.

04DFRobot
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You will then see a dialog box pop up. 

Select the second item “Manually Search 

for Drivers”. A browse window will appear 

that requires you to point it to the correct 

directory.

Navigate the browse dialog to your 

Arduino directory. Inside this directory, 

there is a subfolder called “drivers” where 

the Arduino drivers are stored. Select this 

directory and then click 789:;<.

05DFRobot
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Hopefully this window will appear.

This shows that drivers have been 

successfully installed!

Return to “Device Manager”. The computer will 

have assigned a serial port to the microcontroller

(your computer will show it as Arduino Uno). The 

serial port will vary depending on your computer,

but should appear as =>?@AB CDEEDFGH IJ K
ｮLMIGNO

06DFRobot
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If you encounter issues, check this 

website for help:

https://www.arduino.cc/



3.Introduction to Arduino IDE

Inside your Arduino directory, open PArduino.exeQ. The application 

will open and the code editing interface will appear.

If you wish to change the language of the interface, select “File” and 

then “Preferences” to open preferences.

The dialog box shown below will pop up. Select “Editor Language”, 

choose your language and then click OK.

Close Arduino IDE and then reopen it for the changes to take effect.

07DFRobot
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We will use Arduino IDE a lot in these tutorials, so lets learn about its features:

Arduino IDE allows you to edit and upload RSTUSVWX to your microcontroller. Arduino IDE 

calls programs YXZ[\]^[X_` ab\ cd \^[X[ \b\TScVeX` f[ fcee XcWReg XVg YRSTUSVW_ TS Y]Th[_`
SV\^[S \^Vd YXZ[\]^_` ab\ \^[g＠ijkllm Wean＠\^[ XVW[ \^cdUn

The interface shown in the picture above is where you’ll write and upload code within Arduino 

IDE. The main white area is where you input code. We use the C programming language to 

program the microcontroller, which we will discuss in more detail in later chapters. When you 

press ﾓverifyﾔ＠op ﾓuploadﾔ , the code instructions you have written will be translated in to 

machine language by a piece of software called a ﾓcompilerﾔ so that the microcontroller 

can understand it. This process is called qrstuvwvxyz＠{| }~�|�������Ｎ Messages shown in 

the black area will show information about the compiling and upload process.

08DFRobot
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4. Upload a Blink Program

Let�s upload a simple program to become familiar with the uploading process and to test the microcontroller. This code will turn the “L” LED 

light on the microcontroller on and off. The location of the “L” LED is circled in the diagram below.

Connect your computer to the microcontroller via the USB.
In the Arduino IDE, go to File > Examples > 01.Basics > 

Blink.

09DFRobot
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As this is an example program, there will be no syntax errors in the code. When we write 

code ourselves we can click “Verify” to check if there are any syntax errors. Try it now.

The code is run through the compiler. This green bar shows the compiling process.

Hopefully you will see this message:

Before code is uploaded to the microcontroller, the IDE will automatically verify it.

If there are any errors in your code, a big ugly orange message box will appear above the 

compiler window indicating a problem, and your code can not upload until it is fixed!

10DFRobot
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Before we can upload a program, we need to tell the computer where to send it. In Arduino IDE, we 

need to select which type of Arduino board we are using as well as the serial port that the board is 

connected to.

Navigate to Tools > Board and then select Arduino UNO from the list. That�s it!

Now select the serial (COM) port. Navigate to Tools > Port and your available serial ports will 

be listed. Usually this will be “COM” followed by a number. Select the available port.

In our example the board is connected to the computer on COM36.

11DFRobot
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(There are many different types of Arduino board 

of all shapes and sizes. Some have more RAM 

and more I/O pins and can hold larger programs. 

We are using an Arduino Uno variant, so we must 

select Arduino Uno from the boards list.)



We should now be able to upload code to the microcontroller.

Click upload in Arduino IDE. If all is well, the code will verify and then upload to the microcontroller.

When the upload has completed successfully, the microcontroller will automatically reset 

and the code will execute. Is the light blinking?

This concludes the blink tutorial.

If you have any questions or comments about this tutorial, or any other tutorials in 

this guide, feel free to contact us on the DFRobot forum:

http://www.dfrobot.com/forum/

The DFRobot forum is a community where hackers and makers can share their 

exciting ideas. Come and visit to get ideas about what you can make with your 

DFRduino microcontroller, or just share what you��� ���� ��������� ����� ����������
We love your feedback!

To review, there are three fundamental steps to upload 

code to your microcontroller:

1. Verify code

2. Select board and COM port

3. Upload!

12DFRobot
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Simple Automatic Control Devices

Any device that includes a micro-

controller can be considered a simple 

automatic control device. There are 

three essential constituent parts for a 

simple automatic control device:

    An input unit for collecting signals

    An output unit for sending out signals

    A control unit for processing the sig-

nals received (such as a microcontroller).

Let’s draw an analogy between an automatic 

control device and a person. In a person, sig-

nals are sensed through sight, hearing, taste, 

touch and smell, and then processed by 

the brain which then outputs responses to 

each. In this case, the output signal would 

be the actions of that person.

A microcontroller can output responses as 

well. Output responses include sound, light 

and movement (DC Motors, LEDs, servos 

etc.)

Here is another way to explain it: imagine 

someone says “hello” to you, and you 

immediately reply “hello” in return. In this 

case, your ear is the input unit; your brain is 

the control unit and your mouth is the output 

unit.

How can we carry out this whole process 

(receiving signals, processing signals and 

then sending out signals) using our micro-

controller?

As well as our microcontroller, we simply 

need an acoustic sensor and a buzzer. The 

acoustic sensor “hears” a sound, the 

microcontroller receives a signal and then 

outputs a signal to the buzzer for it to buzz. 

In this case the acoustic sensor is the 

input unit; the microcontroller is the control 

unit and the buzzer is the output unit.

01DFRobot 02. How Does A Device “Think”?

Can you tell which components in the 

kit can be used as input units and 

which can be used as output units?

Think!

Output Intput

Control



Output Units - Actuators

Control Unit - DFRduino Uno

A sensor (also known as a transducer) is a physical unit whose 

purpose is to sense or detect the characteristics of its environment 

(such as light, temperature or moisture levels) and then transmit this 

data to another device.

There are many different types of actuators. An actuator is a type of 

device that is responsible for moving or controlling a system or 

mechanism. It is also the mechanism by which a control system 

acts upon an environment. It may convert electrical energy into mo-

tion, sound or light. A buzzer or speaker are actuators that output

sound.

The microcontroller is the control unit. Think of it as the brain of 

your device.

02DFRobot

The three categories of sensor pins are as follows:

    Digital Pin

    Analog Pin

    Protocol Pin (Digital)

A protocol pin is also a kind of digital pin. I2C, Serial and SPI are 

frequently used digital pins.







Input Units - Sensors

Sensor Pins

02. How Does A Device “Think”?



The Relationship

Between Programs and Hardware

Digital Signals & Analog Signals in the 

World of Electronics 

03DFRobot

The input unit, control unit and output unit mentioned above are all 

hardware. In the context of our person analogy, hardware is the 

body of our device. However, the brain is much more important as 

it produces ideas and then controls actions every person takes. 

Code here functions as the mind of a person. Both body and mind 

are indispensable to a person.

The input unit, the microcontroller and the output unit 

communicate by signals, which in turn are processed by code. 

How do input units and controllers communicate with each 

other? How do controllers communicate with the output units? 

To answer the above questions, we first need to understand two 

concepts: digital signals and analog signals.

The Difference between

Digital & Analog Signals

“Digital” & “Analog” in a DFRobot KitDigital Signals:

A digital signal has two states: HIGH or LOW.

HIGH is a 5V signal and represents “1” (or on).

LOW is a 0V signal and represents 0 (or off).

Analog Signals:

An analog signal has a range of values.

The analog pins of your microcontroller can have between 0V and 

5V is mapped to a range between 0 and 1023. For instance, 0 is 

mapped as 0V; 1023 is mapped as 5V and 512 is mapped as 2.5V.

Here are two ways to tell whether sensors in your DFRobot Kit 

are digital or analog:

(1) If a sensor has a green wire it uses digital signal; if a 

sensor has a blue wire it uses analog signal.

(2) “A” or “D” may be marked on the sensor’s board. “D” rep-

resents “digital” and “A” represents “analog”.

02. How Does A Device “Think”?
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I/O Expansion Shield V7.1

Let’s take a look at the DFRobot I/O Expansion Shield. 

This shield gives us lots of extra pins to connect sensors to. 

It stacks neatly on top of your microcontroller, ������ �¡¢£ �¤¥
¦��  �§¢¨§© ª��«¬ ¢�­�� ®«¯ §¡ «­�¨­��¬¥

Analog and digital pins are marked on the expansion shield. 

The area with “A” is for analog sensors, and the area with 

“D” is for digital ones.

D
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I2C Port

Green: Digital Pins (0~13)

Red: VCC

Black: GND

Blue: Analog Pins(0~5)

Constant 3.3V Power Output

Reset Button

Red: VCC

Black: GND

XBee/Bluetooth Bee Headers
Servo Power Input

APC220/Bluetooth Headers

SD Module Headers

Run/Upload Switch

3.5V/5V Power Output Switch

External Power Input (6~12V)
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Different colors shown in our DF Kit have different 

meanings:

Green = Digital signal

Blue = Analog signal

Red = Power

Black = Ground

The advantage of the I/O expansion shield is that there are more power and ground pins than those on the bare microcontroller board. This 

gives you enough power pins to connect various sensors at the same time.

On the expansion shield, there are a row of power pins in red and a row of GND pins in black below the digital pins.

If you would like to know more about the sensor expansion shield, please 

refer to the DFRobot wiki for information:

http://www.dfrobot.com/wiki/index.php/IO_Expansion_Shield_for_Arduino_V7_SKU:DFR0265

This session gives you a general idea of what makes our devices work.

Are you excited to get your devices going? You’ll get a chance to in the next 

lesson!

02. How Does A Device “Think”?
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01DFRobot 03. Analog and Digital Signals

Let's begin!
Let°± draw an analogy between microcontrollers and people

The microcontroller is the “brain”.

Code is the microcontroller°± “mind”.

Hardware (sensors and actuators) are the microcontroller’s “body”.

Signals, such as analog and digital signals, are the microcontroller°± “nerve impulses”.

In this session, we will explore the differences between analog and digital signals in more 

detail.
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Digital Signals
We will use a digital button module to demonstrate a digital signal. This is included in your kit.

Parts Needed:

DFRduino Uno

(and USB cable)
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Connections

Take the Sensor Expansion Shield and stack it on top of your microcontroller – make sure that the pins are correctly aligned to avoid damage 

to the shield.

Take the Digital Push Button module and connect it to Digital Pin 2 (be sure that the power, ground and signal connections are correct or you 

risk damaging your components!)

See the diagram below for further details:
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Fig. 2-1 Digital Pin Connection

When the connections are made, connect the USB cable. This will power on the microcontroller. We can now prepare our program to upload.

03. Analog and Digital Signals
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Serial Port Monitoring

Click “Upload”. Arduino IDE will verify the code and then upload it to 

your microcontroller.

Once the upload is complete, open the serial monitor. To do this, 

navigate to ｔｯｯｬｳ＠＾＠ｓ･ｲｩ｡ｬ＠ｍｯｮｩｴｯｲ, or click the magnifying 

glass icon on the top right hand corner of the toolbar.

ｩｮｴ＠ｰｵｳｨｂｵｴｴｯｮ＠］＠Ｒ［＠＠＠＠＠＠＠＠＠＠＠＠＠ＯＯ｣ｯｮｮ･｣ｴ＠ｴｯ＠､ｩｧｩｴ｡ｬ＠ｰｩｮ＠Ｒ

ｶｯｩ､＠ｳ･ｴｵｰＨＩ＠ｻ＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠ＯＯ＠ｩｮｩｴｩ｡ｬ＠ｦｵｮ｣ｴｩｯｮ

＠＠ｓ･ｲｩ｡ｬＮ｢･ｧｩｮＨＹＶＰＰＩ［＠＠＠＠＠＠＠＠＠＠＠＠ＯＯ＠ｳ･ｴ＠ｵｰ＠｢｡ｵ､＠ｲ｡ｴ･＠ｯｦ＠ｴｨ･＠ｳ･ｲｩ｡ｬ＠ｰｯｲｴ

＠＠ｰｩｮｍｯ､･ＨｰｵｳｨｂｵｴｴｯｮＬ＠ｉｎｐｕｔＩ［＠＠＠＠ＯＯ＠ｳ･ｴ＠ｴｨ･＠｢ｵｴｴｯｮ＠ｴｯ＠｢･＠ｩｮ＠ｴｨ･＠ｯｵｴｰｵｴ＠ｭｯ､･

ｽ

ｶｯｩ､＠ｬｯｯｰＨＩ＠ｻ＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠＠ＯＯｭ｡ｩｮ＠ｦｵｮ｣ｴｩｯｮ
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The baud rate is the data speed that the serial port communicates. It 

needs to be set to 9600 baud.

“0” and “1” or off and on are the two values of digital signal. We can 

use this in various ways with our devices.

The serial monitor shows information from the microcontroller. We 

are going to use it to view the status of the button. You should see 

“0” appearing continuously. This indicates that the button is off 

(not being pressed).

If you press the button, you will see “1” appear for as long as the button 

is pressed. This indicates that the button is on (being pressed).

Open Arduino IDE and select: File > Examples > 01.Basics > DigitalReadSerial

The following code should appear:

Serial Monitor

Autoscroll Both NL & CR 9600 baud

03. Analog and Digital Signals
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Analog Signal

DFRduino Uno
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I/O Sensor Expansion 
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x1Analog Rotation Sensor

In this section we are going to explore analog signal in more 

detail. We are going to use a sensor which uses analog val-

ues: a rotation sensor.

ARotation Sensor-L
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