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Preface

INTRODUCTION

This chapter contains general information that will be useful to know before using the 

MCP9800 Temperature Data Logger Demo Board 2. Items discussed in this chapter 

include:

• Document Layout

• Conventions Used in this Guide

• Recommended Reading

• The Microchip Web Site

• Customer Support

• Document Revision History

DOCUMENT LAYOUT 

This document describes how to use the MCP9800 Temperature Data Logger Demo 

Board 2. The manual layout is as follows:

• Chapter 1. “Product Overview” –  Important information about the MCP9800 

Temperature Data Logger Demo Board 2. 

• Chapter 2. “Installation and Operation” – Demonstrates what programs need 

to be installed and how to program the microcontroller on the PCB, as well as 

reading the data out and displaying the data in an Excel® spreadsheet.

• Appendix A. – “Schematic and Bill of Materials (BOM)”

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 

documentation are constantly evolving to meet customer needs, so some actual dialogs 

and/or tool descriptions may differ from those in this document. Please refer to our web site 

(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 

page, in front of the page number. The numbering convention for the DS number is 

“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the 

document.

For the most up-to-date information on development tools, see the MPLAB® IDE on-line help. 

Select the Help menu, and then Topics to open a list of available on-line help files.
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 

dialog

“Save project before build”

Underlined, italic text with 

right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 

where N is the total number of 

digits, R is the radix and n is a 

digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 

any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 

character: { | }

Choice of mutually exclusive 

arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 

user

void main (void)
{ ...
}
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RECOMMENDED READING

The following Microchip documents are available and recommended as supplemental 

reference resources.

MCP9800 Data Sheet, “2-Wire High-Accuracy Temperature Sensor” (DS21909)

24LC16B Data Sheet, “16K I2C™ Serial EEPROM” (DS21703)

PIC10F202 Data Sheet, “PIC10F200/202/204/206 Data Sheet” (DS41239)

MCP100/101 Data Sheet, “Microcontroller Supervisory Circuit with Push-Pull 

Output” (DS11187)

SEEVAL® 32 User’s Guide, “SEEVAL® 32 Quick Start Guide” (DS51338)

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web 

site is used as a means to make files and information easily available to customers. 

Accessible by using your favorite Internet browser, the web site contains the following 

information:

• Product Support – Data sheets and errata, application notes and sample 

programs, design resources, user’s guides and hardware support documents, 

latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 

support requests, online discussion groups, Microchip consultant program 

member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 

press releases, listing of seminars and events, listings of Microchip sales offices, 

distributors and factory representatives



MCP9800 Temperature Data Logger Demo Board 2 User’s Guide

DS22027A-page 4 © 2007 Microchip Technology Inc.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 

(FAE) for support. Local sales offices are also available to help customers. A listing of 

sales offices and locations is included in the back of this document.

Technical support is available through the web site at: http://support.microchip.com

DOCUMENT REVISION HISTORY

Revision A (January 2007)

Initial Release of this Document.
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Chapter 1.  Product Overview

1.1 INTRODUCTION

This chapter contains an overview of the MCP9800 Temperature Data Logger Demo 

Board 2 and covers the following topics:

• What is the MCP9800 Temperature Data Logger Demo Board 2?

• What does the MCP9800 Temperature Data Logger Demo Board 2 include?

1.2 WHAT IS THE MCP9800 TEMPERATURE DATA LOGGER DEMO BOARD 2?

The MCP9800 Temperature Data Logger Demo Board 2 is a PCB assembly that uses 

a PIC10F202 to read temperature data using I2C™ communication from a Microchip 

MCP9800 temperature sensor, and stores that data, also using I2C communication, to 

a 24LC16B Serial EEPROM. The board can then be placed into a SEEVAL® 32 Serial 

EEPROM Evaluation tool and the content can be read and stored into a .hex file. We 

have also provided an Excel spreadsheet that can be used to import the .hex file so 

that the data may be graphed on your computer screen.

1.3 WHAT DOES THE MCP9800 TEMPERATURE DATA LOGGER DEMO BOARD 
2 KIT INCLUDE?

This MCP9800 Temperature Data Logger Demo Board 2 Kit includes:

• Two MCP9800 Temperature Data Logger Demo Boards.

On the data CD provided:

• MCP9800 Temperature Data Logger Demo Board 2 User’s Guide (DS22027)

• SEEVAL® 32 Quick Start User’s Guide (DS51338)

• PIC10F202 Firmware (SEEVALDM_DL.asm)

• Excel Spreadsheet (Temperature Graph.xls)
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Chapter 2.  Installation and Operation

2.1 INTRODUCTION

The MCP9800 Temperature Data Logger Demo Board 2, once programmed, will log 

temperature measurements for a predetermined amount of time until the 24LC16B is 

fully programmed with temperature data (i.e., 2,048 temperature readings). Each sam-

ple uses one byte of memory. The intervals can be changed in the firmware we have 

provided by changing the TIMEOUTVAL variable. The firmware will take measurements 

for approximately 45 minutes (approx. 1 sample/sec).

2.2 FEATURES

The MCP9800 Temperature Data Logger Demo Board 2 has the following features:

• Small PCB layout. Can be placed virtually anywhere you need to measure 

temperature.

• Standard ICSP™ pinout so the firmware can be modified using a PICkit™ 2 pro-

grammer or any of Microchip’s programming tools using the ICSP programming 

adapter. 

• Standard Two-Wire 8-pin pinout (inverted) for easy reading of the 24LC16B into 

the SEEVAL® 32 evaluation tool software.

2.3 GETTING STARTED

This section describes how to get your MCP9800 Temperature Data Logger Demo 

Board 2 programmed and ready to take temperature readings. The boards have been 

pre-programmed at the factory with the default settings, so it is not necessary to 

program them unless the firmware has been modified. It will also show how to read the 

logged data from the board into the SEEVAL® 32 evaluation tool software. Then it will 

show how to export that data from the SEEVAL 32 evaluation tool software and also 

how to import and display the data on an Excel spreadsheet.
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FIGURE 1-1: MCP9800 Temperature Data Logger Demo Board 2 Functional 

Block Diagram

2.3.1 Programming the PIC10F202

1. Download and Install the PICkit™ 2 programmer software onto your PC.

2. Copy the SEEVALDM-DL.hex file (supplied on the CD that came with this kit) 

onto your PC.

3. When the PICkit™ 2 programmer software is started the main window will be 

displayed on the PC, as indicated in Figure 1-2.

4. Be sure that the battery (BT1) is installed and the jumper for Power is connected 

(JP1).

5. Connect the MCP9800 Temperature Data Logger Demo Board 2 to the PICkit™ 

2 programmer (both programmer and board should be face up when connect-

ing).

6. PICkit™ 2 programmer should have a green led on the front indicating that no 

errors have occurred.

PIC10F202
(U3)

24LC16B
Serial EEPROM

(U2)

MCP9800
Temp. Sensor

(U4)

SEEVAL® 32 
Evaluation Tool 

Header (U1)

MCP101
Voltage Supervisor

(U5)

Status LED
(D2)

PICkit™ 2 
Programmer

Power

Battery Jumper
(JP1)

Supply

3.3 VDC

(Battery)

Header (J1)
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FIGURE 1-2: PICkit™ 2 Programmer GUI Window on the PC

7. Select Device Family>Baseline. 

8. Select PIC10F202 from the Device pull-down menu. 

9. Select File>Import Hex from the File pull-down menu. A file window will appear. 

Locate, select, and open SEEVALDM-DL.hex from your PC.

10. Click on the Write Device Button in the PICkit™ 2 Programmer window. The 

PIC10F202 will be written to with the SEEVALDM-DL.hex firmware. Once com-

pleted, the status bar in the middle of the window will indicate Write Successful.

11. Disconnect the MCP9800 Temperature Data Logger Demo Board 2 from the 

PICkit™ 2 programmer. Remove and replace the Power Header (JP1). Led 

should begin flashing indicating that the PIC10F202 is reading temperature from 

the MCP9800 and storing the data into the 24LC16B.

12. LED will flash indicating that measurements are being taken until the 24LC16B 

has reached its storage limit (2,048 bytes).

2.3.2 Reading Data from the MCP9800 Temperature Data Logger 
Demo Board 2 board

1. Download and install the SEEVAL® 32 evaluation tool software using the 

SEEVAL® 32 Quick Start User’s Guide.

2. When the SEEVAL 32 evaluation tool software is started the main window will be 

displayed on the PC, as indicated in Figure 1-3.

3. Select “I2C” from the Protocol pull-down menu.

4. Select “24AA16/24LC16B” from the Device Name pull-down menu.
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5. Insert the MCP9800 Temperature Data Logger Demo Board 2 into to SEEVAL® 

32 evaluation board. To do this, flip the board upside down making sure the ICSP 

pins are facing the right side of the SEEVAL® 32 evaluation board. Place the 8 

header pins in the rear (right side) of the ZIF socket. Close the socket.

6. Select Read>Entire Device to read the 24LC16B.

7. Your data (hexadecimal) will be displayed on the SEEVAL® 32 evaluation tool 

software GUI.

FIGURE 1-3: SEEVAL® 32 Evaluation Tool GUI Window on the PC

2.3.3 Storing your Data

Select File>Export>Hex File and store your data to your PC (filename.hex).

2.3.4 Displaying Temperature Data

1. Open file Temperature Graph.xls (Provided on the CD). Choose enable 

macros if prompted. (May need to adjust security settings here if you are unable 

to launch the file.)

2. Press the Import Data button.

3. Find your data file on your PC (filename.hex), Press Open Button.

4. Enter “1” for sample period when asked and press OK. If you have changed the 

sample period in the firmware you will need to adjust the sample period here, 

default is approximately 1 sample/sec.

5. Temperatures both positive and negative will be displayed on the graph. Tabs at 

the bottom of the graph will show either °F or °C.
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2.4 FUNCTIONAL DESCRIPTION

2.4.1 The MCP9800 Temperature Data Logger Demo Board 2

This demo board was originally developed for the use in a class to teach people the 

basics of the I2C™ protocol. The code is formatted in such a manner that it is easy to 

read and modify should one need to. Table 1-1 and Table 1-2 show some of the basic 

subroutines and constant definitions used in the code. The TIMEOUTVAL variable may 

be modified to put longer delays between measurements. Any value between 1 

(default) and 255 may be used to vary the sample rate. The higher the number, the 

slower the sample rate. The TIMEOUTVAL variable is approximately the number of sec-

onds delay between measurements. 

2.5 I2C™ SUBROUTINES

The following subroutines provide low-level I2C support:

The following constants have been defined for communicating with the 24LC16B and 

MCP9800:

Subroutine Descriptions

TABLE 1-1: I2C™ SUBROUTINES

Subroutine Description

BSTART Generate an I2C™ bus Start condition.

BSTOP Generate an I2C™ bus Stop condition.

SEND_ACK Generate an I2C™ bus Acknowledge condition.

SEND_NACK Generate an I2C™ bus Not Acknowledge condition.

BYTEOUT Output an entire byte to the I2C™ bus.

BYTEIN Input an entire byte from the I2C™ bus.

TABLE 1-2: CONSTANT DEFINITIONS

Constant Value Description

MEM_WRITE b’10100000’ Control byte for EEPROM write operation

MEM_READ b’10100001’ Control byte for EEPROM read operation

TEMP_WRITE b’10010000’ Control byte for temp. sensor write operation

TEMP_READ b’10010001’ Control byte for temp. sensor read operation

TEMP_REG 0x00 Temperature register address for temp. sensor

CONFIG_REG 0x01 Configuration register address for temp. sensor

SHUTDOWN b’00000001’ Configuration value for Shutdown mode

ONESHOT b’10000001’ Configuration value for One-Shot mode

BSTART

Description: Generate an I2C bus Start condition.

Arguments: None.

Output: None.

Return Value: 0

Code Example: call BSTART ; Generate Start

BSTOP

Description: Generate an I2C bus Stop condition.

Arguments: None.
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Output: None.

Return Value: 0

Code Example: call BSTOP ; Generate Stop

SEND_ACK

Description: Generate an I2C bus Acknowledge condition.

Arguments: None.

Output: None.

Return Value: 0

Code Example: call SEND_ACK ; Send ACK to continue reading

SEND_NACK

Description: Generate an I2C bus Not Acknowledge condition.

Arguments: None.

Output: None.

Return Value: 0

Code Example: call SEND_NACK ; Send NACK to end operation

BYTEOUT

Description: Output an entire byte to the I2C bus.

Arguments: WREG

Data byte to be transmitted to the I2C bus.

pollflag<0>

Flag indicating whether or not currently polling (1 if polling, 0 otherwise).

Output: None.

Return Value: 0 if an Acknowledge was received.

-1 if an Acknowledge was not received and pollflag<0> is set.

Remarks: If an Acknowledge was not received and pollflag<0> is cleared, this sub-

routine sets the current state to ERR1_STATE and goes to sleep. This

state is used to indicate that an Acknowledge error occurred.

Code Example: movlw 0x7F ; Load 0x7F into WREG
call BYTEOUT ; Output byte

BYTEIN

Description: Input an entire byte from the I2C bus.

Arguments: None.

Output: buffer

Data byte read from the I2C bus.

Return Value: 0

Code Example: call BYTEIN ; Input byte
call SEND_NACK ; Send NACK to end operation
movfw buffer ; Copy data to WREG

BSTOP
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2.5.1 The MCP9800 

The MCP9800 comes with user-programmable registers that provide flexibility for tem-

perature-sensing applications. The register settings allow user-selectable 9-bit to 12-bit 

temperature measurement resolution, configuration of the power-saving Shutdown and 

One-Shot (single conversion on command while in Shutdown) modes and the specifi-

cation of both temperature alert output and hysteresis limits. When the temperature 

changes beyond the specified limits, the MCP9800 outputs an alert signal. The user 

has the option of setting the alert output signal polarity as an active-low or active-high 

comparator output for thermostat operation, or as a temperature event interrupt output 

for microprocessor-based systems.

This device has I2C/SMBus-compatible serial interface (refer to the MCP9800 data 

sheet (DS21909) for further details).

2.5.2 The 24LC16B

The 24LC16B is a 16 Kbit Electrically Erasable PROM. This device has 

I2C/SMBus-compatible serial interface. Low-voltage design permits operation down to 

1.8V with standby and active currents of only 1µa and 1mA, respectively. The device 

also has a page write capability for up to 16 bytes of data. 

2.5.3 The MCP101

The MCP101 is a voltage supervisory device designed to keep a microcontroller in 

Reset until the system voltage has reached the proper level and stabilized. It also 

operates as protection from brown-out conditions when the supply voltage drops below 

a safe operating level. 
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Appendix A. Schematic and Bill of Materials (BOM)

FIGURE 1-1: MCP9800 Temp Sensor SEEVAL® 32 Data Logger Schematic
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CR: Cross Drawing

CS: Consign BOM

PL: Pack List : Part

RoHS: Lead Free L: Label

   Bill of Materials

102-00128 REV: 1 Part No: MCP9800DM-DL2

Qty Reference Mfgr. Part Number Distributor Vendor/Part Number

R

o

H

S Rev

C

R

C

S PL Type

1 1
 -  -

102-00128-D
 -  -

1 N N N D

2 1
 -  -

103-00128
 -  -

1 N N N D

3 1
 -  -

104-00128-D
 -  -

1 N N N D

4 1
 -  -

105-00128
 -  -

1 N N N D

5 1
 -  -

113-00128
 -  -

1 N N N D

6 1
 -  -

108-00004
 -  -

2 N N N LBL

7 1 PCB
 -

104-00128
 -  -

1 Y N N P

8 5

C1,C3,C4,C

5,C6 Kemet  C0603C104K4RACTU Digi-Key 399-1096-1-ND Y 1 Y N N P

9 1 C2

Panasonic - 

ECG ECJ-1VBFJ475K Digi-Key PCC13495CT-ND Y 1 Y N N P

10 1 D1

Panasonic - 

SSG MA2YD2600L Digi-Key MA2YD2600LCT-ND Y 1 Y N N P

11 1 D2

Lite-On 

Trading USA LTST-C170CKT Digi-Key 160-1176-1-ND Y 1 Y N N P

12 3 R1,R2,R4

Panasonic - 

ECG  ERJ-3EKF1002V Digi-Key P10.0KHCT-ND Y 1 Y N N P

13 1 R3

Panasonic - 

ECG ERJ-3EKF2430V Digi-Key P243HCT-ND Y 1 Y N N P

14 1 BT1 Keystone Electr 103 Digi-Key 103K-ND Y 1 Y N N P

15 1 J1

JAMECO 

VALUEPRO JS1109-6-R Jameco 153700 Y 1 Y N N P

16 1 JP1

JAMECO 

VALUEPRO 7000-1X2SG-R Jameco 108338 Y 1 Y N N P

17 2 U1

JAMECO 

VALUEPRO JS-1109-4-R Jameco 117560 Y 1 Y N N P

18 1 BT1 

Panasonic - 

BSG CR2032 Digi-Key P189-ND Y 1 Y N N P

 HOLDER BATTERY COIN 20MM 1-CELL

HEADER,.1"ST MALE,1RW,6PIN,

HEADER,.1",2PIN,GOLDTAIL

 HEADER,.1"MALE,4PIN, GOLDTAIL

BATTERY LITHIUM COIN 3V 20MM

DIODE SCHOTTKY 60V 800MA MINI-2P

LED RED CLEAR 0805 SMD

RES 10.0K OHM 1/10W 1% 0603 SMD

RES 243 OHM 1/10W 1% 0603 SMD

PCB FABRICATION DRAWING, MCP9800 SEEVAL Based 

Temperature Data Logger

RoHS Compliant Bare PCB, MCP9800 SEEVAL Based Temperature 

Data Logger

CAP .10UF 16V CERAMIC X7R 0603

CAP 4.7UF 6.3V CERAMIC X5R 0603

Gerber Files,  105-00128R1.ZIP

MCP9800 SEEVAL Based Temperature Data Logger

MCP9800 SEEVAL Based Temperature Data Logger Test Procedure

Label, AIPD Assembly and Serial Numbers, Very Small

Microchip Technology Incorporated KEY

2355 W. Chandler Blvd.

Chandler, AZ 85224-6199

Description

PCB ASSY DWG, MCP9800 SEEVAL Based Temperature Data Logger

SCHEMATIC, MCP9800 SEEVAL Based Temperature Data Logger

MCP9800 SEEVAL Based Temperature Data Logger

ASSEMBLY NUMBER:

ASSEMBLY NAME:
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CR: Cross Drawing

CS: Consign BOM

PL: Pack List : Part

RoHS: Lead Free L: Label

   Bill of Materials

102-00128 REV: 1 Part No: MCP9800DM-DL2

Qty Reference Mfgr. Part Number Distributor Vendor/Part Number

R

o

H

S Rev

C

R

C

S PL Type

Microchip Technology Incorporated KEY

2355 W. Chandler Blvd.

Chandler, AZ 85224-6199

Description

MCP9800 SEEVAL Based Temperature Data Logger

ASSEMBLY NUMBER:

ASSEMBLY NAME:

19 1 U2 Microchip 24LC16BT-I/OT Microchip 24LC16BT-I/OT Y 1 N Y N P

20 1 U3 Microchip PIC10F202T-E/OT Microchip PIC10F202T-E/OT Y 1 N Y N P

21 1 U4 Microchip MCP9800A0T-M/OTG Microchip MCP9800A0T-M/OTG Y 1 N Y N P

22 1 U5 Microchip MCP101T-450I/TT Microchip MCP101T-450I/TT Y 1 N Y N P

6-Pin, 8-Bit Flash Microcontrollers

Microcontroller Supervisory Circuit with Push-Pull Output

2-Wire High-Accuracy Temperature Sensor

16K I2C™ Serial EEPROM
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