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1 Overview
This document gives instructions towards implementing the demo software available for the
Tower F-RAM Module (TWR-FRAM). The TWR-FRAM module is designed to work with the

Freescale Tower System.
The Tower F-RAM demo software features:

e Control of processor peripherals (SPI and 12C)
e Access of serial memory (SPI and 12C)

e Programming of state savers

e Access of parallel memory (coming soon)

TWR-FRAM Quick Start Guide
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2 HW/SW Requirements
Hardware

e TWR-FRAM module
e TWR-K53N512 (software developed and tested on this platform)
o Note: This board is designed to meet the Tower System Module interface so
other Freescale Tower MCU modules are compatible for development.
o TWR-ELEV
e miniUSB-to-USB cable (available in TWR-K53N512 kit)

Software

e Windows OS

e |AR Embedded Workbench for ARM

o Keil uVision4

e PE Micro OSBDM Virtual Serial Toolkit

TWR-FRAM Quick Start Guide
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3 Hardware Instructions

After unpacking the TWR-FRAM Kkit, notice the “RAMTRON” printing on the TWR-FRAM. This is the
primary side of the board and should be connected to the Primary Elevator. If the jumpers have not
been changed, it is suggested to place the board on the top level of the elevator.

Battery clip
(3V battery included)  256-Kb I?C Serial F-RAM

1-Mb SPI
Serial F-RAM 4-Mb Parallel
F-RAM
256-Kb il I Rt Lc L O-Dit nonvolatile
CTCXO/ i ioniiN-n cui e IREEE (PI0 State Saver
Processor il S R S, T e
Companion 448 1 \ S

R_AHTRDN_ §E— .
e Primary (Functional)
Connections

256-Kb I°C RTC/ 256-Kb SPIRTC/
Processor Companion  Processor Companion

Go ahead and construct the Tower System. Make sure to connect the primary side of all the Tower
modules to the primary elevator. The primary side of each board is indicated by the white line along
the connector (this can be seen below the RAMTRON label in the picture above). The primary elevator

is indicated by white PCl connectors.

TWR-FRAM Quick Start Guide 5
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Assembled TWR-FRAM Memory Module with Freescale Tower System
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4 Jumper Instructions and Table
This section provides the jumper table and configuration instructions to interface with demo
software.

4.1 Jumper Instructions

The TWR K53N512 has multiple channels for 12C and SPI communication and there are jumpers
on the TWR-FRAM to allow for all possible communication channels. The demo software
communicates via 12C0 and SPI0 channels.

For 12CO (Elevator pins B50 and B51) : Set J12 and J13 to 2-3
For SPIO (Elevator pins B44, B45, B46 and B48): Set J4, J7, J8, J10 to 2-3

To enable FM33256 and disable FM25V10: Set J32 to 1-2 and J38 to 2-3

A-pin Jumper

3-pin jumper

B-pin jumper

-
> -
= 4
-
Q2
o
=
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4.2 Jumper Table

Jumper Option Type Setting Description
J1 DSPI Voltage 4-pin 1-2 DSPI voltage 1.6V

2-3 DSPI voltage 3.0V

*3-4* DSPI voltage 1.8V

12 VTWR Voltage 4-pin 1-2 VTWR voltage 5V
*3-4%* VTWR voltage 3.3V

J3 DSPI PWR 4-pin 1-2 /SHDN DSPI via pin B22
*3.4% /SHDN DSPI via pin A35

J4 SPI MISO 6-pin 1-2 Connect to pin B11

*2-3* Connect to pin B44

4-5 Connect to pin B56

J5 DSPI D1 6-pin 1-2 Connect to pin B11

*2-3% Connect to pin B44

4-5 Connect to pin B56

J6 DSPI DO 6-pin 1-2 Connect to pin B10

*2-3* Connect to pin B45

4-5 Connect to pin B57

17 SPI MOSI 6-pin 1-2 Connect to pin B10

*2-3% Connect to pin B45

4-5 Connect to pin B57

J8 SPI SCK 6-pin 1-2 Connect to pin B7

*2-3* Connect to pin B48

4-5 Connect to pin B58

J9 DSPI CLK 6-pin 1-2 Connect to pin B7

*2-3% Connect to pin B48

4-5 Connect to pin B58

J10 SPI CS 6-pin 1-2 Connect to pin B9

*2-3* Connect to pin B46

4-5 Connect to pin B47

5-6 Connect to pin B55

J11 DSPI CS 6-pin 1-2 Connect to pin B9

*2-3% Connect to pin B46

4-5 Connect to pin B47

5-6 Connect to pin B55

J12 12C SCL 6-pin 1-2 Connect to pin A7

*2-3*% Connect to pin B50

TWR-FRAM Quick Start Guide
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4-5 Connect to pin B57
J13 12C SDA 6-pin 1-2 Connect to pin A8
*2-3% Connect to pin B51
4-5 Connect to pin B56
J14 INTERRUPT 6-pin 1-2 Connect to pin B58
*2-3% Connect to pin B56
4-5 Connect to pin B62
J15 RESET 6-pin 1-2 Connect to pin A62
*2-3% Connect to pin A47
4-5 Connect to pin A63
116 State Saver Enable 3-pin *1-2% Connects EN pin to B35
2-3 Connects EN pin to gnd
J17 FM31L278 RESET 3-pin 1-2 Connects to RESET jumper
*2-3% Disconnects pin from RESET jumper
J18 FM31L278 PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J23 FM31T378 RESET 3-pin 1-2 Connects to RESET jumper
*2-3* Disconnects pin from RESET jumper
124 FM31T378 INT 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J25 FM31T378 FOUT 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
J26 FM31T378 PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
132 FM33256B /CS 3-pin 1-2 Disconnects from SPI CS jumper
*2-3% Connects pin to SPI CS jumper
J33 FM33256B ACS 3-pin 1-2 Connects to INTERRUPT jumper
*2-3% Disconnects pin from INTERRUPT jumper
J36 FM33256B PFO 3-pin 1-2 Connects to INTERRUPT jumper
*2-3* Disconnects pin from INTERRUPT jumper
137 FM33256B RESET 3-pin *1-2%* Connects to RESET jumper
2-3 Disconnects pin from RESET jumper
J38 FM25V10 /CS 3-pin 1-2 Connects to SPI CS jumper
*2-3% Disconnects pin from SPI CS jumper
Enables '138 decoder to drive chip
Jae FM22L16 SELECT 3-pin *1-2% enables to FM22L16 devices
Disables '138 decoder from driving chip
2-3 enables to FM22L16 devices

TWR-FRAM Quick Start Guide
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5 Software Instructions

5.1 IAR Embedded Workbench for ARM
To develop on and access the IAR project demos built for the TWR-K53N512, it is necessary to

download IAR Embedded Workbench for ARM.

Note: Please check that you have the latest version of IAR Embedded Workbench for ARM
installed (i.e. these projects were developed on version 6.4 and are confirmed to NOT work
on version 6.1).

Go to IAR home website (www.iar.com) under the “Software Download” section and download
IAR Embedded Workbench for ARM processors.

Follow the instructions of the install executable.

5.2 Keil pVision4
To develop on and access the Keil project demos built for the TWR-K53N512, it is necessary to
download Keil puVision4.

Note: Please check that you have the latest version Keil pVision4 for MDK-ARM installed.

Go to Keil home website (www.keil.com) and select “Product Downloads” under the “Software
Downloads” section. Download Keil MDK-ARM.

Follow the instructions of the install executable.

You will also need to download and install the Freescale Kinetis OSJITAG drivers for Keil.
(http://www.keil.com/download/docs/408.asp)

5.3 PE Micro OSBDM Virtual Serial Toolkit

This package is used mainly for the drivers to interface with the OSJTAG and its serial terminal
capabilities. A different serial terminal application can be used but it is still necessary to get the
appropriate drivers if it is intended to use the OSITAG.

Go to the PE Micro OSBDM website (www.pemicro.com/osbdm). Download the package by
following the “OSBDM Virtual Serial Toolkit” link. Use the pdf installation instructions for the
drivers and toolkit by following the link “Installation & Operation of the OSBDM”.

TWR-FRAM Quick Start Guide 10
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5.4 Connect the Tower System to PC
If you have not already, connect the USB cable to the TWR-K53N512 miniUSB port.

If this is the first time you have connected the Tower System with a PC containing updated P&E drivers,
the PC may indicate that the firmware needs to be updated (Follow the instructions for the OSBDM
Virtual Serial Toolkit if these have not been installed and updated).

r 2
B Updating firmware of P&E Interface... |ﬂlﬁ

Interface hardware detected with old firmware.
Updating... (Please Wait)

Current Firmware: 29.07
Update Firmware: 30.21

Verifying MCU flash hytes at Address 300004660 : Success.

L

Once the system is connected, the onboard demo should be running.
Go to Start -> All Programs -> P&E OSBDM OSJTAG Virtual Serial Toolkit ->Utilities->Terminal Utility

Make sure the settings are:

Port: <appropriate COM> (“USB COM” works on this PC)
Baud: 115200

Parity: None

Bits: 8

Click “Open Serial Port” and text should appear below the button saying “Open.”

At this point, everything necessary to interface with the demos should be available.

TWR-FRAM Quick Start Guide 11
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6 Demo Instructions for IAR
The demo software can be downloaded at www.ramtron/go/towerFRAM.com . Unzip

“TWR_FRAM_demos”. The directory structure is as follows:

. TWE_FR&M_demos
. build
| iar
. config files
J hello_world
| i2c_mem
| parallel_mem
| spi_mem
| statesawver
| SIC
| commaon
| cpu
J drivers
| platforms

| projects

Inside the build folder, this contains the IAR workspaces for each project. The src folder contains the
source files for the projects.

TWR-FRAM Project Descriptions:
SPI_mem — provides example code for interfacing with the F-RAM SPI devices FM33256B and

FM25V10. For the processor companion part (FM33256B), the code will activate the RTC, set the time
and date, read from the event counters, and write data to the memory.

NOTE: The SPI_mem project can only interact with one SPI device at a time. By default, the
program in interface with the processor companion (FM33256B). To interface with the FM25V10,
comment the define for the FM33256B and uncomment the define for FM25V10 (like shown below).
Then, recompile the project.

#include "k53_spi.h"
J/available devices

//define FM33256B
#define FM25V10

12C_mem — provides example code for interfacing with the F-RAM 12C devices FM31T378,
FM31256, and FM24W256. For the processor companion parts (FM31T378 and FM31256), the code will
activate the RTC, set the time and date, read from the event counters, and write data to the memory of
all 3 components.

statesaver — provides example code of interfacing with the FM1106 devices. The state savers
are connected to LEDs and the project will light a pattern by controlling the FM1106.

parallel_mem — provides example code of interfacing with the FM22L16 devices.

TWR-FRAM Quick Start Guide 12



RaEMTRON

6.1 Running the demo

1. StartlAR
a. Start -> All Programs -> IAR Systems -> IAR Embedded Workbench for ARM -> IAR
Embedded Workbench

. T-Zip -
. Accessories
. Autolt w3
. Carrera
. Cisco Systems VPN Client
, DW WLAN
| Freescale CodeWarrior
. Freescale Medical GUI
. Freescale MQX 38 E
. Games
.. HI-TECH Software
) IAR Systems
@ AR Systems License Activation
@ AR Systems License Manager
. IAR Embedded Workbench for ARM
g_i IAR Embedded Workbench
| IAR Product Information Log File

m

2 Release notes (English)
c?] Release notes (Japanese)
. IAR Embedded Workbench for STMi
J iTunes

. Maintenance

. Microchip

. Microsoft Office
J Microsoft Silverlight

. Microsoft Silverlight 3 SDK
. Microsoft SQL Server 2008

J Microsoft Sync Framework -
1 Back
| Search programs and files 2 |

2. Open the demo workspace
a. File-> Open ->Workspace...
b. Go to the desired project under {unzip directory}/TWR_FRAM_demos/build/iar/
c. Open the IAR IDE Workspace in the project folder

TWR-FRAM Quick Start Guide
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[Fin] B View Progect Tock Window Heip

Hew
Open

Save Workapece
Close Workzpace

File—.
Werkipace.

HesdenSource File

el i A B B aie|PRINE S

Crl+Q

é@' COpen Workspace

[

o) [« build » iar v statesaver » [ 44 |[ Search statesaver o]
Organize » New folder = 0 @
< Favorites MName Date modified Type

Bl Desktop . RAM_128KB 6/12/2012 8:38 AM File folder
& Downloads | settings 6/12/2012 8:38 AM File folder

';.__I Recent Places
. Libraries

- Computer
& Local Disk ()

“! Metwork

<

4| statesaver

5/8/2012 4:13 PM

Type: IAR IDE Workspace

Size: 174 bytes

Date modified: 5/8/2012 4:13 PM

[

File name:

IAR IDE Work

v’ [Workspace Files (*.eww) ']

el |

Cancel I

3. Rebuild and Execute in debugger

da.

Select: Project-> Rebuild All

b. Select: Project -> Download and Debug

i. 1AR may ask for a changed reference for the “crt0.s” assembly file

towards the crt0.s file located:

{unzip directory}/TWR_FRAM_demos/src/cpu/crt0.s

2
;

@
=

TWR-FRAM Quick Start Guide
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3R statesaver - IAR Embeddad WorkbeRGRTBE ;T
File Edit View Project Debug Disassembly JTAG Tools Window Help
DNeH@ & s 2R o A eI erERH BUNS| DD
S22 LE2 2| X
Warkspace * | statesaver |MK533210 | ertd | uart | start | common | k53_tower | printf | io |pmc | stdlib | sysinit
Riah_128KE X void main (veid)
i £ B, {
Files 2 ] E SHAEERS
B (J statesaver_k... v = for{int v = 0; y<5; y++){
[ comman init GPIO():
@ [ drivers
CalaR printf{"\nTurn on LEDs!!\n");
@ [ plattarrms //emulates a clock tick
I—E[:Iprojed GPIOC PTOR = (1 << 55 CLK SHIFT); //Inverts output ( 0 -> 1 or 1 -> 0}
| I— isrh pause (DI S
Sateiaaar] GPIOC_PTO Get Alternative File
Output
L10utp printf(™of | Could not find the following source file:
| C:\Users\semley\Desktop \ TWR_FRAM_demos'src'\cputcrtl.s
Ei int
=] {or{:l_n % Suggested altemative:
//inw | e
GPIOD | -
GEIOD ise = e 8o
GPICD [] ¥ possible, dont show this dialog again
GPICE_|
GPICE |
GPIOE_PTOR |= (1 << LED& SHIFT);
GPIOE_PTOR |= (1 << LED7_SHIFT);
GPIOE_PTOR |= (1 << LED8_ SHIFT);
statesaver k53 tower < Lfeh T"’-" Celiber o il I
=
Log

Thu Sep 06, 2012 14:33:29: Loaded debugee: ENTWR_FRAM_dermosibuildiiarstatesaveBAM_1 28KB\Exehstatesaver_kb3_tower.out
Thu Sep 06, 2012 14:33:30: CPU reset by debugger.

Thu Sep 06, 2012 14:33:30:

Thu Sep 06, 2012 14:33:30: Software resetwas performed

Thu Sep 06, 2012 14:33:30: Target reset

Debug Log | Build

c. Select: Debug -> Go

d. Select: Debug -> Stop Debugging (when ready to quit Debug mode)

TWR-FRAM Quick Start Guide 15
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6.2 Creating a New Project
There is an executable called “make_new_project” located in:

{unzip directory}/TWR_FRAM_demos/build/iar/

Run the executable and a terminal opens asking for the name of the new project.

jGcript to create a new project based off the hello_world project
Hew project name:

L

r -
B CAUsers\jhunter\Freescale\TWR_FRAM_demos\build\iar\make_new_project.exe |£|&l

Enter the new project name and you will see the directory appear in the build and src folders.

TWR-FRAM Quick Start Guide
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7 Demo Instructions for Keil
The demo software can be downloaded at www.ramtron/go/towerFRAM.com . Unzip
“TWR_FRAM_demos”. The directory structure is as follows:

4 | TWR_FRAM_demos

4 . build

> g iar

4 . kel
| i2c_mem

. parallel_mem
| spi_mem
J statesaver

* e SIC

Inside the build folder, this contains the Keil workspaces for each project. The src files are contained in
the build folder for each project as well.

TWR-FRAM Project Descriptions:

SPI_mem — provides example code for interfacing with the F-RAM SPI devices FM33256B and
FM25V10. For the processor companion part (FM33256B), the code will activate the RTC, set the time
and date, read from the event counters, and write data to the memory.

NOTE: The SPI_mem project can only interact with one SPI device at a time. By default, the
program in interface with the processor companion (FM33256B). To interface with the FM25V10,
comment the define for the FM33256B and uncomment the define for FM25V10 (like shown below).
Then, recompile the project.

#include "k53 _spi.h”

Slavailashle devices
f/define FM33256B
#define FM25V1O0

12C_mem — provides example code for interfacing with the F-RAM 12C devices FM31T378,
FM31256, and FM24W256. For the processor companion parts (FM31T378 and FM31256), the code will
activate the RTC, set the time and date, read from the event counters, and write data to the memory of
all 3 components.

statesaver — provides example code of interfacing with the FM1106 devices. The statesavers
are connected to LEDs and the project will light a pattern by controlling the FM1106.

parallel_mem — provides example code of interfacing with the FM22L16 devices.

7.1 Running the demo
1. Start Keil

TWR-FRAM Quick Start Guide 17
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a. Start -> All Programs -> Keil uVision4

H Adobe Reader X
(®) Apple Software Update
@ Default Programs
i Desktop Gadget Gallery
%} Internet Explorer (G4-bit)
(= Internet Explorer
Keil uVisiond
fil Microsoft SkyDrive
ﬂ Maovie Maker
' Photo Gallery
&9 Safari
£ Windows Anytime Upgrade
& wWindows DVD Maker
55 Windows Fax and Scan
) Windows Live Mail
2 Windows Live Messenger
€ Windows Media Center
@ Windows Media Player
&1 Windows Update
a4, XPS Viewer

W 7-Zip

. Accessories

| Autolt v3

2. Open the demo workspace
a. Project-> Open Project
b. Go to the desired project under {unzip directory}/TWR_FRAM_demos/build/keil/
c. Open the pVision4 Project in the project folder

TWR-FRAM Quick Start Guide
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il

Organize «

MNew folder

- 0 @

MName

Date modified

Type

i Favorites
BE Desktop
% Downloads
‘Ei Recent Places

4@ SkyDrive

= Libraries
EI Documents
Jl Music
|| Pictures
E Videos

18 Computer
&, Local Disk [C:)

¥ statesaver

8/6/2012 3:43 AM w¥isiond Pro

* e

1 | »

File name:

~ | Project Files {*uvproj; *uvmpw |

[ open [+ [ Conca |

3. Make that the debugger is configured for Pemicro OSJtag/Multilink/Cyclone

TWR-FRAM Quick Start Guide
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Click Debug Tab

a0 oo

Click OK

Select: Project -> Options for Target

Select “Pemicro OSJtag/Multilink/Cyclone” on the right and select “Use:” radio button

-
Options for Target Target 1'

™ Use Simulator
[ Limit Speed to Real-Time

Devic:el Targeti Outpuil Ustingl User I C."E-I—I-I Asm I Linker Debug |Uti|'rties 1

Settings || & Use: [Femicro OSutag/Muink /Cycla_v] _Settings |

Altera Blaster Cortex Debugger
Stellans ICDI

¥ Load Application at Startup W Runto mainf)

Initislization File:

Sigrnum Systems JTAGiet
[ Load | 7NK / L Trace Cortex
Initializatia ST-Link (Deprecated Version)
i"‘_“' ULINK Fro Cortex Debugger
~Dbg_Ry MULink Debugger
SiLabs UDA Debugger

-

~ Restore Debug Session Settings -  Restore SToLink De-buer
¥ Breakpoints ¥ Toolbox v B D[-J : —
v Watch Windows & Pefformance Anafyzer ¥ Vet iTowe FRLaaE
v Memory Display v Memory Display

CPU DLL: Parameter: Dirver DLL: Parameter:

|SAHMCM3.DLL 1-MPU

!SAHMCMJ.DLL |—MPU

Dialog DLL: Farameter; Diglog DLL: Farameter:
iDCM.DLL ;-pCM‘i iTCM.DLL |1:cru14
oK |  Cancel | Defauts | Help

4. Rebuild and Execute in debugger
a. Select: Project-> Rebuild all target files
b. Select: Debug -> Start/Stop Debug Session
c. Select: Debug -> Run
d. Select: Debug -> Stop Debugging (when ready to quit Debug mode)

TWR-FRAM Quick Start Guide
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